source: projects/specs/trunk/u/uClibc/uClibc-vl.spec @ 7155

Revision 7155, 3.2 KB checked in by daisuke, 11 years ago (diff)

uClibc:

  • update to 0.9.33.2
  • update config
Line 
1#define prever rc3
2
3Summary: C library for embedded Linux
4Summary(ja): 組み込みLinux用のCライブラリ
5
6Name: uClibc
7Version: 0.9.33.2
8Release: 1%{?_dist_release}
9
10Group: Development/Libraries
11License: LGPLv2
12URL: http://www.uclibc.org/
13Source0: http://www.uclibc.org/downloads/%{name}-%{version}.tar.xz
14Source1: uClibc.config
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16
17%global debug_package %{nil}
18# This package only contains a static library
19
20ExcludeArch: ppc64
21# uclibc 0.9.30 does not support ppc64
22
23%description
24uClibc is a C library for developing embedded Linux systems.
25It is much smaller than the GNU C Library, but nearly all applications
26supported by glibc also work perfectly with uClibc.
27
28%package devel
29Summary: Header files and libraries for uClibc library
30Summary(ja): Header files and libraries for uClibc library
31Group: Development/Libraries
32Provides: uClibc-static = %{version}-%{release}
33
34%description devel
35uClibc is a C library for developing embedded Linux systems.
36It is much smaller than the GNU C Library, but nearly all applications
37supported by glibc also work perfectly with uClibc.
38This package contains the header files and libraries
39needed for uClibc package.
40
41%prep
42%setup -q -n %{name}-%{version}
43
44cat %{SOURCE1} >.config1
45iconv -f windows-1252 -t utf-8 README >README.pom
46mv README.pom README
47
48%build
49mkdir kernel-include
50cp -a /usr/include/asm kernel-include
51cp -a /usr/include/asm-generic kernel-include
52cp -a /usr/include/linux kernel-include
53
54arch=`uname -m | sed -e 's/i.86/i386/' -e 's/ppc/powerpc/'`
55echo "TARGET_$arch=y" >.config
56echo "TARGET_ARCH=\"$arch\"" >>.config
57cat .config1 >>.config
58
59yes "" | make oldconfig %{?_smp_mflags}
60make V=1 %{?_smp_mflags}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64mkdir -p $RPM_BUILD_ROOT/lib
65make install PREFIX="$RPM_BUILD_ROOT/"
66make install_headers PREFIX="$RPM_BUILD_ROOT/" DEVEL_PREFIX=""
67cp -a kernel-include/* $RPM_BUILD_ROOT/include/
68
69# move libraries to proper subdirectory
70mkdir -p $RPM_BUILD_ROOT/%{_libdir}/uClibc
71mv  $RPM_BUILD_ROOT/lib/*  $RPM_BUILD_ROOT/%{_libdir}/uClibc/
72rm -rf  $RPM_BUILD_ROOT/lib/
73
74# move the header files to /usr subdirectory
75mkdir -p $RPM_BUILD_ROOT/%{_includedir}/uClibc
76mv  $RPM_BUILD_ROOT/include/*  $RPM_BUILD_ROOT/%{_includedir}/uClibc
77rm -rf  $RPM_BUILD_ROOT/include/
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%files devel
83%defattr(-,root,root,-)
84%doc README docs/Glibc_vs_uClibc_Differences.txt docs/threads.txt docs/uClibc_vs_SuSv3.txt
85%doc TODO DEDICATION.mjn3 MAINTAINERS
86%doc docs/PORTING COPYING.LIB
87%{_includedir}/uClibc
88%{_libdir}/uClibc
89
90%changelog
91* Mon Nov 26 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.33.2-1
92- update to 0.9.33.2
93- update config
94
95* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.32-1.rc3
96- initial build for Vine Linux
97
98* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.32-0.2.rc2
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
100
101* Mon Feb  7 2011 Tom Callaway <spot@fedoraproject.org> - 0.9.32-0.1.rc2
102- update config for 0.9.32-rc2, busybox
103- patch getutent
104
105* Tue Nov  9 2010 Ivana Hutarova Varekova <varekova@redhat.com> - 0.9.31-2
106- update to 0.9.31
107
108* Fri Jun  5 2009 Ivana Varekova <varekova@redhat.com> - 0.9.30.1-2
109- initial build for Red Hat
Note: See TracBrowser for help on using the repository browser.