source: projects/specs/trunk/t/twitux/twitux-vl.spec @ 521

Revision 521, 3.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define ver 0.69
2%define rel 3
3
4Summary: GTK+ application for Twitter.com
5Summary(ja): Twitter.comのためのGTK+アプリケーション
6Name: twitux
7Version: %{ver}
8Release: %{rel}%{?_dist_release}
9Source0: %{name}-%{version}.tar.bz2
10Source1: twitux-ja.po
11Patch0: twitux-0.69-help.patch
12Patch1: twitux-0.69-r372.patch
13License: GPLv2+
14Group: Applications/Internet
15URL: https://sourceforge.net/projects/twitux
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22BuildRequires: gtk2-devel >= 2.14.0, glib2-devel >= 2.15.5
23BuildRequires: libsexy-devel, libsoup-devel, libnotify-devel
24BuildRequires: libcanberra-devel >= 0.4
25BuildRequires: dbus-devel >= 0.61, dbus-glib-devel
26BuildRequires(install,check): desktop-file-utils
27PreReq: desktop-file-utils, rarian-compat
28
29
30%description
31Twitux it's a free and open source GTK+ application for Twitter.com.
32you can: Send status, View friend status and see what they are doing ,
33Send direct messages to your Twitter friends, GUI notificactions
34when a friend update their status.. and more :)
35
36%description -l ja
37Twitux フリーで、オープンソースで開発されている GTK+ ベースの
38Twitter クライアントです。
39このクライアントを使うと、ステータスの送信から、友達のステータス
40や彼らが何をしているのかの確認、友達宛のダイレクトメッセージの送信、
41友達がステータスを更新した時の GUI による通知等々が利用できます。
42
43%prep
44%setup -q
45%patch0 -p 1
46%{__cp} -f %{SOURCE1} po/ja.po
47%{__rm} -f po/ja.gmo
48%patch1 -p 1
49
50%build
51%configure --disable-schemas-install
52%{__make} %{?_smp_mflags}
53
54%install
55%{__rm} -rf ${RPM_BUILD_ROOT}
56%{makeinstall}
57%{__rm} -f ${RPM_BUILD_ROOT}%{_datadir}/icons/hicolor/icon-theme.cache
58%find_lang %{name}
59
60
61%clean
62%{__rm} -rf ${RPM_BUILD_ROOT}
63
64
65%check
66make check
67%{_bindir}/desktop-file-validate ${RPM_BUILD_ROOT}%{_datadir}/applications/twitux.desktop
68
69
70%post
71%{_bindir}/update-desktop-database %{_datadir}/applications
72%{_bindir}/scrollkeeper-update > /dev/null 2>&1 || :
73export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
74SCHEMAS="twitux.schemas"
75for S in $SCHEMAS; do
76  %{_bindir}/gconftool-2 --makefile-install-rule \
77    %{_sysconfdir}/gconf/schemas/$S > /dev/null
78done
79
80
81%pre
82if [ "$1" -gt 1 ]; then
83  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
84  SCHEMAS="twitux.schemas"
85  for S in $SCHEMAS; do
86    %{_bindir}/gconftool-2 --makefile-uninstall-rule \
87      %{_sysconfdir}/gconf/schemas/$S > /dev/null
88  done
89fi
90
91
92%preun
93if [ "$1" -eq 0 ]; then
94  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
95  SCHEMAS="twitux.schemas"
96  for S in $SCHEMAS; do
97    %{_bindir}/gconftool-2 --makefile-uninstall-rule \
98      %{_sysconfdir}/gconf/schemas/$S > /dev/null
99  done
100fi
101
102%postun
103%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
104%{_bindir}/scrollkeeper-update > /dev/null 2>&1 || :
105
106
107%files -f %{name}.lang
108%defattr(-,root,root)
109%doc
110%{_bindir}/twitux
111%{_sysconfdir}/gconf/schemas/twitux.schemas
112%{_datadir}/applications/twitux.desktop
113%{_datadir}/gnome/help/twitux
114%{_datadir}/icons/hicolor/*/apps/*
115%{_datadir}/twitux
116%{_datadir}/omf/twitux
117
118%changelog
119* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.69-3
120- add japanese description
121
122* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> 0.69-2
123- fix avatar size and memory leak (Patch2): patch from upstream SVN)
124
125* Sun Mar 29 2009 IWAI, Masaharu <iwai@alib.jp> 0.69-1
126- initial release
127
Note: See TracBrowser for help on using the repository browser.