source: projects/specs/trunk/t/tsclient/tsclient-vl.spec @ 521

Revision 521, 4.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1
2%define gtk2_version 2.2.0
3%define gnome_panel 2.2.0
4%define rdesktop_version 1.3.0
5%define vnc_version 4.0
6%define desktop_file_utils_version 0.4
7
8Summary: Client for VNC and Windows Terminal Server
9Summary(ja): VNC および Windows ターミナルサーバ用クライアント
10Name: tsclient
11Version: 2.0.2
12Release: 2%{?_dist_release}
13URL: http://sourceforge.net/projects/tsclient
14Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
15
16License: GPL+
17Group: User Interface/X
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19
20Requires: rdesktop
21#Requires: vnc
22
23BuildRequires: gnome-desktop-devel
24BuildRequires: libgnomeui-devel
25BuildRequires: libnotify-devel
26BuildRequires: NetworkManager-glib-devel
27BuildRequires: gtk2-devel >= %{gtk2_version}
28BuildRequires: gnome-panel-devel >= %{gnome_panel}
29BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
30BuildRequires: gettext
31BuildRequires: autoconf, automake, libtool, intltool
32
33# reported upstream
34Patch0: icon-names.patch
35# reported upstream
36Patch2: edit-dialog-crash.patch
37# reported upstream
38Patch3: vnc-password-optional.patch
39# reported upstream
40Patch4: vnc-remote-screen-size.patch
41# NOT reported upstream; there's no simple way to make it support both
42# realvnc and tightvnc
43Patch5: realvnc-args.patch
44Patch6: tsclient-libgnomeui.patch
45
46%description
47tsclient is a frontend that makes it easy to use rdesktop and vncviewer.
48
49%package devel
50Summary: Header files needed to write tsclient plugins
51Summary(ja): Header files needed to write tsclient plugins
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56The tsclient-devel package contains header files that are needed to
57develop tsclient plugins.
58
59%prep
60%setup -q
61%patch0 -p1 -b .icon-names
62%patch2 -p1 -b .edit-dialog-crash
63%patch3 -p1 -b .vnc-password
64%patch4 -p1 -b .vnc-remotesize
65%patch5 -p1 -b .realvnc-args
66%patch6 -p1 -b .libgnomeui
67libtoolize --force --copy
68autoreconf -f -i
69
70%build
71
72%configure
73make %{?_smp_mflags}
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78make install DESTDIR=$RPM_BUILD_ROOT
79
80rm -rf $RPM_BUILD_ROOT/var/scrollkeeper
81
82desktop-file-install --vendor tsclient --delete-original      \
83  --dir $RPM_BUILD_ROOT%{_datadir}/applications               \
84  --remove-category Application                               \
85  $RPM_BUILD_ROOT%{_datadir}/applications/*
86
87rm -rf $RPM_BUILD_ROOT/usr/lib/tsclient/plugins/*.{a,la}
88
89%find_lang %{name}
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post
95export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/tsc-handlers.schemas >& /dev/null || :
97touch --no-create %{_datadir}/icons/hicolor
98if [ -x /usr/bin/gtk-update-icon-cache ]; then
99  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
100fi
101
102%pre
103if [ "$1" -gt 1 ]; then
104  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
105  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/tsc-handlers.schemas >& /dev/null || :
106fi
107
108%preun
109if [ "$1" -eq 0 ]; then
110  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
111  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/tsc-handlers.schemas >& /dev/null || :
112fi
113
114%postun
115touch --no-create %{_datadir}/icons/hicolor
116if [ -x /usr/bin/gtk-update-icon-cache ]; then
117  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
118fi
119
120
121%files -f %{name}.lang
122%defattr(-,root,root)
123%doc COPYING AUTHORS
124%{_bindir}/*
125%{_datadir}/applications/*.desktop
126%{_sysconfdir}/gconf/schemas/tsc-handlers.schemas
127%{_libdir}/tsclient
128%{_datadir}/gnome/autostart/tsc-autostart.desktop
129%{_datadir}/icons/hicolor/scalable/apps/tsclient.svg
130%{_datadir}/tsclient
131
132%files devel
133%{_includedir}/tsclient
134
135
136%changelog
137* Sat May 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-2
138- remove Requires: vnc
139
140* Thu May 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-1
141- new upstream release
142
143* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.148-1vl5
144- applied new versioning policy, spec in utf-8
145- changed _serverdir, %%{_libdir} => %%{_prefix}/lib
146
147* Fri Dec  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.148-0vl1
148- new upstream release
149- dropped Patch13
150
151* Tue May 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.140-0vl1
152- new upstream release
153- remove banner-ja.png that are now included in upstream
154- update ja.po
155
156* Mon Feb 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.132-0vl4
157- add Patch13 to support -gworkarea
158
159* Fri Dec 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.132-0vl3
160- add banner-ja.png
161
162* Fri Dec 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.132-0vl2
163- add Vine default fontpath to XDMCP(Xnest) option.
164
165* Fri Dec 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.132-0vl1
166- initial build  for Vine Linux
167- add ja.po
168
169* Mon Sep 30 2002 - Erick Woods <erick@gnomepro.com>
170 - This file was created
171
Note: See TracBrowser for help on using the repository browser.