source: projects/specs/trunk/t/tsclient/tsclient-vl.spec @ 986

Revision 986, 5.1 KB checked in by daisuke, 14 years ago (diff)

tsclient: rebuild with NetworkManager-0.8

Line 
1
2%define gtk2_version 2.2.0
3%define gnome_panel 2.2.0
4%define rdesktop_version 1.3.0
5%define vnc_version 4.0
6%define desktop_file_utils_version 0.4
7
8Summary: Client for VNC and Windows Terminal Server
9Summary(ja): VNC および Windows ターミナルサーバ用クライアント
10Name: tsclient
11Version: 2.0.2
12Release: 4%{?_dist_release}
13URL: http://sourceforge.net/projects/tsclient
14Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
15
16License: GPL+
17Group: User Interface/X
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19
20Requires: rdesktop
21#Requires: vnc
22
23BuildRequires: gnome-desktop-devel
24BuildRequires: libgnomeui-devel
25BuildRequires: libnotify-devel
26BuildRequires: NetworkManager-glib-devel
27BuildRequires: gtk2-devel >= %{gtk2_version}
28BuildRequires: gnome-panel >= %{gnome_panel}
29BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
30BuildRequires: gettext
31BuildRequires: autoconf, automake, libtool, intltool
32
33# reported upstream
34Patch0: icon-names.patch
35# reported upstream
36Patch2: edit-dialog-crash.patch
37# reported upstream
38Patch3: vnc-password-optional.patch
39# reported upstream
40Patch4: vnc-remote-screen-size.patch
41# NOT reported upstream; there's no simple way to make it support both
42# realvnc and tightvnc
43Patch5: realvnc-args.patch
44Patch6: tsclient-libgnomeui.patch
45Patch10: tsclient-2.0.2-nm08.patch
46
47%description
48tsclient is a frontend that makes it easy to use rdesktop and vncviewer.
49
50%package devel
51Summary: Header files needed to write tsclient plugins
52Summary(ja): Header files needed to write tsclient plugins
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
55
56%description devel
57The tsclient-devel package contains header files that are needed to
58develop tsclient plugins.
59
60%prep
61%setup -q
62%patch0 -p1 -b .icon-names
63%patch2 -p1 -b .edit-dialog-crash
64%patch3 -p1 -b .vnc-password
65%patch4 -p1 -b .vnc-remotesize
66%patch5 -p1 -b .realvnc-args
67%patch6 -p1 -b .libgnomeui
68%patch10 -p1 -b .nm08
69libtoolize --force --copy
70autoreconf -f -i
71
72%build
73
74%configure
75make %{?_smp_mflags}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80make install DESTDIR=$RPM_BUILD_ROOT
81
82rm -rf $RPM_BUILD_ROOT/var/scrollkeeper
83
84desktop-file-install --vendor tsclient --delete-original      \
85  --dir $RPM_BUILD_ROOT%{_datadir}/applications               \
86  --remove-category Application                               \
87  $RPM_BUILD_ROOT%{_datadir}/applications/*
88
89rm -rf $RPM_BUILD_ROOT/usr/lib/tsclient/plugins/*.{a,la}
90
91%find_lang %{name}
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%post
97export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
98gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/tsc-handlers.schemas >& /dev/null || :
99touch --no-create %{_datadir}/icons/hicolor
100if [ -x /usr/bin/gtk-update-icon-cache ]; then
101  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
102fi
103
104%pre
105if [ "$1" -gt 1 ]; then
106  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
107  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/tsc-handlers.schemas >& /dev/null || :
108fi
109
110%preun
111if [ "$1" -eq 0 ]; then
112  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
113  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/tsc-handlers.schemas >& /dev/null || :
114fi
115
116%postun
117touch --no-create %{_datadir}/icons/hicolor
118if [ -x /usr/bin/gtk-update-icon-cache ]; then
119  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
120fi
121
122
123%files -f %{name}.lang
124%defattr(-,root,root)
125%doc COPYING AUTHORS
126%{_bindir}/*
127%{_datadir}/applications/*.desktop
128%{_sysconfdir}/gconf/schemas/tsc-handlers.schemas
129%{_libdir}/tsclient
130%{_datadir}/gnome/autostart/tsc-autostart.desktop
131%{_datadir}/icons/hicolor/scalable/apps/tsclient.svg
132%{_datadir}/tsclient
133
134%files devel
135%{_includedir}/tsclient
136
137
138%changelog
139* Wed May 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-4
140- rebuild with NetworkManager-0.8
141- add patch10 to build with NetworkManager-0.8
142
143* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.2-3
144- rebuild with GNOME-2.30
145- change BuildRequires: gnome-panel-devel -> gnome-panel
146
147* Sat May 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-2
148- remove Requires: vnc
149
150* Thu May 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-1
151- new upstream release
152
153* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.148-1vl5
154- applied new versioning policy, spec in utf-8
155- changed _serverdir, %%{_libdir} => %%{_prefix}/lib
156
157* Fri Dec  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.148-0vl1
158- new upstream release
159- dropped Patch13
160
161* Tue May 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.140-0vl1
162- new upstream release
163- remove banner-ja.png that are now included in upstream
164- update ja.po
165
166* Mon Feb 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.132-0vl4
167- add Patch13 to support -gworkarea
168
169* Fri Dec 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.132-0vl3
170- add banner-ja.png
171
172* Fri Dec 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.132-0vl2
173- add Vine default fontpath to XDMCP(Xnest) option.
174
175* Fri Dec 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.132-0vl1
176- initial build  for Vine Linux
177- add ja.po
178
179* Mon Sep 30 2002 - Erick Woods <erick@gnomepro.com>
180 - This file was created
181
Note: See TracBrowser for help on using the repository browser.