source: projects/specs/trunk/t/trousers/trousers-vl.spec @ 12316

Revision 12316, 10.9 KB checked in by tomop, 4 years ago (diff)

updated 22 packages

actdiag-0.5.4-1

blockdiag-1.5.4-1

clamav-0.102.1-1

ghostscript-9.27-3

git-2.24.1-1

incron-0.5.12-4

iputils-20190709-2

libsass-3.6.3-1

libxslt-1.1.34-1

nginx-1.16.1-4

nsd-4.2.4-1

nwdiag-1.0.4-1

oniguruma-6.9.4-1

php73-7.3.12-1

python-funcparserlib-0.3.6-1

python-webcolors-1.10-1

samba-4.10.10-1

seqdiag-0.9.6-1

strongswan-5.8.1-1

trousers-0.3.14-1

unbound-1.9.6-1

unrar-free-0.0.1.20140707-1

Line 
1%bcond_with systemd
2%global _unpackaged_files_terminate_build 1
3
4Name: trousers
5Summary: TCG's Software Stack v1.2
6Version: 0.3.14
7Release: 1%{?_dist_release}
8Group: System Environment/Libraries
9
10Vendor: Project Vine
11Distribution: Vine Linux
12Packager: tomop
13
14License: BSD
15URL: http://trousers.sourceforge.net
16Source0: https://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
17Source1: tcsd.service
18Source1000: tcsd.init
19Patch1:  trousers-0.3.13-noinline.patch
20Patch2:  trousers-openssl1.1.patch
21
22BuildRequires: libtool, openssl-devel
23Requires(pre): shadow-utils
24Requires: %{name}-lib%{?_isa} = %{version}-%{release}
25%if %{with systemd}
26BuildRequires: systemd
27Requires(post): systemd-units
28Requires(preun): systemd-units
29Requires(postun): systemd-units
30%endif
31
32%description
33TrouSerS is an implementation of the Trusted Computing Group's Software Stack
34(TSS) specification. You can use TrouSerS to write applications that make use
35of your TPM hardware. TPM hardware can create, store and use RSA keys
36securely (without ever being exposed in memory), verify a platform's software
37state using cryptographic hashes and more.
38
39%package lib
40Summary: TrouSerS libtspi library
41Group: Development/Libraries
42# Needed obsoletes due to the -lib subpackage split
43Obsoletes: trousers < 0.3.13-4
44
45%description lib
46The libtspi library for use in Trusted Computing enabled applications.
47
48%package static
49Summary: TrouSerS TCG Device Driver Library
50Group: Development/Libraries
51Requires: %{name}-devel%{?_isa} = %{version}-%{release}
52
53%description static
54The TCG Device Driver Library (TDDL) used by the TrouSerS tcsd as the
55interface to the TPM's device driver. For more information about writing
56applications to the TDDL interface, see the latest TSS spec at
57https://www.trustedcomputinggroup.org/specs/TSS.
58
59%package devel
60Summary: TrouSerS header files and documentation
61Group: Development/Libraries
62Requires: %{name}-lib%{?_isa} = %{version}-%{release}
63
64%description devel
65Header files and man pages for use in creating Trusted Computing enabled
66applications.
67
68%prep
69%setup -q -c
70%patch1 -p1 -b .noinline
71%patch2 -p1 -b .ssl1.1
72# fix man page paths
73sed -i -e 's|/var/tpm|/var/lib/tpm|g' -e 's|/usr/local/var|/var|g' man/man5/tcsd.conf.5.in man/man8/tcsd.8.in
74
75%build
76%configure --with-gui=openssl
77make -k %{?_smp_mflags}
78
79%install
80mkdir -p ${RPM_BUILD_ROOT}/%{_localstatedir}/lib/tpm
81make install DESTDIR=${RPM_BUILD_ROOT} INSTALL="install -p"
82rm -f ${RPM_BUILD_ROOT}/%{_libdir}/libtspi.la
83
84%if %{with systemd}
85mkdir -p $RPM_BUILD_ROOT%{_unitdir}
86install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_unitdir}/
87%else
88mkdir -p $RPM_BUILD_ROOT%{_initdir}
89install -m 0755 %{SOURCE1000} $RPM_BUILD_ROOT%{_initdir}/tcsd
90%endif
91
92%pre
93getent group tss >/dev/null || groupadd -g 59 -r tss
94getent passwd tss >/dev/null || \
95useradd -r -u 59 -g tss -d /dev/null -s /sbin/nologin \
96 -c "Account used by the trousers package to sandbox the tcsd daemon" tss
97exit 0
98
99%post
100%if %{with systemd}
101%systemd_post tcsd.service
102%else
103/sbin/chkconfig --add tcsd
104%endif
105
106%preun
107%if %{with systemd}
108%systemd_preun tcsd.service
109%else
110if [ $1 -eq 0 ]; then
111  /sbin/service tcsd stop
112  /sbin/chkconfig --del tcsd
113fi
114%endif
115
116%postun
117%if %{with systemd}
118%systemd_postun_with_restart tcsd.service
119%else
120if [ $1 -gt 0 ]; then
121  /sbin/service tcsd condrestart
122fi
123%endif
124
125%post lib -p /sbin/ldconfig
126
127%postun lib -p /sbin/ldconfig
128
129%files
130%doc README ChangeLog
131%{_sbindir}/tcsd
132%config(noreplace) %attr(0600, tss, tss) %{_sysconfdir}/tcsd.conf
133%{_mandir}/man5/*
134%{_mandir}/man8/*
135%if %{with systemd}
136%attr(644,root,root) %{_unitdir}/tcsd.service
137%else
138%{_initdir}/tcsd
139%endif
140
141%attr(0700, tss, tss) %{_localstatedir}/lib/tpm/
142
143%files lib
144%{!?_licensedir:%global license %%doc}
145%license LICENSE
146%{_libdir}/libtspi.so.?
147%{_libdir}/libtspi.so.?.?.?
148
149%files devel
150# The files to be used by developers, 'trousers-devel'
151%doc doc/LTC-TSS_LLD_08_r2.pdf doc/TSS_programming_SNAFUs.txt
152%attr(0755, root, root) %{_libdir}/libtspi.so
153%{_includedir}/tss/
154%{_includedir}/trousers/
155%{_mandir}/man3/Tspi_*
156
157%files static
158# The only static library shipped by trousers, the TDDL
159%{_libdir}/libtddl.a
160
161%changelog
162* Wed Nov 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.3.14-1
163- new upstream release.
164
165* Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.3.13-12
166- rebuilt with openssl-1.1.1.
167- enabled Patch2.
168
169* Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.3.13-11
170- initial build for Vine Linux.
171
172* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.13-10
173- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
174
175* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.13-9
176- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
177
178* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.13-8
179- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
180
181* Tue Feb  7 2017 Peter Robinson <pbrobinson@fedoraproject.org> 0.3.13-7
182- Add patch for OpenSSL 1.1
183
184* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.13-6
185- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
186
187* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.13-5
188- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
189
190* Tue May 26 2015 Tomáš Mráz <tmraz@redhat.com> 0.3.13-4
191- Split libtspi to a trousers-lib subpackage (#1225062)
192- Fix FTBFS with current gcc (drop inline keyword when bogus)
193
194* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.13-3
195- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
196
197* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.13-2
198- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
199
200* Thu May 15 2014 Steve Grubb <sgrubb@redhat.com> 0.3.13-1
201- New upstream bug fix release
202
203* Tue Mar 18 2014 Steve Grubb <sgrubb@redhat.com> 0.3.11.2-3
204- Fix crash when linking libgnutls and libmysqlclient (#1069079)
205- Don't order tcsd after syslog.target (#1055198)
206
207* Thu Feb 13 2014 Peter Robinson <pbrobinson@fedoraproject.org> 0.3.11.2-2
208- Minor spec cleanups
209
210* Mon Aug 19 2013 Steve Grubb <sgrubb@redhat.com> 0.3.11.2-1
211- New upstream bug fix and license change release
212
213* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.10-4
214- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
215
216* Sun Jun 02 2013 Steve Grubb <sgrubb@redhat.com> 0.3.10-3
217- Remove +x bit from service file (#963916)
218
219* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.10-2
220- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
221
222* Tue Sep 25 2012 Steve Grubb <sgrubb@redhat.com> 0.3.10-1
223- New upstream bug fix release
224
225* Thu Aug 30 2012 Steve Grubb <sgrubb@redhat.com> 0.3.9-4
226- Make daemon full RELRO
227
228* Mon Aug 27 2012 Steve Grubb <sgrubb@redhat.com> 0.3.9-3
229- bz #836476 - Provide native systemd service
230
231* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.9-2
232- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
233
234* Thu Jun 21 2012 Steve Grubb <sgrubb@redhat.com> 0.3.9-1
235- New upstream bug fix release
236
237* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.6-2
238- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
239
240* Fri Apr 08 2011 Steve Grubb <sgrubb@redhat.com> 0.3.6-1
241- New upstream bug fix release
242
243* Thu Feb 10 2011 Miloš Jakubíček <xjakub@fi.muni.cz> - 0.3.4-5
244- Fix paths in man pages, mark them as %%doc -- fix BZ#676394
245
246* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.4-4
247- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
248
249* Sat May 01 2010 Miloš Jakubíček <xjakub@fi.muni.cz> - 0.3.4-3
250- Fix init script to conform to Fedora guidelines
251- Do not overuse macros
252
253* Mon Feb 08 2010 Steve Grubb <sgrubb@redhat.com> 0.3.4-2
254- Fix issue freeing a data structure
255
256* Fri Jan 29 2010 Steve Grubb <sgrubb@redhat.com> 0.3.4-1
257- New upstream bug fix release
258- Upstream requested the tpm-emulator patch be dropped
259
260* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.3.1-19
261- rebuilt with new openssl
262
263* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.1-18
264- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
265
266* Thu May 14 2009 Milos Jakubicek <xjakub@fi.muni.cz> - 0.3.1-17
267- Do not overuse macros.
268- Removed unnecessary file requirements on chkconfig, ldconfig and service,
269  now requiring the initscripts and chkconfig packages.
270
271* Wed May 06 2009 Milos Jakubicek <xjakub@fi.muni.cz> - 0.3.1-16
272- Fix a typo in groupadd causing the %%pre scriptlet to fail (resolves BZ#486155).
273
274* Mon Apr 27 2009 Milos Jakubicek <xjakub@fi.muni.cz> - 0.3.1-15
275- Fix FTBFS: added trousers-0.3.1-gcc44.patch
276
277* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.1-14
278- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
279
280* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 0.3.1-13
281- rebuild with new openssl
282
283* Tue Dec 16 2008 David Woodhouse <David.Woodhouse@intel.com> - 0.3.1-12
284- Bump release to avoid wrong tag in rawhide
285
286* Tue Dec 16 2008 David Woodhouse <David.Woodhouse@intel.com> - 0.3.1-11
287- Work around SELinux namespace pollution (#464037)
288- Use SO_REUSEADDR
289- Use TPM emulator if it's available and no hardware is
290
291* Fri Aug 08 2008 Emily Ratliff <ratliff@austin.ibm.com> - 0.3.1-10
292- Use the uid/gid pair assigned to trousers from BZ#457593
293
294* Fri Aug 01 2008 Emily Ratliff <ratliff@austin.ibm.com> - 0.3.1-9
295- Incorporated changes from the RHEL package which were done by Steve Grubb
296
297* Wed Jun 04 2008 Emily Ratliff <ratliff@austin.ibm.com> - 0.3.1-8
298- Fix cast issue preventing successful build on ppc64 and x86_64
299
300* Tue Jun 03 2008 Emily Ratliff <ratliff@austin.ibm.com> - 0.3.1-7
301- Fix for BZ #434267 and #440733. Patch authored by Debora Velarde
302
303* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.3.1-6
304- Autorebuild for GCC 4.3
305
306* Mon Dec 17 2007 Kent Yoder <kyoder@users.sf.net> - 0.3.1-5
307- Updated static rpm's comment line (too long)
308
309* Thu Dec 13 2007 Kent Yoder <kyoder@users.sf.net> - 0.3.1-4
310- Updated specfile for RHBZ#323441 comment #28
311
312* Wed Dec 12 2007 Kent Yoder <kyoder@users.sf.net> - 0.3.1-3
313- Updated specfile for RHBZ#323441 comment #22
314
315* Wed Nov 28 2007 Kent Yoder <kyoder@users.sf.net> - 0.3.1-2
316- Updated to include the include dirs in the devel package;
317added the no-install-hooks patch
318
319* Wed Nov 28 2007 Kent Yoder <kyoder@users.sf.net> - 0.3.1-1
320- Updated specfile for RHBZ#323441 comment #13
321
322* Mon Nov 12 2007 Kent Yoder <kyoder@users.sf.net> - 0.3.1
323- Updated specfile for comments in RHBZ#323441
324
325* Wed Jun 07 2006 Kent Yoder <kyoder@users.sf.net> - 0.2.6-1
326- Updated build section to use smp_mflags
327- Removed .la file from installed dest and files section
328
329* Tue Jun 06 2006 Kent Yoder <kyoder@users.sf.net> - 0.2.6-1
330- Initial add of changelog tag for trousers CVS
Note: See TracBrowser for help on using the repository browser.