source: projects/specs/trunk/t/trousers/trousers-vl.spec @ 11578

Revision 11578, 10.6 KB checked in by tomop, 6 years ago (diff)

trousers-0.3.13-11 and strongswan-5.6.2-2

Line 
1%bcond_with systemd
2%global _unpackaged_files_terminate_build 1
3
4Name: trousers
5Summary: TCG's Software Stack v1.2
6Version: 0.3.13
7Release: 11%{?_dist_release}
8License: BSD
9Group: System Environment/Libraries
10Url: http://trousers.sourceforge.net
11Vendor: Project Vine
12Distribution: Vine Linux
13Packager: tomop
14
15Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
16Source1: tcsd.service
17Source1000: tcsd.init
18Patch1:  trousers-0.3.13-noinline.patch
19Patch2:  trousers-openssl1.1.patch
20
21BuildRequires: libtool, openssl-devel
22Requires(pre): shadow-utils
23Requires: %{name}-lib%{?_isa} = %{version}-%{release}
24%if %{with systemd}
25BuildRequires: systemd
26Requires(post): systemd-units
27Requires(preun): systemd-units
28Requires(postun): systemd-units
29%endif
30
31%description
32TrouSerS is an implementation of the Trusted Computing Group's Software Stack
33(TSS) specification. You can use TrouSerS to write applications that make use
34of your TPM hardware. TPM hardware can create, store and use RSA keys
35securely (without ever being exposed in memory), verify a platform's software
36state using cryptographic hashes and more.
37
38%package lib
39Summary: TrouSerS libtspi library
40Group: Development/Libraries
41# Needed obsoletes due to the -lib subpackage split
42Obsoletes: trousers < 0.3.13-4
43
44%description lib
45The libtspi library for use in Trusted Computing enabled applications.
46
47%package static
48Summary: TrouSerS TCG Device Driver Library
49Group: Development/Libraries
50Requires: %{name}-devel%{?_isa} = %{version}-%{release}
51
52%description static
53The TCG Device Driver Library (TDDL) used by the TrouSerS tcsd as the
54interface to the TPM's device driver. For more information about writing
55applications to the TDDL interface, see the latest TSS spec at
56https://www.trustedcomputinggroup.org/specs/TSS.
57
58%package devel
59Summary: TrouSerS header files and documentation
60Group: Development/Libraries
61Requires: %{name}-lib%{?_isa} = %{version}-%{release}
62
63%description devel
64Header files and man pages for use in creating Trusted Computing enabled
65applications.
66
67%prep
68%setup -q
69%patch1 -p1 -b .noinline
70#patch2 -p1 -b .ssl1.1
71# fix man page paths
72sed -i -e 's|/var/tpm|/var/lib/tpm|g' -e 's|/usr/local/var|/var|g' man/man5/tcsd.conf.5.in man/man8/tcsd.8.in
73
74%build
75%configure --with-gui=openssl
76make -k %{?_smp_mflags}
77
78%install
79mkdir -p ${RPM_BUILD_ROOT}/%{_localstatedir}/lib/tpm
80make install DESTDIR=${RPM_BUILD_ROOT} INSTALL="install -p"
81rm -f ${RPM_BUILD_ROOT}/%{_libdir}/libtspi.la
82
83%if %{with systemd}
84mkdir -p $RPM_BUILD_ROOT%{_unitdir}
85install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_unitdir}/
86%else
87mkdir -p $RPM_BUILD_ROOT%{_initdir}
88install -m 0755 %{SOURCE1000} $RPM_BUILD_ROOT%{_initdir}/tcsd
89%endif
90
91%pre
92getent group tss >/dev/null || groupadd -g 59 -r tss
93getent passwd tss >/dev/null || \
94useradd -r -u 59 -g tss -d /dev/null -s /sbin/nologin \
95 -c "Account used by the trousers package to sandbox the tcsd daemon" tss
96exit 0
97
98%post
99%if %{with systemd}
100%systemd_post tcsd.service
101%else
102/sbin/chkconfig --add tcsd
103%endif
104
105%preun
106%if %{with systemd}
107%systemd_preun tcsd.service
108%else
109if [ $1 -eq 0 ]; then
110  /sbin/service tcsd stop
111  /sbin/chkconfig --del tcsd
112fi
113%endif
114
115%postun
116%if %{with systemd}
117%systemd_postun_with_restart tcsd.service
118%else
119if [ $1 -gt 0 ]; then
120  /sbin/service tcsd condrestart
121fi
122%endif
123
124%post lib -p /sbin/ldconfig
125
126%postun lib -p /sbin/ldconfig
127
128%files
129%doc README ChangeLog
130%{_sbindir}/tcsd
131%config(noreplace) %attr(0600, tss, tss) %{_sysconfdir}/tcsd.conf
132%{_mandir}/man5/*
133%{_mandir}/man8/*
134%if %{with systemd}
135%attr(644,root,root) %{_unitdir}/tcsd.service
136%else
137%{_initdir}/tcsd
138%endif
139
140%attr(0700, tss, tss) %{_localstatedir}/lib/tpm/
141
142%files lib
143%{!?_licensedir:%global license %%doc}
144%license LICENSE
145%{_libdir}/libtspi.so.?
146%{_libdir}/libtspi.so.?.?.?
147
148%files devel
149# The files to be used by developers, 'trousers-devel'
150%doc doc/LTC-TSS_LLD_08_r2.pdf doc/TSS_programming_SNAFUs.txt
151%attr(0755, root, root) %{_libdir}/libtspi.so
152%{_includedir}/tss/
153%{_includedir}/trousers/
154%{_mandir}/man3/Tspi_*
155
156%files static
157# The only static library shipped by trousers, the TDDL
158%{_libdir}/libtddl.a
159
160%changelog
161* Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.3.13-11
162- initial build for Vine Linux.
163
164* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.13-10
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
166
167* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.13-9
168- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
169
170* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.13-8
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
172
173* Tue Feb  7 2017 Peter Robinson <pbrobinson@fedoraproject.org> 0.3.13-7
174- Add patch for OpenSSL 1.1
175
176* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.13-6
177- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
178
179* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.13-5
180- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
181
182* Tue May 26 2015 Tomáš Mráz <tmraz@redhat.com> 0.3.13-4
183- Split libtspi to a trousers-lib subpackage (#1225062)
184- Fix FTBFS with current gcc (drop inline keyword when bogus)
185
186* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.13-3
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
188
189* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.13-2
190- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
191
192* Thu May 15 2014 Steve Grubb <sgrubb@redhat.com> 0.3.13-1
193- New upstream bug fix release
194
195* Tue Mar 18 2014 Steve Grubb <sgrubb@redhat.com> 0.3.11.2-3
196- Fix crash when linking libgnutls and libmysqlclient (#1069079)
197- Don't order tcsd after syslog.target (#1055198)
198
199* Thu Feb 13 2014 Peter Robinson <pbrobinson@fedoraproject.org> 0.3.11.2-2
200- Minor spec cleanups
201
202* Mon Aug 19 2013 Steve Grubb <sgrubb@redhat.com> 0.3.11.2-1
203- New upstream bug fix and license change release
204
205* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.10-4
206- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
207
208* Sun Jun 02 2013 Steve Grubb <sgrubb@redhat.com> 0.3.10-3
209- Remove +x bit from service file (#963916)
210
211* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.10-2
212- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
213
214* Tue Sep 25 2012 Steve Grubb <sgrubb@redhat.com> 0.3.10-1
215- New upstream bug fix release
216
217* Thu Aug 30 2012 Steve Grubb <sgrubb@redhat.com> 0.3.9-4
218- Make daemon full RELRO
219
220* Mon Aug 27 2012 Steve Grubb <sgrubb@redhat.com> 0.3.9-3
221- bz #836476 - Provide native systemd service
222
223* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.9-2
224- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
225
226* Thu Jun 21 2012 Steve Grubb <sgrubb@redhat.com> 0.3.9-1
227- New upstream bug fix release
228
229* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.6-2
230- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
231
232* Fri Apr 08 2011 Steve Grubb <sgrubb@redhat.com> 0.3.6-1
233- New upstream bug fix release
234
235* Thu Feb 10 2011 Miloš Jakubíček <xjakub@fi.muni.cz> - 0.3.4-5
236- Fix paths in man pages, mark them as %%doc -- fix BZ#676394
237
238* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.4-4
239- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
240
241* Sat May 01 2010 Miloš Jakubíček <xjakub@fi.muni.cz> - 0.3.4-3
242- Fix init script to conform to Fedora guidelines
243- Do not overuse macros
244
245* Mon Feb 08 2010 Steve Grubb <sgrubb@redhat.com> 0.3.4-2
246- Fix issue freeing a data structure
247
248* Fri Jan 29 2010 Steve Grubb <sgrubb@redhat.com> 0.3.4-1
249- New upstream bug fix release
250- Upstream requested the tpm-emulator patch be dropped
251
252* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.3.1-19
253- rebuilt with new openssl
254
255* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.1-18
256- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
257
258* Thu May 14 2009 Milos Jakubicek <xjakub@fi.muni.cz> - 0.3.1-17
259- Do not overuse macros.
260- Removed unnecessary file requirements on chkconfig, ldconfig and service,
261  now requiring the initscripts and chkconfig packages.
262
263* Wed May 06 2009 Milos Jakubicek <xjakub@fi.muni.cz> - 0.3.1-16
264- Fix a typo in groupadd causing the %%pre scriptlet to fail (resolves BZ#486155).
265
266* Mon Apr 27 2009 Milos Jakubicek <xjakub@fi.muni.cz> - 0.3.1-15
267- Fix FTBFS: added trousers-0.3.1-gcc44.patch
268
269* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.1-14
270- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
271
272* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 0.3.1-13
273- rebuild with new openssl
274
275* Tue Dec 16 2008 David Woodhouse <David.Woodhouse@intel.com> - 0.3.1-12
276- Bump release to avoid wrong tag in rawhide
277
278* Tue Dec 16 2008 David Woodhouse <David.Woodhouse@intel.com> - 0.3.1-11
279- Work around SELinux namespace pollution (#464037)
280- Use SO_REUSEADDR
281- Use TPM emulator if it's available and no hardware is
282
283* Fri Aug 08 2008 Emily Ratliff <ratliff@austin.ibm.com> - 0.3.1-10
284- Use the uid/gid pair assigned to trousers from BZ#457593
285
286* Fri Aug 01 2008 Emily Ratliff <ratliff@austin.ibm.com> - 0.3.1-9
287- Incorporated changes from the RHEL package which were done by Steve Grubb
288
289* Wed Jun 04 2008 Emily Ratliff <ratliff@austin.ibm.com> - 0.3.1-8
290- Fix cast issue preventing successful build on ppc64 and x86_64
291
292* Tue Jun 03 2008 Emily Ratliff <ratliff@austin.ibm.com> - 0.3.1-7
293- Fix for BZ #434267 and #440733. Patch authored by Debora Velarde
294
295* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.3.1-6
296- Autorebuild for GCC 4.3
297
298* Mon Dec 17 2007 Kent Yoder <kyoder@users.sf.net> - 0.3.1-5
299- Updated static rpm's comment line (too long)
300
301* Thu Dec 13 2007 Kent Yoder <kyoder@users.sf.net> - 0.3.1-4
302- Updated specfile for RHBZ#323441 comment #28
303
304* Wed Dec 12 2007 Kent Yoder <kyoder@users.sf.net> - 0.3.1-3
305- Updated specfile for RHBZ#323441 comment #22
306
307* Wed Nov 28 2007 Kent Yoder <kyoder@users.sf.net> - 0.3.1-2
308- Updated to include the include dirs in the devel package;
309added the no-install-hooks patch
310
311* Wed Nov 28 2007 Kent Yoder <kyoder@users.sf.net> - 0.3.1-1
312- Updated specfile for RHBZ#323441 comment #13
313
314* Mon Nov 12 2007 Kent Yoder <kyoder@users.sf.net> - 0.3.1
315- Updated specfile for comments in RHBZ#323441
316
317* Wed Jun 07 2006 Kent Yoder <kyoder@users.sf.net> - 0.2.6-1
318- Updated build section to use smp_mflags
319- Removed .la file from installed dest and files section
320
321* Tue Jun 06 2006 Kent Yoder <kyoder@users.sf.net> - 0.2.6-1
322- Initial add of changelog tag for trousers CVS
Note: See TracBrowser for help on using the repository browser.