source: projects/specs/trunk/t/transmission/transmission-vl.spec @ 7733

Revision 7733, 15.3 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1Name:           transmission
2Version:        2.81
3Release:        1%{?_dist_release}
4Summary:        A lightweight BitTorrent client
5Summary(ja):    軽量な BitTorrent クライアント
6
7Group:          Applications/Internet
8License:        MIT and GPLv2
9URL:            http://www.transmissionbt.com/
10Source0:        http://download.m0k.org/transmission/files/transmission-%{version}.tar.xz
11Source1:        transmission-daemon-init
12#Patch0:         desktop_fix.patch
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  openssl-devel
17BuildRequires:  curl-devel >= 7.18.0
18BuildRequires:  dbus-glib-devel
19BuildRequires:  glib2-devel >= 2.28.0
20BuildRequires:  libnotify-devel
21BuildRequires:  gtk3-devel >= 3.2.0
22BuildRequires:  desktop-file-utils
23BuildRequires:  gettext >= 0.14.1
24BuildRequires:  intltool >= 0.40
25BuildRequires:  libcanberra-devel
26BuildRequires:  libevent-devel
27
28Requires: transmission-cli
29Requires: transmission-gtk
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: kudoh
34
35%description
36Transmission is a free, lightweight BitTorrent client. It features a
37simple, intuitive interface on top on an efficient, cross-platform
38back-end.
39
40%description -l ja
41Transmission はフリーで軽量な BitTorrent クライアントです。
42シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
43
44
45%package common
46Summary: Common files for Transmission BitTorrent client
47Summary(ja): Transmission BitTorrent クライアントの共通ファイル
48Group: Applications/Internet
49Obsoletes:      transmission =< 1.83
50
51%description common
52Transmission is a free, lightweight BitTorrent client. This package
53contains the common files used by the different front-ends.
54
55%description -l ja common
56Transmission はフリーで軽量な BitTorrent クライアントです。
57このパッケージは異なるフロントエンドにより使用される
58共通ファイルを含みます。
59
60%package cli
61Summary:       Transmission command line implementation
62Summary(ja):   Transmission のコマンドライン実装
63Group:         Applications/Internet
64Requires:      transmission-common
65Provides:      transmission = %{version}-%{release}
66
67%description cli
68Command line version of Transmission BitTorrent client.
69
70%description cli -l ja
71Transmission BitTorrent クライアントのコマンドライン版です。
72
73%package daemon
74Summary:       Transmission daemon
75Summary(ja):   Transmission デーモン
76Group:         Applications/Internet
77Requires:      transmission-common
78Requires(pre): shadow-utils
79Requires(post): chkconfig
80Requires(preun): chkconfig
81Requires(preun): initscripts
82Requires(postun): initscripts
83Provides:      transmission = %{version}-%{release}
84
85%description daemon
86Transmission BitTorrent client daemon.
87
88%description daemon -l ja
89Transmission BitTorrent クライアントデーモンです。
90
91%package gtk
92Summary: GTK Interface for Transmission BitTorrent client
93Summary(ja): Transmission BitTorrent client の GTK インターフェイス
94Group: Applications/Internet
95BuildRequires:  gtk3-devel >= 3.2.0
96
97Requires:       %{name}-common = %{version}
98Provides:       %{name} = %{version}-%{release}
99Provides:       %{name}-gui = %{version}-%{release}
100Obsoletes:      transmission =< 1.83
101
102%description gtk
103Transmission is a free, lightweight BitTorrent client. It features a
104simple, intuitive interface on top of an efficient back-end.
105
106This package provides the GTK Interface.
107
108%description -l ja gtk
109Transmission はフリーで軽量な BitTorrent クライアントです。
110シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
111
112このパッケージは GTK インターフェイスを提供します。
113
114%package qt
115Summary: Qt4 Interface for Transmission BitTorrent client
116Summary(ja): Transmission BitTorrent client の Qt4 インターフェイス
117Group: Applications/Internet
118Provides:       %{name}-gui = %{version}-%{release}
119Requires:       %{name}-common = %{version}
120BuildRequires:  qt4-devel qt4-designer
121
122%description qt
123Transmission is a simple BitTorrent client. It features a very simple,
124intuitive interface on top on an efficient, cross-platform back-end.
125
126This package contains QTransmission, a QT4 based GUI for Transmission
127loosely based on the GTK+ client.
128
129%description -l ja qt
130Transmission はフリーで軽量な BitTorrent クライアントです。
131シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
132
133このパッケージは QTransmission - GTK+ クライアントに概ね基づいた
134Transmission の QT4 ベース GUI - を含みます。
135
136%pre daemon
137getent group transmission >/dev/null || groupadd -r transmission
138getent passwd transmission >/dev/null || \
139useradd -r -g transmission -d /var/lib/transmission -s /sbin/nologin \
140        -c "transmission daemon account" transmission
141exit 0
142
143%prep
144%setup -q
145#sed -i "s/x-bittorrent;x-scheme-handler\/magnet;/x-bittorrent;/g" \
146#        gtk/transmission-gtk.desktop.in
147#sed -i "s/OnlyShowIn=Unity/OnlyShowIn=Unity;/g" \
148#        gtk/transmission-gtk.desktop.in
149#%patch0 -p1
150
151%build
152%configure --disable-static --enable-daemon \
153           --enable-utp --enable-nls --enable-cli
154make %{?_smp_mflags} CC=%{__cc}
155#make CFLAGS="$RPM_OPT_FLAGS"
156
157#for QT gui build
158pushd qt
159%{_libdir}/qt4/bin/qmake qtr.pro
160make %{?_smp_mflags}
161popd
162
163%install
164rm -rf $RPM_BUILD_ROOT
165
166mkdir -p %{buildroot}%{_initddir}
167install -m755 %{SOURCE1} %{buildroot}%{_initddir}/transmission-daemon
168mkdir -p %{buildroot}/var/lib/transmission
169
170make install DESTDIR=$RPM_BUILD_ROOT
171make install INSTALL_ROOT=%{buildroot}%{_prefix} -C qt
172
173%find_lang %{name}-gtk
174
175desktop-file-install --vendor "" \
176        --delete-original \
177        --dir $RPM_BUILD_ROOT%{_datadir}/applications/ \
178        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-gtk.desktop
179
180mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
181cat > $RPM_BUILD_ROOT%{_datadir}/applications/transmission-qt.desktop << EOF
182[Desktop Entry]
183Encoding=UTF-8
184Name=Qtransmission Bittorrent Client
185Name[ja]=Qtransmission Bittorrent クライアント
186GenericName=BitTorrent Client
187GenericName[ja]=BitTorrent クライアント
188Comment=Download and share files over BitTorrent
189Comment[ja]=BitTorrent でファイルをダウンロード及び共有します
190Exec=transmission-qt %F
191Icon=transmission
192Terminal=false
193Type=Application
194MimeType=application/x-bittorrent;
195Categories=Network;FileTransfer;P2P;Qt;
196NotShowIn=GNOME;MATE;XFCE;LXDE;
197EOF
198
199%clean
200rm -rf $RPM_BUILD_ROOT
201
202%post daemon
203/sbin/chkconfig --add transmission-daemon
204
205
206%post gtk
207touch --no-create %{_datadir}/icons/hicolor || :
208%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
209update-desktop-database > /dev/null 2>&1 || :
210
211
212%postun gtk
213touch --no-create %{_datadir}/icons/hicolor || :
214%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
215update-desktop-database > /dev/null 2>&1 || :
216
217%preun daemon
218if [ $1 = 0 ] ; then
219    /sbin/service transmission-daemon stop >/dev/null 2>&1
220    /sbin/chkconfig --del transmission-daemon
221fi
222
223%postun daemon
224if [ "$1" -ge "1" ] ; then
225    /sbin/service transmission-daemon condrestart >/dev/null 2>&1 || :
226fi
227
228%files
229
230%files common
231%defattr(-, root, root, -)
232%doc AUTHORS COPYING NEWS README
233%{_bindir}/transmission-create
234%{_bindir}/transmission-edit
235%{_bindir}/transmission-remote
236%{_bindir}/transmission-show
237%{_datadir}/transmission/web/
238%{_datadir}/pixmaps/*
239%{_datadir}/icons/hicolor/*/apps/transmission.*
240%doc %{_mandir}/man1/transmission-create*
241%doc %{_mandir}/man1/transmission-edit*
242%doc %{_mandir}/man1/transmission-remote*
243%doc %{_mandir}/man1/transmission-show*
244
245%files cli
246%defattr(-, root, root, -)
247%{_bindir}/transmission-cli
248%doc %{_mandir}/man1/transmission-cli*
249
250%files daemon
251%defattr(-, root, root, -)
252%{_bindir}/transmission-daemon
253%{_initddir}/transmission-daemon
254%attr(-,transmission, transmission)/var/lib/transmission/
255%doc %{_mandir}/man1/transmission-daemon*
256
257%files gtk -f %{name}-gtk.lang
258%defattr(-,root,root)
259%{_bindir}/%{name}-gtk
260%{_datadir}/applications/%{name}-gtk.desktop
261%{_mandir}/man1/transmission-gtk.1*
262
263%files qt
264%defattr(-,root,root)
265%{_bindir}/transmission-qt
266%{_datadir}/applications/transmission-qt.desktop
267%{_mandir}/man1/transmission-qt.1*
268
269%changelog
270* Sat Jul 20 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.81-1
271- new upstream release
272
273* Sat Jun 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.80-1
274- new upstream release
275
276* Sun Feb 24 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.77-1
277- new upstream release
278
279* Fri Jan 11 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.76-1
280- new upstream release
281
282* Fri Dec 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.75-1
283- new upstream release
284
285* Thu Oct 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.73-1
286- new upstream release
287
288* Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.72-1
289- new upstream release
290
291* Thu Sep 27 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.71-1
292- new upstream release
293- deleted Patch0
294- changed BuildRequires: gtk3-devel >= 3.4.0
295
296* Wed Jul 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.61-1
297- new upstream release
298- deleted conditional branch for GTK+2
299  - because not supported GTK+2, GTK+3 only
300
301* Sat Jul 07 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.60-1
302- new upstream release
303
304* Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.52-1
305- new upstream release
306- added patch0 to fix .desktop validate
307
308* Thu Apr 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.51-1
309- new upstream release
310- fixed conditional branch
311
312* Thu Feb 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.50-1
313- new upstream release
314- deleted unrecognized option: --enable-gtk
315- fixed transmission-qt desktop entry a little
316
317* Wed Nov 09 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.42-1
318- new upstream release
319- aded BuildRequires: gtk3-devel >= 3.2.0
320  - made conditional branch for Vine 6 (support for GTK+2)
321
322* Mon Oct 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.41-1
323- new upstream release
324- changed BuildRequires
325  - gtk2-devel >= 2.6.0 to gtk2-devel >= 2.22.0
326  - glib2-devel >= 2.28.0
327- deleted unrecognized option: --enable-libcanberra
328
329* Thu Aug 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.33-1
330- new upstream release
331- remove BuildRequires: GConf2-devel
332
333* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32-2
334- rebuild with libnotify-0.7
335
336* Sun Jul 03 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.32-1
337- new upstream release
338
339* Thu May 19 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.31-1
340- new upstream release
341- suppressed warning in installing desktop file
342- added configure option
343  --enable-utp, --enable-nls, --enable-cli, --enable-daemon
344
345* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22-1
346- update to 2.22
347
348* Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.20-1
349- Update to upstream 2.20
350
351* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.13-2
352- rebuilt with openssl-1.0.0c
353
354* Sat Dec 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.13-1
355- Update to upstream 2.13
356- deleted disable option
357- added configure option --enable-gtk
358
359* Mon Nov 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.12-1
360- Update to upstream 2.12
361
362* Mon Oct 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.11-1
363- Update to upstream 2.11
364
365* Thu Oct 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.10-2
366- fixed and changed transmission-qt.desktop
367  - did not show transmission-qt.desktop in LXDE
368
369* Mon Oct 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.10-1
370- Update to upstream 2.10
371
372* Mon Aug 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.04-1
373- Update to upstream 2.04
374
375* Fri Jul 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.03-1
376- Update to upstream 2.03
377
378* Fri Jul 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.01-1
379- Update to upstream 2.01
380
381* Fri Jun 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.00-1
382- Update to upstream 2.00
383
384* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.93-1
385- Update to upstream 1.93
386
387* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.92-1
388- Update to upstream 1.92
389- applied new naming policy to spec
390
391* Mon Feb 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.91-1
392- Update to upstream 1.91
393- changed summary, summary(ja) a little
394- added %configure option --enable-libcanberra --enable-daemon
395- added Source1 from Fedora
396- splitted common, cli, daemon, gtk, qt packages
397
398* Sat Jan 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.83-1
399- Update to upstream 1.83
400- added BuildRequires:  libcanberra-devel, libevent-devel
401
402* Sun Jan 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.82-1
403- Update to upstream 1.82
404
405* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.80-1
406- Update to upstream 1.80
407- changed BuildRequires: intltool >= 0.40
408
409* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.77-1
410- Update to upstream 1.77
411- dropt Patch1
412- aded BuildRequires:  GConf2-devel
413
414* Mon Oct 26 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.76-1
415- Update to upstream 1.76
416
417* Tue Sep 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.75-2
418- a few fixed transmission_ja_po.patch
419- added --disable-static=no to configure option
420- run gtk-update-icon-cache in %post, %postun
421- cleaned up spec
422
423* Tue Sep 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.75-1
424- Update to upstream 1.75
425
426* Sun Jul 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.73-1
427- Update to upstream 1.73
428
429* Sun Jun 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.72-1
430- Update to upstream 1.72
431- cleaned up spec
432
433* Tue Jun 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.71-1
434- Update to upstream 1.71
435
436* Sat Jun 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.70-1
437- Update to upstream 1.70
438
439* Tue May 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.61-1
440- Update to upstream 1.61
441- added BuildRequires:  glib2-devel
442
443* Wed May 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.60-1
444- Update to upstream 1.60
445- spec in UTF-8
446
447* Mon Apr 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.52-1
448- Update to upstream 1.52
449- fixed Desktop-file name
450- fixed BuildRoot
451
452* Sat Feb 28 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.51-1
453- Update to upstream 1.51
454- changed BuildRequires:  curl-devel >= 7.18.0
455- dropped Patch1
456
457* Sun Feb 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.50-1
458- Update to upstream 1.50
459
460* Thu Jan 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.42-2
461- added Summary(ja)
462- fixed Lisense
463- added patch1 (transmission-1.42-libevent.patch, from Fedora)
464- fixed %build
465- changed %install
466- fixed %changelog
467
468* Sat Dec 27 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.42-1
469- initial build for VineSeed
470- Update to upstream 1.42
471- dropped Patch0 (transmission-0.71-manpath.patch)
472- added patch0 (transmission_ja_po.patch, to fix ja.po)
473- modified %files, %install
474- modified BuildRoot
475- added BuildRequires to curl-devel, dbus-glib-devel, libnotify-devel
476
477* Mon Feb 4 2008 Denis Leroy <denis@poolshark.org> - 1.04-1
478- Update to upstream 1.04
479- Modified Build-Require
480
481* Thu Aug 16 2007 Denis Leroy <denis@poolshark.org> - 0.80-1
482- Update to upstream 0.80
483
484* Wed May  2 2007 Denis Leroy <denis@poolshark.org> - 0.72-1
485- Update to 0.72
486- Added libevent BR
487
488* Wed Apr 25 2007 Denis Leroy <denis@poolshark.org> - 0.71-1
489- Update to 0.71
490- Removed custom desktop file
491- Added patch to fix manpath
492
493* Thu Sep 28 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-3
494- Added project icon
495- Honor cc variable
496
497* Mon Sep 25 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-2
498- Removed ldconfig Requires
499
500* Wed Sep 13 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-1
501- First version
502
Note: See TracBrowser for help on using the repository browser.