source: projects/specs/trunk/t/transmission/transmission-vl.spec @ 6244

Revision 6244, 14.5 KB checked in by kudoh, 12 years ago (diff)
Line 
1Name:           transmission
2Version:        2.52
3Release:        1%{?_dist_release}
4Summary:        A lightweight BitTorrent client
5Summary(ja):    軽量な BitTorrent クライアント
6
7Group:          Applications/Internet
8License:        MIT and GPLv2
9URL:            http://www.transmissionbt.com/
10Source0:        http://download.m0k.org/transmission/files/transmission-%{version}.tar.xz
11Source1:        transmission-daemon-init
12Patch0:         desktop_fix.patch
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  openssl-devel
17BuildRequires:  curl-devel >= 7.18.0
18BuildRequires:  dbus-glib-devel
19BuildRequires:  glib2-devel >= 2.28.0
20BuildRequires:  libnotify-devel
21
22%if %{?_dist_release} == "vl6"
23BuildRequires:  gtk2-devel >= 2.22.0
24%elif
25BuildRequires:  gtk3-devel >= 3.2.0
26%endif
27
28BuildRequires:  desktop-file-utils
29BuildRequires:  gettext >= 0.14.1
30BuildRequires:  intltool >= 0.40
31BuildRequires:  libcanberra-devel
32BuildRequires:  libevent-devel
33
34Requires: transmission-cli
35Requires: transmission-gtk
36
37Vendor: Project Vine
38Distribution: Vine Linux
39Packager: kudoh
40
41%description
42Transmission is a free, lightweight BitTorrent client. It features a
43simple, intuitive interface on top on an efficient, cross-platform
44back-end.
45
46%description -l ja
47Transmission はフリーで軽量な BitTorrent クライアントです。
48シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
49
50
51%package common
52Summary: Common files for Transmission BitTorrent client
53Summary(ja): Transmission BitTorrent クライアントの共通ファイル
54Group: Applications/Internet
55Obsoletes:      transmission =< 1.83
56
57%description common
58Transmission is a free, lightweight BitTorrent client. This package
59contains the common files used by the different front-ends.
60
61%description -l ja common
62Transmission はフリーで軽量な BitTorrent クライアントです。
63このパッケージは異なるフロントエンドにより使用される
64共通ファイルを含みます。
65
66%package cli
67Summary:       Transmission command line implementation
68Summary(ja):   Transmission のコマンドライン実装
69Group:         Applications/Internet
70Requires:      transmission-common
71Provides:      transmission = %{version}-%{release}
72
73%description cli
74Command line version of Transmission BitTorrent client.
75
76%description cli -l ja
77Transmission BitTorrent クライアントのコマンドライン版です。
78
79%package daemon
80Summary:       Transmission daemon
81Summary(ja):   Transmission デーモン
82Group:         Applications/Internet
83Requires:      transmission-common
84Requires(pre): shadow-utils
85Requires(post): chkconfig
86Requires(preun): chkconfig
87Requires(preun): initscripts
88Requires(postun): initscripts
89Provides:      transmission = %{version}-%{release}
90
91%description daemon
92Transmission BitTorrent client daemon.
93
94%description daemon -l ja
95Transmission BitTorrent クライアントデーモンです。
96
97%package gtk
98Summary: GTK Interface for Transmission BitTorrent client
99Summary(ja): Transmission BitTorrent client の GTK インターフェイス
100Group: Applications/Internet
101
102%if %{?_dist_release} == "vl6"
103BuildRequires:  gtk2-devel >= 2.22.0
104%elif
105BuildRequires:  gtk3-devel >= 3.2.0
106%endif
107
108Requires:       %{name}-common = %{version}
109Provides:       %{name} = %{version}-%{release}
110Provides:       %{name}-gui = %{version}-%{release}
111Obsoletes:      transmission =< 1.83
112
113%description gtk
114Transmission is a free, lightweight BitTorrent client. It features a
115simple, intuitive interface on top of an efficient back-end.
116
117This package provides the GTK Interface.
118
119%description -l ja gtk
120Transmission はフリーで軽量な BitTorrent クライアントです。
121シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
122
123このパッケージは GTK インターフェイスを提供します。
124
125%package qt
126Summary: Qt4 Interface for Transmission BitTorrent client
127Summary(ja): Transmission BitTorrent client の Qt4 インターフェイス
128Group: Applications/Internet
129Provides:       %{name}-gui = %{version}-%{release}
130Requires:       %{name}-common = %{version}
131BuildRequires:  qt4-devel qt4-designer
132
133%description qt
134Transmission is a simple BitTorrent client. It features a very simple,
135intuitive interface on top on an efficient, cross-platform back-end.
136
137This package contains QTransmission, a QT4 based GUI for Transmission
138loosely based on the GTK+ client.
139
140%description -l ja qt
141Transmission はフリーで軽量な BitTorrent クライアントです。
142シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
143
144このパッケージは QTransmission - GTK+ クライアントに概ね基づいた
145Transmission の QT4 ベース GUI - を含みます。
146
147%pre daemon
148getent group transmission >/dev/null || groupadd -r transmission
149getent passwd transmission >/dev/null || \
150useradd -r -g transmission -d /var/lib/transmission -s /sbin/nologin \
151        -c "transmission daemon account" transmission
152exit 0
153
154%prep
155%setup -q
156#sed -i "s/x-bittorrent;x-scheme-handler\/magnet;/x-bittorrent;/g" \
157#        gtk/transmission-gtk.desktop.in
158#sed -i "s/OnlyShowIn=Unity/OnlyShowIn=Unity;/g" \
159#        gtk/transmission-gtk.desktop.in
160%patch0 -p1
161
162%build
163%configure --disable-static --enable-daemon \
164           --enable-utp --enable-nls --enable-cli
165make %{?_smp_mflags} CC=%{__cc}
166#make CFLAGS="$RPM_OPT_FLAGS"
167
168#for QT gui build
169pushd qt
170%{_libdir}/qt4/bin/qmake qtr.pro
171make %{?_smp_mflags}
172popd
173
174%install
175rm -rf $RPM_BUILD_ROOT
176
177mkdir -p %{buildroot}%{_initddir}
178install -m755 %{SOURCE1} %{buildroot}%{_initddir}/transmission-daemon
179mkdir -p %{buildroot}/var/lib/transmission
180
181make install DESTDIR=$RPM_BUILD_ROOT
182make install INSTALL_ROOT=%{buildroot}%{_prefix} -C qt
183
184%find_lang %{name}-gtk
185
186desktop-file-install --vendor "" \
187        --delete-original \
188        --dir $RPM_BUILD_ROOT%{_datadir}/applications/ \
189        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-gtk.desktop
190
191mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
192cat > $RPM_BUILD_ROOT%{_datadir}/applications/transmission-qt.desktop << EOF
193[Desktop Entry]
194Encoding=UTF-8
195Name=Qtransmission Bittorrent Client
196Name[ja]=Qtransmission Bittorrent クライアント
197GenericName=BitTorrent Client
198GenericName[ja]=BitTorrent クライアント
199Comment=Download and share files over BitTorrent
200Comment[ja]=BitTorrent でファイルをダウンロード及び共有します
201Exec=transmission-qt %F
202Icon=transmission
203Terminal=false
204Type=Application
205MimeType=application/x-bittorrent;
206Categories=Network;FileTransfer;P2P;Qt;
207NotShowIn=GNOME;MATE;XFCE;LXDE;
208EOF
209
210%clean
211rm -rf $RPM_BUILD_ROOT
212
213%post daemon
214/sbin/chkconfig --add transmission-daemon
215
216
217%post gtk
218touch --no-create %{_datadir}/icons/hicolor || :
219%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
220update-desktop-database > /dev/null 2>&1 || :
221
222
223%postun gtk
224touch --no-create %{_datadir}/icons/hicolor || :
225%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
226update-desktop-database > /dev/null 2>&1 || :
227
228%preun daemon
229if [ $1 = 0 ] ; then
230    /sbin/service transmission-daemon stop >/dev/null 2>&1
231    /sbin/chkconfig --del transmission-daemon
232fi
233
234%postun daemon
235if [ "$1" -ge "1" ] ; then
236    /sbin/service transmission-daemon condrestart >/dev/null 2>&1 || :
237fi
238
239%files
240
241%files common
242%defattr(-, root, root, -)
243%doc AUTHORS COPYING NEWS README
244%{_bindir}/transmission-create
245%{_bindir}/transmission-edit
246%{_bindir}/transmission-remote
247%{_bindir}/transmission-show
248%{_datadir}/transmission/web/
249%{_datadir}/pixmaps/*
250%{_datadir}/icons/hicolor/*/apps/transmission.*
251%doc %{_mandir}/man1/transmission-create*
252%doc %{_mandir}/man1/transmission-edit*
253%doc %{_mandir}/man1/transmission-remote*
254%doc %{_mandir}/man1/transmission-show*
255
256%files cli
257%defattr(-, root, root, -)
258%{_bindir}/transmission-cli
259%doc %{_mandir}/man1/transmission-cli*
260
261%files daemon
262%defattr(-, root, root, -)
263%{_bindir}/transmission-daemon
264%{_initddir}/transmission-daemon
265%attr(-,transmission, transmission)/var/lib/transmission/
266%doc %{_mandir}/man1/transmission-daemon*
267
268%files gtk -f %{name}-gtk.lang
269%defattr(-,root,root)
270%{_bindir}/%{name}-gtk
271%{_datadir}/applications/%{name}-gtk.desktop
272%{_mandir}/man1/transmission-gtk.1*
273
274%files qt
275%defattr(-,root,root)
276%{_bindir}/transmission-qt
277%{_datadir}/applications/transmission-qt.desktop
278%{_mandir}/man1/transmission-qt.1*
279
280%changelog
281* Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.52-1
282- new upstream release
283- added patch0 to fix .desktop validate
284
285* Thu Apr 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.51-1
286- new upstream release
287- fixed conditional branch
288
289* Thu Feb 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.50-1
290- new upstream release
291- deleted unrecognized option: --enable-gtk
292- fixed transmission-qt desktop entry a little
293
294* Wed Nov 09 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.42-1
295- new upstream release
296- aded BuildRequires: gtk3-devel >= 3.2.0
297  - made conditional branch for Vine 6 (support for GTK+2)
298
299* Mon Oct 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.41-1
300- new upstream release
301- changed BuildRequires
302  - gtk2-devel >= 2.6.0 to gtk2-devel >= 2.22.0
303  - glib2-devel >= 2.28.0
304- deleted unrecognized option: --enable-libcanberra
305
306* Thu Aug 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.33-1
307- new upstream release
308- remove BuildRequires: GConf2-devel
309
310* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32-2
311- rebuild with libnotify-0.7
312
313* Sun Jul 03 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.32-1
314- new upstream release
315
316* Thu May 19 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.31-1
317- new upstream release
318- suppressed warning in installing desktop file
319- added configure option
320  --enable-utp, --enable-nls, --enable-cli, --enable-daemon
321
322* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22-1
323- update to 2.22
324
325* Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.20-1
326- Update to upstream 2.20
327
328* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.13-2
329- rebuilt with openssl-1.0.0c
330
331* Sat Dec 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.13-1
332- Update to upstream 2.13
333- deleted disable option
334- added configure option --enable-gtk
335
336* Mon Nov 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.12-1
337- Update to upstream 2.12
338
339* Mon Oct 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.11-1
340- Update to upstream 2.11
341
342* Thu Oct 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.10-2
343- fixed and changed transmission-qt.desktop
344  - did not show transmission-qt.desktop in LXDE
345
346* Mon Oct 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.10-1
347- Update to upstream 2.10
348
349* Mon Aug 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.04-1
350- Update to upstream 2.04
351
352* Fri Jul 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.03-1
353- Update to upstream 2.03
354
355* Fri Jul 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.01-1
356- Update to upstream 2.01
357
358* Fri Jun 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.00-1
359- Update to upstream 2.00
360
361* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.93-1
362- Update to upstream 1.93
363
364* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.92-1
365- Update to upstream 1.92
366- applied new naming policy to spec
367
368* Mon Feb 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.91-1
369- Update to upstream 1.91
370- changed summary, summary(ja) a little
371- added %configure option --enable-libcanberra --enable-daemon
372- added Source1 from Fedora
373- splitted common, cli, daemon, gtk, qt packages
374
375* Sat Jan 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.83-1
376- Update to upstream 1.83
377- added BuildRequires:  libcanberra-devel, libevent-devel
378
379* Sun Jan 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.82-1
380- Update to upstream 1.82
381
382* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.80-1
383- Update to upstream 1.80
384- changed BuildRequires: intltool >= 0.40
385
386* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.77-1
387- Update to upstream 1.77
388- dropt Patch1
389- aded BuildRequires:  GConf2-devel
390
391* Mon Oct 26 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.76-1
392- Update to upstream 1.76
393
394* Tue Sep 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.75-2
395- a few fixed transmission_ja_po.patch
396- added --disable-static=no to configure option
397- run gtk-update-icon-cache in %post, %postun
398- cleaned up spec
399
400* Tue Sep 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.75-1
401- Update to upstream 1.75
402
403* Sun Jul 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.73-1
404- Update to upstream 1.73
405
406* Sun Jun 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.72-1
407- Update to upstream 1.72
408- cleaned up spec
409
410* Tue Jun 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.71-1
411- Update to upstream 1.71
412
413* Sat Jun 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.70-1
414- Update to upstream 1.70
415
416* Tue May 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.61-1
417- Update to upstream 1.61
418- added BuildRequires:  glib2-devel
419
420* Wed May 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.60-1
421- Update to upstream 1.60
422- spec in UTF-8
423
424* Mon Apr 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.52-1
425- Update to upstream 1.52
426- fixed Desktop-file name
427- fixed BuildRoot
428
429* Sat Feb 28 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.51-1
430- Update to upstream 1.51
431- changed BuildRequires:  curl-devel >= 7.18.0
432- dropped Patch1
433
434* Sun Feb 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.50-1
435- Update to upstream 1.50
436
437* Thu Jan 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.42-2
438- added Summary(ja)
439- fixed Lisense
440- added patch1 (transmission-1.42-libevent.patch, from Fedora)
441- fixed %build
442- changed %install
443- fixed %changelog
444
445* Sat Dec 27 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.42-1
446- initial build for VineSeed
447- Update to upstream 1.42
448- dropped Patch0 (transmission-0.71-manpath.patch)
449- added patch0 (transmission_ja_po.patch, to fix ja.po)
450- modified %files, %install
451- modified BuildRoot
452- added BuildRequires to curl-devel, dbus-glib-devel, libnotify-devel
453
454* Thu Feb 4 2008 Denis Leroy <denis@poolshark.org> - 1.04-1
455- Update to upstream 1.04
456- Modified Build-Require
457
458* Thu Aug 16 2007 Denis Leroy <denis@poolshark.org> - 0.80-1
459- Update to upstream 0.80
460
461* Wed May  2 2007 Denis Leroy <denis@poolshark.org> - 0.72-1
462- Update to 0.72
463- Added libevent BR
464
465* Wed Apr 25 2007 Denis Leroy <denis@poolshark.org> - 0.71-1
466- Update to 0.71
467- Removed custom desktop file
468- Added patch to fix manpath
469
470* Thu Sep 28 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-3
471- Added project icon
472- Honor cc variable
473
474* Mon Sep 25 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-2
475- Removed ldconfig Requires
476
477* Wed Sep 13 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-1
478- First version
479
Note: See TracBrowser for help on using the repository browser.