source: projects/specs/trunk/t/transmission/transmission-vl.spec @ 6077

Revision 6077, 14.2 KB checked in by kudoh, 12 years ago (diff)
Line 
1Name:           transmission
2Version:        2.51
3Release:        1%{?_dist_release}
4Summary:        A lightweight BitTorrent client
5Summary(ja):    軽量な BitTorrent クライアント
6
7Group:          Applications/Internet
8License:        MIT and GPLv2
9URL:            http://www.transmissionbt.com/
10Source0:        http://download.m0k.org/transmission/files/transmission-%{version}.tar.xz
11Source1:        transmission-daemon-init
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires:  openssl-devel
16BuildRequires:  curl-devel >= 7.18.0
17BuildRequires:  dbus-glib-devel
18BuildRequires:  glib2-devel >= 2.28.0
19BuildRequires:  libnotify-devel
20
21%if %{?_dist_release} == "vl6"
22BuildRequires:  gtk2-devel >= 2.22.0
23%elif
24BuildRequires:  gtk3-devel >= 3.2.0
25%endif
26
27BuildRequires:  desktop-file-utils
28BuildRequires:  gettext >= 0.14.1
29BuildRequires:  intltool >= 0.40
30BuildRequires:  libcanberra-devel
31BuildRequires:  libevent-devel
32
33Requires: transmission-cli
34Requires: transmission-gtk
35
36Vendor: Project Vine
37Distribution: Vine Linux
38Packager: kudoh
39
40%description
41Transmission is a free, lightweight BitTorrent client. It features a
42simple, intuitive interface on top on an efficient, cross-platform
43back-end.
44
45%description -l ja
46Transmission はフリーで軽量な BitTorrent クライアントです。
47シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
48
49
50%package common
51Summary: Common files for Transmission BitTorrent client
52Summary(ja): Transmission BitTorrent クライアントの共通ファイル
53Group: Applications/Internet
54Obsoletes:      transmission =< 1.83
55
56%description common
57Transmission is a free, lightweight BitTorrent client. This package
58contains the common files used by the different front-ends.
59
60%description -l ja common
61Transmission はフリーで軽量な BitTorrent クライアントです。
62このパッケージは異なるフロントエンドにより使用される
63共通ファイルを含みます。
64
65%package cli
66Summary:       Transmission command line implementation
67Summary(ja):   Transmission のコマンドライン実装
68Group:         Applications/Internet
69Requires:      transmission-common
70Provides:      transmission = %{version}-%{release}
71
72%description cli
73Command line version of Transmission BitTorrent client.
74
75%description cli -l ja
76Transmission BitTorrent クライアントのコマンドライン版です。
77
78%package daemon
79Summary:       Transmission daemon
80Summary(ja):   Transmission デーモン
81Group:         Applications/Internet
82Requires:      transmission-common
83Requires(pre): shadow-utils
84Requires(post): chkconfig
85Requires(preun): chkconfig
86Requires(preun): initscripts
87Requires(postun): initscripts
88Provides:      transmission = %{version}-%{release}
89
90%description daemon
91Transmission BitTorrent client daemon.
92
93%description daemon -l ja
94Transmission BitTorrent クライアントデーモンです。
95
96%package gtk
97Summary: GTK Interface for Transmission BitTorrent client
98Summary(ja): Transmission BitTorrent client の GTK インターフェイス
99Group: Applications/Internet
100
101%if %{?_dist_release} == "vl6"
102BuildRequires:  gtk2-devel >= 2.22.0
103%elif
104BuildRequires:  gtk3-devel >= 3.2.0
105%endif
106
107Requires:       %{name}-common = %{version}
108Provides:       %{name} = %{version}-%{release}
109Provides:       %{name}-gui = %{version}-%{release}
110Obsoletes:      transmission =< 1.83
111
112%description gtk
113Transmission is a free, lightweight BitTorrent client. It features a
114simple, intuitive interface on top of an efficient back-end.
115
116This package provides the GTK Interface.
117
118%description -l ja gtk
119Transmission はフリーで軽量な BitTorrent クライアントです。
120シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
121
122このパッケージは GTK インターフェイスを提供します。
123
124%package qt
125Summary: Qt4 Interface for Transmission BitTorrent client
126Summary(ja): Transmission BitTorrent client の Qt4 インターフェイス
127Group: Applications/Internet
128Provides:       %{name}-gui = %{version}-%{release}
129Requires:       %{name}-common = %{version}
130BuildRequires:  qt4-devel qt4-designer
131
132%description qt
133Transmission is a simple BitTorrent client. It features a very simple,
134intuitive interface on top on an efficient, cross-platform back-end.
135
136This package contains QTransmission, a QT4 based GUI for Transmission
137loosely based on the GTK+ client.
138
139%description -l ja qt
140Transmission はフリーで軽量な BitTorrent クライアントです。
141シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
142
143このパッケージは QTransmission - GTK+ クライアントに概ね基づいた
144Transmission の QT4 ベース GUI - を含みます。
145
146%pre daemon
147getent group transmission >/dev/null || groupadd -r transmission
148getent passwd transmission >/dev/null || \
149useradd -r -g transmission -d /var/lib/transmission -s /sbin/nologin \
150        -c "transmission daemon account" transmission
151exit 0
152
153%prep
154%setup -q
155sed -i "s/x-bittorrent;x-scheme-handler\/magnet;/x-bittorrent;/g" \
156        gtk/transmission-gtk.desktop.in
157
158%build
159%configure --disable-static --enable-daemon \
160           --enable-utp --enable-nls --enable-cli
161make %{?_smp_mflags} CC=%{__cc}
162#make CFLAGS="$RPM_OPT_FLAGS"
163
164#for QT gui build
165pushd qt
166%{_libdir}/qt4/bin/qmake qtr.pro
167make %{?_smp_mflags}
168popd
169
170%install
171rm -rf $RPM_BUILD_ROOT
172
173mkdir -p %{buildroot}%{_initddir}
174install -m755 %{SOURCE1} %{buildroot}%{_initddir}/transmission-daemon
175mkdir -p %{buildroot}/var/lib/transmission
176
177make install DESTDIR=$RPM_BUILD_ROOT
178make install INSTALL_ROOT=%{buildroot}%{_prefix} -C qt
179
180%find_lang %{name}-gtk
181
182desktop-file-install --vendor "" \
183        --delete-original \
184        --dir $RPM_BUILD_ROOT%{_datadir}/applications/ \
185        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-gtk.desktop
186
187mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
188cat > $RPM_BUILD_ROOT%{_datadir}/applications/transmission-qt.desktop << EOF
189[Desktop Entry]
190Encoding=UTF-8
191Name=Qtransmission Bittorrent Client
192Name[ja]=Qtransmission Bittorrent クライアント
193GenericName=BitTorrent Client
194GenericName[ja]=BitTorrent クライアント
195Comment=Download and share files over BitTorrent
196Comment[ja]=BitTorrent でファイルをダウンロード及び共有します
197Exec=transmission-qt %F
198Icon=transmission
199Terminal=false
200Type=Application
201MimeType=application/x-bittorrent;
202Categories=Network;FileTransfer;P2P;Qt;
203NotShowIn=GNOME;MATE;XFCE;LXDE;
204EOF
205
206%clean
207rm -rf $RPM_BUILD_ROOT
208
209%post daemon
210/sbin/chkconfig --add transmission-daemon
211
212
213%post gtk
214touch --no-create %{_datadir}/icons/hicolor || :
215%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
216update-desktop-database > /dev/null 2>&1 || :
217
218
219%postun gtk
220touch --no-create %{_datadir}/icons/hicolor || :
221%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
222update-desktop-database > /dev/null 2>&1 || :
223
224%preun daemon
225if [ $1 = 0 ] ; then
226    /sbin/service transmission-daemon stop >/dev/null 2>&1
227    /sbin/chkconfig --del transmission-daemon
228fi
229
230%postun daemon
231if [ "$1" -ge "1" ] ; then
232    /sbin/service transmission-daemon condrestart >/dev/null 2>&1 || :
233fi
234
235%files
236
237%files common
238%defattr(-, root, root, -)
239%doc AUTHORS COPYING NEWS README
240%{_bindir}/transmission-create
241%{_bindir}/transmission-edit
242%{_bindir}/transmission-remote
243%{_bindir}/transmission-show
244%{_datadir}/transmission/web/
245%{_datadir}/pixmaps/*
246%{_datadir}/icons/hicolor/*/apps/transmission.*
247%doc %{_mandir}/man1/transmission-create*
248%doc %{_mandir}/man1/transmission-edit*
249%doc %{_mandir}/man1/transmission-remote*
250%doc %{_mandir}/man1/transmission-show*
251
252%files cli
253%defattr(-, root, root, -)
254%{_bindir}/transmission-cli
255%doc %{_mandir}/man1/transmission-cli*
256
257%files daemon
258%defattr(-, root, root, -)
259%{_bindir}/transmission-daemon
260%{_initddir}/transmission-daemon
261%attr(-,transmission, transmission)/var/lib/transmission/
262%doc %{_mandir}/man1/transmission-daemon*
263
264%files gtk -f %{name}-gtk.lang
265%defattr(-,root,root)
266%{_bindir}/%{name}-gtk
267%{_datadir}/applications/%{name}-gtk.desktop
268%{_mandir}/man1/transmission-gtk.1*
269
270%files qt
271%defattr(-,root,root)
272%{_bindir}/transmission-qt
273%{_datadir}/applications/transmission-qt.desktop
274%{_mandir}/man1/transmission-qt.1*
275
276%changelog
277* Thu Apr 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.51-1
278- new upstream release
279- fixed conditional branch
280
281* Thu Feb 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.50-1
282- new upstream release
283- deleted unrecognized option: --enable-gtk
284- fixed transmission-qt desktop entry a little
285
286* Wed Nov 09 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.42-1
287- new upstream release
288- aded BuildRequires: gtk3-devel >= 3.2.0
289  - made conditional branch for Vine 6 (support for GTK+2)
290
291* Mon Oct 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.41-1
292- new upstream release
293- changed BuildRequires
294  - gtk2-devel >= 2.6.0 to gtk2-devel >= 2.22.0
295  - glib2-devel >= 2.28.0
296- deleted unrecognized option: --enable-libcanberra
297
298* Thu Aug 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.33-1
299- new upstream release
300- remove BuildRequires: GConf2-devel
301
302* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32-2
303- rebuild with libnotify-0.7
304
305* Sun Jul 03 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.32-1
306- new upstream release
307
308* Thu May 19 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.31-1
309- new upstream release
310- suppressed warning in installing desktop file
311- added configure option
312  --enable-utp, --enable-nls, --enable-cli, --enable-daemon
313
314* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22-1
315- update to 2.22
316
317* Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.20-1
318- Update to upstream 2.20
319
320* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.13-2
321- rebuilt with openssl-1.0.0c
322
323* Sat Dec 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.13-1
324- Update to upstream 2.13
325- deleted disable option
326- added configure option --enable-gtk
327
328* Mon Nov 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.12-1
329- Update to upstream 2.12
330
331* Mon Oct 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.11-1
332- Update to upstream 2.11
333
334* Thu Oct 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.10-2
335- fixed and changed transmission-qt.desktop
336  - did not show transmission-qt.desktop in LXDE
337
338* Mon Oct 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.10-1
339- Update to upstream 2.10
340
341* Mon Aug 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.04-1
342- Update to upstream 2.04
343
344* Fri Jul 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.03-1
345- Update to upstream 2.03
346
347* Fri Jul 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.01-1
348- Update to upstream 2.01
349
350* Fri Jun 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.00-1
351- Update to upstream 2.00
352
353* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.93-1
354- Update to upstream 1.93
355
356* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.92-1
357- Update to upstream 1.92
358- applied new naming policy to spec
359
360* Mon Feb 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.91-1
361- Update to upstream 1.91
362- changed summary, summary(ja) a little
363- added %configure option --enable-libcanberra --enable-daemon
364- added Source1 from Fedora
365- splitted common, cli, daemon, gtk, qt packages
366
367* Sat Jan 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.83-1
368- Update to upstream 1.83
369- added BuildRequires:  libcanberra-devel, libevent-devel
370
371* Sun Jan 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.82-1
372- Update to upstream 1.82
373
374* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.80-1
375- Update to upstream 1.80
376- changed BuildRequires: intltool >= 0.40
377
378* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.77-1
379- Update to upstream 1.77
380- dropt Patch1
381- aded BuildRequires:  GConf2-devel
382
383* Mon Oct 26 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.76-1
384- Update to upstream 1.76
385
386* Tue Sep 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.75-2
387- a few fixed transmission_ja_po.patch
388- added --disable-static=no to configure option
389- run gtk-update-icon-cache in %post, %postun
390- cleaned up spec
391
392* Tue Sep 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.75-1
393- Update to upstream 1.75
394
395* Sun Jul 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.73-1
396- Update to upstream 1.73
397
398* Sun Jun 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.72-1
399- Update to upstream 1.72
400- cleaned up spec
401
402* Tue Jun 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.71-1
403- Update to upstream 1.71
404
405* Sat Jun 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.70-1
406- Update to upstream 1.70
407
408* Tue May 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.61-1
409- Update to upstream 1.61
410- added BuildRequires:  glib2-devel
411
412* Wed May 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.60-1
413- Update to upstream 1.60
414- spec in UTF-8
415
416* Mon Apr 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.52-1
417- Update to upstream 1.52
418- fixed Desktop-file name
419- fixed BuildRoot
420
421* Sat Feb 28 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.51-1
422- Update to upstream 1.51
423- changed BuildRequires:  curl-devel >= 7.18.0
424- dropped Patch1
425
426* Sun Feb 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.50-1
427- Update to upstream 1.50
428
429* Thu Jan 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.42-2
430- added Summary(ja)
431- fixed Lisense
432- added patch1 (transmission-1.42-libevent.patch, from Fedora)
433- fixed %build
434- changed %install
435- fixed %changelog
436
437* Sat Dec 27 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.42-1
438- initial build for VineSeed
439- Update to upstream 1.42
440- dropped Patch0 (transmission-0.71-manpath.patch)
441- added patch0 (transmission_ja_po.patch, to fix ja.po)
442- modified %files, %install
443- modified BuildRoot
444- added BuildRequires to curl-devel, dbus-glib-devel, libnotify-devel
445
446* Thu Feb 4 2008 Denis Leroy <denis@poolshark.org> - 1.04-1
447- Update to upstream 1.04
448- Modified Build-Require
449
450* Thu Aug 16 2007 Denis Leroy <denis@poolshark.org> - 0.80-1
451- Update to upstream 0.80
452
453* Wed May  2 2007 Denis Leroy <denis@poolshark.org> - 0.72-1
454- Update to 0.72
455- Added libevent BR
456
457* Wed Apr 25 2007 Denis Leroy <denis@poolshark.org> - 0.71-1
458- Update to 0.71
459- Removed custom desktop file
460- Added patch to fix manpath
461
462* Thu Sep 28 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-3
463- Added project icon
464- Honor cc variable
465
466* Mon Sep 25 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-2
467- Removed ldconfig Requires
468
469* Wed Sep 13 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-1
470- First version
471
Note: See TracBrowser for help on using the repository browser.