source: projects/specs/trunk/t/transmission/transmission-vl.spec @ 5768

Revision 5768, 14.0 KB checked in by kudoh, 12 years ago (diff)
Line 
1Name:           transmission
2Version:        2.50
3Release:        1%{?_dist_release}
4Summary:        A lightweight BitTorrent client
5Summary(ja):    軽量な BitTorrent クライアント
6
7Group:          Applications/Internet
8License:        MIT and GPLv2
9URL:            http://www.transmissionbt.com/
10Source0:        http://download.m0k.org/transmission/files/transmission-%{version}.tar.xz
11Source1:        transmission-daemon-init
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires:  openssl-devel
16BuildRequires:  curl-devel >= 7.18.0
17BuildRequires:  dbus-glib-devel
18BuildRequires:  glib2-devel >= 2.28.0
19BuildRequires:  libnotify-devel
20BuildRequires:  gtk3-devel >= 3.2.0
21
22%if %{?_dist_release} == "vl6"
23BuildRequires:  gtk2-devel >= 2.22.0
24%endif
25
26BuildRequires:  desktop-file-utils
27BuildRequires:  gettext >= 0.14.1
28BuildRequires:  intltool >= 0.40
29BuildRequires:  libcanberra-devel
30BuildRequires:  libevent-devel
31
32Requires: transmission-cli
33Requires: transmission-gtk
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: kudoh
38
39%description
40Transmission is a free, lightweight BitTorrent client. It features a
41simple, intuitive interface on top on an efficient, cross-platform
42back-end.
43
44%description -l ja
45Transmission はフリーで軽量な BitTorrent クライアントです。
46シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
47
48
49%package common
50Summary: Common files for Transmission BitTorrent client
51Summary(ja): Transmission BitTorrent クライアントの共通ファイル
52Group: Applications/Internet
53Obsoletes:      transmission =< 1.83
54
55%description common
56Transmission is a free, lightweight BitTorrent client. This package
57contains the common files used by the different front-ends.
58
59%description -l ja common
60Transmission はフリーで軽量な BitTorrent クライアントです。
61このパッケージは異なるフロントエンドにより使用される
62共通ファイルを含みます。
63
64%package cli
65Summary:       Transmission command line implementation
66Summary(ja):   Transmission のコマンドライン実装
67Group:         Applications/Internet
68Requires:      transmission-common
69Provides:      transmission = %{version}-%{release}
70
71%description cli
72Command line version of Transmission BitTorrent client.
73
74%description cli -l ja
75Transmission BitTorrent クライアントのコマンドライン版です。
76
77%package daemon
78Summary:       Transmission daemon
79Summary(ja):   Transmission デーモン
80Group:         Applications/Internet
81Requires:      transmission-common
82Requires(pre): shadow-utils
83Requires(post): chkconfig
84Requires(preun): chkconfig
85Requires(preun): initscripts
86Requires(postun): initscripts
87Provides:      transmission = %{version}-%{release}
88
89%description daemon
90Transmission BitTorrent client daemon.
91
92%description daemon -l ja
93Transmission BitTorrent クライアントデーモンです。
94
95%package gtk
96Summary: GTK Interface for Transmission BitTorrent client
97Summary(ja): Transmission BitTorrent client の GTK インターフェイス
98Group: Applications/Internet
99BuildRequires:  gtk2-devel >= 2.6.0
100Requires:       %{name}-common = %{version}
101Provides:       %{name} = %{version}-%{release}
102Provides:       %{name}-gui = %{version}-%{release}
103Obsoletes:      transmission =< 1.83
104
105%description gtk
106Transmission is a free, lightweight BitTorrent client. It features a
107simple, intuitive interface on top of an efficient back-end.
108
109This package provides the GTK Interface.
110
111%description -l ja gtk
112Transmission はフリーで軽量な BitTorrent クライアントです。
113シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
114
115このパッケージは GTK インターフェイスを提供します。
116
117%package qt
118Summary: Qt4 Interface for Transmission BitTorrent client
119Summary(ja): Transmission BitTorrent client の Qt4 インターフェイス
120Group: Applications/Internet
121Provides:       %{name}-gui = %{version}-%{release}
122Requires:       %{name}-common = %{version}
123BuildRequires:  qt4-devel qt4-designer
124
125%description qt
126Transmission is a simple BitTorrent client. It features a very simple,
127intuitive interface on top on an efficient, cross-platform back-end.
128
129This package contains QTransmission, a QT4 based GUI for Transmission
130loosely based on the GTK+ client.
131
132%description -l ja qt
133Transmission はフリーで軽量な BitTorrent クライアントです。
134シンプル且つ直感的なインターフェイス、クロスプラットフォームなバックエンドが特色です。
135
136このパッケージは QTransmission - GTK+ クライアントに概ね基づいた
137Transmission の QT4 ベース GUI - を含みます。
138
139%pre daemon
140getent group transmission >/dev/null || groupadd -r transmission
141getent passwd transmission >/dev/null || \
142useradd -r -g transmission -d /var/lib/transmission -s /sbin/nologin \
143        -c "transmission daemon account" transmission
144exit 0
145
146%prep
147%setup -q
148sed -i "s/x-bittorrent;x-scheme-handler\/magnet;/x-bittorrent;/g" \
149        gtk/transmission-gtk.desktop.in
150
151%build
152%configure --disable-static --enable-daemon \
153           --enable-utp --enable-nls --enable-cli
154make %{?_smp_mflags} CC=%{__cc}
155#make CFLAGS="$RPM_OPT_FLAGS"
156
157#for QT gui build
158pushd qt
159%{_libdir}/qt4/bin/qmake qtr.pro
160make %{?_smp_mflags}
161popd
162
163%install
164rm -rf $RPM_BUILD_ROOT
165
166mkdir -p %{buildroot}%{_initddir}
167install -m755 %{SOURCE1} %{buildroot}%{_initddir}/transmission-daemon
168mkdir -p %{buildroot}/var/lib/transmission
169
170make install DESTDIR=$RPM_BUILD_ROOT
171make install INSTALL_ROOT=%{buildroot}%{_prefix} -C qt
172
173%find_lang %{name}-gtk
174
175desktop-file-install --vendor "" \
176        --delete-original \
177        --dir $RPM_BUILD_ROOT%{_datadir}/applications/ \
178        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-gtk.desktop
179
180mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
181cat > $RPM_BUILD_ROOT%{_datadir}/applications/transmission-qt.desktop << EOF
182[Desktop Entry]
183Encoding=UTF-8
184Name=Qtransmission Bittorrent Client
185Name[ja]=Qtransmission Bittorrent クライアント
186GenericName=BitTorrent Client
187GenericName[ja]=BitTorrent クライアント
188Comment=Download and share files over BitTorrent
189Comment[ja]=BitTorrent でファイルをダウンロード及び共有します
190Exec=transmission-qt %F
191Icon=transmission
192Terminal=false
193Type=Application
194MimeType=application/x-bittorrent;
195Categories=Network;FileTransfer;P2P;Qt;
196NotShowIn=GNOME;MATE;XFCE;LXDE;
197EOF
198
199%clean
200rm -rf $RPM_BUILD_ROOT
201
202%post daemon
203/sbin/chkconfig --add transmission-daemon
204
205
206%post gtk
207touch --no-create %{_datadir}/icons/hicolor || :
208%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
209update-desktop-database > /dev/null 2>&1 || :
210
211
212%postun gtk
213touch --no-create %{_datadir}/icons/hicolor || :
214%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
215update-desktop-database > /dev/null 2>&1 || :
216
217%preun daemon
218if [ $1 = 0 ] ; then
219    /sbin/service transmission-daemon stop >/dev/null 2>&1
220    /sbin/chkconfig --del transmission-daemon
221fi
222
223%postun daemon
224if [ "$1" -ge "1" ] ; then
225    /sbin/service transmission-daemon condrestart >/dev/null 2>&1 || :
226fi
227
228%files
229
230%files common
231%defattr(-, root, root, -)
232%doc AUTHORS COPYING NEWS README
233%{_bindir}/transmission-create
234%{_bindir}/transmission-edit
235%{_bindir}/transmission-remote
236%{_bindir}/transmission-show
237%{_datadir}/transmission/web/
238%{_datadir}/pixmaps/*
239%{_datadir}/icons/hicolor/*/apps/transmission.*
240%doc %{_mandir}/man1/transmission-create*
241%doc %{_mandir}/man1/transmission-edit*
242%doc %{_mandir}/man1/transmission-remote*
243%doc %{_mandir}/man1/transmission-show*
244
245%files cli
246%defattr(-, root, root, -)
247%{_bindir}/transmission-cli
248%doc %{_mandir}/man1/transmission-cli*
249
250%files daemon
251%defattr(-, root, root, -)
252%{_bindir}/transmission-daemon
253%{_initddir}/transmission-daemon
254%attr(-,transmission, transmission)/var/lib/transmission/
255%doc %{_mandir}/man1/transmission-daemon*
256
257%files gtk -f %{name}-gtk.lang
258%defattr(-,root,root)
259%{_bindir}/%{name}-gtk
260%{_datadir}/applications/%{name}-gtk.desktop
261%{_mandir}/man1/transmission-gtk.1*
262
263%files qt
264%defattr(-,root,root)
265%{_bindir}/transmission-qt
266%{_datadir}/applications/transmission-qt.desktop
267%{_mandir}/man1/transmission-qt.1*
268
269%changelog
270* Thu Feb 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.50-1
271- new upstream release
272- deleted unrecognized option: --enable-gtk
273- fixed transmission-qt desktop entry a little
274
275* Wed Nov 09 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.42-1
276- new upstream release
277- aded BuildRequires: gtk3-devel >= 3.2.0
278  - made conditional branch for Vine 6 (support for GTK+2)
279
280* Mon Oct 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.41-1
281- new upstream release
282- changed BuildRequires
283  - gtk2-devel >= 2.6.0 to gtk2-devel >= 2.22.0
284  - glib2-devel >= 2.28.0
285- deleted unrecognized option: --enable-libcanberra
286
287* Thu Aug 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.33-1
288- new upstream release
289- remove BuildRequires: GConf2-devel
290
291* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32-2
292- rebuild with libnotify-0.7
293
294* Sun Jul 03 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.32-1
295- new upstream release
296
297* Thu May 19 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.31-1
298- new upstream release
299- suppressed warning in installing desktop file
300- added configure option
301  --enable-utp, --enable-nls, --enable-cli, --enable-daemon
302
303* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22-1
304- update to 2.22
305
306* Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.20-1
307- Update to upstream 2.20
308
309* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.13-2
310- rebuilt with openssl-1.0.0c
311
312* Sat Dec 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.13-1
313- Update to upstream 2.13
314- deleted disable option
315- added configure option --enable-gtk
316
317* Mon Nov 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.12-1
318- Update to upstream 2.12
319
320* Mon Oct 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.11-1
321- Update to upstream 2.11
322
323* Thu Oct 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.10-2
324- fixed and changed transmission-qt.desktop
325  - did not show transmission-qt.desktop in LXDE
326
327* Mon Oct 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.10-1
328- Update to upstream 2.10
329
330* Mon Aug 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.04-1
331- Update to upstream 2.04
332
333* Fri Jul 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.03-1
334- Update to upstream 2.03
335
336* Fri Jul 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.01-1
337- Update to upstream 2.01
338
339* Fri Jun 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.00-1
340- Update to upstream 2.00
341
342* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.93-1
343- Update to upstream 1.93
344
345* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.92-1
346- Update to upstream 1.92
347- applied new naming policy to spec
348
349* Mon Feb 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.91-1
350- Update to upstream 1.91
351- changed summary, summary(ja) a little
352- added %configure option --enable-libcanberra --enable-daemon
353- added Source1 from Fedora
354- splitted common, cli, daemon, gtk, qt packages
355
356* Sat Jan 30 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.83-1
357- Update to upstream 1.83
358- added BuildRequires:  libcanberra-devel, libevent-devel
359
360* Sun Jan 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.82-1
361- Update to upstream 1.82
362
363* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.80-1
364- Update to upstream 1.80
365- changed BuildRequires: intltool >= 0.40
366
367* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.77-1
368- Update to upstream 1.77
369- dropt Patch1
370- aded BuildRequires:  GConf2-devel
371
372* Mon Oct 26 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.76-1
373- Update to upstream 1.76
374
375* Tue Sep 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.75-2
376- a few fixed transmission_ja_po.patch
377- added --disable-static=no to configure option
378- run gtk-update-icon-cache in %post, %postun
379- cleaned up spec
380
381* Tue Sep 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.75-1
382- Update to upstream 1.75
383
384* Sun Jul 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.73-1
385- Update to upstream 1.73
386
387* Sun Jun 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.72-1
388- Update to upstream 1.72
389- cleaned up spec
390
391* Tue Jun 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.71-1
392- Update to upstream 1.71
393
394* Sat Jun 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.70-1
395- Update to upstream 1.70
396
397* Tue May 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.61-1
398- Update to upstream 1.61
399- added BuildRequires:  glib2-devel
400
401* Wed May 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.60-1
402- Update to upstream 1.60
403- spec in UTF-8
404
405* Mon Apr 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.52-1
406- Update to upstream 1.52
407- fixed Desktop-file name
408- fixed BuildRoot
409
410* Sat Feb 28 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.51-1
411- Update to upstream 1.51
412- changed BuildRequires:  curl-devel >= 7.18.0
413- dropped Patch1
414
415* Sun Feb 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.50-1
416- Update to upstream 1.50
417
418* Thu Jan 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.42-2
419- added Summary(ja)
420- fixed Lisense
421- added patch1 (transmission-1.42-libevent.patch, from Fedora)
422- fixed %build
423- changed %install
424- fixed %changelog
425
426* Sat Dec 27 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.42-1
427- initial build for VineSeed
428- Update to upstream 1.42
429- dropped Patch0 (transmission-0.71-manpath.patch)
430- added patch0 (transmission_ja_po.patch, to fix ja.po)
431- modified %files, %install
432- modified BuildRoot
433- added BuildRequires to curl-devel, dbus-glib-devel, libnotify-devel
434
435* Thu Feb 4 2008 Denis Leroy <denis@poolshark.org> - 1.04-1
436- Update to upstream 1.04
437- Modified Build-Require
438
439* Thu Aug 16 2007 Denis Leroy <denis@poolshark.org> - 0.80-1
440- Update to upstream 0.80
441
442* Wed May  2 2007 Denis Leroy <denis@poolshark.org> - 0.72-1
443- Update to 0.72
444- Added libevent BR
445
446* Wed Apr 25 2007 Denis Leroy <denis@poolshark.org> - 0.71-1
447- Update to 0.71
448- Removed custom desktop file
449- Added patch to fix manpath
450
451* Thu Sep 28 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-3
452- Added project icon
453- Honor cc variable
454
455* Mon Sep 25 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-2
456- Removed ldconfig Requires
457
458* Wed Sep 13 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-1
459- First version
460
Note: See TracBrowser for help on using the repository browser.