source: projects/specs/trunk/t/tracker/tracker-vl.spec @ 521

Revision 521, 6.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: An object database, tag/metadata database, search tool and indexer
2Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
3Name: tracker
4Version: 0.6.91
5Release: 1%{?_dist_release}
6License: GPL
7Group: Applications/System
8URL: http://www.gnome.org/projects/tracker/
9
10Source0: http://www.gnome.org/projects/tracker/tracker-%{version}.tar.bz2
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13BuildRequires: gmime-devel, poppler-devel, gettext, file
14BuildRequires: gnome-desktop-devel, gamin-devel
15BuildRequires: libexif-devel, libgsf-devel, totem-pl-parser-devel
16BuildRequires: gstreamer-devel
17BuildRequires: desktop-file-utils, intltool
18BuildRequires: raptor-devel >= 1.4.18
19BuildRequires: sqlite3-devel
20BuildRequires: dbus-devel >= 1.0
21BuildRequires: dbus-glib >= 0.73
22BuildRequires: autoconf, automake
23
24%description
25Tracker is a powerful desktop-neutral first class object database,
26tag/metadata database, search tool and indexer.
27
28It consists of a common object database that allows entities to have an
29almost infinte number of properties, metadata (both embedded/harvested as
30well as user definable), a comprehensive database of keywords/tags and
31links to other entities.
32
33It provides additional features for file based objects including context
34linking and audit trails for a file object.
35
36It has the ability to index, store, harvest metadata. retrieve and search 
37all types of files and other first class objects
38
39%package devel
40Summary: Headers for developing programs that will use %{name}
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: pkgconfig
44Requires: dbus-glib-devel
45
46%description devel
47This package contains the static libraries and header files needed for
48developing with tracker
49
50%package search-tool
51Summary: Tracker search tool(s)
52Group: User Interface/Desktops
53Requires: %{name} = %{version}-%{release}
54
55%description search-tool
56Graphical frontend to tracker search facilities. This has dependencies on
57GNOME libraries
58
59%prep
60%setup -q
61
62# remove shebangs from the python files as none should be executable scripts
63sed -e '/^#!\//,1 d' -i python/deskbar-handler/*.py
64
65%build
66libtoolize --force --copy
67intltoolize --copy --force
68autoreconf -i -f
69%configure --disable-static \
70           --enable-video-extractor=external
71
72# Disable rpath
73sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
74sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
75
76# make %{?_smp_mflags} fails
77%__make
78
79                                                                               
80%install
81rm -rf %{buildroot}
82make DESTDIR=%{buildroot} install
83
84desktop-file-install --delete-original               \
85        --vendor=""                             \
86        --dir=%{buildroot}%{_datadir}/applications   \
87        %{buildroot}%{_datadir}/applications/%{name}-search-tool.desktop
88
89rm -rf %{buildroot}%{_libdir}/*.{a,la}
90
91%find_lang %{name}
92
93%clean
94rm -rf %{buildroot}
95
96%post
97/sbin/ldconfig
98touch --no-create %{_datadir}/icons/hicolor
99if [ -x /usr/bin/gtk-update-icon-cache ]; then
100  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
101fi
102 
103%postun
104/sbin/ldconfig
105touch --no-create %{_datadir}/icons/hicolor
106if [ -x /usr/bin/gtk-update-icon-cache ]; then
107  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
108fi
109 
110%files -f %{name}.lang
111%defattr(-, root, root, -)
112%doc AUTHORS ChangeLog COPYING NEWS README
113%doc %{_datadir}/gtk-doc/html/libtracker-common/
114%doc %{_datadir}/gtk-doc/html/libtracker-module/
115%{_bindir}/tracker*
116%exclude %{_bindir}/tracker-search-tool
117%exclude %{_bindir}/tracker-preferences
118%exclude %{_bindir}/tracker-applet
119%{_libexecdir}/tracker*
120%{_libdir}/*.so.*
121%{_libdir}/tracker/
122%{_datadir}/tracker/
123%{_datadir}/dbus-1/services/org.freedesktop.Tracker.*
124%{_sysconfdir}/xdg/autostart/trackerd.desktop
125%{_mandir}/*/tracker*.gz
126
127%files devel
128%defattr(-, root, root, -)
129%{_includedir}/tracker*
130%{_includedir}/libtracker-gtk/*
131%{_libdir}/*.so
132%{_libdir}/pkgconfig/*.pc
133
134%files search-tool
135%defattr(-, root, root, -)
136%{_bindir}/tracker-applet
137%{_bindir}/tracker-search-tool
138%{_bindir}/tracker-preferences
139%{_datadir}/icons/*/*/apps/tracker.*
140%{_datadir}/applications/*.desktop
141%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
142
143%changelog
144* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
145- new upstream release
146
147* Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
148- rebuild with poppler-0.10.2
149- spec in UTF-8
150
151* Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
152- new upstream release
153- update Patch1
154- drop Patch10 (no more necessary)
155- add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
156- remove --enable-external-sqlite option (no more bundled sqlite exist)
157- apply new versioning policy
158
159* Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
160- new upstream release
161
162* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
163- add Patch10 to fix selecting video-extractor
164- use external video extractor(totem) instead of gstreamer/xine
165
166* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
167- initial build for Vine Linux
168
169* Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
170- Ship both autostart desktop files in the main package (BZ #233323)
171
172* Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
173- Package the deskbar plugin properly (BZ #228308)
174
175* Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
176- Split out tracker-search-tool sub-packages, for the GUI facility
177- Add proper requires for the -devel subpackage
178- Deal with the rpmlint complaints on rpath
179
180* Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
181- Update to 0.5.4
182
183* Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
184- Update to 0.5.3
185
186* Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
187- Apply patch on Makefile.am instead of Makefile.in
188- Add libtool to BR
189
190* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
191- Update to 0.5.2
192
193* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
194- Update to new version
195
196* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
197- Have the devel subpackage require pkgconfig
198- Make the description field not have more than 76 characters on a line
199- Fix up the RPM group
200
201* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
202- Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
203
204* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
205- Remove unneeded BRs (gnome-utils-devel and openssl-devel)
206
207* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
208- Add autostart desktop file.
209- Edit the package description as suggested in review
210
211* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
212- More cleaups to the spec file.
213
214* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
215- Add needed BRs
216
217* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
218- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.