source: projects/specs/trunk/t/tracker-miners/tracker-miners-vl.spec @ 12386

Revision 12386, 7.8 KB checked in by tomop, 4 years ago (diff)

updated 15 packages

epiphany-3.30.5-3

evolution-data-server-3.30.5-3

harfbuzz-2.6.4-2

icu-67.1-1

libvisio-0.1.7-3

php74-7.4.5-2

postfix-3.5.1-2

qt5-qtbase-5.12.8-2

qt5-qtlocation-5.12.8-2

qt5-qtwebengine-5.12.8-2

samba-4.12.1-2

tracker-miners-2.3.3-2

tracker-2.3.4-1

webkitgtk4-2.28.1-1

xfsprogs-5.6.0-1

Line 
1%bcond_with systemd
2
3%global with_enca 1
4%global with_libcue 1
5%global with_rss 0
6
7%global tracker_version 2.3.4
8
9%global systemd_units tracker-extract.service tracker-miner-fs.service %{?_with_rss:tracker-miner-rss.service} tracker-writeback.service
10
11# Exclude private libraries from autogenerated provides and requires
12%global __provides_exclude_from ^%{_libdir}/tracker-miners-2.0/
13%global __requires_exclude ^(libtracker-extract\.so|libtracker-miners-common\.so|libextract-.*\.so|libwriteback-.*\.so)
14
15Name:           tracker-miners
16Version:        2.3.3
17Release:        2%{?_dist_release}%{?with_systemd:.systemd}
18Summary:        Tracker miners and metadata extractors
19Group:          Applications/Services
20Vendor:         Project Vine
21Distribution:   Vine Linux
22
23# libtracker-extract is LGPLv2+; the miners are a mix of GPLv2+ and LGPLv2+ code
24License:        GPLv2+ and LGPLv2+
25URL:            https://wiki.gnome.org/Projects/Tracker
26%define         shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
27Source0:        https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
28
29BuildRequires:  gcc
30BuildRequires:  giflib-devel
31BuildRequires:  intltool
32BuildRequires:  meson
33%if %{with systemd}
34BuildRequires:  systemd
35%endif
36BuildRequires:  pkgconfig(dbus-1)
37%if 0%{?with_enca}
38BuildRequires:  pkgconfig(enca)
39%endif
40BuildRequires:  pkgconfig(exempi-2.0)
41BuildRequires:  flac-devel
42BuildRequires:  pkgconfig(gexiv2)
43BuildRequires:  pkgconfig(gstreamer-1.0)
44BuildRequires:  pkgconfig(gstreamer-pbutils-1.0)
45BuildRequires:  pkgconfig(gstreamer-tag-1.0)
46BuildRequires:  pkgconfig(icu-i18n)
47BuildRequires:  pkgconfig(icu-uc)
48%if 0%{?with_libcue}
49BuildRequires:  pkgconfig(libcue)
50%endif
51BuildRequires:  pkgconfig(libexif)
52%if 0%{?with_rss}
53BuildRequires:  pkgconfig(libgrss)
54%endif
55BuildRequires:  pkgconfig(libgsf-1)
56BuildRequires:  pkgconfig(libgxps)
57#BuildRequires:  pkgconfig(libiptcdata)
58BuildRequires:  pkgconfig(libjpeg)
59#BuildRequires:  pkgconfig(libosinfo-1.0)
60BuildRequires:  pkgconfig(libpng)
61BuildRequires:  pkgconfig(libseccomp)
62BuildRequires:  pkgconfig(libtiff-4)
63BuildRequires:  pkgconfig(libxml-2.0)
64BuildRequires:  pkgconfig(poppler-glib)
65BuildRequires:  pkgconfig(taglib_c)
66BuildRequires:  pkgconfig(totem-plparser)
67BuildRequires:  pkgconfig(tracker-sparql-2.0)
68BuildRequires:  pkgconfig(upower-glib)
69BuildRequires:  pkgconfig(vorbisfile)
70BuildRequires:  pkgconfig(zlib)
71
72%if %{with systemd}
73%{?systemd_requires}
74%endif
75Requires(post,postun): desktop-file-utils
76Requires:       tracker%{?_isa} >= %{tracker_version}
77# tracker-miners was split out from tracker in 1.99.2
78Obsoletes:      tracker < 1.99.2
79Conflicts:      tracker < 1.99.2
80
81%description
82Tracker is a powerful desktop-neutral first class object database,
83tag/metadata database and search tool.
84
85This package contains various miners and metadata extractors for tracker.
86
87
88%prep
89%autosetup -p1
90
91
92%build
93# Disable the functional tests for now, they use python bytecodes.
94%meson \
95  -Dfunctional_tests=false \
96  -Diptc=disabled \
97  -Diso=disabled \
98  -Dminer_rss=false \
99%if %{with systemd}
100  -Dsystemd_user_services=%{_userunitdir}
101%endif
102  %{nil}
103%meson_build
104
105
106%install
107%meson_install
108
109rm -rf %{buildroot}%{_datadir}/tracker-tests
110
111%find_lang %{name}
112
113
114%post
115%if %{with systemd}
116%systemd_user_post %{systemd_units}
117%endif
118if [ $1 -eq 1 ]; then
119  glib-compile-schemas /usr/share/glib-2.0/schemas ||:
120  update-desktop-database -q > /dev/null || :
121fi
122
123%if %{with systemd}
124%preun
125%systemd_user_preun %{systemd_units}
126%endif
127
128%postun
129%if %{with systemd}
130%systemd_user_postun_with_restart %{systemd_units}
131%endif
132if [ $1 -eq 0 ]; then
133  glib-compile-schemas /usr/share/glib-2.0/schemas ||:
134  update-desktop-database -q > /dev/null || :
135fi
136
137
138%files -f %{name}.lang
139%license COPYING
140%doc AUTHORS NEWS README.md
141%{_libdir}/tracker-miners-2.0/
142%{_libexecdir}/tracker*
143%{_datadir}/dbus-1/services/org.freedesktop.Tracker*
144%{_datadir}/glib-2.0/schemas/*
145%{_datadir}/tracker/
146%{_datadir}/tracker-miners/
147%{_mandir}/man1/tracker-*.1*
148%config(noreplace) %{_sysconfdir}/xdg/autostart/tracker*.desktop
149%if %{with systemd}
150%{_userunitdir}/tracker*.service
151%endif
152
153%changelog
154* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.3-2
155- rebuilt with icu-67.
156
157* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.3-1
158- new upstream release.
159
160* Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.1
161- initial build for Vine Linux.
162- new upstream release.
163
164* Mon Sep 09 2019 Kalev Lember <klember@redhat.com> - 2.3.0-1
165- Update to 2.3.0
166
167* Fri Sep 06 2019 Nikola Forró <nforro@redhat.com> - 2.2.99.1-2
168- Rebuilt for exempi 2.5.1
169
170* Fri Sep 06 2019 Kalev Lember <klember@redhat.com> - 2.2.99.1-1
171- Update to 2.2.99.1
172
173* Mon Aug 12 2019 Kalev Lember <klember@redhat.com> - 2.2.99.0-1
174- Update to 2.2.99.0
175
176* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.2-2
177- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
178
179* Fri May 03 2019 David King <amigadave@amigadave.com> - 2.2.2-1
180- Update to 2.2.2
181
182* Fri Mar 08 2019 Kalev Lember <klember@redhat.com> - 2.2.1-1
183- Update to 2.2.1
184
185* Thu Feb 21 2019 Kalev Lember <klember@redhat.com> - 2.2.0-3
186- Exclude private libraries from autogenerated provides and requires
187
188* Thu Feb 21 2019 Kalev Lember <klember@redhat.com> - 2.2.0-2
189- Fix the package to be installable again
190
191* Wed Feb 20 2019 Kalev Lember <klember@redhat.com> - 2.2.0-1
192- Update to 2.2.0
193- Switch to the meson build system
194
195* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.5-4
196- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
197
198* Wed Jan 23 2019 Pete Walter <pwalter@fedoraproject.org> - 2.1.5-3
199- Rebuild for ICU 63
200
201* Mon Jan 21 2019 Kevin Fenzi <kevin@scrye.com> - 2.1.5-2
202- Rebuild to drop libiptcdata deps
203
204* Fri Sep 28 2018 Kalev Lember <klember@redhat.com> - 2.1.5-1
205- Update to 2.1.5
206
207* Wed Sep 05 2018 Kalev Lember <klember@redhat.com> - 2.1.4-2
208- Rebuilt with fixed vala
209
210* Tue Sep 04 2018 Kalev Lember <klember@redhat.com> - 2.1.4-1
211- Update to 2.1.4
212
213* Mon Sep 03 2018 Kalev Lember <klember@redhat.com> - 2.1.3-1
214- Update to 2.1.3
215
216* Sun Aug 19 2018 Kalev Lember <klember@redhat.com> - 2.1.1-1
217- Update to 2.1.1
218
219* Wed Jul 25 2018 Kalev Lember <klember@redhat.com> - 2.1.0-1
220- Update to 2.1.0
221
222* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.5-3
223- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
224
225* Tue Jul 10 2018 Pete Walter <pwalter@fedoraproject.org> - 2.0.5-2
226- Rebuild for ICU 62
227
228* Tue Jun 26 2018 Kalev Lember <klember@redhat.com> - 2.0.5-1
229- Update to 2.0.5
230
231* Mon Apr 30 2018 Pete Walter <pwalter@fedoraproject.org> - 2.0.4-4
232- Rebuild for ICU 61.1
233
234* Sun Feb 11 2018 Sandro Mani <manisandro@gmail.com> - 2.0.4-3
235- Rebuild (giflib)
236
237* Thu Feb 08 2018 Kalev Lember <klember@redhat.com> - 2.0.4-2
238- Rebuild to really enable the RAW extractor
239
240* Wed Feb 07 2018 Kalev Lember <klember@redhat.com> - 2.0.4-1
241- Update to 2.0.4
242- Enable new gexiv2 based RAW extractor
243
244* Thu Nov 30 2017 Pete Walter <pwalter@fedoraproject.org> - 2.0.3-2
245- Rebuild for ICU 60.1
246
247* Tue Nov 21 2017 Kalev Lember <klember@redhat.com> - 2.0.3-1
248- Update to 2.0.3
249
250* Fri Oct 06 2017 Kalev Lember <klember@redhat.com> - 2.0.2-1
251- Update to 2.0.2
252
253* Tue Sep 19 2017 Kalev Lember <klember@redhat.com> - 2.0.0-3
254- Backport a fix for a crash when processing virtual elements (#1488707)
255
256* Fri Sep 15 2017 Kalev Lember <klember@redhat.com> - 2.0.0-2
257- Package review fixes (#1491725):
258- Pass --disable-mp3 to use the generic gstreamer extractor
259- Disable libstemmer support to match the previous behaviour
260- Fix removing .so symlinks for private libraries
261- Remove ldconfig rpm scripts as we don't install any shared libraries
262- Correct license tag and add comment explaining mixed source licensing
263
264* Thu Sep 14 2017 Kalev Lember <klember@redhat.com> - 2.0.0-1
265- Initial Fedora packaging
Note: See TracBrowser for help on using the repository browser.