source: projects/specs/trunk/t/tracker-miners/tracker-miners-vl.spec @ 12344

Revision 12344, 7.6 KB checked in by tomop, 4 years ago (diff)

updated 10 packages

epiphany-3.30.5-2

evolution-data-server-3.30.5-2

gnucash-3.8b-1

harfbuzz-2.6.4-1

libboost-1.66.0-5

tracker-miners-2.3.3-1

tracker-2.2.2-3

webkitgtk4-2.28.0-2

xfsdump-3.1.9-1

xfsprogs-5.5.0-1

Line 
1%bcond_with systemd
2
3%global with_enca 1
4%global with_libcue 1
5%global with_rss 0
6
7%global tracker_version 2.2.0
8
9%global systemd_units tracker-extract.service tracker-miner-fs.service tracker-miner-rss.service tracker-writeback.service
10
11# Exclude private libraries from autogenerated provides and requires
12%global __provides_exclude_from ^%{_libdir}/tracker-miners-2.0/
13%global __requires_exclude ^(libtracker-extract\.so|libtracker-miners-common\.so|libextract-.*\.so|libwriteback-.*\.so)
14
15Name:           tracker-miners
16Version:        2.3.3
17Release:        1%{?_dist_release}
18Summary:        Tracker miners and metadata extractors
19Group:          Applications/Services
20
21Vendor:         Project Vine
22Distribution:   Vine Linux
23
24# libtracker-extract is LGPLv2+; the miners are a mix of GPLv2+ and LGPLv2+ code
25License:        GPLv2+ and LGPLv2+
26URL:            https://wiki.gnome.org/Projects/Tracker
27
28%define         shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
29Source0:        https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
30
31BuildRequires:  gcc
32BuildRequires:  giflib-devel
33BuildRequires:  intltool
34BuildRequires:  meson
35%if %{with systemd}
36BuildRequires:  systemd
37%endif
38BuildRequires:  pkgconfig(dbus-1)
39%if 0%{?with_enca}
40BuildRequires:  pkgconfig(enca)
41%endif
42BuildRequires:  pkgconfig(exempi-2.0)
43BuildRequires:  flac-devel
44BuildRequires:  pkgconfig(gexiv2)
45BuildRequires:  pkgconfig(gstreamer-1.0)
46BuildRequires:  pkgconfig(gstreamer-pbutils-1.0)
47BuildRequires:  pkgconfig(gstreamer-tag-1.0)
48BuildRequires:  pkgconfig(icu-i18n)
49BuildRequires:  pkgconfig(icu-uc)
50%if 0%{?with_libcue}
51BuildRequires:  pkgconfig(libcue)
52%endif
53BuildRequires:  pkgconfig(libexif)
54%if 0%{?with_rss}
55BuildRequires:  pkgconfig(libgrss)
56%endif
57BuildRequires:  pkgconfig(libgsf-1)
58BuildRequires:  pkgconfig(libgxps)
59#BuildRequires:  pkgconfig(libiptcdata)
60BuildRequires:  pkgconfig(libjpeg)
61#BuildRequires:  pkgconfig(libosinfo-1.0)
62BuildRequires:  pkgconfig(libpng)
63BuildRequires:  pkgconfig(libseccomp)
64BuildRequires:  pkgconfig(libtiff-4)
65BuildRequires:  pkgconfig(libxml-2.0)
66BuildRequires:  pkgconfig(poppler-glib)
67BuildRequires:  pkgconfig(taglib_c)
68BuildRequires:  pkgconfig(totem-plparser)
69BuildRequires:  pkgconfig(tracker-sparql-2.0)
70BuildRequires:  pkgconfig(upower-glib)
71BuildRequires:  pkgconfig(vorbisfile)
72BuildRequires:  pkgconfig(zlib)
73
74%if %{with systemd}
75%{?systemd_requires}
76%endif
77Requires(post,postun): desktop-file-utils
78Requires:       tracker%{?_isa} >= %{tracker_version}
79# tracker-miners was split out from tracker in 1.99.2
80Obsoletes:      tracker < 1.99.2
81Conflicts:      tracker < 1.99.2
82
83%description
84Tracker is a powerful desktop-neutral first class object database,
85tag/metadata database and search tool.
86
87This package contains various miners and metadata extractors for tracker.
88
89
90%prep
91%autosetup -p1
92
93
94%build
95# Disable the functional tests for now, they use python bytecodes.
96%meson \
97  -Dfunctional_tests=false \
98  -Diptc=disabled \
99  -Diso=disabled \
100  -Dminer_rss=false \
101%if %{with systemd}
102  -Dsystemd_user_services=%{_userunitdir}
103%endif
104  %{nil}
105%meson_build
106
107
108%install
109%meson_install
110
111rm -rf %{buildroot}%{_datadir}/tracker-tests
112
113%find_lang %{name}
114
115
116%post
117%if %{with systemd}
118%systemd_user_post %{systemd_units}
119%endif
120if [ $1 -eq 1 ]; then
121  glib-compile-schemas /usr/share/glib-2.0/schemas ||:
122  update-desktop-database -q > /dev/null || :
123fi
124
125%if %{with systemd}
126%preun
127%systemd_user_preun %{systemd_units}
128%endif
129
130%postun
131%if %{with systemd}
132%systemd_user_postun_with_restart %{systemd_units}
133%endif
134if [ $1 -eq 0 ]; then
135  glib-compile-schemas /usr/share/glib-2.0/schemas ||:
136  update-desktop-database -q > /dev/null || :
137fi
138
139
140%files -f %{name}.lang
141%license COPYING
142%doc AUTHORS NEWS README.md
143%{_libdir}/tracker-miners-2.0/
144%{_libexecdir}/tracker*
145%{_datadir}/dbus-1/services/org.freedesktop.Tracker*
146%{_datadir}/glib-2.0/schemas/*
147%{_datadir}/tracker/
148%{_datadir}/tracker-miners/
149%{_mandir}/man1/tracker-*.1*
150%config(noreplace) %{_sysconfdir}/xdg/autostart/tracker*.desktop
151%if %{with systemd}
152%{_userunitdir}/tracker*.service
153%endif
154
155%changelog
156* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.3-1
157- new upstream release.
158
159* Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.1
160- initial build for Vine Linux.
161- new upstream release.
162
163* Mon Sep 09 2019 Kalev Lember <klember@redhat.com> - 2.3.0-1
164- Update to 2.3.0
165
166* Fri Sep 06 2019 Nikola Forró <nforro@redhat.com> - 2.2.99.1-2
167- Rebuilt for exempi 2.5.1
168
169* Fri Sep 06 2019 Kalev Lember <klember@redhat.com> - 2.2.99.1-1
170- Update to 2.2.99.1
171
172* Mon Aug 12 2019 Kalev Lember <klember@redhat.com> - 2.2.99.0-1
173- Update to 2.2.99.0
174
175* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.2-2
176- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
177
178* Fri May 03 2019 David King <amigadave@amigadave.com> - 2.2.2-1
179- Update to 2.2.2
180
181* Fri Mar 08 2019 Kalev Lember <klember@redhat.com> - 2.2.1-1
182- Update to 2.2.1
183
184* Thu Feb 21 2019 Kalev Lember <klember@redhat.com> - 2.2.0-3
185- Exclude private libraries from autogenerated provides and requires
186
187* Thu Feb 21 2019 Kalev Lember <klember@redhat.com> - 2.2.0-2
188- Fix the package to be installable again
189
190* Wed Feb 20 2019 Kalev Lember <klember@redhat.com> - 2.2.0-1
191- Update to 2.2.0
192- Switch to the meson build system
193
194* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.5-4
195- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
196
197* Wed Jan 23 2019 Pete Walter <pwalter@fedoraproject.org> - 2.1.5-3
198- Rebuild for ICU 63
199
200* Mon Jan 21 2019 Kevin Fenzi <kevin@scrye.com> - 2.1.5-2
201- Rebuild to drop libiptcdata deps
202
203* Fri Sep 28 2018 Kalev Lember <klember@redhat.com> - 2.1.5-1
204- Update to 2.1.5
205
206* Wed Sep 05 2018 Kalev Lember <klember@redhat.com> - 2.1.4-2
207- Rebuilt with fixed vala
208
209* Tue Sep 04 2018 Kalev Lember <klember@redhat.com> - 2.1.4-1
210- Update to 2.1.4
211
212* Mon Sep 03 2018 Kalev Lember <klember@redhat.com> - 2.1.3-1
213- Update to 2.1.3
214
215* Sun Aug 19 2018 Kalev Lember <klember@redhat.com> - 2.1.1-1
216- Update to 2.1.1
217
218* Wed Jul 25 2018 Kalev Lember <klember@redhat.com> - 2.1.0-1
219- Update to 2.1.0
220
221* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.5-3
222- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
223
224* Tue Jul 10 2018 Pete Walter <pwalter@fedoraproject.org> - 2.0.5-2
225- Rebuild for ICU 62
226
227* Tue Jun 26 2018 Kalev Lember <klember@redhat.com> - 2.0.5-1
228- Update to 2.0.5
229
230* Mon Apr 30 2018 Pete Walter <pwalter@fedoraproject.org> - 2.0.4-4
231- Rebuild for ICU 61.1
232
233* Sun Feb 11 2018 Sandro Mani <manisandro@gmail.com> - 2.0.4-3
234- Rebuild (giflib)
235
236* Thu Feb 08 2018 Kalev Lember <klember@redhat.com> - 2.0.4-2
237- Rebuild to really enable the RAW extractor
238
239* Wed Feb 07 2018 Kalev Lember <klember@redhat.com> - 2.0.4-1
240- Update to 2.0.4
241- Enable new gexiv2 based RAW extractor
242
243* Thu Nov 30 2017 Pete Walter <pwalter@fedoraproject.org> - 2.0.3-2
244- Rebuild for ICU 60.1
245
246* Tue Nov 21 2017 Kalev Lember <klember@redhat.com> - 2.0.3-1
247- Update to 2.0.3
248
249* Fri Oct 06 2017 Kalev Lember <klember@redhat.com> - 2.0.2-1
250- Update to 2.0.2
251
252* Tue Sep 19 2017 Kalev Lember <klember@redhat.com> - 2.0.0-3
253- Backport a fix for a crash when processing virtual elements (#1488707)
254
255* Fri Sep 15 2017 Kalev Lember <klember@redhat.com> - 2.0.0-2
256- Package review fixes (#1491725):
257- Pass --disable-mp3 to use the generic gstreamer extractor
258- Disable libstemmer support to match the previous behaviour
259- Fix removing .so symlinks for private libraries
260- Remove ldconfig rpm scripts as we don't install any shared libraries
261- Correct license tag and add comment explaining mixed source licensing
262
263* Thu Sep 14 2017 Kalev Lember <klember@redhat.com> - 2.0.0-1
264- Initial Fedora packaging
Note: See TracBrowser for help on using the repository browser.