source: projects/specs/trunk/t/tracker-miners/tracker-miners-vl.spec @ 12282

Revision 12282, 7.5 KB checked in by tomop, 5 years ago (diff)

updated 3 packages

gnome-books-3.34.0-2

gnome-epub-thumbnailer-1.5-11

tracker-miners-2.3.1-1

Line 
1%bcond_with systemd
2
3%global with_enca 1
4%global with_libcue 1
5%global with_rss 0
6
7%global tracker_version 2.2.0
8
9%global systemd_units tracker-extract.service tracker-miner-fs.service tracker-miner-rss.service tracker-writeback.service
10
11# Exclude private libraries from autogenerated provides and requires
12%global __provides_exclude_from ^%{_libdir}/tracker-miners-2.0/
13%global __requires_exclude ^(libtracker-extract\.so|libtracker-miners-common\.so|libextract-.*\.so|libwriteback-.*\.so)
14
15Name:           tracker-miners
16Version:        2.3.1
17Release:        1%{?_dist_release}
18Summary:        Tracker miners and metadata extractors
19Group:          Applications/Services
20
21Vendor:         Project Vine
22Distribution:   Vine Linux
23
24# libtracker-extract is LGPLv2+; the miners are a mix of GPLv2+ and LGPLv2+ code
25License:        GPLv2+ and LGPLv2+
26URL:            https://wiki.gnome.org/Projects/Tracker
27
28%define         shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
29Source0:        https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
30
31BuildRequires:  gcc
32BuildRequires:  giflib-devel
33BuildRequires:  intltool
34BuildRequires:  meson
35%if %{with systemd}
36BuildRequires:  systemd
37%endif
38BuildRequires:  pkgconfig(dbus-1)
39%if 0%{?with_enca}
40BuildRequires:  pkgconfig(enca)
41%endif
42BuildRequires:  pkgconfig(exempi-2.0)
43BuildRequires:  flac-devel
44BuildRequires:  pkgconfig(gexiv2)
45BuildRequires:  pkgconfig(gstreamer-1.0)
46BuildRequires:  pkgconfig(gstreamer-pbutils-1.0)
47BuildRequires:  pkgconfig(gstreamer-tag-1.0)
48BuildRequires:  pkgconfig(icu-i18n)
49BuildRequires:  pkgconfig(icu-uc)
50%if 0%{?with_libcue}
51BuildRequires:  pkgconfig(libcue)
52%endif
53BuildRequires:  pkgconfig(libexif)
54%if 0%{?with_rss}
55BuildRequires:  pkgconfig(libgrss)
56%endif
57BuildRequires:  pkgconfig(libgsf-1)
58BuildRequires:  pkgconfig(libgxps)
59#BuildRequires:  pkgconfig(libiptcdata)
60BuildRequires:  pkgconfig(libjpeg)
61#BuildRequires:  pkgconfig(libosinfo-1.0)
62BuildRequires:  pkgconfig(libpng)
63BuildRequires:  pkgconfig(libseccomp)
64BuildRequires:  pkgconfig(libtiff-4)
65BuildRequires:  pkgconfig(libxml-2.0)
66BuildRequires:  pkgconfig(poppler-glib)
67BuildRequires:  pkgconfig(taglib_c)
68BuildRequires:  pkgconfig(totem-plparser)
69BuildRequires:  pkgconfig(tracker-sparql-2.0)
70BuildRequires:  pkgconfig(upower-glib)
71BuildRequires:  pkgconfig(vorbisfile)
72BuildRequires:  pkgconfig(zlib)
73
74%if %{with systemd}
75%{?systemd_requires}
76%endif
77Requires:       tracker%{?_isa} >= %{tracker_version}
78
79# tracker-miners was split out from tracker in 1.99.2
80Obsoletes:      tracker < 1.99.2
81Conflicts:      tracker < 1.99.2
82
83%description
84Tracker is a powerful desktop-neutral first class object database,
85tag/metadata database and search tool.
86
87This package contains various miners and metadata extractors for tracker.
88
89
90%prep
91%autosetup -p1
92
93
94%build
95# Disable the functional tests for now, they use python bytecodes.
96%meson \
97  -Dfunctional_tests=false \
98  -Diptc=disabled \
99  -Diso=disabled \
100  -Dminer_rss=false \
101%if %{with systemd}
102  -Dsystemd_user_services=%{_userunitdir}
103%endif
104  %{nil}
105%meson_build
106
107
108%install
109%meson_install
110
111rm -rf %{buildroot}%{_datadir}/tracker-tests
112
113%find_lang %{name}
114
115
116%post
117%if %{with systemd}
118%systemd_user_post %{systemd_units}
119%endif
120if [ $1 -eq 1 ]; then
121  glib-compile-schemas /usr/share/glib-2.0/schemas ||:
122  update-desktop-database -q > /dev/null || :
123fi
124
125%if %{with systemd}
126%preun
127%systemd_user_preun %{systemd_units}
128%endif
129
130%postun
131%if %{with systemd}
132%systemd_user_postun_with_restart %{systemd_units}
133%endif
134if [ $1 -eq 0 ]; then
135  glib-compile-schemas /usr/share/glib-2.0/schemas ||:
136  update-desktop-database -q > /dev/null || :
137fi
138
139
140%files -f %{name}.lang
141%license COPYING
142%doc AUTHORS NEWS README.md
143%{_libdir}/tracker-miners-2.0/
144%{_libexecdir}/tracker*
145%{_datadir}/dbus-1/services/org.freedesktop.Tracker*
146%{_datadir}/glib-2.0/schemas/*
147%{_datadir}/tracker/
148%{_datadir}/tracker-miners/
149%{_mandir}/man1/tracker-*.1*
150%config(noreplace) %{_sysconfdir}/xdg/autostart/tracker*.desktop
151%if %{with systemd}
152%{_userunitdir}/tracker*.service
153%endif
154
155%changelog
156* Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.1
157- initial build for Vine Linux.
158- new upstream release.
159
160* Mon Sep 09 2019 Kalev Lember <klember@redhat.com> - 2.3.0-1
161- Update to 2.3.0
162
163* Fri Sep 06 2019 Nikola Forró <nforro@redhat.com> - 2.2.99.1-2
164- Rebuilt for exempi 2.5.1
165
166* Fri Sep 06 2019 Kalev Lember <klember@redhat.com> - 2.2.99.1-1
167- Update to 2.2.99.1
168
169* Mon Aug 12 2019 Kalev Lember <klember@redhat.com> - 2.2.99.0-1
170- Update to 2.2.99.0
171
172* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.2-2
173- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
174
175* Fri May 03 2019 David King <amigadave@amigadave.com> - 2.2.2-1
176- Update to 2.2.2
177
178* Fri Mar 08 2019 Kalev Lember <klember@redhat.com> - 2.2.1-1
179- Update to 2.2.1
180
181* Thu Feb 21 2019 Kalev Lember <klember@redhat.com> - 2.2.0-3
182- Exclude private libraries from autogenerated provides and requires
183
184* Thu Feb 21 2019 Kalev Lember <klember@redhat.com> - 2.2.0-2
185- Fix the package to be installable again
186
187* Wed Feb 20 2019 Kalev Lember <klember@redhat.com> - 2.2.0-1
188- Update to 2.2.0
189- Switch to the meson build system
190
191* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.5-4
192- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
193
194* Wed Jan 23 2019 Pete Walter <pwalter@fedoraproject.org> - 2.1.5-3
195- Rebuild for ICU 63
196
197* Mon Jan 21 2019 Kevin Fenzi <kevin@scrye.com> - 2.1.5-2
198- Rebuild to drop libiptcdata deps
199
200* Fri Sep 28 2018 Kalev Lember <klember@redhat.com> - 2.1.5-1
201- Update to 2.1.5
202
203* Wed Sep 05 2018 Kalev Lember <klember@redhat.com> - 2.1.4-2
204- Rebuilt with fixed vala
205
206* Tue Sep 04 2018 Kalev Lember <klember@redhat.com> - 2.1.4-1
207- Update to 2.1.4
208
209* Mon Sep 03 2018 Kalev Lember <klember@redhat.com> - 2.1.3-1
210- Update to 2.1.3
211
212* Sun Aug 19 2018 Kalev Lember <klember@redhat.com> - 2.1.1-1
213- Update to 2.1.1
214
215* Wed Jul 25 2018 Kalev Lember <klember@redhat.com> - 2.1.0-1
216- Update to 2.1.0
217
218* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.5-3
219- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
220
221* Tue Jul 10 2018 Pete Walter <pwalter@fedoraproject.org> - 2.0.5-2
222- Rebuild for ICU 62
223
224* Tue Jun 26 2018 Kalev Lember <klember@redhat.com> - 2.0.5-1
225- Update to 2.0.5
226
227* Mon Apr 30 2018 Pete Walter <pwalter@fedoraproject.org> - 2.0.4-4
228- Rebuild for ICU 61.1
229
230* Sun Feb 11 2018 Sandro Mani <manisandro@gmail.com> - 2.0.4-3
231- Rebuild (giflib)
232
233* Thu Feb 08 2018 Kalev Lember <klember@redhat.com> - 2.0.4-2
234- Rebuild to really enable the RAW extractor
235
236* Wed Feb 07 2018 Kalev Lember <klember@redhat.com> - 2.0.4-1
237- Update to 2.0.4
238- Enable new gexiv2 based RAW extractor
239
240* Thu Nov 30 2017 Pete Walter <pwalter@fedoraproject.org> - 2.0.3-2
241- Rebuild for ICU 60.1
242
243* Tue Nov 21 2017 Kalev Lember <klember@redhat.com> - 2.0.3-1
244- Update to 2.0.3
245
246* Fri Oct 06 2017 Kalev Lember <klember@redhat.com> - 2.0.2-1
247- Update to 2.0.2
248
249* Tue Sep 19 2017 Kalev Lember <klember@redhat.com> - 2.0.0-3
250- Backport a fix for a crash when processing virtual elements (#1488707)
251
252* Fri Sep 15 2017 Kalev Lember <klember@redhat.com> - 2.0.0-2
253- Package review fixes (#1491725):
254- Pass --disable-mp3 to use the generic gstreamer extractor
255- Disable libstemmer support to match the previous behaviour
256- Fix removing .so symlinks for private libraries
257- Remove ldconfig rpm scripts as we don't install any shared libraries
258- Correct license tag and add comment explaining mixed source licensing
259
260* Thu Sep 14 2017 Kalev Lember <klember@redhat.com> - 2.0.0-1
261- Initial Fedora packaging
Note: See TracBrowser for help on using the repository browser.