source: projects/specs/trunk/t/trac/trac-vl.spec @ 604

Revision 604, 4.0 KB checked in by owa, 14 years ago (diff)

updated trac to 0.11.6

Line 
1## %define python_sitelib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(0)')
2%define name trac
3%define version 0.11.6
4%define release 1%{?_dist_release}
5%define japanize ja1
6
7Summary: A web-based software project management and bug/issue tracking system
8Summary(ja): Web ベースのソフトウェアプロジェクト管理およびバグ追跡システム
9Name: %{name}
10Version: %{version}
11Release: %{release}
12Source0: http://www.i-act.co.jp/project/products/downloads/Trac-%{version}.%{japanize}.zip
13Patch0: trac-0.11.4.ja1-default_charset.patch
14Patch1: trac-0.11.3.ja1-fix_sourceforge2trac.py.patch
15License: modified BSD-style License
16Group: Applications/Development
17URL: http://trac.edgewall.org/
18
19BuildArch: noarch
20Requires: python, python-genshi >= 0.5, python-setuptools >= 0.6b1
21#Requires: pysqlite
22BuildRequires: python-devel, python-genshi >= 0.5, python-setuptools >= 0.6b1
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%description
29Trac is an enhanced wiki and issue tracking system for software
30development projects. Trac uses a minimalistic approach to
31web-based software project management. Our mission is to help
32developers write great software while staying out of the way.
33Trac should impose as little as possible on a team's established
34development process and policies.
35
36%description -l ja
37Trac はソフトウェア開発プロジェクトのマネージメントにおける
38最小限のアプローチを提供する Web アプリケーションです。
39ソフトウェア開発の上でのチケット解決、機能追加、および
40すべての工程において、効果的なトラッキングとハンドリングを
41簡素化することを目標としています。
42Trac の全てのアスペクトは、一つの目標のもとに設計されています。
43古びた方法でプロジェクトを運営している、ソフトウェア開発者の
44助けとなること。そのために、チームが既に確立している
45開発プロセスと開発ポリシーに影響をなるべく与えないこと。
46
47%prep
48%setup -q -n Trac-%{version}.%{japanize}
49%patch0 -p1
50%patch1 -p1
51
52%build
53%{__python} setup.py build
54
55%install
56rm -rf ${RPM_BUILD_ROOT}
57%{__python} setup.py install --root=${RPM_BUILD_ROOT}
58
59## deleting files
60%{__rm} -f contrib/trac-post-commit-hook.cmd
61%{__rm} -rf contrib/rpm
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(-,root,root)
68%doc AUTHORS COPYING* ChangeLog* README* RELEASE* TESTING-README* THANKS* UPGRADE*
69%doc doc sample-plugins wiki-macros contrib
70%{_bindir}/*
71%{python_sitelib}/Trac-*.egg-info
72%{python_sitelib}/trac
73
74%changelog
75* Wed Mar 17 2010 Shu KONNO <owa@bg.wakwak.com> 0.11.6-1
76- updated Trac to 0.11.6.ja1
77- rebuilt with python-2.6
78- dropt BR: pysqlite (included in python-2.6)
79
80* Sat Apr 25 2009 IWAI, Masaharu <iwai@alib.jp> 0.11.4-1
81- new upstream release
82- update default charset patch (Patch0)
83  - add patching default wiki page
84
85* Mon Apr  6 2009 IWAI, Masaharu <iwai@alib.jp> 0.11.3-2
86- add Requires: pysqlite
87- fix 0.11.3-1 changelog
88  - update Requires and BuildRequires
89
90* Sun Apr  5 2009 IWAI, Masaharu <iwai@alib.jp> 0.11.3-1
91- new upstream release
92- update License value
93- update default_charset patch (Patch0)
94- update %%files section
95- add fix sourceforge2trac.py.patch (Patch1)
96- update Requires
97  - drop clearsilver, silvercity, pysqlite, python-pyxml, subversion-python
98  - add python-genshi >= 0.5, python-setuptools >= 0.6b1
99- update BuildRequires
100  - add python-genshi >= 0.5, python-setuptools >= 0.6b1
101
102* Mon Oct 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.10.5-2
103- added %%python_sitelib macro to be independent of platforms
104- added BuildArch: noarch
105
106* Mon Oct 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.10.5-1
107- upgraded to 0.10.5, the newest 0.10.x line, including security and bug fixes
108- spec in UTF-8
109- modified Patch0 to set utf-8 as default encoding
110
111* Wed Aug 22 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.10.4-0vl1
112- initial build for Vine Linux
113- add Patch0 to change default_charset to euc-jp
114
Note: See TracBrowser for help on using the repository browser.