source: projects/specs/trunk/t/tpb/tpb-vl.spec @ 521

Revision 521, 4.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           tpb
2Version:        0.6.4
3Release:        2%{?_dist_release}
4Summary:        IBM ThinkPad button support utility
5Summary(ja):    IBM ThinkPad ボタンサポートユーティリティ
6Group:          System Environment/Base
7License:        GPL
8URL:            http://www.nongnu.org/tpb/
9Source0:        http://savannah.nongnu.org/download/tpb/tpb-%{version}.tar.gz
10Source1:        http://savannah.nongnu.org/download/tpb/tpb-%{version}.tar.gz.sig
11Patch0:         %{name}-defaultconfig.patch
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires:  libxosd-devel >= 2.0.0
15BuildRequires:  xorg-x11-devel
16BuildRequires:  gettext
17BuildRequires:  libXt-devel
18
19Requires:       xorg-x11-xinit
20Requires:       udev
21Requires:       MAKEDEV
22
23%description
24With TPB it is possible to bind a program to the ThinkPad, Mail, Home
25and Search buttons. TPB can also run a callback program on each state
26change with the changed state and the new state as options.  So it is
27possible to trigger several actions on different events.  TPB has a
28on-screen display (OSD) to show volume, mute, brightness and some
29other information.  Furthermore TPB supports a software mixer, as the
30R series ThinkPads have no hardware mixer to change the volume.
31
32
33%prep
34%setup -q
35%patch0 -p0
36
37# Start tpb at X startup:
38cat <<EOF > %{name}.xinit
39#!/bin/sh
40%{_bindir}/tpb -d
41EOF
42
43# For the initial MAKEDEV at post-install time, and possibly later:
44cat <<EOF > %{name}.makedev
45# Custom permissions for nvram for use with tpb(1).
46c 664 root root         10 144  1   1 nvram
47EOF
48
49# Permissions fixup:
50cat <<EOF > %{name}.rules
51# Custom permissions for nvram for use with tpb(1).
52KERNEL=="nvram", MODE="0664"
53EOF
54
55%build
56%configure
57make %{?_smp_mflags}
58
59
60%install
61rm -rf $RPM_BUILD_ROOT
62make install DESTDIR=$RPM_BUILD_ROOT
63install -Dm 755 %{name}.xinit \
64  $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/%{name}.sh
65install -Dpm 644 %{name}.rules \
66  $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/90-%{name}.rules
67install -Dpm 644 %{name}.makedev \
68  $RPM_BUILD_ROOT%{_sysconfdir}/makedev.d/zz_%{name}
69%find_lang %{name}
70
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75
76%files -f %{name}.lang
77%defattr(-,root,root,-)
78%doc ChangeLog COPYING CREDITS README doc/callback_example.sh doc/nvram.txt
79%config %{_sysconfdir}/X11/xinit/xinitrc.d/%{name}.sh
80%config(noreplace) %{_sysconfdir}/tpbrc
81%config(noreplace) %{_sysconfdir}/udev/rules.d/*-%{name}.rules
82%config(noreplace) %{_sysconfdir}/makedev.d/*%{name}
83%{_bindir}/tpb
84%{_mandir}/man1/tpb.1*
85
86# Note: need read access here.
87#%attr(644,root,root) %dev(c,10,144) /dev/nvram
88
89
90%changelog
91* Wed Sep 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.6.4-2
92- added nvram rules
93- added Requires: udev, MAKEDEV
94
95* Fri Jul 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.6.4-1vl5
96- new upstream release
97- changed XOrg-devel to xorg-x11-devel
98- added BuildRequires: libXt-devel, Requires: xorg-x11-xinit
99
100* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.3-3vl5
101- applied new versioning policy, spec in utf-8
102
103* Sat Sep 11 2004 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 0.6.3-2vl1
104- based on Fedora
105- new upstream release
106- fixed BuildRoot, BuildRequires
107- delete Epoch
108- added summary(ja)
109
110* Wed Jun  2 2004 Ville Skytta <ville.skytta at iki.fi> - 0:0.6.2-0.fdr.2
111- Rename xinit scriptlet to tpb.sh (bug 1227, bugzilla.redhat.com/122869).
112
113* Wed May 19 2004 Ville Skytta <ville.skytta at iki.fi> - 0:0.6.2-0.fdr.1
114- Update to 0.6.2.
115- Improve default configuration.
116- Remove LD_ASSUME_KERNEL hack.
117
118* Mon Jan 19 2004 Ville Skytta <ville.skytta at iki.fi> - 0:0.6.1-0.fdr.1
119- Update to 0.6.1.
120
121* Mon Nov 24 2003 Ville Skytta <ville.skytta at iki.fi> - 0:0.6.0-0.fdr.3
122- Don't use MAKEDEV to create /dev/nvram.
123
124* Wed Oct 22 2003 Ville Skytta <ville.skytta at iki.fi> - 0:0.6.0-0.fdr.2
125- Add LD_ASSUME_KERNEL=2.4.1 workaround to xinit script.
126  http://savannah.nongnu.org/bugs/?func=detailbug&bug_id=3260&group_id=2320
127
128* Mon Aug 11 2003 Ville Skytta <ville.skytta at iki.fi> - 0:0.6.0-0.fdr.1
129- Update to 0.6.0.
130
131* Tue May 27 2003 Ville Skytta <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.4
132- Make /dev/nvram readable again (#296).
133
134* Sun May 18 2003 Ville Skytta <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.3
135- Use MAKEDEV for creating the nvram device node and own it.
136- Mark xinit file as config to make rpmlint happy.
137- %%{buildroot} -> $RPM_BUILD_ROOT.
138- Make the build honor $RPM_OPT_FLAGS.
139
140* Sat Apr 19 2003 Ville Skytta <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.2
141- Don't require tpctl (#177).
142
143* Fri Apr 11 2003 Ville Skytta <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.1
144- Update to 0.5.1.
145
146* Sun Apr  6 2003 Ville Skytta <ville.skytta at iki.fi> - 0:0.5.0-0.fdr.1
147- Update to 0.5.0.
148- Save .spec in UTF-8.
149
150* Sun Mar 30 2003 Ville Skytta <ville.skytta at iki.fi> - 0:0.4.2-0.fdr.1
151- Rebuild according to Fedora RC3 guidelines.
152
153* Sat Feb  8 2003 Ville Skytta <ville.skytta at iki.fi> - 0.4.2-1.fedora.1
154- First Fedora release.
Note: See TracBrowser for help on using the repository browser.