source: projects/specs/trunk/t/totem/totem-vl.spec @ 9569

Revision 9569, 18.3 KB checked in by Takemikaduchi, 9 years ago (diff)

cogl: add patch
others: new upstream release

Line 
1# define versions
2%define _glib_ver               2.44.0
3%define _gtk_ver                3.16.0
4%define _gnomeicon_ver          3.12.0
5%define _gnome_doc_utils_ver    0.20.0
6%define _dbus_ver               1.6.0
7%define _gst_ver                1.2.0
8%define _gstpb_ver              1.2.0
9%define _gstpg_ver              1.2.0
10%define _gstpbad_ver            1.2.0
11%define _xulrunner_ver          1.9
12%define _nautilus_ver           3.16.0
13%define _shared_mime_info_ver   0.17
14%define _unique_ver             1.0
15%define _totem_pl_parser_ver    3.4.4
16
17%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
18
19Summary:        Movie player for GNOME 3
20Summary(ja):    GNOME3 用動画プレイヤー
21Name:           totem
22Version:        3.16.1
23Release:        1%{?_dist_release}
24License:        GPL
25Group:          Applications/Multimedia
26URL:            http://www.gnome.org/projects/totem/
27Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33Packager:       Takemikaduchi
34
35BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
36BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
37BuildRequires:  dbus-devel >= %{_dbus_ver}
38BuildRequires:  nautilus-devel >= %{_nautilus_ver}
39BuildRequires:  gnome-desktop3-devel
40BuildRequires:  gettext
41BuildRequires:  perl-XML-Parser
42BuildRequires:  iso-codes
43BuildRequires:  yelp-tools
44BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
45BuildRequires:  grilo-devel
46BuildRequires:  bluez-libs-devel >= 4.15
47BuildRequires:  lirc
48BuildRequires:  unique-devel >= %{_unique_ver}
49BuildRequires:  python-devel
50BuildRequires:  pylint
51BuildRequires:  pygobject3-devel
52BuildRequires:  libpeas-devel
53BuildRequires:  libXtst-devel
54BuildRequires:  gsettings-desktop-schemas-devel
55BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
56BuildRequires:  vala
57
58BuildRequires:  gstreamer1-devel >= %{_gst_ver}
59BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
60BuildRequires:  gstreamer1-plugins-good >= %{_gstpg_ver}
61BuildRequires:  gstreamer1-plugins-bad-free-devel >= %{_gstpbad_ver}
62
63BuildRequires:  clutter-gtk-devel
64BuildRequires:  clutter-gst3-devel
65
66BuildRequires:  nautilus-devel >= %{_nautilus_ver}
67BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
68
69
70Requires:       gstreamer1 >= %{_gst_ver}
71Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
72Requires:       gstreamer1-plugins-good >= %{_gstpg_ver}
73Requires:       gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
74Requires:       iso-codes
75
76Obsoletes:      nautilus-media
77Obsoletes:      %{name}-gstreamer < 2.30.1-2
78Obsoletes:      %{name}-xine < 2.30.1-2
79Obsoletes:      %{name}-common < 2.30.1-3
80Obsoletes:      %{name}-mozilla < 3.14.0
81
82Provides:       nautilus-media
83Provides:       %{name}-common = %{version}-%{release}
84
85Requires(post):     ldconfig, desktop-file-utils
86Requires(postun):   ldconfig, desktop-file-utils
87
88%description
89Totem is simple movie player for the Gnome desktop. It features a
90simple playlist, a full-screen mode, seek and volume controls, as well as
91a pretty complete keyboard navigation.
92
93%package devel
94Summary:        Plugin writer's documentation for totem
95Group:          Development/Libraries
96Requires:       %{name} = %{version}-%{release}
97
98%description devel
99The %{name}-devel package contains API documentation for
100developing developing plugins for %{name}.
101
102%prep
103%setup -q
104
105%build
106#DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
107#export MOZILLA_PLUGINDIR=%{mozplug_dir}
108%configure \
109        --enable-python \
110        --enable-vala \
111        --enable-nautilus
112
113make %{?_smp_mflags}
114
115%install
116rm -rf $RPM_BUILD_ROOT
117
118make install DESTDIR=$RPM_BUILD_ROOT
119
120# remove unneeded files
121%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
122%__rm -f %{buildroot}%{_libdir}/*.{a,la}
123%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
124%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
125%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
126%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
127%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
128
129# remove unused file
130%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
131%__rm -f %{buildroot}%{_libexecdir}/%{name}/totem-bugreport.py
132 
133%find_lang %{name} --with-gnome
134
135# save space by linking identical images in translated docs
136helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
137for f in $helpdir/C/figures/*.png; do
138  b="$(basename $f)"
139  for d in $helpdir/*; do
140    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
141      g="$d/figures/$b"
142      if [ -f "$g" ]; then
143        if cmp -s $f $g; then
144          rm "$g"; ln -s "../../C/figures/$b" "$g"
145        fi
146      fi
147    fi
148  done
149done
150
151
152%clean
153%__rm -rf %{buildroot}
154
155%post
156%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
157touch %{_datadir}/icons/hicolor
158if [ -x /usr/bin/gtk-update-icon-cache ]; then
159  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
160fi
161
162%postun
163%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
164touch %{_datadir}/icons/hicolor
165if [ -x /usr/bin/gtk-update-icon-cache ]; then
166  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
167fi
168glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
169
170%posttrans
171glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
172
173%files -f %{name}.lang
174%defattr(-,root,root,-)
175%doc AUTHORS COPYING ChangeLog NEWS README TODO
176%{_bindir}/totem
177%{_bindir}/totem-audio-preview
178%{_bindir}/totem-video-thumbnailer
179%{_datadir}/GConf/gsettings/opensubtitles.convert
180#%{_datadir}/GConf/gsettings/pythonconsole.convert
181%{_datadir}/GConf/gsettings/totem.convert
182%{_datadir}/appdata/org.gnome.Totem.appdata.xml
183%{_datadir}/applications/org.gnome.Totem.desktop
184%{_datadir}/dbus-1/services/org.gnome.Totem.service
185%{_datadir}/glib-2.0/schemas/*.xml
186%{_datadir}/icons/*/*/*/*
187%{_datadir}/thumbnailers/totem.thumbnailer
188%{_datadir}/%{name}
189%{_datadir}/gtk-doc/html/totem
190%{_libdir}/libtotem.so.*
191%{_libdir}/girepository-1.0/*.typelib
192%dir %{_libdir}/totem
193%dir %{_libdir}/totem/plugins
194%{_libdir}/totem/plugins/apple-trailers/
195%{_libdir}/totem/plugins/autoload-subtitles
196%{_libdir}/totem/plugins/brasero-disc-recorder
197%{_libdir}/totem/plugins/dbus
198%{_libdir}/totem/plugins/gromit
199%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
200%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
201%{_libdir}/totem/plugins/lirc
202%{_libdir}/totem/plugins/media-player-keys
203%{_libdir}/totem/plugins/ontop
204%{_libdir}/totem/plugins/opensubtitles
205%{_libdir}/totem/plugins/properties
206%{_libdir}/totem/plugins/pythonconsole
207%{_libdir}/totem/plugins/recent
208%{_libdir}/totem/plugins/rotation
209%{_libdir}/totem/plugins/screensaver
210%{_libdir}/totem/plugins/screenshot
211%{_libdir}/totem/plugins/skipto
212%{_libdir}/totem/plugins/save-file/libsave-file.so
213%{_libdir}/totem/plugins/save-file/save-file.plugin
214%{_libdir}/totem/plugins/vimeo
215%{_libdir}/nautilus/extensions-3.0/*.so*
216%{_mandir}/man1/*
217
218%files devel
219%defattr(-, root, root,-)
220%{_includedir}/totem
221%{_libdir}/libtotem.so
222%{_libdir}/pkgconfig/totem.pc
223%{_datadir}/gir-1.0/Totem-1.0.gir
224%{_datadir}/gtk-doc/html/totem
225
226
227%changelog
228* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
229- new upstream release
230
231* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
232- new upstream release
233- change BuildRequires: clutter-gst3-devel instead of clutter-gst-devel
234
235* Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
236- new upstream release
237
238* Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
239- new upstream release
240
241* Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
242- new upstream release
243- add BuildRequires: gnome-desktop3-devel
244- remove BuildRequires: xulrunner-devel
245- remove %%{name}-mozilla subpackage
246
247* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
248- new upstream release
249
250* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
251- new upstream release
252
253* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
254- new upstream release
255
256* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
257- rebuild with VineSeed environment
258
259* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
260- new upstream release
261
262* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
263- new upstream release
264
265* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
266- new upstream release
267- add BuildRequires: yelp-tools, vala
268- change configure option (--enable-vala)
269
270* Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
271- new upstream release
272
273* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
274- new upstream release
275- change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
276
277* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
278- new upstream release
279- add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
280
281* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
282- new upstream release
283
284* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
285- add configure option (--disable-vegas-plugin)
286
287* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
288- new upstream release
289
290* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
291- new upstream release
292- add BuildRequires: pylint
293- remove BuildRequires: libgdata-devel
294
295* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
296- new upstream release
297
298* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
299- new upstream release
300
301* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
302- new upstream release
303- change BuildRequires: pygobject3-devel instead of pygobject-devel
304
305* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
306- new upstream release
307- change BuildRequires: gtk3-devel instead of gtk2-devel
308- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
309                     clutter-gst-devel, libmx-devel
310- change configure option (--disable-vala)
311
312* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
313- new upstream release
314- fix %files
315
316* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
317- new upstream release
318
319* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
320- clean up spec file
321- remove totem-common and merged to totem main package.
322  - add Obsoletes: totem-common
323- remove unneeded BR: and R:
324  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
325  - libmusicbrainz, alternatives
326- remove explicit dependency
327  - gtk2, glib2, dbus
328- add R: pygtk2, pyxdg, python-Coherence for python plugins
329- add R: gstreamer-plugins-good
330
331* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
332- rebuild with libgdata (add youtube plugin)
333- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
334- add Obsolete: totem-gstreamer, totem-xine)
335
336* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
337- new upstream release
338- chagnge _gst_ver from 0.10.19 to 0.10.29
339
340* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
341- new upstream release
342- drop totem-tracker package
343- add BuildRequires: unique-devel
344- remove BuildRequires: hal-devel
345- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
346
347* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
348- remove unneeded autoreconf
349- add BR: lirc
350
351* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
352- new upstream release
353
354* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
355- remove bemused plugin
356
357* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
358- new upstream release
359
360* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
361- added tracker video search sub-package
362
363* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
364- new upstream release
365
366* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
367- new upstream release
368
369* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
370- remove libxine dependency from totem-common
371- build xine backend with minimum dependency
372
373* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
374- add BR: bluez-libs-devel >= 4.15
375- fix typo in %%postun xine
376
377* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
378- rebuild with bluez-libs-devel-4.15
379
380* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
381- new upstream release
382
383* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
384- new upstream release
385
386* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
387- new upstream release
388- add patch1 to build with xulrunner-1.9
389
390* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
391- new upstream release
392
393* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
394- new upstream release
395- disabled devel package (replaced by totem-pl-parser-devel)
396
397* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
398- new upstream release
399- update version macros
400- enable browser plugins on x86_64
401
402* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
403- new upstream release
404
405* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
406- upstream release
407- drop obsolete ja.po.patch (patch0)
408- revert change of 1.4.4-0vl2
409
410* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
411- upstream release
412- enable browser plugins (exclude x86_64 arch)
413
414* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
415- upstream release
416
417* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
418- update configure options
419- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
420
421* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
422- fix mistranslation (patch0)
423- add icon symlink
424- add BuildRequires: gstreamer-plugins-good
425
426* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
427- upstream release
428- update %%_glib_ver, %%_xine_ver
429- add BuildRequires: hal
430- update %%configure options
431- update %%files
432
433* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
434- upstream release
435
436* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
437- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
438
439* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
440- upstream release
441- drop obsolete patch0
442
443* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
444- upstream release
445- add patch0 to build with intltool-0.35
446
447* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
448- upstream release
449
450* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
451- upstream release
452- update alternatives entry
453
454* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
455- upstream release
456- drop fix-sort-function.patch (was merged to upstream, #331426)
457
458* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
459- rebuild with gnome-2.14rc
460
461* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
462- upstream release
463- add macros
464  - _gtk_ver, _glib_ver
465  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
466  - _dbus_ver
467  - _gst_ver, gstpb_ver, _xine_ver
468- add fix-sort-function.patch to build with glib < 2.9.1
469
470* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
471- upstream release
472- add BuildRequires:
473  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
474  - gnome-vfs2-devel >= 2.9.92
475  - dbus-devel >= 0.35
476- use gstreamer-0.10 as backend for totem-gstreamer
477
478* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
479- use gstreamer08 instead of gstreamer
480
481* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
482- upstream release
483
484* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
485- fix missing links
486  - update file list
487  - update update-alternatives scripts
488- fix totem-gstreamer's %%postun script
489
490* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
491- upstream release
492- add BuildRequires: iso-codes, libmusicbrainz-devel
493- add Requires: iso-codes, libmusicbrains to -common package
494- remove BuildRequires: nautilus-cd-burner
495- remove Requires: nautilus-cd-burner from -common package
496
497* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
498- totem-gstreamer obsoletes nautilus-media
499
500* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
501- upstream release
502- add Requires(post,postun): alternatives for gstreamer,xine
503- add Requires(postun,triggers): alternatives for common
504
505* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
506- upstream release
507
508* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
509- build xine backend
510  - move common files to common package
511  - move GStreamer related files to gstreamer package
512  - install xine related files to xine package
513- fix scripts
514
515* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
516- upstream release
517- update URL
518- move *.{a,la} to devel package
519
520* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
521- fix %%{post,preun} script (video-thumbnail.schemas)
522- sync with Fedora Core's 1.0.1-1
523
524  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
525  - Update to upstream version 1.0.1
526  - Break out devel package
527
528* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
529- add %%{post,pre}un script
530
531* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
532- initial build for Vine Linux
533
534* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
535- fix %%post
536
537* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
538- Obsolete nautilus-media
539- Install property page and thumbnailer
540
541* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
542- Update to 0.101
543 
544* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
545- Grab patch totem-0.100-desktopfile.patch from CVS to fix
546  missing menu entry (144088)
547- Remove workaround for desktop file being misinstalled, fixed
548  by above patch
549
550* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
551- New upstream version 0.100
552
553* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
554- update to 0.99.22
555
556* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
557- Add patch to remove removed items from package from help
558
559* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
560- New upstream 0.99.19
561  - Fixes crasher with CD playback (see NEWS)
562
563* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
564- Call update-desktop-database in post
565
566* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
567- update to 0.99.18
568
569* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
570- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
571
Note: See TracBrowser for help on using the repository browser.