source: projects/specs/trunk/t/totem/totem-vl.spec @ 9475

Revision 9475, 18.3 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME-3.16.0

Line 
1# define versions
2%define _glib_ver               2.44.0
3%define _gtk_ver                3.16.0
4%define _gnomeicon_ver          3.12.0
5%define _gnome_doc_utils_ver    0.20.0
6%define _dbus_ver               1.6.0
7%define _gst_ver                1.2.0
8%define _gstpb_ver              1.2.0
9%define _gstpg_ver              1.2.0
10%define _gstpbad_ver            1.2.0
11%define _xulrunner_ver          1.9
12%define _nautilus_ver           3.16.0
13%define _shared_mime_info_ver   0.17
14%define _unique_ver             1.0
15%define _totem_pl_parser_ver    3.4.4
16
17%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
18
19Summary:        Movie player for GNOME 3
20Summary(ja):    GNOME3 用動画プレイヤー
21Name:           totem
22Version:        3.16.0
23Release:        1%{?_dist_release}
24License:        GPL
25Group:          Applications/Multimedia
26URL:            http://www.gnome.org/projects/totem/
27Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33Packager:       Takemikaduchi
34
35BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
36BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
37BuildRequires:  dbus-devel >= %{_dbus_ver}
38BuildRequires:  nautilus-devel >= %{_nautilus_ver}
39BuildRequires:  gnome-desktop3-devel
40BuildRequires:  gettext
41BuildRequires:  perl-XML-Parser
42BuildRequires:  iso-codes
43BuildRequires:  yelp-tools
44BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
45BuildRequires:  grilo-devel
46BuildRequires:  bluez-libs-devel >= 4.15
47BuildRequires:  lirc
48BuildRequires:  unique-devel >= %{_unique_ver}
49BuildRequires:  python-devel
50BuildRequires:  pylint
51BuildRequires:  pygobject3-devel
52BuildRequires:  libpeas-devel
53BuildRequires:  libXtst-devel
54BuildRequires:  gsettings-desktop-schemas-devel
55BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
56BuildRequires:  vala
57
58BuildRequires:  gstreamer1-devel >= %{_gst_ver}
59BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
60BuildRequires:  gstreamer1-plugins-good >= %{_gstpg_ver}
61BuildRequires:  gstreamer1-plugins-bad-free-devel >= %{_gstpbad_ver}
62
63BuildRequires:  clutter-gtk-devel
64BuildRequires:  clutter-gst3-devel
65BuildRequires:  libmx-devel
66
67BuildRequires:  nautilus-devel >= %{_nautilus_ver}
68BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
69
70Requires:       gstreamer1 >= %{_gst_ver}
71Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
72Requires:       gstreamer1-plugins-good >= %{_gstpg_ver}
73Requires:       gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
74Requires:       iso-codes
75
76Obsoletes:      nautilus-media
77Obsoletes:      %{name}-gstreamer < 2.30.1-2
78Obsoletes:      %{name}-xine < 2.30.1-2
79Obsoletes:      %{name}-common < 2.30.1-3
80Obsoletes:      %{name}-mozilla < 3.14.0
81
82Provides:       nautilus-media
83Provides:       %{name}-common = %{version}-%{release}
84
85Requires(post):     ldconfig, desktop-file-utils
86Requires(postun):   ldconfig, desktop-file-utils
87
88%description
89Totem is simple movie player for the Gnome desktop. It features a
90simple playlist, a full-screen mode, seek and volume controls, as well as
91a pretty complete keyboard navigation.
92
93%package devel
94Summary:        Plugin writer's documentation for totem
95Group:          Development/Libraries
96Requires:       %{name} = %{version}-%{release}
97
98%description devel
99The %{name}-devel package contains API documentation for
100developing developing plugins for %{name}.
101
102%prep
103%setup -q
104
105%build
106DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
107export MOZILLA_PLUGINDIR=%{mozplug_dir}
108
109%configure \
110        --enable-python \
111        --enable-vala \
112        --enable-nautilus
113
114make %{?_smp_mflags}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118
119make install DESTDIR=$RPM_BUILD_ROOT
120
121# remove unneeded files
122%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
123%__rm -f %{buildroot}%{_libdir}/*.{a,la}
124%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
125%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
126%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
127%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
128%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
129
130# remove unused file
131%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
132%__rm -f %{buildroot}%{_libexecdir}/%{name}/totem-bugreport.py
133 
134%find_lang %{name} --with-gnome
135
136# save space by linking identical images in translated docs
137helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
138for f in $helpdir/C/figures/*.png; do
139  b="$(basename $f)"
140  for d in $helpdir/*; do
141    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
142      g="$d/figures/$b"
143      if [ -f "$g" ]; then
144        if cmp -s $f $g; then
145          rm "$g"; ln -s "../../C/figures/$b" "$g"
146        fi
147      fi
148    fi
149  done
150done
151
152
153%clean
154%__rm -rf %{buildroot}
155
156%post
157%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
158touch %{_datadir}/icons/hicolor
159if [ -x /usr/bin/gtk-update-icon-cache ]; then
160  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
161fi
162
163%postun
164%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
165touch %{_datadir}/icons/hicolor
166if [ -x /usr/bin/gtk-update-icon-cache ]; then
167  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
168fi
169glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
170
171%posttrans
172glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
173
174%files -f %{name}.lang
175%defattr(-,root,root,-)
176%doc AUTHORS COPYING ChangeLog NEWS README TODO
177%{_bindir}/totem
178%{_bindir}/totem-audio-preview
179%{_bindir}/totem-video-thumbnailer
180%{_datadir}/GConf/gsettings/opensubtitles.convert
181#%{_datadir}/GConf/gsettings/pythonconsole.convert
182%{_datadir}/GConf/gsettings/totem.convert
183%{_datadir}/appdata/org.gnome.Totem.appdata.xml
184%{_datadir}/applications/org.gnome.Totem.desktop
185%{_datadir}/dbus-1/services/org.gnome.Totem.service
186%{_datadir}/glib-2.0/schemas/*.xml
187%{_datadir}/icons/*/*/*/*
188%{_datadir}/thumbnailers/totem.thumbnailer
189%{_datadir}/%{name}
190%{_datadir}/gtk-doc/html/totem
191%{_libdir}/libtotem.so.*
192%{_libdir}/girepository-1.0/*.typelib
193%dir %{_libdir}/totem
194%dir %{_libdir}/totem/plugins
195%{_libdir}/totem/plugins/apple-trailers/
196%{_libdir}/totem/plugins/autoload-subtitles
197%{_libdir}/totem/plugins/brasero-disc-recorder
198%{_libdir}/totem/plugins/chapters
199%{_libdir}/totem/plugins/dbus
200%{_libdir}/totem/plugins/gromit
201%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
202%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
203%{_libdir}/totem/plugins/lirc
204%{_libdir}/totem/plugins/media-player-keys
205%{_libdir}/totem/plugins/ontop
206%{_libdir}/totem/plugins/opensubtitles
207%{_libdir}/totem/plugins/properties
208%{_libdir}/totem/plugins/pythonconsole
209%{_libdir}/totem/plugins/recent
210%{_libdir}/totem/plugins/rotation
211%{_libdir}/totem/plugins/screensaver
212%{_libdir}/totem/plugins/screenshot
213%{_libdir}/totem/plugins/skipto
214%{_libdir}/totem/plugins/save-file/libsave-file.so
215%{_libdir}/totem/plugins/save-file/save-file.plugin
216%{_libdir}/totem/plugins/vimeo
217%{_libdir}/nautilus/extensions-3.0/*.so*
218%{_mandir}/man1/*
219
220%files devel
221%defattr(-, root, root,-)
222%{_includedir}/totem
223%{_libdir}/libtotem.so
224%{_libdir}/pkgconfig/totem.pc
225%{_datadir}/gir-1.0/Totem-1.0.gir
226%{_datadir}/gtk-doc/html/totem
227
228
229%changelog
230* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
231- new upstream release
232- change BuildRequires: clutter-gst3-devel instead of clutter-gst-devel
233
234* Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
235- new upstream release
236
237* Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
238- new upstream release
239
240* Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
241- new upstream release
242- add BuildRequires: gnome-desktop3-devel
243- remove BuildRequires: xulrunner-devel
244- remove %%{name}-mozilla subpackage
245
246* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
247- new upstream release
248
249* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
250- new upstream release
251
252* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
253- new upstream release
254
255* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
256- rebuild with VineSeed environment
257
258* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
259- new upstream release
260
261* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
262- new upstream release
263
264* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
265- new upstream release
266- add BuildRequires: yelp-tools, vala
267- change configure option (--enable-vala)
268
269* Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
270- new upstream release
271
272* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
273- new upstream release
274- change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
275
276* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
277- new upstream release
278- add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
279
280* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
281- new upstream release
282
283* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
284- add configure option (--disable-vegas-plugin)
285
286* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
287- new upstream release
288
289* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
290- new upstream release
291- add BuildRequires: pylint
292- remove BuildRequires: libgdata-devel
293
294* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
295- new upstream release
296
297* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
298- new upstream release
299
300* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
301- new upstream release
302- change BuildRequires: pygobject3-devel instead of pygobject-devel
303
304* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
305- new upstream release
306- change BuildRequires: gtk3-devel instead of gtk2-devel
307- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
308                     clutter-gst-devel, libmx-devel
309- change configure option (--disable-vala)
310
311* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
312- new upstream release
313- fix %files
314
315* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
316- new upstream release
317
318* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
319- clean up spec file
320- remove totem-common and merged to totem main package.
321  - add Obsoletes: totem-common
322- remove unneeded BR: and R:
323  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
324  - libmusicbrainz, alternatives
325- remove explicit dependency
326  - gtk2, glib2, dbus
327- add R: pygtk2, pyxdg, python-Coherence for python plugins
328- add R: gstreamer-plugins-good
329
330* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
331- rebuild with libgdata (add youtube plugin)
332- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
333- add Obsolete: totem-gstreamer, totem-xine)
334
335* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
336- new upstream release
337- chagnge _gst_ver from 0.10.19 to 0.10.29
338
339* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
340- new upstream release
341- drop totem-tracker package
342- add BuildRequires: unique-devel
343- remove BuildRequires: hal-devel
344- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
345
346* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
347- remove unneeded autoreconf
348- add BR: lirc
349
350* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
351- new upstream release
352
353* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
354- remove bemused plugin
355
356* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
357- new upstream release
358
359* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
360- added tracker video search sub-package
361
362* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
363- new upstream release
364
365* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
366- new upstream release
367
368* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
369- remove libxine dependency from totem-common
370- build xine backend with minimum dependency
371
372* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
373- add BR: bluez-libs-devel >= 4.15
374- fix typo in %%postun xine
375
376* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
377- rebuild with bluez-libs-devel-4.15
378
379* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
380- new upstream release
381
382* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
383- new upstream release
384
385* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
386- new upstream release
387- add patch1 to build with xulrunner-1.9
388
389* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
390- new upstream release
391
392* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
393- new upstream release
394- disabled devel package (replaced by totem-pl-parser-devel)
395
396* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
397- new upstream release
398- update version macros
399- enable browser plugins on x86_64
400
401* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
402- new upstream release
403
404* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
405- upstream release
406- drop obsolete ja.po.patch (patch0)
407- revert change of 1.4.4-0vl2
408
409* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
410- upstream release
411- enable browser plugins (exclude x86_64 arch)
412
413* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
414- upstream release
415
416* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
417- update configure options
418- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
419
420* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
421- fix mistranslation (patch0)
422- add icon symlink
423- add BuildRequires: gstreamer-plugins-good
424
425* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
426- upstream release
427- update %%_glib_ver, %%_xine_ver
428- add BuildRequires: hal
429- update %%configure options
430- update %%files
431
432* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
433- upstream release
434
435* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
436- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
437
438* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
439- upstream release
440- drop obsolete patch0
441
442* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
443- upstream release
444- add patch0 to build with intltool-0.35
445
446* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
447- upstream release
448
449* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
450- upstream release
451- update alternatives entry
452
453* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
454- upstream release
455- drop fix-sort-function.patch (was merged to upstream, #331426)
456
457* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
458- rebuild with gnome-2.14rc
459
460* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
461- upstream release
462- add macros
463  - _gtk_ver, _glib_ver
464  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
465  - _dbus_ver
466  - _gst_ver, gstpb_ver, _xine_ver
467- add fix-sort-function.patch to build with glib < 2.9.1
468
469* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
470- upstream release
471- add BuildRequires:
472  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
473  - gnome-vfs2-devel >= 2.9.92
474  - dbus-devel >= 0.35
475- use gstreamer-0.10 as backend for totem-gstreamer
476
477* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
478- use gstreamer08 instead of gstreamer
479
480* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
481- upstream release
482
483* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
484- fix missing links
485  - update file list
486  - update update-alternatives scripts
487- fix totem-gstreamer's %%postun script
488
489* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
490- upstream release
491- add BuildRequires: iso-codes, libmusicbrainz-devel
492- add Requires: iso-codes, libmusicbrains to -common package
493- remove BuildRequires: nautilus-cd-burner
494- remove Requires: nautilus-cd-burner from -common package
495
496* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
497- totem-gstreamer obsoletes nautilus-media
498
499* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
500- upstream release
501- add Requires(post,postun): alternatives for gstreamer,xine
502- add Requires(postun,triggers): alternatives for common
503
504* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
505- upstream release
506
507* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
508- build xine backend
509  - move common files to common package
510  - move GStreamer related files to gstreamer package
511  - install xine related files to xine package
512- fix scripts
513
514* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
515- upstream release
516- update URL
517- move *.{a,la} to devel package
518
519* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
520- fix %%{post,preun} script (video-thumbnail.schemas)
521- sync with Fedora Core's 1.0.1-1
522
523  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
524  - Update to upstream version 1.0.1
525  - Break out devel package
526
527* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
528- add %%{post,pre}un script
529
530* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
531- initial build for Vine Linux
532
533* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
534- fix %%post
535
536* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
537- Obsolete nautilus-media
538- Install property page and thumbnailer
539
540* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
541- Update to 0.101
542 
543* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
544- Grab patch totem-0.100-desktopfile.patch from CVS to fix
545  missing menu entry (144088)
546- Remove workaround for desktop file being misinstalled, fixed
547  by above patch
548
549* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
550- New upstream version 0.100
551
552* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
553- update to 0.99.22
554
555* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
556- Add patch to remove removed items from package from help
557
558* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
559- New upstream 0.99.19
560  - Fixes crasher with CD playback (see NEWS)
561
562* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
563- Call update-desktop-database in post
564
565* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
566- update to 0.99.18
567
568* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
569- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
570
Note: See TracBrowser for help on using the repository browser.