source: projects/specs/trunk/t/totem/totem-vl.spec @ 9336

Revision 9336, 18.1 KB checked in by Takemikaduchi, 9 years ago (diff)

eudev: fix udev-post.init
others: new upstream release

Line 
1# define versions
2%define _glib_ver               2.42.0
3%define _gtk_ver                3.14.0
4%define _gnomeicon_ver          3.12.0
5%define _gnome_doc_utils_ver    0.20.0
6%define _dbus_ver               1.6.0
7%define _gst_ver                1.2.0
8%define _gstpb_ver              1.2.0
9%define _gstpg_ver              1.2.0
10%define _gstpbad_ver            1.2.0
11%define _xulrunner_ver          1.9
12%define _nautilus_ver           3.14.0
13%define _shared_mime_info_ver   0.17
14%define _unique_ver             1.0
15%define _totem_pl_parser_ver    3.4.4
16
17%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
18
19Summary:        Movie player for GNOME 3
20Summary(ja):    GNOME3 用動画プレイヤー
21Name:           totem
22Version:        3.14.2
23Release:        1%{?_dist_release}
24License:        GPL
25Group:          Applications/Multimedia
26URL:            http://www.gnome.org/projects/totem/
27Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.14/%{name}-%{version}.tar.xz
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33Packager:       Takemikaduchi
34
35BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
36BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
37BuildRequires:  dbus-devel >= %{_dbus_ver}
38BuildRequires:  nautilus-devel >= %{_nautilus_ver}
39BuildRequires:  gnome-desktop3-devel
40BuildRequires:  gettext
41BuildRequires:  perl-XML-Parser
42BuildRequires:  iso-codes
43BuildRequires:  yelp-tools
44BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
45BuildRequires:  grilo-devel
46BuildRequires:  bluez-libs-devel >= 4.15
47BuildRequires:  lirc
48BuildRequires:  unique-devel >= %{_unique_ver}
49BuildRequires:  python-devel
50BuildRequires:  pylint
51BuildRequires:  pygobject3-devel
52BuildRequires:  libpeas-devel
53BuildRequires:  libXtst-devel
54BuildRequires:  gsettings-desktop-schemas-devel
55BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
56BuildRequires:  vala
57
58BuildRequires:  gstreamer1-devel >= %{_gst_ver}
59BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
60BuildRequires:  gstreamer1-plugins-good >= %{_gstpg_ver}
61BuildRequires:  gstreamer1-plugins-bad-free-devel >= %{_gstpbad_ver}
62
63BuildRequires:  clutter-gtk-devel
64BuildRequires:  clutter-gst-devel
65BuildRequires:  libmx-devel
66
67BuildRequires:  nautilus-devel >= %{_nautilus_ver}
68BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
69
70Requires:       gstreamer1 >= %{_gst_ver}
71Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
72Requires:       gstreamer1-plugins-good >= %{_gstpg_ver}
73Requires:       gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
74Requires:       iso-codes
75
76Obsoletes:      nautilus-media
77Obsoletes:      %{name}-gstreamer < 2.30.1-2
78Obsoletes:      %{name}-xine < 2.30.1-2
79Obsoletes:      %{name}-common < 2.30.1-3
80Obsoletes:      %{name}-mozilla < 3.14.0
81
82Provides:       nautilus-media
83Provides:       %{name}-common = %{version}-%{release}
84
85Requires(post):     ldconfig, desktop-file-utils
86Requires(postun):   ldconfig, desktop-file-utils
87
88%description
89Totem is simple movie player for the Gnome desktop. It features a
90simple playlist, a full-screen mode, seek and volume controls, as well as
91a pretty complete keyboard navigation.
92
93%package devel
94Summary:        Plugin writer's documentation for totem
95Group:          Development/Libraries
96Requires:       %{name} = %{version}-%{release}
97
98%description devel
99The %{name}-devel package contains API documentation for
100developing developing plugins for %{name}.
101
102%prep
103%setup -q
104
105%build
106DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
107export MOZILLA_PLUGINDIR=%{mozplug_dir}
108
109%configure \
110        --enable-python \
111        --enable-vala \
112        --enable-nautilus
113
114make %{?_smp_mflags}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118
119make install DESTDIR=$RPM_BUILD_ROOT
120
121# remove unneeded files
122%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
123%__rm -f %{buildroot}%{_libdir}/*.{a,la}
124%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
125%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
126%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
127%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
128%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
129
130# remove unused file
131%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
132%__rm -f %{buildroot}%{_libexecdir}/%{name}/totem-bugreport.py
133 
134%find_lang %{name} --with-gnome
135
136# save space by linking identical images in translated docs
137helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
138for f in $helpdir/C/figures/*.png; do
139  b="$(basename $f)"
140  for d in $helpdir/*; do
141    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
142      g="$d/figures/$b"
143      if [ -f "$g" ]; then
144        if cmp -s $f $g; then
145          rm "$g"; ln -s "../../C/figures/$b" "$g"
146        fi
147      fi
148    fi
149  done
150done
151
152
153%clean
154%__rm -rf %{buildroot}
155
156%post
157%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
158touch %{_datadir}/icons/hicolor
159if [ -x /usr/bin/gtk-update-icon-cache ]; then
160  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
161fi
162
163%postun
164%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
165touch %{_datadir}/icons/hicolor
166if [ -x /usr/bin/gtk-update-icon-cache ]; then
167  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
168fi
169glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
170
171%posttrans
172glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
173
174%files -f %{name}.lang
175%defattr(-,root,root,-)
176%doc AUTHORS COPYING ChangeLog NEWS README TODO
177%{_bindir}/totem
178%{_bindir}/totem-audio-preview
179%{_bindir}/totem-video-thumbnailer
180%{_datadir}/GConf/gsettings/opensubtitles.convert
181#%{_datadir}/GConf/gsettings/pythonconsole.convert
182%{_datadir}/GConf/gsettings/totem.convert
183%{_datadir}/appdata/org.gnome.Totem.appdata.xml
184%{_datadir}/applications/org.gnome.Totem.desktop
185%{_datadir}/dbus-1/services/org.gnome.Totem.service
186%{_datadir}/glib-2.0/schemas/*.xml
187%{_datadir}/icons/*/*/*/*
188%{_datadir}/thumbnailers/totem.thumbnailer
189%{_datadir}/%{name}
190%{_datadir}/gtk-doc/html/totem
191%{_libdir}/libtotem.so.*
192%{_libdir}/girepository-1.0/*.typelib
193%dir %{_libdir}/totem
194%dir %{_libdir}/totem/plugins
195%{_libdir}/totem/plugins/apple-trailers/
196%{_libdir}/totem/plugins/autoload-subtitles
197%{_libdir}/totem/plugins/brasero-disc-recorder
198%{_libdir}/totem/plugins/chapters
199%{_libdir}/totem/plugins/dbus
200%{_libdir}/totem/plugins/gromit
201%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
202%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
203%{_libdir}/totem/plugins/lirc
204%{_libdir}/totem/plugins/media-player-keys
205%{_libdir}/totem/plugins/ontop
206%{_libdir}/totem/plugins/opensubtitles
207%{_libdir}/totem/plugins/properties
208%{_libdir}/totem/plugins/pythonconsole
209%{_libdir}/totem/plugins/recent
210%{_libdir}/totem/plugins/rotation
211%{_libdir}/totem/plugins/screensaver
212%{_libdir}/totem/plugins/screenshot
213%{_libdir}/totem/plugins/skipto
214%{_libdir}/totem/plugins/save-file/libsave-file.so
215%{_libdir}/totem/plugins/save-file/save-file.plugin
216%{_libdir}/totem/plugins/vimeo
217%{_libdir}/nautilus/extensions-3.0/*.so*
218%{_mandir}/man1/*
219
220%files devel
221%defattr(-, root, root,-)
222%{_includedir}/totem
223%{_libdir}/libtotem.so
224%{_libdir}/pkgconfig/totem.pc
225%{_datadir}/gir-1.0/Totem-1.0.gir
226%{_datadir}/gtk-doc/html/totem
227
228
229%changelog
230* Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
231- new upstream release
232
233* Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
234- new upstream release
235
236* Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
237- new upstream release
238- add BuildRequires: gnome-desktop3-devel
239- remove BuildRequires: xulrunner-devel
240- remove %%{name}-mozilla subpackage
241
242* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
243- new upstream release
244
245* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
246- new upstream release
247
248* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
249- new upstream release
250
251* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
252- rebuild with VineSeed environment
253
254* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
255- new upstream release
256
257* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
258- new upstream release
259
260* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
261- new upstream release
262- add BuildRequires: yelp-tools, vala
263- change configure option (--enable-vala)
264
265* Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
266- new upstream release
267
268* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
269- new upstream release
270- change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
271
272* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
273- new upstream release
274- add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
275
276* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
277- new upstream release
278
279* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
280- add configure option (--disable-vegas-plugin)
281
282* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
283- new upstream release
284
285* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
286- new upstream release
287- add BuildRequires: pylint
288- remove BuildRequires: libgdata-devel
289
290* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
291- new upstream release
292
293* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
294- new upstream release
295
296* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
297- new upstream release
298- change BuildRequires: pygobject3-devel instead of pygobject-devel
299
300* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
301- new upstream release
302- change BuildRequires: gtk3-devel instead of gtk2-devel
303- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
304                     clutter-gst-devel, libmx-devel
305- change configure option (--disable-vala)
306
307* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
308- new upstream release
309- fix %files
310
311* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
312- new upstream release
313
314* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
315- clean up spec file
316- remove totem-common and merged to totem main package.
317  - add Obsoletes: totem-common
318- remove unneeded BR: and R:
319  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
320  - libmusicbrainz, alternatives
321- remove explicit dependency
322  - gtk2, glib2, dbus
323- add R: pygtk2, pyxdg, python-Coherence for python plugins
324- add R: gstreamer-plugins-good
325
326* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
327- rebuild with libgdata (add youtube plugin)
328- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
329- add Obsolete: totem-gstreamer, totem-xine)
330
331* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
332- new upstream release
333- chagnge _gst_ver from 0.10.19 to 0.10.29
334
335* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
336- new upstream release
337- drop totem-tracker package
338- add BuildRequires: unique-devel
339- remove BuildRequires: hal-devel
340- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
341
342* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
343- remove unneeded autoreconf
344- add BR: lirc
345
346* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
347- new upstream release
348
349* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
350- remove bemused plugin
351
352* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
353- new upstream release
354
355* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
356- added tracker video search sub-package
357
358* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
359- new upstream release
360
361* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
362- new upstream release
363
364* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
365- remove libxine dependency from totem-common
366- build xine backend with minimum dependency
367
368* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
369- add BR: bluez-libs-devel >= 4.15
370- fix typo in %%postun xine
371
372* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
373- rebuild with bluez-libs-devel-4.15
374
375* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
376- new upstream release
377
378* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
379- new upstream release
380
381* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
382- new upstream release
383- add patch1 to build with xulrunner-1.9
384
385* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
386- new upstream release
387
388* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
389- new upstream release
390- disabled devel package (replaced by totem-pl-parser-devel)
391
392* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
393- new upstream release
394- update version macros
395- enable browser plugins on x86_64
396
397* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
398- new upstream release
399
400* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
401- upstream release
402- drop obsolete ja.po.patch (patch0)
403- revert change of 1.4.4-0vl2
404
405* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
406- upstream release
407- enable browser plugins (exclude x86_64 arch)
408
409* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
410- upstream release
411
412* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
413- update configure options
414- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
415
416* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
417- fix mistranslation (patch0)
418- add icon symlink
419- add BuildRequires: gstreamer-plugins-good
420
421* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
422- upstream release
423- update %%_glib_ver, %%_xine_ver
424- add BuildRequires: hal
425- update %%configure options
426- update %%files
427
428* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
429- upstream release
430
431* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
432- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
433
434* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
435- upstream release
436- drop obsolete patch0
437
438* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
439- upstream release
440- add patch0 to build with intltool-0.35
441
442* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
443- upstream release
444
445* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
446- upstream release
447- update alternatives entry
448
449* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
450- upstream release
451- drop fix-sort-function.patch (was merged to upstream, #331426)
452
453* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
454- rebuild with gnome-2.14rc
455
456* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
457- upstream release
458- add macros
459  - _gtk_ver, _glib_ver
460  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
461  - _dbus_ver
462  - _gst_ver, gstpb_ver, _xine_ver
463- add fix-sort-function.patch to build with glib < 2.9.1
464
465* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
466- upstream release
467- add BuildRequires:
468  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
469  - gnome-vfs2-devel >= 2.9.92
470  - dbus-devel >= 0.35
471- use gstreamer-0.10 as backend for totem-gstreamer
472
473* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
474- use gstreamer08 instead of gstreamer
475
476* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
477- upstream release
478
479* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
480- fix missing links
481  - update file list
482  - update update-alternatives scripts
483- fix totem-gstreamer's %%postun script
484
485* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
486- upstream release
487- add BuildRequires: iso-codes, libmusicbrainz-devel
488- add Requires: iso-codes, libmusicbrains to -common package
489- remove BuildRequires: nautilus-cd-burner
490- remove Requires: nautilus-cd-burner from -common package
491
492* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
493- totem-gstreamer obsoletes nautilus-media
494
495* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
496- upstream release
497- add Requires(post,postun): alternatives for gstreamer,xine
498- add Requires(postun,triggers): alternatives for common
499
500* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
501- upstream release
502
503* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
504- build xine backend
505  - move common files to common package
506  - move GStreamer related files to gstreamer package
507  - install xine related files to xine package
508- fix scripts
509
510* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
511- upstream release
512- update URL
513- move *.{a,la} to devel package
514
515* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
516- fix %%{post,preun} script (video-thumbnail.schemas)
517- sync with Fedora Core's 1.0.1-1
518
519  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
520  - Update to upstream version 1.0.1
521  - Break out devel package
522
523* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
524- add %%{post,pre}un script
525
526* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
527- initial build for Vine Linux
528
529* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
530- fix %%post
531
532* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
533- Obsolete nautilus-media
534- Install property page and thumbnailer
535
536* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
537- Update to 0.101
538 
539* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
540- Grab patch totem-0.100-desktopfile.patch from CVS to fix
541  missing menu entry (144088)
542- Remove workaround for desktop file being misinstalled, fixed
543  by above patch
544
545* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
546- New upstream version 0.100
547
548* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
549- update to 0.99.22
550
551* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
552- Add patch to remove removed items from package from help
553
554* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
555- New upstream 0.99.19
556  - Fixes crasher with CD playback (see NEWS)
557
558* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
559- Call update-desktop-database in post
560
561* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
562- update to 0.99.18
563
564* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
565- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
566
Note: See TracBrowser for help on using the repository browser.