source: projects/specs/trunk/t/totem/totem-vl.spec @ 9073

Revision 9073, 17.9 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME 3.14.1

Line 
1# define versions
2%define _glib_ver               2.42.0
3%define _gtk_ver                3.14.0
4%define _gnomeicon_ver          3.12.0
5%define _gnome_doc_utils_ver    0.20.0
6%define _dbus_ver               1.6.0
7%define _gst_ver                1.2.0
8%define _gstpb_ver              1.2.0
9%define _gstpg_ver              1.2.0
10%define _gstpbad_ver            1.2.0
11%define _xulrunner_ver          1.9
12%define _nautilus_ver           3.14.0
13%define _shared_mime_info_ver   0.17
14%define _unique_ver             1.0
15%define _totem_pl_parser_ver    3.4.4
16
17%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
18
19Summary:        Movie player for GNOME 3
20Summary(ja):    GNOME3 用動画プレイヤー
21Name:           totem
22Version:        3.14.0
23Release:        1%{?_dist_release}
24License:        GPL
25Group:          Applications/Multimedia
26URL:            http://www.gnome.org/projects/totem/
27Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.14/%{name}-%{version}.tar.xz
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33Packager:       Takemikaduchi
34
35BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
36BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
37BuildRequires:  dbus-devel >= %{_dbus_ver}
38BuildRequires:  nautilus-devel >= %{_nautilus_ver}
39BuildRequires:  gnome-desktop3-devel
40BuildRequires:  gettext
41BuildRequires:  perl-XML-Parser
42BuildRequires:  iso-codes
43BuildRequires:  yelp-tools
44BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
45BuildRequires:  grilo-devel
46BuildRequires:  bluez-libs-devel >= 4.15
47BuildRequires:  lirc
48BuildRequires:  unique-devel >= %{_unique_ver}
49BuildRequires:  python-devel
50BuildRequires:  pylint
51BuildRequires:  pygobject3-devel
52BuildRequires:  libpeas-devel
53BuildRequires:  libXtst-devel
54BuildRequires:  gsettings-desktop-schemas-devel
55BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
56BuildRequires:  vala
57
58BuildRequires:  gstreamer1-devel >= %{_gst_ver}
59BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
60BuildRequires:  gstreamer1-plugins-good >= %{_gstpg_ver}
61BuildRequires:  gstreamer1-plugins-bad-free-devel >= %{_gstpbad_ver}
62
63BuildRequires:  clutter-gtk-devel
64BuildRequires:  clutter-gst-devel
65BuildRequires:  libmx-devel
66
67BuildRequires:  nautilus-devel >= %{_nautilus_ver}
68BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
69
70Requires:       gstreamer1 >= %{_gst_ver}
71Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
72Requires:       gstreamer1-plugins-good >= %{_gstpg_ver}
73Requires:       gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
74Requires:       iso-codes
75
76Obsoletes:      nautilus-media
77Obsoletes:      %{name}-gstreamer < 2.30.1-2
78Obsoletes:      %{name}-xine < 2.30.1-2
79Obsoletes:      %{name}-common < 2.30.1-3
80Obsoletes:      %{name}-mozilla < 3.14.0
81
82Provides:       nautilus-media
83Provides:       %{name}-common = %{version}-%{release}
84
85Requires(post):     ldconfig, desktop-file-utils
86Requires(postun):   ldconfig, desktop-file-utils
87
88%description
89Totem is simple movie player for the Gnome desktop. It features a
90simple playlist, a full-screen mode, seek and volume controls, as well as
91a pretty complete keyboard navigation.
92
93%package devel
94Summary:        Plugin writer's documentation for totem
95Group:          Development/Libraries
96Requires:       %{name} = %{version}-%{release}
97
98%description devel
99The %{name}-devel package contains API documentation for
100developing developing plugins for %{name}.
101
102%prep
103%setup -q
104
105%build
106DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
107export MOZILLA_PLUGINDIR=%{mozplug_dir}
108
109%configure \
110        --enable-python \
111        --enable-vala \
112        --enable-nautilus
113
114make %{?_smp_mflags}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118
119make install DESTDIR=$RPM_BUILD_ROOT
120
121# remove unneeded files
122%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
123%__rm -f %{buildroot}%{_libdir}/*.{a,la}
124%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
125%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
126%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
127%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
128%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
129
130# remove unused file
131%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
132%__rm -f %{buildroot}%{_libexecdir}/%{name}/totem-bugreport.py
133 
134%find_lang %{name} --with-gnome
135
136# save space by linking identical images in translated docs
137helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
138for f in $helpdir/C/figures/*.png; do
139  b="$(basename $f)"
140  for d in $helpdir/*; do
141    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
142      g="$d/figures/$b"
143      if [ -f "$g" ]; then
144        if cmp -s $f $g; then
145          rm "$g"; ln -s "../../C/figures/$b" "$g"
146        fi
147      fi
148    fi
149  done
150done
151
152
153%clean
154%__rm -rf %{buildroot}
155
156%post
157%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
158touch %{_datadir}/icons/hicolor
159if [ -x /usr/bin/gtk-update-icon-cache ]; then
160  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
161fi
162
163%postun
164%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
165touch %{_datadir}/icons/hicolor
166if [ -x /usr/bin/gtk-update-icon-cache ]; then
167  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
168fi
169glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
170
171%posttrans
172glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
173
174%files -f %{name}.lang
175%defattr(-,root,root,-)
176%doc AUTHORS COPYING ChangeLog NEWS README TODO
177%{_bindir}/totem
178%{_bindir}/totem-audio-preview
179%{_bindir}/totem-video-thumbnailer
180%{_datadir}/GConf/gsettings/opensubtitles.convert
181#%{_datadir}/GConf/gsettings/pythonconsole.convert
182%{_datadir}/GConf/gsettings/totem.convert
183%{_datadir}/appdata/org.gnome.Totem.appdata.xml
184%{_datadir}/applications/org.gnome.Totem.desktop
185%{_datadir}/dbus-1/services/org.gnome.Totem.service
186%{_datadir}/glib-2.0/schemas/*.xml
187%{_datadir}/icons/*/*/*/*
188%{_datadir}/thumbnailers/totem.thumbnailer
189%{_datadir}/%{name}
190%{_datadir}/gtk-doc/html/totem
191%{_libdir}/libtotem.so.*
192%{_libdir}/girepository-1.0/*.typelib
193%dir %{_libdir}/totem
194%dir %{_libdir}/totem/plugins
195%{_libdir}/totem/plugins/apple-trailers/
196%{_libdir}/totem/plugins/autoload-subtitles
197%{_libdir}/totem/plugins/brasero-disc-recorder
198%{_libdir}/totem/plugins/chapters
199%{_libdir}/totem/plugins/dbus
200%{_libdir}/totem/plugins/gromit
201%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
202%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
203%{_libdir}/totem/plugins/lirc
204%{_libdir}/totem/plugins/media-player-keys
205%{_libdir}/totem/plugins/ontop
206%{_libdir}/totem/plugins/opensubtitles
207%{_libdir}/totem/plugins/properties
208%{_libdir}/totem/plugins/pythonconsole
209%{_libdir}/totem/plugins/recent
210%{_libdir}/totem/plugins/rotation
211%{_libdir}/totem/plugins/screensaver
212%{_libdir}/totem/plugins/screenshot
213%{_libdir}/totem/plugins/skipto
214%{_libdir}/totem/plugins/save-file/libsave-file.so
215%{_libdir}/totem/plugins/save-file/save-file.plugin
216%{_libdir}/totem/plugins/vimeo
217%{_libdir}/nautilus/extensions-3.0/*.so*
218%{_mandir}/man1/*
219
220%files devel
221%defattr(-, root, root,-)
222%{_includedir}/totem
223%{_libdir}/libtotem.so
224%{_libdir}/pkgconfig/totem.pc
225%{_datadir}/gir-1.0/Totem-1.0.gir
226%{_datadir}/gtk-doc/html/totem
227
228
229%changelog
230* Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
231- new upstream release
232- add BuildRequires: gnome-desktop3-devel
233- remove BuildRequires: xulrunner-devel
234- remove %%{name}-mozilla subpackage
235
236* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
237- new upstream release
238
239* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
240- new upstream release
241
242* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
243- new upstream release
244
245* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
246- rebuild with VineSeed environment
247
248* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
249- new upstream release
250
251* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
252- new upstream release
253
254* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
255- new upstream release
256- add BuildRequires: yelp-tools, vala
257- change configure option (--enable-vala)
258
259* Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
260- new upstream release
261
262* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
263- new upstream release
264- change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
265
266* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
267- new upstream release
268- add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
269
270* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
271- new upstream release
272
273* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
274- add configure option (--disable-vegas-plugin)
275
276* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
277- new upstream release
278
279* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
280- new upstream release
281- add BuildRequires: pylint
282- remove BuildRequires: libgdata-devel
283
284* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
285- new upstream release
286
287* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
288- new upstream release
289
290* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
291- new upstream release
292- change BuildRequires: pygobject3-devel instead of pygobject-devel
293
294* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
295- new upstream release
296- change BuildRequires: gtk3-devel instead of gtk2-devel
297- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
298                     clutter-gst-devel, libmx-devel
299- change configure option (--disable-vala)
300
301* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
302- new upstream release
303- fix %files
304
305* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
306- new upstream release
307
308* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
309- clean up spec file
310- remove totem-common and merged to totem main package.
311  - add Obsoletes: totem-common
312- remove unneeded BR: and R:
313  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
314  - libmusicbrainz, alternatives
315- remove explicit dependency
316  - gtk2, glib2, dbus
317- add R: pygtk2, pyxdg, python-Coherence for python plugins
318- add R: gstreamer-plugins-good
319
320* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
321- rebuild with libgdata (add youtube plugin)
322- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
323- add Obsolete: totem-gstreamer, totem-xine)
324
325* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
326- new upstream release
327- chagnge _gst_ver from 0.10.19 to 0.10.29
328
329* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
330- new upstream release
331- drop totem-tracker package
332- add BuildRequires: unique-devel
333- remove BuildRequires: hal-devel
334- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
335
336* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
337- remove unneeded autoreconf
338- add BR: lirc
339
340* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
341- new upstream release
342
343* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
344- remove bemused plugin
345
346* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
347- new upstream release
348
349* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
350- added tracker video search sub-package
351
352* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
353- new upstream release
354
355* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
356- new upstream release
357
358* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
359- remove libxine dependency from totem-common
360- build xine backend with minimum dependency
361
362* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
363- add BR: bluez-libs-devel >= 4.15
364- fix typo in %%postun xine
365
366* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
367- rebuild with bluez-libs-devel-4.15
368
369* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
370- new upstream release
371
372* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
373- new upstream release
374
375* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
376- new upstream release
377- add patch1 to build with xulrunner-1.9
378
379* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
380- new upstream release
381
382* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
383- new upstream release
384- disabled devel package (replaced by totem-pl-parser-devel)
385
386* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
387- new upstream release
388- update version macros
389- enable browser plugins on x86_64
390
391* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
392- new upstream release
393
394* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
395- upstream release
396- drop obsolete ja.po.patch (patch0)
397- revert change of 1.4.4-0vl2
398
399* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
400- upstream release
401- enable browser plugins (exclude x86_64 arch)
402
403* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
404- upstream release
405
406* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
407- update configure options
408- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
409
410* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
411- fix mistranslation (patch0)
412- add icon symlink
413- add BuildRequires: gstreamer-plugins-good
414
415* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
416- upstream release
417- update %%_glib_ver, %%_xine_ver
418- add BuildRequires: hal
419- update %%configure options
420- update %%files
421
422* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
423- upstream release
424
425* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
426- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
427
428* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
429- upstream release
430- drop obsolete patch0
431
432* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
433- upstream release
434- add patch0 to build with intltool-0.35
435
436* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
437- upstream release
438
439* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
440- upstream release
441- update alternatives entry
442
443* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
444- upstream release
445- drop fix-sort-function.patch (was merged to upstream, #331426)
446
447* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
448- rebuild with gnome-2.14rc
449
450* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
451- upstream release
452- add macros
453  - _gtk_ver, _glib_ver
454  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
455  - _dbus_ver
456  - _gst_ver, gstpb_ver, _xine_ver
457- add fix-sort-function.patch to build with glib < 2.9.1
458
459* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
460- upstream release
461- add BuildRequires:
462  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
463  - gnome-vfs2-devel >= 2.9.92
464  - dbus-devel >= 0.35
465- use gstreamer-0.10 as backend for totem-gstreamer
466
467* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
468- use gstreamer08 instead of gstreamer
469
470* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
471- upstream release
472
473* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
474- fix missing links
475  - update file list
476  - update update-alternatives scripts
477- fix totem-gstreamer's %%postun script
478
479* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
480- upstream release
481- add BuildRequires: iso-codes, libmusicbrainz-devel
482- add Requires: iso-codes, libmusicbrains to -common package
483- remove BuildRequires: nautilus-cd-burner
484- remove Requires: nautilus-cd-burner from -common package
485
486* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
487- totem-gstreamer obsoletes nautilus-media
488
489* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
490- upstream release
491- add Requires(post,postun): alternatives for gstreamer,xine
492- add Requires(postun,triggers): alternatives for common
493
494* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
495- upstream release
496
497* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
498- build xine backend
499  - move common files to common package
500  - move GStreamer related files to gstreamer package
501  - install xine related files to xine package
502- fix scripts
503
504* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
505- upstream release
506- update URL
507- move *.{a,la} to devel package
508
509* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
510- fix %%{post,preun} script (video-thumbnail.schemas)
511- sync with Fedora Core's 1.0.1-1
512
513  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
514  - Update to upstream version 1.0.1
515  - Break out devel package
516
517* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
518- add %%{post,pre}un script
519
520* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
521- initial build for Vine Linux
522
523* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
524- fix %%post
525
526* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
527- Obsolete nautilus-media
528- Install property page and thumbnailer
529
530* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
531- Update to 0.101
532 
533* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
534- Grab patch totem-0.100-desktopfile.patch from CVS to fix
535  missing menu entry (144088)
536- Remove workaround for desktop file being misinstalled, fixed
537  by above patch
538
539* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
540- New upstream version 0.100
541
542* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
543- update to 0.99.22
544
545* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
546- Add patch to remove removed items from package from help
547
548* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
549- New upstream 0.99.19
550  - Fixes crasher with CD playback (see NEWS)
551
552* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
553- Call update-desktop-database in post
554
555* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
556- update to 0.99.18
557
558* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
559- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
560
Note: See TracBrowser for help on using the repository browser.