source: projects/specs/trunk/t/totem/totem-vl.spec @ 8447

Revision 8447, 18.6 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.2

Line 
1# build browser plugins
2%define build_plugin    %{!?_without_mozilla:1}%{?_without_mozilla:0}
3
4# define versions
5%define _glib_ver               2.40.0
6%define _gtk_ver                3.12.0
7%define _gnomeicon_ver          3.12.0
8%define _gnome_doc_utils_ver    0.20.0
9%define _dbus_ver               1.6.0
10%define _gst_ver                1.2.0
11%define _gstpb_ver              1.2.0
12%define _gstpg_ver              1.2.0
13%define _gstpbad_ver            1.2.0
14%define _xulrunner_ver          1.9
15%define _nautilus_ver           3.12.0
16%define _shared_mime_info_ver   0.17
17%define _unique_ver             1.0
18%define _totem_pl_parser_ver    3.4.4
19
20%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
21%define mozplug_dir %{_libdir}/mozilla/plugins
22
23Summary:        Movie player for GNOME 3
24Summary(ja):    GNOME3 用動画プレイヤー
25Name:           totem
26Version:        3.12.1
27Release:        1%{?_dist_release}
28License:        GPL
29Group:          Applications/Multimedia
30URL:            http://www.gnome.org/projects/totem/
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.12/%{name}-%{version}.tar.xz
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34
35Vendor:         Project Vine
36Distribution:   Vine Linux
37Packager:       Takemikaduchi
38
39BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
40BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
41BuildRequires:  dbus-devel >= %{_dbus_ver}
42BuildRequires:  nautilus-devel >= %{_nautilus_ver}
43BuildRequires:  gettext
44BuildRequires:  perl-XML-Parser
45BuildRequires:  iso-codes
46BuildRequires:  yelp-tools
47BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
48BuildRequires:  grilo-devel
49BuildRequires:  bluez-libs-devel >= 4.15
50BuildRequires:  lirc
51BuildRequires:  unique-devel >= %{_unique_ver}
52BuildRequires:  python-devel
53BuildRequires:  pylint
54BuildRequires:  pygobject3-devel
55BuildRequires:  libpeas-devel
56BuildRequires:  libXtst-devel
57BuildRequires:  gsettings-desktop-schemas-devel
58BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
59BuildRequires:  vala
60
61BuildRequires:  gstreamer1-devel >= %{_gst_ver}
62BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
63BuildRequires:  gstreamer1-plugins-good >= %{_gstpg_ver}
64BuildRequires:  gstreamer1-plugins-bad-free-devel >= %{_gstpbad_ver}
65
66BuildRequires:  clutter-gtk-devel
67BuildRequires:  clutter-gst-devel
68BuildRequires:  libmx-devel
69
70
71%if %{build_plugin}
72BuildRequires:  xulrunner-devel >= %{_xulrunner_ver}
73BuildRequires:  nautilus-devel >= %{_nautilus_ver}
74BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
75%endif
76
77Requires:       gstreamer1 >= %{_gst_ver}
78Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
79Requires:       gstreamer1-plugins-good >= %{_gstpg_ver}
80Requires:       gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
81Requires:       iso-codes
82
83Obsoletes:      nautilus-media
84Obsoletes:      %{name}-gstreamer < 2.30.1-2
85Obsoletes:      %{name}-xine < 2.30.1-2
86Obsoletes:      %{name}-common < 2.30.1-3
87
88Provides:       nautilus-media
89Provides:       %{name}-common = %{version}-%{release}
90
91Requires(post):     ldconfig, desktop-file-utils
92Requires(postun):   ldconfig, desktop-file-utils
93
94%description
95Totem is simple movie player for the Gnome desktop. It features a
96simple playlist, a full-screen mode, seek and volume controls, as well as
97a pretty complete keyboard navigation.
98
99%if %{build_plugin}
100%package mozilla
101Summary:        Totem movie plugin for Mozilla
102Summary(ja):    Mozilla 用 Totem 動画プラグイン
103Group:          Applications/Internet
104Requires:       %{name} = %{version}-%{release}
105Obsoletes:      %{name}-mozilla-common
106Obsoletes:      %{name}-mozilla-gstreamer
107Obsoletes:      %{name}-mozilla-xine
108
109%description mozilla
110Totem is simple movie player for the Gnome desktop. It features a
111simple playlist, a full-screen mode, seek and volume controls, as well as
112a pretty complete keyboard navigation.
113
114This package contains a Totem video plugin for Mozilla. It allows Totem
115movie player to be embedded into a web browser.
116
117%endif
118
119%package devel
120Summary:        Plugin writer's documentation for totem
121Group:          Development/Libraries
122Requires:       %{name} = %{version}-%{release}
123
124%description devel
125The %{name}-devel package contains API documentation for
126developing developing plugins for %{name}.
127
128%prep
129%setup -q
130
131%build
132DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
133export MOZILLA_PLUGINDIR=%{mozplug_dir}
134
135%configure \
136        --enable-python \
137        --enable-vala \
138        --enable-nautilus \
139        --enable-gmp-plugin \
140        --enable-narrowspace-plugin \
141        --enable-mully-plugin \
142        --disable-vegas-plugin \
143%if %{build_plugin}
144        --enable-browser-plugins
145%else
146        --disable-browser-plugins
147%endif
148
149make %{?_smp_mflags}
150
151%install
152rm -rf $RPM_BUILD_ROOT
153
154make install DESTDIR=$RPM_BUILD_ROOT
155
156# remove unneeded files
157%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
158%__rm -f %{buildroot}%{_libdir}/*.{a,la}
159%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
160%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
161%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
162%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
163%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
164
165# remove unused file
166%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
167 
168%find_lang %{name} --with-gnome
169
170# save space by linking identical images in translated docs
171helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
172for f in $helpdir/C/figures/*.png; do
173  b="$(basename $f)"
174  for d in $helpdir/*; do
175    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
176      g="$d/figures/$b"
177      if [ -f "$g" ]; then
178        if cmp -s $f $g; then
179          rm "$g"; ln -s "../../C/figures/$b" "$g"
180        fi
181      fi
182    fi
183  done
184done
185
186
187%clean
188%__rm -rf %{buildroot}
189
190%post
191%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
192touch %{_datadir}/icons/hicolor
193if [ -x /usr/bin/gtk-update-icon-cache ]; then
194  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
195fi
196
197%postun
198%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
199touch %{_datadir}/icons/hicolor
200if [ -x /usr/bin/gtk-update-icon-cache ]; then
201  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
202fi
203glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
204
205%posttrans
206glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
207
208%files -f %{name}.lang
209%defattr(-,root,root,-)
210%doc AUTHORS COPYING ChangeLog NEWS README TODO
211%{_bindir}/totem
212%{_bindir}/totem-audio-preview
213%{_bindir}/totem-video-thumbnailer
214%{_datadir}/GConf/gsettings/opensubtitles.convert
215#%{_datadir}/GConf/gsettings/pythonconsole.convert
216%{_datadir}/GConf/gsettings/totem.convert
217%{_datadir}/appdata/%{name}.appdata.xml
218%{_datadir}/applications/%{name}.desktop
219%{_datadir}/glib-2.0/schemas/*.xml
220%{_datadir}/icons/*/*/*/*
221%{_datadir}/thumbnailers/totem.thumbnailer
222%{_datadir}/%{name}
223%{_datadir}/gtk-doc/html/totem
224%{_libdir}/libtotem.so.*
225%{_libdir}/girepository-1.0/*.typelib
226%dir %{_libdir}/totem
227%dir %{_libdir}/totem/plugins
228%{_libdir}/totem/plugins/apple-trailers/
229%{_libdir}/totem/plugins/autoload-subtitles
230%{_libdir}/totem/plugins/brasero-disc-recorder
231%{_libdir}/totem/plugins/chapters
232%{_libdir}/totem/plugins/dbus
233%{_libdir}/totem/plugins/gromit
234%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
235%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
236%{_libdir}/totem/plugins/lirc
237%{_libdir}/totem/plugins/media-player-keys
238%{_libdir}/totem/plugins/ontop
239%{_libdir}/totem/plugins/opensubtitles
240%{_libdir}/totem/plugins/properties
241%{_libdir}/totem/plugins/pythonconsole
242%{_libdir}/totem/plugins/recent
243%{_libdir}/totem/plugins/rotation
244%{_libdir}/totem/plugins/screensaver
245%{_libdir}/totem/plugins/screenshot
246%{_libdir}/totem/plugins/skipto
247%{_libdir}/totem/plugins/save-file/libsave-file.so
248%{_libdir}/totem/plugins/save-file/save-file.plugin
249%{_libdir}/totem/plugins/vimeo
250%if %{build_plugin}
251%{_libdir}/nautilus/extensions-3.0/*.so*
252%endif
253%{_libexecdir}/%{name}/totem-bugreport.py
254%{_mandir}/man1/*
255
256%if %{build_plugin}
257%files mozilla
258%defattr(-,root,root,-)
259%{mozplug_dir}/*
260%{_libexecdir}/totem-plugin-viewer
261%endif
262
263%files devel
264%defattr(-, root, root,-)
265%{_includedir}/totem
266%{_libdir}/libtotem.so
267%{_libdir}/pkgconfig/totem.pc
268%{_datadir}/gir-1.0/Totem-1.0.gir
269%{_datadir}/gtk-doc/html/totem
270
271
272%changelog
273* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
274- new upstream release
275
276* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
277- new upstream release
278
279* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
280- rebuild with VineSeed environment
281
282* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
283- new upstream release
284
285* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
286- new upstream release
287
288* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
289- new upstream release
290- add BuildRequires: yelp-tools, vala
291- change configure option (--enable-vala)
292
293* Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
294- new upstream release
295
296* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
297- new upstream release
298- change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
299
300* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
301- new upstream release
302- add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
303
304* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
305- new upstream release
306
307* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
308- add configure option (--disable-vegas-plugin)
309
310* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
311- new upstream release
312
313* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
314- new upstream release
315- add BuildRequires: pylint
316- remove BuildRequires: libgdata-devel
317
318* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
319- new upstream release
320
321* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
322- new upstream release
323
324* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
325- new upstream release
326- change BuildRequires: pygobject3-devel instead of pygobject-devel
327
328* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
329- new upstream release
330- change BuildRequires: gtk3-devel instead of gtk2-devel
331- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
332                     clutter-gst-devel, libmx-devel
333- change configure option (--disable-vala)
334
335* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
336- new upstream release
337- fix %files
338
339* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
340- new upstream release
341
342* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
343- clean up spec file
344- remove totem-common and merged to totem main package.
345  - add Obsoletes: totem-common
346- remove unneeded BR: and R:
347  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
348  - libmusicbrainz, alternatives
349- remove explicit dependency
350  - gtk2, glib2, dbus
351- add R: pygtk2, pyxdg, python-Coherence for python plugins
352- add R: gstreamer-plugins-good
353
354* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
355- rebuild with libgdata (add youtube plugin)
356- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
357- add Obsolete: totem-gstreamer, totem-xine)
358
359* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
360- new upstream release
361- chagnge _gst_ver from 0.10.19 to 0.10.29
362
363* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
364- new upstream release
365- drop totem-tracker package
366- add BuildRequires: unique-devel
367- remove BuildRequires: hal-devel
368- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
369
370* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
371- remove unneeded autoreconf
372- add BR: lirc
373
374* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
375- new upstream release
376
377* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
378- remove bemused plugin
379
380* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
381- new upstream release
382
383* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
384- added tracker video search sub-package
385
386* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
387- new upstream release
388
389* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
390- new upstream release
391
392* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
393- remove libxine dependency from totem-common
394- build xine backend with minimum dependency
395
396* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
397- add BR: bluez-libs-devel >= 4.15
398- fix typo in %%postun xine
399
400* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
401- rebuild with bluez-libs-devel-4.15
402
403* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
404- new upstream release
405
406* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
407- new upstream release
408
409* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
410- new upstream release
411- add patch1 to build with xulrunner-1.9
412
413* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
414- new upstream release
415
416* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
417- new upstream release
418- disabled devel package (replaced by totem-pl-parser-devel)
419
420* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
421- new upstream release
422- update version macros
423- enable browser plugins on x86_64
424
425* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
426- new upstream release
427
428* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
429- upstream release
430- drop obsolete ja.po.patch (patch0)
431- revert change of 1.4.4-0vl2
432
433* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
434- upstream release
435- enable browser plugins (exclude x86_64 arch)
436
437* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
438- upstream release
439
440* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
441- update configure options
442- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
443
444* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
445- fix mistranslation (patch0)
446- add icon symlink
447- add BuildRequires: gstreamer-plugins-good
448
449* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
450- upstream release
451- update %%_glib_ver, %%_xine_ver
452- add BuildRequires: hal
453- update %%configure options
454- update %%files
455
456* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
457- upstream release
458
459* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
460- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
461
462* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
463- upstream release
464- drop obsolete patch0
465
466* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
467- upstream release
468- add patch0 to build with intltool-0.35
469
470* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
471- upstream release
472
473* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
474- upstream release
475- update alternatives entry
476
477* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
478- upstream release
479- drop fix-sort-function.patch (was merged to upstream, #331426)
480
481* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
482- rebuild with gnome-2.14rc
483
484* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
485- upstream release
486- add macros
487  - _gtk_ver, _glib_ver
488  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
489  - _dbus_ver
490  - _gst_ver, gstpb_ver, _xine_ver
491- add fix-sort-function.patch to build with glib < 2.9.1
492
493* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
494- upstream release
495- add BuildRequires:
496  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
497  - gnome-vfs2-devel >= 2.9.92
498  - dbus-devel >= 0.35
499- use gstreamer-0.10 as backend for totem-gstreamer
500
501* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
502- use gstreamer08 instead of gstreamer
503
504* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
505- upstream release
506
507* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
508- fix missing links
509  - update file list
510  - update update-alternatives scripts
511- fix totem-gstreamer's %%postun script
512
513* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
514- upstream release
515- add BuildRequires: iso-codes, libmusicbrainz-devel
516- add Requires: iso-codes, libmusicbrains to -common package
517- remove BuildRequires: nautilus-cd-burner
518- remove Requires: nautilus-cd-burner from -common package
519
520* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
521- totem-gstreamer obsoletes nautilus-media
522
523* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
524- upstream release
525- add Requires(post,postun): alternatives for gstreamer,xine
526- add Requires(postun,triggers): alternatives for common
527
528* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
529- upstream release
530
531* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
532- build xine backend
533  - move common files to common package
534  - move GStreamer related files to gstreamer package
535  - install xine related files to xine package
536- fix scripts
537
538* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
539- upstream release
540- update URL
541- move *.{a,la} to devel package
542
543* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
544- fix %%{post,preun} script (video-thumbnail.schemas)
545- sync with Fedora Core's 1.0.1-1
546
547  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
548  - Update to upstream version 1.0.1
549  - Break out devel package
550
551* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
552- add %%{post,pre}un script
553
554* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
555- initial build for Vine Linux
556
557* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
558- fix %%post
559
560* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
561- Obsolete nautilus-media
562- Install property page and thumbnailer
563
564* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
565- Update to 0.101
566 
567* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
568- Grab patch totem-0.100-desktopfile.patch from CVS to fix
569  missing menu entry (144088)
570- Remove workaround for desktop file being misinstalled, fixed
571  by above patch
572
573* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
574- New upstream version 0.100
575
576* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
577- update to 0.99.22
578
579* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
580- Add patch to remove removed items from package from help
581
582* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
583- New upstream 0.99.19
584  - Fixes crasher with CD playback (see NEWS)
585
586* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
587- Call update-desktop-database in post
588
589* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
590- update to 0.99.18
591
592* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
593- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
594
Note: See TracBrowser for help on using the repository browser.