source: projects/specs/trunk/t/totem/totem-vl.spec @ 521

Revision 521, 19.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# select backend (GStreamer, xine)
2#define build_gst       1
3%define build_xine      1
4
5# build browser plugins
6%define build_plugin    %{!?_without_mozilla:1}%{?_without_mozilla:0}
7
8# define versions
9%define _glib_ver               2.20.0
10%define _gtk_ver                2.16.0
11%define _gnomevfs_ver           2.24.0
12%define _gnomeui_ver            2.24.0
13%define _gnomeicon_ver          2.26.0
14%define _gnome_desktop_ver      2.26.0
15%define _libgnome_ver           2.26.0
16%define _gnome_doc_utils_ver    0.16.0
17%define _dbus_ver               1.0
18%define _hal_ver                0.5
19%define _gst_ver                0.10.19
20%define _gstpb_ver              0.10.7
21%define _xine_ver               1.1.11.1
22%define _gecko_ver              1.9
23%define _nautilus_ver           2.26.0
24%define _shared_mime_info_ver   0.17
25
26%define nautilus_extdir %{_libdir}/nautilus/extensions-2.0
27%define mozplug_dir %{_libdir}/mozilla/plugins
28
29Summary:        Movie player for GNOME 2
30Summary(ja):    GNOME2 用動画プレイヤー
31Name:           totem
32Version:        2.26.3
33Release:        2%{?_dist_release}
34License:        GPL
35Group:          Applications/Multimedia
36URL:            http://www.gnome.org/projects/totem/
37Source0:        http://ftp.gnome.org/pub/GNOME/sources/totem/2.26/totem-%{version}.tar.bz2
38
39BuildRoot:      %{_tmppath}/%{name}-%{version}-root
40Vendor:         Project Vine
41Distribution:   Vine Linux
42
43BuildRequires:  gtk2-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
44BuildRequires:  gnome-desktop-devel >= %{_gnome_desktop_ver}
45BuildRequires:  gnome-vfs2-devel >= %{_gnomevfs_ver}
46BuildRequires:  libgnomeui-devel >= %{_gnomeui_ver}
47BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
48BuildRequires:  libgnome-devel >= %{_libgnome_ver}
49BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
50BuildRequires:  dbus-devel >= %{_dbus_ver}
51BuildRequires:  hal-devel >= %{_hal_ver}
52BuildRequires:  libmusicbrainz-devel
53BuildRequires:  nautilus >= %{_nautilus_ver}
54BuildRequires:  gettext, scrollkeeper
55BuildRequires:  perl-XML-Parser
56BuildRequires:  iso-codes
57BuildRequires:  totem-pl-parser-devel
58BuildRequires:  bluez-libs-devel >= 4.15
59BuildRequires:  lirc
60
61Requires: %{name}-common = %{version}-%{release}
62Requires: %{name}-gstreamer = %{version}-%{release}
63
64%if %{build_plugin}
65BuildRequires:  gecko-devel >= %{_gecko_ver}
66BuildRequires:  nautilus-devel >= %{_nautilus_ver}
67BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
68%endif
69
70%description
71Totem is simple movie player for the Gnome desktop. It features a
72simple playlist, a full-screen mode, seek and volume controls, as well as
73a pretty complete keyboard navigation.
74This is virtual package to install totem common package and totem backend
75package.
76
77%package gstreamer
78Summary:        GStramer backend for Totem
79Summary(ja):    Totem 用 GStreamer バックエンド
80Group:          Applications/Multimedia
81Requires:       %{name}-common = %{version}-%{release}
82Requires:       gstreamer >= %{_gst_ver}
83Requires:       gstreamer-plugins-base >= %{_gstpb_ver}
84BuildRequires:  gstreamer-devel >= %{_gst_ver}
85BuildRequires:  gstreamer-plugins-base-devel >= %{_gstpb_ver}
86BuildRequires:  gstreamer-plugins-good
87Obsoletes:      %{name} < 1.0.2-0vl2, nautilus-media
88Provides:       %{name} = %{version}-%{release}
89
90Requires(post):   alternatives
91Requires(postun): alternatives
92
93%description gstreamer
94Totem is simple movie player for the Gnome desktop. It features a
95simple playlist, a full-screen mode, seek and volume controls, as well as
96a pretty complete keyboard navigation.
97
98%if %{build_xine}
99%package xine
100Summary:        Xine backend for Totem
101Summary(ja):    Totem 用 Xine バックエンド
102Group:          Applications/Multimedia
103Requires:       %{name}-common = %{version}-%{release}
104Requires:       xine-lib >= %{_xine_ver}
105BuildRequires:  xine-lib-devel >= %{_xine_ver}
106Obsoletes:      %{name} < 1.0.2-0vl2
107Provides:       %{name} = %{version}-%{release}
108
109Requires(post):   alternatives
110Requires(postun): alternatives
111
112%description xine
113Totem is simple movie player for the Gnome desktop. It features a
114simple playlist, a full-screen mode, seek and volume controls, as well as
115a pretty complete keyboard navigation.
116%endif
117
118%package common
119Summary:        common files for Totem
120Summary(ja):    Totem の共通ファイル
121Group:          Applications/Multimedia
122Requires:       gtk2 >= %{_gtk_ver}, glib2 >= %{_glib_ver}
123Requires:       gnome-desktop-libs >= %{_gnome_desktop_ver}
124Requires:       gnome-vfs2 >= %{_gnomevfs_ver}
125Requires:       libgnomeui >= %{_gnomeui_ver}
126Requires:       libgnome >= %{_libgnome_ver}
127Requires:       dbus >= %{_dbus_ver}
128Requires:       hal >= %{_hal_ver}
129Requires:       iso-codes, libmusicbrainz
130Conflicts:      %{name} < 1.0.2-0vl2
131
132Requires(post):     ldconfig, scrollkeeper, desktop-file-utils, GConf2
133Requires(postun):   ldconfig, scrollkeeper, desktop-file-utils, alternatives
134Requires(preun):    GConf2
135Requires(triggers): alternatives
136
137%description common
138Totem is simple movie player for the Gnome desktop. It features a
139simple playlist, a full-screen mode, seek and volume controls, as well as
140a pretty complete keyboard navigation.
141
142This package contains common files for Totem (GStreamer/xine backend).
143
144%if %{build_plugin}
145%package mozilla
146Summary:        Totem movie plugin for Mozilla
147Summary(ja):    Mozilla 用 Totem 動画プラグイン
148Group:          Applications/Internet
149Requires:       %{name}-common = %{version}-%{release}
150Obsoletes:      %{name}-mozilla-common
151Obsoletes:      %{name}-mozilla-gstreamer
152Obsoletes:      %{name}-mozilla-xine
153
154Requires(post):   alternatives
155Requires(postun): alternatives
156
157%description mozilla
158Totem is simple movie player for the Gnome desktop. It features a
159simple playlist, a full-screen mode, seek and volume controls, as well as
160a pretty complete keyboard navigation.
161
162This package contains a Totem video plugin for Mozilla. It allows Totem
163movie player to be embedded into a web browser.
164
165%package tracker
166Summary:        Tracker-based video search plugin for Totem
167Summary(ja):    Tracker を使った Totem 用動画検索プラグイン
168Group:          Applications/Multimedia
169Requires:       %{name}-common = %{version}-%{release}
170BuildRequires:  tracker-devel
171
172%description tracker
173A plugin to allow searching local videos, based on their tags, metadata,
174or filenames, as indexing by the Tracker indexer.
175%endif
176
177%prep
178%setup -q -c
179# Whatever needs to be changed in both copies do here
180## remember to update me when changing %doc
181for i in AUTHORS COPYING ChangeLog NEWS README TODO;do
182  cp totem-%{version}/$i .
183done
184
185# duplicate sources
186cp -a totem-%{version} xine
187mv totem-%{version} gstreamer
188
189%build
190
191# build Totem (GStreamer backend)
192pushd gstreamer
193DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-0.10 --print-all > /dev/null
194export MOZILLA_PLUGINDIR=%{mozplug_dir}
195%configure \
196        --disable-lirc \
197        --disable-vanity \
198        --disable-nvtv \
199        --disable-schemas-install \
200        --disable-scrollkeeper \
201        --disable-xine \
202        --enable-gstreamer \
203%if %{build_plugin}
204        --enable-browser-plugins \
205        --enable-nautilus \
206        --enable-mozilla \
207        --with-mozilla=libxul \
208        --enable-basic-plugin \
209        --enable-gmp-plugin \
210        --enable-complex-plugin \
211        --enable-narrowspace-plugin \
212        --enable-mully-plugin
213%else
214        --disable-browser-plugins
215%endif
216make %{?_smp_mflags}
217popd
218
219# build Totem (xine backend)
220%if %{build_xine}
221pushd xine
222export MOZILLA_PLUGINDIR=%{mozplug_dir}
223%configure \
224        --disable-lirc \
225        --disable-vanity \
226        --disable-nvtv \
227        --disable-schemas-install \
228        --disable-scrollkeeper \
229        --disable-gstreamer \
230        --enable-xine \
231        --disable-nautilus \
232        --disable-mozilla \
233        --disable-browser-plugins
234cd src/backend/
235make %{?_smp_mflags}
236popd
237%endif
238
239%install
240rm -rf $RPM_BUILD_ROOT
241export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
242
243# install Totem (GStreamer backend)
244pushd gstreamer/
245make install DESTDIR=$RPM_BUILD_ROOT
246mv $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget.so.0.0.0 \
247   $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0
248# language hack
249%find_lang %{name} --with-gnome
250mv %{name}.lang ../
251popd
252
253# install Totem (xine backend)
254%if %{build_xine}
255pushd xine/src/backend/
256make install DESTDIR=$RPM_BUILD_ROOT
257mv $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget.so.0.0.0 \
258   $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget-xine.so.0.0.0
259popd
260%endif
261
262# remove unneeded files
263%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
264%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
265%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
266%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
267%__rm -f %{buildroot}%{_libdir}/libbaconvideowidget*.{a,la}
268%__rm -f %{buildroot}%{_libdir}/libbaconvideowidget.so
269%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
270%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
271 
272%find_lang %{name} --with-gnome
273
274%clean
275%__rm -rf %{buildroot}
276
277%post gstreamer
278%{_syssbindir}/update-alternatives --install \
279        %{_libdir}/libbaconvideowidget.so.0.0.0 totem \
280        %{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0 10
281/sbin/ldconfig
282
283%postun gstreamer
284[ "$1" = "1" ] && exit
285%{_syssbindir}/update-alternatives --remove \
286        totem %{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0
287[ -f "%{_libdir}/libbaconvideowidget.so.0.0.0" ] || %{_syssbindir}/update-alternatives --auto totem
288/sbin/ldconfig
289
290%if %{build_xine}
291%post xine
292%{_syssbindir}/update-alternatives --install \
293        %{_libdir}/libbaconvideowidget.so.0.0.0 totem \
294        %{_libdir}/libbaconvideowidget-xine.so.0.0.0 15
295/sbin/ldconfig
296
297%postun xine
298[ "$1" = "1" ] && exit
299%{_syssbindir}/update-alternatives --remove \
300        totem %{_libdir}/libbaconvideowidget-xine.so.0.0.0
301[ -f "%{_libdir}/libbaconvideowidget.so.0.0.0" ] || %{_syssbindir}/update-alternatives --auto totem
302/sbin/ldconfig
303%endif
304
305%post common
306%{_bindir}/scrollkeeper-update -q
307%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
308export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
309gconftool-2 --makefile-install-rule \
310        %{_sysconfdir}/gconf/schemas/totem.schemas \
311        %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
312        %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
313    >& /dev/null || :
314touch %{_datadir}/icons/hicolor
315if [ -x /usr/bin/gtk-update-icon-cache ]; then
316  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
317fi
318
319%pre common
320if [ "$1" -gt 1 ]; then
321    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
322    gconftool-2 --makefile-uninstall-rule \
323        %{_sysconfdir}/gconf/schemas/totem.schemas \
324        %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
325        %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
326        >& /dev/null || :
327fi
328
329%preun common
330if [ "$1" -eq 0 ]; then
331    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
332    gconftool-2 --makefile-uninstall-rule \
333        %{_sysconfdir}/gconf/schemas/totem.schemas \
334        %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
335        %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
336 >& /dev/null || :
337fi
338
339%postun common
340%{_bindir}/scrollkeeper-update -q
341%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
342touch %{_datadir}/icons/hicolor
343if [ -x /usr/bin/gtk-update-icon-cache ]; then
344  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
345fi
346[ -f "%{_bindir}/totem" ] || %{_syssbindir}/update-alternatives --auto totem
347
348%triggerpostun common -- %{name} < 1.0.2-0vl2
349export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
350for schema in totem totem-video-thumbnail totem-handlers ; do
351        %{_bindir}/gconftool-2 --makefile-install-rule \
352                %{_sysconfdir}/gconf/schemas/${schema}.schemas > /dev/null ||:
353done
354[ -f "%{_bindir}/totem" ] || %{_syssbindir}/update-alternatives --auto totem
355
356
357%files
358
359%files gstreamer
360%defattr(-,root,root,-)
361%{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0
362
363%if %{build_xine}
364%files xine
365%defattr(-,root,root,-)
366%{_libdir}/libbaconvideowidget-xine.so.0.0.0
367%endif
368
369%files common -f %{name}.lang
370%defattr(-,root,root,-)
371%doc AUTHORS COPYING ChangeLog NEWS README TODO
372%config %{_sysconfdir}/gconf/schemas/*.schemas
373%{_bindir}/totem
374%{_bindir}/totem-audio-preview
375%{_bindir}/totem-video-indexer
376%{_bindir}/totem-video-thumbnailer
377%{_datadir}/applications/%{name}.desktop
378%{_datadir}/icons/*/*/apps/*
379%{_datadir}/icons/*/*/devices/*
380%{_datadir}/%{name}
381%{_datadir}/gtk-doc/html/totem
382%dir %{_libdir}/totem
383%dir %{_libdir}/totem/plugins
384%{_libdir}/totem/plugins/brasero-disc-recorder
385%{_libdir}/totem/plugins/coherence_upnp
386%{_libdir}/totem/plugins/gromit
387%{_libdir}/totem/plugins/jamendo
388%{_libdir}/totem/plugins/lirc
389%{_libdir}/totem/plugins/media-player-keys
390%{_libdir}/totem/plugins/ontop
391%{_libdir}/totem/plugins/opensubtitles
392%{_libdir}/totem/plugins/properties
393%{_libdir}/totem/plugins/pythonconsole
394%{_libdir}/totem/plugins/screensaver
395%{_libdir}/totem/plugins/screenshot
396%{_libdir}/totem/plugins/skipto
397%{_libdir}/totem/plugins/thumbnail
398%{_libdir}/totem/plugins/youtube
399%{_libdir}/totem/plugins/totem
400%if %{build_plugin}
401%{_libdir}/nautilus/extensions-2.0/*.so*
402%endif
403%{_libdir}/libbaconvideowidget.so*
404%{_libexecdir}/%{name}/totem-bugreport.py
405%{_mandir}/man1/*
406
407%if %{build_plugin}
408%files mozilla
409%defattr(-,root,root,-)
410%{mozplug_dir}/*
411%{_libexecdir}/totem-plugin-viewer
412
413%files tracker
414%defattr(-, root, root)
415%{_libdir}/totem/plugins/tracker
416%endif
417
418%changelog
419* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
420- remove unneeded autoreconf
421- add BR: lirc
422
423* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
424- new upstream release
425
426* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
427- remove bemused plugin
428
429* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
430- new upstream release
431
432* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
433- added tracker video search sub-package
434
435* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
436- new upstream release
437
438* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
439- new upstream release
440
441* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
442- remove libxine dependency from totem-common
443- build xine backend with minimum dependency
444
445* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
446- add BR: bluez-libs-devel >= 4.15
447- fix typo in %%postun xine
448
449* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
450- rebuild with bluez-libs-devel-4.15
451
452* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
453- new upstream release
454
455* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
456- new upstream release
457
458* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
459- new upstream release
460- add patch1 to build with xulrunner-1.9
461
462* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
463- new upstream release
464
465* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
466- new upstream release
467- disabled devel package (replaced by totem-pl-parser-devel)
468
469* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
470- new upstream release
471- update version macros
472- enable browser plugins on x86_64
473
474* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
475- new upstream release
476
477* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
478- upstream release
479- drop obsolete ja.po.patch (patch0)
480- revert change of 1.4.4-0vl2
481
482* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
483- upstream release
484- enable browser plugins (exclude x86_64 arch)
485
486* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
487- upstream release
488
489* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
490- update configure options
491- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
492
493* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
494- fix mistranslation (patch0)
495- add icon symlink
496- add BuildRequires: gstreamer-plugins-good
497
498* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
499- upstream release
500- update %%_glib_ver, %%_xine_ver
501- add BuildRequires: hal
502- update %%configure options
503- update %%files
504
505* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
506- upstream release
507
508* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
509- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
510
511* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
512- upstream release
513- drop obsolete patch0
514
515* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
516- upstream release
517- add patch0 to build with intltool-0.35
518
519* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
520- upstream release
521
522* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
523- upstream release
524- update alternatives entry
525
526* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
527- upstream release
528- drop fix-sort-function.patch (was merged to upstream, #331426)
529
530* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
531- rebuild with gnome-2.14rc
532
533* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
534- upstream release
535- add macros
536  - _gtk_ver, _glib_ver
537  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
538  - _dbus_ver
539  - _gst_ver, gstpb_ver, _xine_ver
540- add fix-sort-function.patch to build with glib < 2.9.1
541
542* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
543- upstream release
544- add BuildRequires:
545  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
546  - gnome-vfs2-devel >= 2.9.92
547  - dbus-devel >= 0.35
548- use gstreamer-0.10 as backend for totem-gstreamer
549
550* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
551- use gstreamer08 instead of gstreamer
552
553* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
554- upstream release
555
556* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
557- fix missing links
558  - update file list
559  - update update-alternatives scripts
560- fix totem-gstreamer's %%postun script
561
562* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
563- upstream release
564- add BuildRequires: iso-codes, libmusicbrainz-devel
565- add Requires: iso-codes, libmusicbrains to -common package
566- remove BuildRequires: nautilus-cd-burner
567- remove Requires: nautilus-cd-burner from -common package
568
569* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
570- totem-gstreamer obsoletes nautilus-media
571
572* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
573- upstream release
574- add Requires(post,postun): alternatives for gstreamer,xine
575- add Requires(postun,triggers): alternatives for common
576
577* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
578- upstream release
579
580* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
581- build xine backend
582  - move common files to common package
583  - move GStreamer related files to gstreamer package
584  - install xine related files to xine package
585- fix scripts
586
587* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
588- upstream release
589- update URL
590- move *.{a,la} to devel package
591
592* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
593- fix %%{post,preun} script (video-thumbnail.schemas)
594- sync with Fedora Core's 1.0.1-1
595
596  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
597  - Update to upstream version 1.0.1
598  - Break out devel package
599
600* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
601- add %%{post,pre}un script
602
603* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
604- initial build for Vine Linux
605
606* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
607- fix %%post
608
609* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
610- Obsolete nautilus-media
611- Install property page and thumbnailer
612
613* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
614- Update to 0.101
615 
616* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
617- Grab patch totem-0.100-desktopfile.patch from CVS to fix
618  missing menu entry (144088)
619- Remove workaround for desktop file being misinstalled, fixed
620  by above patch
621
622* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
623- New upstream version 0.100
624
625* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
626- update to 0.99.22
627
628* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
629- Add patch to remove removed items from package from help
630
631* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
632- New upstream 0.99.19
633  - Fixes crasher with CD playback (see NEWS)
634
635* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
636- Call update-desktop-database in post
637
638* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
639- update to 0.99.18
640
641* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
642- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
643
Note: See TracBrowser for help on using the repository browser.