source: projects/specs/trunk/t/totem/totem-vl.spec @ 7088

Revision 7088, 18.1 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# build browser plugins
2%define build_plugin    %{!?_without_mozilla:1}%{?_without_mozilla:0}
3
4# define versions
5%define _glib_ver               2.34.0
6%define _gtk_ver                3.4.0
7%define _gnomeicon_ver          3.4.0
8%define _gnome_doc_utils_ver    0.20.0
9%define _dbus_ver               1.4.0
10%define _gst_ver                0.11.93
11%define _gstpb_ver              0.11.93
12%define _gstpg_ver              0.11.93
13%define _gstpbad_ver            0.11.93
14%define _xulrunner_ver          1.9
15%define _nautilus_ver           3.4.0
16%define _shared_mime_info_ver   0.17
17%define _unique_ver             1.0
18%define _totem_pl_parser_ver    2.32.0
19
20%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
21%define mozplug_dir %{_libdir}/mozilla/plugins
22
23Summary:        Movie player for GNOME 3
24Summary(ja):    GNOME3 用動画プレイヤー
25Name:           totem
26Version:        3.6.3
27Release:        1%{?_dist_release}
28License:        GPL
29Group:          Applications/Multimedia
30URL:            http://www.gnome.org/projects/totem/
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/totem/3.6/totem-%{version}.tar.xz
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34
35Vendor:         Project Vine
36Distribution:   Vine Linux
37Packager:       Takemikaduchi
38
39BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
40BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
41BuildRequires:  dbus-devel >= %{_dbus_ver}
42BuildRequires:  nautilus-devel >= %{_nautilus_ver}
43BuildRequires:  gettext, scrollkeeper
44BuildRequires:  perl-XML-Parser
45BuildRequires:  iso-codes
46BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
47BuildRequires:  grilo-devel
48BuildRequires:  bluez-libs-devel >= 4.15
49BuildRequires:  lirc
50BuildRequires:  unique-devel >= %{_unique_ver}
51BuildRequires:  python-devel
52BuildRequires:  pylint
53BuildRequires:  pygobject3-devel
54BuildRequires:  libpeas-devel
55BuildRequires:  libXtst-devel
56BuildRequires:  gsettings-desktop-schemas-devel
57BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
58
59BuildRequires:  gstreamer1-devel >= %{_gst_ver}
60BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
61BuildRequires:  gstreamer1-plugins-good >= %{_gstpg_ver}
62BuildRequires:  gstreamer1-plugins-bad-free-devel >= %{_gstpbad_ver}
63
64BuildRequires:  clutter-gtk-devel
65BuildRequires:  clutter-gst-devel
66BuildRequires:  libmx-devel
67
68%if %{build_plugin}
69BuildRequires:  xulrunner-devel >= %{_xulrunner_ver}
70BuildRequires:  nautilus-devel >= %{_nautilus_ver}
71BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
72%endif
73
74Requires:       gstreamer1 >= %{_gst_ver}
75Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
76Requires:       gstreamer1-plugins-good >= %{_gstpg_ver}
77Requires:       gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
78Requires:       iso-codes
79
80Obsoletes:      nautilus-media
81Obsoletes:      %{name}-gstreamer < 2.30.1-2
82Obsoletes:      %{name}-xine < 2.30.1-2
83Obsoletes:      %{name}-common < 2.30.1-3
84
85Provides:       nautilus-media
86Provides:       %{name}-common = %{version}-%{release}
87
88Requires(post):     ldconfig, scrollkeeper, desktop-file-utils, GConf2
89Requires(postun):   ldconfig, scrollkeeper, desktop-file-utils
90Requires(preun):    GConf2
91
92%description
93Totem is simple movie player for the Gnome desktop. It features a
94simple playlist, a full-screen mode, seek and volume controls, as well as
95a pretty complete keyboard navigation.
96
97%if %{build_plugin}
98%package mozilla
99Summary:        Totem movie plugin for Mozilla
100Summary(ja):    Mozilla 用 Totem 動画プラグイン
101Group:          Applications/Internet
102Requires:       %{name} = %{version}-%{release}
103Obsoletes:      %{name}-mozilla-common
104Obsoletes:      %{name}-mozilla-gstreamer
105Obsoletes:      %{name}-mozilla-xine
106
107%description mozilla
108Totem is simple movie player for the Gnome desktop. It features a
109simple playlist, a full-screen mode, seek and volume controls, as well as
110a pretty complete keyboard navigation.
111
112This package contains a Totem video plugin for Mozilla. It allows Totem
113movie player to be embedded into a web browser.
114
115%endif
116
117%package devel
118Summary:        Plugin writer's documentation for totem
119Group:          Development/Libraries
120Requires:       %{name} = %{version}-%{release}
121
122%description devel
123The %{name}-devel package contains API documentation for
124developing developing plugins for %{name}.
125
126%prep
127%setup -q
128
129%build
130DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
131export MOZILLA_PLUGINDIR=%{mozplug_dir}
132
133%configure \
134        --disable-scrollkeeper \
135        --enable-python \
136        --disable-vala \
137        --enable-nautilus \
138        --enable-gmp-plugin \
139        --enable-narrowspace-plugin \
140        --enable-mully-plugin \
141        --disable-vegas-plugin \
142%if %{build_plugin}
143        --enable-browser-plugins
144%else
145        --disable-browser-plugins
146%endif
147
148make %{?_smp_mflags}
149
150%install
151rm -rf $RPM_BUILD_ROOT
152export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
153
154make install DESTDIR=$RPM_BUILD_ROOT
155
156# remove unneeded files
157%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
158%__rm -f %{buildroot}%{_libdir}/*.{a,la}
159%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
160%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
161%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
162%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
163%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
164
165# remove unused file
166%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
167 
168%find_lang %{name} --with-gnome
169
170# save space by linking identical images in translated docs
171helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
172for f in $helpdir/C/figures/*.png; do
173  b="$(basename $f)"
174  for d in $helpdir/*; do
175    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
176      g="$d/figures/$b"
177      if [ -f "$g" ]; then
178        if cmp -s $f $g; then
179          rm "$g"; ln -s "../../C/figures/$b" "$g"
180        fi
181      fi
182    fi
183  done
184done
185
186
187%clean
188%__rm -rf %{buildroot}
189
190%post
191%{_bindir}/scrollkeeper-update -q
192%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
193touch %{_datadir}/icons/hicolor
194if [ -x /usr/bin/gtk-update-icon-cache ]; then
195  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
196fi
197
198%postun
199%{_bindir}/scrollkeeper-update -q
200%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
201touch %{_datadir}/icons/hicolor
202if [ -x /usr/bin/gtk-update-icon-cache ]; then
203  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
204fi
205glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
206
207%posttrans
208glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
209
210%files -f %{name}.lang
211%defattr(-,root,root,-)
212%doc AUTHORS COPYING ChangeLog NEWS README TODO
213%{_bindir}/totem
214%{_bindir}/totem-audio-preview
215%{_bindir}/totem-video-thumbnailer
216%{_datadir}/GConf/gsettings/opensubtitles.convert
217#%{_datadir}/GConf/gsettings/pythonconsole.convert
218%{_datadir}/GConf/gsettings/totem.convert
219%{_datadir}/applications/%{name}.desktop
220%{_datadir}/glib-2.0/schemas/*.xml
221%{_datadir}/icons/*/*/*/*
222%{_datadir}/thumbnailers/totem.thumbnailer
223%{_datadir}/%{name}
224%{_datadir}/gtk-doc/html/totem
225%{_libdir}/libtotem.so.*
226%{_libdir}/girepository-1.0/*.typelib
227%dir %{_libdir}/totem
228%dir %{_libdir}/totem/plugins
229%{_libdir}/totem/plugins/apple-trailers/
230%{_libdir}/totem/plugins/autoload-subtitles
231%{_libdir}/totem/plugins/brasero-disc-recorder
232%{_libdir}/totem/plugins/chapters
233%{_libdir}/totem/plugins/dbus
234%{_libdir}/totem/plugins/grilo
235%{_libdir}/totem/plugins/gromit
236%{_libdir}/totem/plugins/lirc
237%{_libdir}/totem/plugins/media-player-keys
238%{_libdir}/totem/plugins/ontop
239%{_libdir}/totem/plugins/opensubtitles
240%{_libdir}/totem/plugins/properties
241%{_libdir}/totem/plugins/pythonconsole
242%{_libdir}/totem/plugins/recent
243%{_libdir}/totem/plugins/screensaver
244%{_libdir}/totem/plugins/screenshot
245%{_libdir}/totem/plugins/skipto
246%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
247%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
248%{_libdir}/totem/plugins/save-file/libsave-file.so
249%{_libdir}/totem/plugins/save-file/save-file.plugin
250%if %{build_plugin}
251%{_libdir}/nautilus/extensions-3.0/*.so*
252%endif
253%{_libexecdir}/%{name}/totem-bugreport.py
254%{_mandir}/man1/*
255
256%if %{build_plugin}
257%files mozilla
258%defattr(-,root,root,-)
259%{mozplug_dir}/*
260%{_libexecdir}/totem-plugin-viewer
261%endif
262
263%files devel
264%defattr(-, root, root,-)
265%{_includedir}/totem
266%{_libdir}/libtotem.so
267%{_libdir}/pkgconfig/totem.pc
268%{_datadir}/gir-1.0/Totem-1.0.gir
269%{_datadir}/gtk-doc/html/totem
270
271
272%changelog
273* Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
274- new upstream release
275
276* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
277- new upstream release
278- change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
279
280* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
281- new upstream release
282- add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
283
284* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
285- new upstream release
286
287* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
288- add configure option (--disable-vegas-plugin)
289
290* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
291- new upstream release
292
293* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
294- new upstream release
295- add BuildRequires: pylint
296- remove BuildRequires: libgdata-devel
297
298* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
299- new upstream release
300
301* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
302- new upstream release
303
304* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
305- new upstream release
306- change BuildRequires: pygobject3-devel instead of pygobject-devel
307
308* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
309- new upstream release
310- change BuildRequires: gtk3-devel instead of gtk2-devel
311- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
312                     clutter-gst-devel, libmx-devel
313- change configure option (--disable-vala)
314
315* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
316- new upstream release
317- fix %files
318
319* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
320- new upstream release
321
322* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
323- clean up spec file
324- remove totem-common and merged to totem main package.
325  - add Obsoletes: totem-common
326- remove unneeded BR: and R:
327  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
328  - libmusicbrainz, alternatives
329- remove explicit dependency
330  - gtk2, glib2, dbus
331- add R: pygtk2, pyxdg, python-Coherence for python plugins
332- add R: gstreamer-plugins-good
333
334* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
335- rebuild with libgdata (add youtube plugin)
336- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
337- add Obsolete: totem-gstreamer, totem-xine)
338
339* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
340- new upstream release
341- chagnge _gst_ver from 0.10.19 to 0.10.29
342
343* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
344- new upstream release
345- drop totem-tracker package
346- add BuildRequires: unique-devel
347- remove BuildRequires: hal-devel
348- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
349
350* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
351- remove unneeded autoreconf
352- add BR: lirc
353
354* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
355- new upstream release
356
357* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
358- remove bemused plugin
359
360* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
361- new upstream release
362
363* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
364- added tracker video search sub-package
365
366* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
367- new upstream release
368
369* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
370- new upstream release
371
372* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
373- remove libxine dependency from totem-common
374- build xine backend with minimum dependency
375
376* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
377- add BR: bluez-libs-devel >= 4.15
378- fix typo in %%postun xine
379
380* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
381- rebuild with bluez-libs-devel-4.15
382
383* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
384- new upstream release
385
386* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
387- new upstream release
388
389* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
390- new upstream release
391- add patch1 to build with xulrunner-1.9
392
393* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
394- new upstream release
395
396* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
397- new upstream release
398- disabled devel package (replaced by totem-pl-parser-devel)
399
400* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
401- new upstream release
402- update version macros
403- enable browser plugins on x86_64
404
405* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
406- new upstream release
407
408* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
409- upstream release
410- drop obsolete ja.po.patch (patch0)
411- revert change of 1.4.4-0vl2
412
413* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
414- upstream release
415- enable browser plugins (exclude x86_64 arch)
416
417* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
418- upstream release
419
420* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
421- update configure options
422- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
423
424* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
425- fix mistranslation (patch0)
426- add icon symlink
427- add BuildRequires: gstreamer-plugins-good
428
429* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
430- upstream release
431- update %%_glib_ver, %%_xine_ver
432- add BuildRequires: hal
433- update %%configure options
434- update %%files
435
436* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
437- upstream release
438
439* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
440- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
441
442* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
443- upstream release
444- drop obsolete patch0
445
446* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
447- upstream release
448- add patch0 to build with intltool-0.35
449
450* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
451- upstream release
452
453* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
454- upstream release
455- update alternatives entry
456
457* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
458- upstream release
459- drop fix-sort-function.patch (was merged to upstream, #331426)
460
461* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
462- rebuild with gnome-2.14rc
463
464* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
465- upstream release
466- add macros
467  - _gtk_ver, _glib_ver
468  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
469  - _dbus_ver
470  - _gst_ver, gstpb_ver, _xine_ver
471- add fix-sort-function.patch to build with glib < 2.9.1
472
473* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
474- upstream release
475- add BuildRequires:
476  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
477  - gnome-vfs2-devel >= 2.9.92
478  - dbus-devel >= 0.35
479- use gstreamer-0.10 as backend for totem-gstreamer
480
481* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
482- use gstreamer08 instead of gstreamer
483
484* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
485- upstream release
486
487* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
488- fix missing links
489  - update file list
490  - update update-alternatives scripts
491- fix totem-gstreamer's %%postun script
492
493* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
494- upstream release
495- add BuildRequires: iso-codes, libmusicbrainz-devel
496- add Requires: iso-codes, libmusicbrains to -common package
497- remove BuildRequires: nautilus-cd-burner
498- remove Requires: nautilus-cd-burner from -common package
499
500* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
501- totem-gstreamer obsoletes nautilus-media
502
503* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
504- upstream release
505- add Requires(post,postun): alternatives for gstreamer,xine
506- add Requires(postun,triggers): alternatives for common
507
508* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
509- upstream release
510
511* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
512- build xine backend
513  - move common files to common package
514  - move GStreamer related files to gstreamer package
515  - install xine related files to xine package
516- fix scripts
517
518* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
519- upstream release
520- update URL
521- move *.{a,la} to devel package
522
523* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
524- fix %%{post,preun} script (video-thumbnail.schemas)
525- sync with Fedora Core's 1.0.1-1
526
527  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
528  - Update to upstream version 1.0.1
529  - Break out devel package
530
531* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
532- add %%{post,pre}un script
533
534* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
535- initial build for Vine Linux
536
537* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
538- fix %%post
539
540* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
541- Obsolete nautilus-media
542- Install property page and thumbnailer
543
544* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
545- Update to 0.101
546 
547* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
548- Grab patch totem-0.100-desktopfile.patch from CVS to fix
549  missing menu entry (144088)
550- Remove workaround for desktop file being misinstalled, fixed
551  by above patch
552
553* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
554- New upstream version 0.100
555
556* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
557- update to 0.99.22
558
559* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
560- Add patch to remove removed items from package from help
561
562* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
563- New upstream 0.99.19
564  - Fixes crasher with CD playback (see NEWS)
565
566* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
567- Call update-desktop-database in post
568
569* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
570- update to 0.99.18
571
572* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
573- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
574
Note: See TracBrowser for help on using the repository browser.