source: projects/specs/trunk/t/totem/totem-vl.spec @ 6890

Revision 6890, 17.8 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1# build browser plugins
2%define build_plugin    %{!?_without_mozilla:1}%{?_without_mozilla:0}
3
4# define versions
5%define _glib_ver               2.34.0
6%define _gtk_ver                3.4.0
7%define _gnomeicon_ver          3.4.0
8%define _gnome_doc_utils_ver    0.20.0
9%define _dbus_ver               1.4.0
10%define _gst_ver                0.11.93
11%define _gstpb_ver              0.11.93
12%define _gstpg_ver              0.11.93
13%define _gstpbad_ver            0.11.93
14%define _xulrunner_ver          1.9
15%define _nautilus_ver           3.4.0
16%define _shared_mime_info_ver   0.17
17%define _unique_ver             1.0
18%define _totem_pl_parser_ver    2.32.0
19
20%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
21%define mozplug_dir %{_libdir}/mozilla/plugins
22
23Summary:        Movie player for GNOME 3
24Summary(ja):    GNOME3 用動画プレイヤー
25Name:           totem
26Version:        3.6.0
27Release:        1%{?_dist_release}
28License:        GPL
29Group:          Applications/Multimedia
30URL:            http://www.gnome.org/projects/totem/
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/totem/3.6/totem-%{version}.tar.xz
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34
35Vendor:         Project Vine
36Distribution:   Vine Linux
37Packager:       Takemikaduchi
38
39BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
40BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
41BuildRequires:  dbus-devel >= %{_dbus_ver}
42BuildRequires:  nautilus-devel >= %{_nautilus_ver}
43BuildRequires:  gettext, scrollkeeper
44BuildRequires:  perl-XML-Parser
45BuildRequires:  iso-codes
46BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
47BuildRequires:  grilo-devel
48BuildRequires:  bluez-libs-devel >= 4.15
49BuildRequires:  lirc
50BuildRequires:  unique-devel >= %{_unique_ver}
51BuildRequires:  python-devel
52BuildRequires:  pylint
53BuildRequires:  pygobject3-devel
54BuildRequires:  libpeas-devel
55BuildRequires:  libXtst-devel
56BuildRequires:  gsettings-desktop-schemas-devel
57BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
58
59BuildRequires:  gstreamer1-devel >= %{_gst_ver}
60BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
61BuildRequires:  gstreamer1-plugins-good >= %{_gstpg_ver}
62BuildRequires:  gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
63
64BuildRequires:  clutter-gtk-devel
65BuildRequires:  clutter-gst-devel
66BuildRequires:  libmx-devel
67
68%if %{build_plugin}
69BuildRequires:  xulrunner-devel >= %{_xulrunner_ver}
70BuildRequires:  nautilus-devel >= %{_nautilus_ver}
71BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
72%endif
73
74Requires:       gstreamer1 >= %{_gst_ver}
75Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
76Requires:       gstreamer1-plugins-good >= %{_gstpg_ver}
77Requires:       iso-codes
78
79Obsoletes:      nautilus-media
80Obsoletes:      %{name}-gstreamer < 2.30.1-2
81Obsoletes:      %{name}-xine < 2.30.1-2
82Obsoletes:      %{name}-common < 2.30.1-3
83
84Provides:       nautilus-media
85Provides:       %{name}-common = %{version}-%{release}
86
87Requires(post):     ldconfig, scrollkeeper, desktop-file-utils, GConf2
88Requires(postun):   ldconfig, scrollkeeper, desktop-file-utils
89Requires(preun):    GConf2
90
91%description
92Totem is simple movie player for the Gnome desktop. It features a
93simple playlist, a full-screen mode, seek and volume controls, as well as
94a pretty complete keyboard navigation.
95
96%if %{build_plugin}
97%package mozilla
98Summary:        Totem movie plugin for Mozilla
99Summary(ja):    Mozilla 用 Totem 動画プラグイン
100Group:          Applications/Internet
101Requires:       %{name} = %{version}-%{release}
102Obsoletes:      %{name}-mozilla-common
103Obsoletes:      %{name}-mozilla-gstreamer
104Obsoletes:      %{name}-mozilla-xine
105
106%description mozilla
107Totem is simple movie player for the Gnome desktop. It features a
108simple playlist, a full-screen mode, seek and volume controls, as well as
109a pretty complete keyboard navigation.
110
111This package contains a Totem video plugin for Mozilla. It allows Totem
112movie player to be embedded into a web browser.
113
114%endif
115
116%package devel
117Summary:        Plugin writer's documentation for totem
118Group:          Development/Libraries
119Requires:       %{name} = %{version}-%{release}
120
121%description devel
122The %{name}-devel package contains API documentation for
123developing developing plugins for %{name}.
124
125%prep
126%setup -q
127
128%build
129DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
130export MOZILLA_PLUGINDIR=%{mozplug_dir}
131
132%configure \
133        --disable-scrollkeeper \
134        --enable-python \
135        --disable-vala \
136        --enable-nautilus \
137        --enable-gmp-plugin \
138        --enable-narrowspace-plugin \
139        --enable-mully-plugin \
140        --disable-vegas-plugin \
141%if %{build_plugin}
142        --enable-browser-plugins
143%else
144        --disable-browser-plugins
145%endif
146
147make %{?_smp_mflags}
148
149%install
150rm -rf $RPM_BUILD_ROOT
151export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
152
153make install DESTDIR=$RPM_BUILD_ROOT
154
155# remove unneeded files
156%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
157%__rm -f %{buildroot}%{_libdir}/*.{a,la}
158%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
159%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
160%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
161%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
162%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
163
164# remove unused file
165%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
166 
167%find_lang %{name} --with-gnome
168
169# save space by linking identical images in translated docs
170helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
171for f in $helpdir/C/figures/*.png; do
172  b="$(basename $f)"
173  for d in $helpdir/*; do
174    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
175      g="$d/figures/$b"
176      if [ -f "$g" ]; then
177        if cmp -s $f $g; then
178          rm "$g"; ln -s "../../C/figures/$b" "$g"
179        fi
180      fi
181    fi
182  done
183done
184
185
186%clean
187%__rm -rf %{buildroot}
188
189%post
190%{_bindir}/scrollkeeper-update -q
191%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
192touch %{_datadir}/icons/hicolor
193if [ -x /usr/bin/gtk-update-icon-cache ]; then
194  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
195fi
196
197%postun
198%{_bindir}/scrollkeeper-update -q
199%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
200touch %{_datadir}/icons/hicolor
201if [ -x /usr/bin/gtk-update-icon-cache ]; then
202  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
203fi
204glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
205
206%posttrans
207glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
208
209%files -f %{name}.lang
210%defattr(-,root,root,-)
211%doc AUTHORS COPYING ChangeLog NEWS README TODO
212%{_bindir}/totem
213%{_bindir}/totem-audio-preview
214%{_bindir}/totem-video-thumbnailer
215%{_datadir}/GConf/gsettings/opensubtitles.convert
216#%{_datadir}/GConf/gsettings/pythonconsole.convert
217%{_datadir}/GConf/gsettings/totem.convert
218%{_datadir}/applications/%{name}.desktop
219%{_datadir}/glib-2.0/schemas/*.xml
220%{_datadir}/icons/*/*/*/*
221%{_datadir}/thumbnailers/totem.thumbnailer
222%{_datadir}/%{name}
223%{_datadir}/gtk-doc/html/totem
224%{_libdir}/libtotem.so.*
225%{_libdir}/girepository-1.0/*.typelib
226%dir %{_libdir}/totem
227%dir %{_libdir}/totem/plugins
228%{_libdir}/totem/plugins/apple-trailers/
229%{_libdir}/totem/plugins/autoload-subtitles
230%{_libdir}/totem/plugins/brasero-disc-recorder
231%{_libdir}/totem/plugins/chapters
232%{_libdir}/totem/plugins/dbus
233%{_libdir}/totem/plugins/grilo
234%{_libdir}/totem/plugins/gromit
235%{_libdir}/totem/plugins/lirc
236%{_libdir}/totem/plugins/media-player-keys
237%{_libdir}/totem/plugins/ontop
238%{_libdir}/totem/plugins/opensubtitles
239%{_libdir}/totem/plugins/properties
240%{_libdir}/totem/plugins/pythonconsole
241%{_libdir}/totem/plugins/recent
242%{_libdir}/totem/plugins/screensaver
243%{_libdir}/totem/plugins/screenshot
244%{_libdir}/totem/plugins/skipto
245%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
246%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
247%{_libdir}/totem/plugins/save-file/libsave-file.so
248%{_libdir}/totem/plugins/save-file/save-file.plugin
249%if %{build_plugin}
250%{_libdir}/nautilus/extensions-3.0/*.so*
251%endif
252%{_libexecdir}/%{name}/totem-bugreport.py
253%{_mandir}/man1/*
254
255%if %{build_plugin}
256%files mozilla
257%defattr(-,root,root,-)
258%{mozplug_dir}/*
259%{_libexecdir}/totem-plugin-viewer
260%endif
261
262%files devel
263%defattr(-, root, root,-)
264%{_includedir}/totem
265%{_libdir}/libtotem.so
266%{_libdir}/pkgconfig/totem.pc
267%{_datadir}/gir-1.0/Totem-1.0.gir
268%{_datadir}/gtk-doc/html/totem
269
270
271%changelog
272* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
273- new upstream release
274- add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
275
276* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
277- new upstream release
278
279* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
280- add configure option (--disable-vegas-plugin)
281
282* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
283- new upstream release
284
285* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
286- new upstream release
287- add BuildRequires: pylint
288- remove BuildRequires: libgdata-devel
289
290* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
291- new upstream release
292
293* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
294- new upstream release
295
296* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
297- new upstream release
298- change BuildRequires: pygobject3-devel instead of pygobject-devel
299
300* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
301- new upstream release
302- change BuildRequires: gtk3-devel instead of gtk2-devel
303- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
304                     clutter-gst-devel, libmx-devel
305- change configure option (--disable-vala)
306
307* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
308- new upstream release
309- fix %files
310
311* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
312- new upstream release
313
314* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
315- clean up spec file
316- remove totem-common and merged to totem main package.
317  - add Obsoletes: totem-common
318- remove unneeded BR: and R:
319  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
320  - libmusicbrainz, alternatives
321- remove explicit dependency
322  - gtk2, glib2, dbus
323- add R: pygtk2, pyxdg, python-Coherence for python plugins
324- add R: gstreamer-plugins-good
325
326* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
327- rebuild with libgdata (add youtube plugin)
328- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
329- add Obsolete: totem-gstreamer, totem-xine)
330
331* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
332- new upstream release
333- chagnge _gst_ver from 0.10.19 to 0.10.29
334
335* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
336- new upstream release
337- drop totem-tracker package
338- add BuildRequires: unique-devel
339- remove BuildRequires: hal-devel
340- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
341
342* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
343- remove unneeded autoreconf
344- add BR: lirc
345
346* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
347- new upstream release
348
349* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
350- remove bemused plugin
351
352* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
353- new upstream release
354
355* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
356- added tracker video search sub-package
357
358* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
359- new upstream release
360
361* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
362- new upstream release
363
364* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
365- remove libxine dependency from totem-common
366- build xine backend with minimum dependency
367
368* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
369- add BR: bluez-libs-devel >= 4.15
370- fix typo in %%postun xine
371
372* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
373- rebuild with bluez-libs-devel-4.15
374
375* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
376- new upstream release
377
378* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
379- new upstream release
380
381* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
382- new upstream release
383- add patch1 to build with xulrunner-1.9
384
385* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
386- new upstream release
387
388* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
389- new upstream release
390- disabled devel package (replaced by totem-pl-parser-devel)
391
392* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
393- new upstream release
394- update version macros
395- enable browser plugins on x86_64
396
397* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
398- new upstream release
399
400* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
401- upstream release
402- drop obsolete ja.po.patch (patch0)
403- revert change of 1.4.4-0vl2
404
405* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
406- upstream release
407- enable browser plugins (exclude x86_64 arch)
408
409* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
410- upstream release
411
412* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
413- update configure options
414- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
415
416* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
417- fix mistranslation (patch0)
418- add icon symlink
419- add BuildRequires: gstreamer-plugins-good
420
421* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
422- upstream release
423- update %%_glib_ver, %%_xine_ver
424- add BuildRequires: hal
425- update %%configure options
426- update %%files
427
428* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
429- upstream release
430
431* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
432- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
433
434* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
435- upstream release
436- drop obsolete patch0
437
438* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
439- upstream release
440- add patch0 to build with intltool-0.35
441
442* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
443- upstream release
444
445* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
446- upstream release
447- update alternatives entry
448
449* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
450- upstream release
451- drop fix-sort-function.patch (was merged to upstream, #331426)
452
453* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
454- rebuild with gnome-2.14rc
455
456* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
457- upstream release
458- add macros
459  - _gtk_ver, _glib_ver
460  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
461  - _dbus_ver
462  - _gst_ver, gstpb_ver, _xine_ver
463- add fix-sort-function.patch to build with glib < 2.9.1
464
465* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
466- upstream release
467- add BuildRequires:
468  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
469  - gnome-vfs2-devel >= 2.9.92
470  - dbus-devel >= 0.35
471- use gstreamer-0.10 as backend for totem-gstreamer
472
473* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
474- use gstreamer08 instead of gstreamer
475
476* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
477- upstream release
478
479* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
480- fix missing links
481  - update file list
482  - update update-alternatives scripts
483- fix totem-gstreamer's %%postun script
484
485* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
486- upstream release
487- add BuildRequires: iso-codes, libmusicbrainz-devel
488- add Requires: iso-codes, libmusicbrains to -common package
489- remove BuildRequires: nautilus-cd-burner
490- remove Requires: nautilus-cd-burner from -common package
491
492* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
493- totem-gstreamer obsoletes nautilus-media
494
495* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
496- upstream release
497- add Requires(post,postun): alternatives for gstreamer,xine
498- add Requires(postun,triggers): alternatives for common
499
500* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
501- upstream release
502
503* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
504- build xine backend
505  - move common files to common package
506  - move GStreamer related files to gstreamer package
507  - install xine related files to xine package
508- fix scripts
509
510* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
511- upstream release
512- update URL
513- move *.{a,la} to devel package
514
515* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
516- fix %%{post,preun} script (video-thumbnail.schemas)
517- sync with Fedora Core's 1.0.1-1
518
519  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
520  - Update to upstream version 1.0.1
521  - Break out devel package
522
523* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
524- add %%{post,pre}un script
525
526* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
527- initial build for Vine Linux
528
529* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
530- fix %%post
531
532* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
533- Obsolete nautilus-media
534- Install property page and thumbnailer
535
536* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
537- Update to 0.101
538 
539* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
540- Grab patch totem-0.100-desktopfile.patch from CVS to fix
541  missing menu entry (144088)
542- Remove workaround for desktop file being misinstalled, fixed
543  by above patch
544
545* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
546- New upstream version 0.100
547
548* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
549- update to 0.99.22
550
551* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
552- Add patch to remove removed items from package from help
553
554* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
555- New upstream 0.99.19
556  - Fixes crasher with CD playback (see NEWS)
557
558* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
559- Call update-desktop-database in post
560
561* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
562- update to 0.99.18
563
564* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
565- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
566
Note: See TracBrowser for help on using the repository browser.