source: projects/specs/trunk/t/totem/totem-vl.spec @ 6256

Revision 6256, 17.4 KB checked in by Takemikaduchi, 12 years ago (diff)

totem: add configure option,
others: new upstream release

Line 
1# build browser plugins
2%define build_plugin    %{!?_without_mozilla:1}%{?_without_mozilla:0}
3
4# define versions
5%define _glib_ver               2.32.0
6%define _gtk_ver                3.4.0
7%define _gnomeicon_ver          3.4.0
8%define _gnome_doc_utils_ver    0.20.0
9%define _dbus_ver               1.4.0
10%define _gst_ver                0.10.30
11%define _gstpb_ver              0.10.30
12%define _gstpg_ver              0.10.24
13%define _xulrunner_ver          1.9
14%define _nautilus_ver           3.4.0
15%define _shared_mime_info_ver   0.17
16%define _unique_ver             1.0
17%define _vala_ver               0.11.1
18%define _totem_pl_parser_ver    2.32.0
19
20%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
21%define mozplug_dir %{_libdir}/mozilla/plugins
22
23Summary:        Movie player for GNOME 3
24Summary(ja):    GNOME3 用動画プレイヤー
25Name:           totem
26Version:        3.4.2
27Release:        2%{?_dist_release}
28License:        GPL
29Group:          Applications/Multimedia
30URL:            http://www.gnome.org/projects/totem/
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/totem/3.4/totem-%{version}.tar.xz
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34
35Vendor:         Project Vine
36Distribution:   Vine Linux
37
38BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
39BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
40BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
41BuildRequires:  dbus-devel >= %{_dbus_ver}
42BuildRequires:  nautilus-devel >= %{_nautilus_ver}
43BuildRequires:  gettext, scrollkeeper
44BuildRequires:  perl-XML-Parser
45BuildRequires:  iso-codes
46BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
47BuildRequires:  bluez-libs-devel >= 4.15
48BuildRequires:  lirc
49BuildRequires:  unique-devel >= %{_unique_ver}
50BuildRequires:  vala-devel >= %{_vala_ver}
51BuildRequires:  python-devel
52BuildRequires:  pylint
53BuildRequires:  pygobject3-devel
54BuildRequires:  libpeas-devel
55BuildRequires:  libXtst-devel
56
57BuildRequires:  gstreamer-devel >= %{_gst_ver}
58BuildRequires:  gstreamer-plugins-base-devel >= %{_gstpb_ver}
59BuildRequires:  gstreamer-plugins-good >= %{_gstpg_ver}
60
61BuildRequires:  clutter-gtk-devel
62BuildRequires:  clutter-gst-devel
63BuildRequires:  libmx-devel
64
65%if %{build_plugin}
66BuildRequires:  xulrunner-devel >= %{_xulrunner_ver}
67BuildRequires:  nautilus-devel >= %{_nautilus_ver}
68BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
69%endif
70
71Requires:       gstreamer >= %{_gst_ver}
72Requires:       gstreamer-plugins-base >= %{_gstpb_ver}
73Requires:       gstreamer-plugins-good >= %{_gstpg_ver}
74Requires:       iso-codes
75# for opensubtitles plugin
76Requires:       pyxdg
77# for python plugins
78Requires:       pygtk2
79# for coherence plugins
80# Requires:     python-Coherence >= 0.6.6.2
81
82Obsoletes:      nautilus-media
83Obsoletes:      %{name}-gstreamer < 2.30.1-2
84Obsoletes:      %{name}-xine < 2.30.1-2
85Obsoletes:      %{name}-common < 2.30.1-3
86
87Provides:       nautilus-media
88Provides:       %{name}-common = %{version}-%{release}
89
90Requires(post):     ldconfig, scrollkeeper, desktop-file-utils, GConf2
91Requires(postun):   ldconfig, scrollkeeper, desktop-file-utils
92Requires(preun):    GConf2
93
94%description
95Totem is simple movie player for the Gnome desktop. It features a
96simple playlist, a full-screen mode, seek and volume controls, as well as
97a pretty complete keyboard navigation.
98
99%if %{build_plugin}
100%package mozilla
101Summary:        Totem movie plugin for Mozilla
102Summary(ja):    Mozilla 用 Totem 動画プラグイン
103Group:          Applications/Internet
104Requires:       %{name} = %{version}-%{release}
105Obsoletes:      %{name}-mozilla-common
106Obsoletes:      %{name}-mozilla-gstreamer
107Obsoletes:      %{name}-mozilla-xine
108
109%description mozilla
110Totem is simple movie player for the Gnome desktop. It features a
111simple playlist, a full-screen mode, seek and volume controls, as well as
112a pretty complete keyboard navigation.
113
114This package contains a Totem video plugin for Mozilla. It allows Totem
115movie player to be embedded into a web browser.
116
117%endif
118
119%package devel
120Summary:        Plugin writer's documentation for totem
121Group:          Development/Libraries
122Requires:       %{name} = %{version}-%{release}
123
124%description devel
125The %{name}-devel package contains API documentation for
126developing developing plugins for %{name}.
127
128%prep
129%setup -q
130
131%build
132DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-0.10 --print-all > /dev/null
133export MOZILLA_PLUGINDIR=%{mozplug_dir}
134
135%configure \
136        --disable-scrollkeeper \
137        --enable-python \
138        --disable-vala \
139        --enable-nautilus \
140        --enable-gmp-plugin \
141        --enable-narrowspace-plugin \
142        --enable-mully-plugin \
143        --disable-vegas-plugin \
144%if %{build_plugin}
145        --enable-browser-plugins
146%else
147        --disable-browser-plugins
148%endif
149
150make %{?_smp_mflags}
151
152%install
153rm -rf $RPM_BUILD_ROOT
154export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
155
156make install DESTDIR=$RPM_BUILD_ROOT
157
158# remove unneeded files
159%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
160%__rm -f %{buildroot}%{_libdir}/*.{a,la}
161%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
162%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
163%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
164%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
165%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
166
167# remove unused file
168%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
169 
170%find_lang %{name} --with-gnome
171
172# save space by linking identical images in translated docs
173helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
174for f in $helpdir/C/figures/*.png; do
175  b="$(basename $f)"
176  for d in $helpdir/*; do
177    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
178      g="$d/figures/$b"
179      if [ -f "$g" ]; then
180        if cmp -s $f $g; then
181          rm "$g"; ln -s "../../C/figures/$b" "$g"
182        fi
183      fi
184    fi
185  done
186done
187
188
189%clean
190%__rm -rf %{buildroot}
191
192%post
193%{_bindir}/scrollkeeper-update -q
194%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
195touch %{_datadir}/icons/hicolor
196if [ -x /usr/bin/gtk-update-icon-cache ]; then
197  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
198fi
199
200%postun
201%{_bindir}/scrollkeeper-update -q
202%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
203touch %{_datadir}/icons/hicolor
204if [ -x /usr/bin/gtk-update-icon-cache ]; then
205  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
206fi
207glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
208
209%posttrans
210glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
211
212%files -f %{name}.lang
213%defattr(-,root,root,-)
214%doc AUTHORS COPYING ChangeLog NEWS README TODO
215%{_bindir}/totem
216%{_bindir}/totem-audio-preview
217%{_bindir}/totem-video-thumbnailer
218%{_datadir}/GConf/gsettings/opensubtitles.convert
219#%{_datadir}/GConf/gsettings/pythonconsole.convert
220%{_datadir}/GConf/gsettings/totem.convert
221%{_datadir}/applications/%{name}.desktop
222%{_datadir}/glib-2.0/schemas/*.xml
223%{_datadir}/icons/*/*/*/*
224%{_datadir}/thumbnailers/totem.thumbnailer
225%{_datadir}/%{name}
226%{_datadir}/gtk-doc/html/totem
227%{_libdir}/libtotem.so.*
228%{_libdir}/girepository-1.0/*.typelib
229%dir %{_libdir}/totem
230%dir %{_libdir}/totem/plugins
231%{_libdir}/totem/plugins/brasero-disc-recorder
232%{_libdir}/totem/plugins/chapters
233%{_libdir}/totem/plugins/dbus
234%{_libdir}/totem/plugins/gromit
235%{_libdir}/totem/plugins/iplayer
236%{_libdir}/totem/plugins/lirc
237%{_libdir}/totem/plugins/media-player-keys
238%{_libdir}/totem/plugins/ontop
239%{_libdir}/totem/plugins/opensubtitles
240%{_libdir}/totem/plugins/properties
241%{_libdir}/totem/plugins/pythonconsole
242%{_libdir}/totem/plugins/screensaver
243%{_libdir}/totem/plugins/screenshot
244%{_libdir}/totem/plugins/skipto
245%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
246%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
247%{_libdir}/totem/plugins/save-file/libsave-file.so
248%{_libdir}/totem/plugins/save-file/save-file.plugin
249%if %{build_plugin}
250%{_libdir}/nautilus/extensions-3.0/*.so*
251%endif
252%{_libexecdir}/%{name}/totem-bugreport.py
253%{_mandir}/man1/*
254
255%if %{build_plugin}
256%files mozilla
257%defattr(-,root,root,-)
258%{mozplug_dir}/*
259%{_libexecdir}/totem-plugin-viewer
260%endif
261
262%files devel
263%defattr(-, root, root,-)
264%{_includedir}/totem
265%{_libdir}/libtotem.so
266%{_libdir}/pkgconfig/totem.pc
267%{_datadir}/gir-1.0/Totem-1.0.gir
268%{_datadir}/gtk-doc/html/totem
269
270
271%changelog
272* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
273- add configure option (--disable-vegas-plugin)
274
275* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
276- new upstream release
277
278* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
279- new upstream release
280- add BuildRequires: pylint
281- remove BuildRequires: libgdata-devel
282
283* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
284- new upstream release
285
286* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
287- new upstream release
288
289* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
290- new upstream release
291- change BuildRequires: pygobject3-devel instead of pygobject-devel
292
293* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
294- new upstream release
295- change BuildRequires: gtk3-devel instead of gtk2-devel
296- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
297                     clutter-gst-devel, libmx-devel
298- change configure option (--disable-vala)
299
300* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
301- new upstream release
302- fix %files
303
304* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
305- new upstream release
306
307* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
308- clean up spec file
309- remove totem-common and merged to totem main package.
310  - add Obsoletes: totem-common
311- remove unneeded BR: and R:
312  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
313  - libmusicbrainz, alternatives
314- remove explicit dependency
315  - gtk2, glib2, dbus
316- add R: pygtk2, pyxdg, python-Coherence for python plugins
317- add R: gstreamer-plugins-good
318
319* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
320- rebuild with libgdata (add youtube plugin)
321- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
322- add Obsolete: totem-gstreamer, totem-xine)
323
324* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
325- new upstream release
326- chagnge _gst_ver from 0.10.19 to 0.10.29
327
328* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
329- new upstream release
330- drop totem-tracker package
331- add BuildRequires: unique-devel
332- remove BuildRequires: hal-devel
333- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
334
335* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
336- remove unneeded autoreconf
337- add BR: lirc
338
339* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
340- new upstream release
341
342* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
343- remove bemused plugin
344
345* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
346- new upstream release
347
348* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
349- added tracker video search sub-package
350
351* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
352- new upstream release
353
354* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
355- new upstream release
356
357* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
358- remove libxine dependency from totem-common
359- build xine backend with minimum dependency
360
361* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
362- add BR: bluez-libs-devel >= 4.15
363- fix typo in %%postun xine
364
365* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
366- rebuild with bluez-libs-devel-4.15
367
368* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
369- new upstream release
370
371* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
372- new upstream release
373
374* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
375- new upstream release
376- add patch1 to build with xulrunner-1.9
377
378* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
379- new upstream release
380
381* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
382- new upstream release
383- disabled devel package (replaced by totem-pl-parser-devel)
384
385* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
386- new upstream release
387- update version macros
388- enable browser plugins on x86_64
389
390* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
391- new upstream release
392
393* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
394- upstream release
395- drop obsolete ja.po.patch (patch0)
396- revert change of 1.4.4-0vl2
397
398* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
399- upstream release
400- enable browser plugins (exclude x86_64 arch)
401
402* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
403- upstream release
404
405* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
406- update configure options
407- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
408
409* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
410- fix mistranslation (patch0)
411- add icon symlink
412- add BuildRequires: gstreamer-plugins-good
413
414* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
415- upstream release
416- update %%_glib_ver, %%_xine_ver
417- add BuildRequires: hal
418- update %%configure options
419- update %%files
420
421* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
422- upstream release
423
424* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
425- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
426
427* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
428- upstream release
429- drop obsolete patch0
430
431* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
432- upstream release
433- add patch0 to build with intltool-0.35
434
435* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
436- upstream release
437
438* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
439- upstream release
440- update alternatives entry
441
442* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
443- upstream release
444- drop fix-sort-function.patch (was merged to upstream, #331426)
445
446* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
447- rebuild with gnome-2.14rc
448
449* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
450- upstream release
451- add macros
452  - _gtk_ver, _glib_ver
453  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
454  - _dbus_ver
455  - _gst_ver, gstpb_ver, _xine_ver
456- add fix-sort-function.patch to build with glib < 2.9.1
457
458* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
459- upstream release
460- add BuildRequires:
461  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
462  - gnome-vfs2-devel >= 2.9.92
463  - dbus-devel >= 0.35
464- use gstreamer-0.10 as backend for totem-gstreamer
465
466* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
467- use gstreamer08 instead of gstreamer
468
469* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
470- upstream release
471
472* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
473- fix missing links
474  - update file list
475  - update update-alternatives scripts
476- fix totem-gstreamer's %%postun script
477
478* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
479- upstream release
480- add BuildRequires: iso-codes, libmusicbrainz-devel
481- add Requires: iso-codes, libmusicbrains to -common package
482- remove BuildRequires: nautilus-cd-burner
483- remove Requires: nautilus-cd-burner from -common package
484
485* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
486- totem-gstreamer obsoletes nautilus-media
487
488* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
489- upstream release
490- add Requires(post,postun): alternatives for gstreamer,xine
491- add Requires(postun,triggers): alternatives for common
492
493* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
494- upstream release
495
496* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
497- build xine backend
498  - move common files to common package
499  - move GStreamer related files to gstreamer package
500  - install xine related files to xine package
501- fix scripts
502
503* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
504- upstream release
505- update URL
506- move *.{a,la} to devel package
507
508* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
509- fix %%{post,preun} script (video-thumbnail.schemas)
510- sync with Fedora Core's 1.0.1-1
511
512  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
513  - Update to upstream version 1.0.1
514  - Break out devel package
515
516* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
517- add %%{post,pre}un script
518
519* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
520- initial build for Vine Linux
521
522* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
523- fix %%post
524
525* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
526- Obsolete nautilus-media
527- Install property page and thumbnailer
528
529* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
530- Update to 0.101
531 
532* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
533- Grab patch totem-0.100-desktopfile.patch from CVS to fix
534  missing menu entry (144088)
535- Remove workaround for desktop file being misinstalled, fixed
536  by above patch
537
538* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
539- New upstream version 0.100
540
541* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
542- update to 0.99.22
543
544* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
545- Add patch to remove removed items from package from help
546
547* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
548- New upstream 0.99.19
549  - Fixes crasher with CD playback (see NEWS)
550
551* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
552- Call update-desktop-database in post
553
554* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
555- update to 0.99.18
556
557* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
558- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
559
Note: See TracBrowser for help on using the repository browser.