source: projects/specs/trunk/t/totem/totem-vl.spec @ 1260

Revision 1260, 16.3 KB checked in by Takemikaduchi, 14 years ago (diff)

update gnome (2.30.2)

Line 
1# build browser plugins
2%define build_plugin    %{!?_without_mozilla:1}%{?_without_mozilla:0}
3
4# define versions
5%define _glib_ver               2.24.0
6%define _gtk_ver                2.20.0
7%define _gnomeicon_ver          2.30.0
8%define _gnome_doc_utils_ver    0.20.0
9%define _dbus_ver               1.2.24
10%define _gst_ver                0.10.29
11%define _gstpb_ver              0.10.29
12%define _gstpg_ver              0.10.22
13%define _xulrunner_ver          1.9
14%define _nautilus_ver           2.26.0
15%define _shared_mime_info_ver   0.17
16%define _unique_ver             1.0
17%define _vala_ver               0.7.5
18%define _totem_pl_parser_ver    2.30.0
19%define _libgdata_ver           0.6.4
20
21%define nautilus_extdir %{_libdir}/nautilus/extensions-2.0
22%define mozplug_dir %{_libdir}/mozilla/plugins
23
24Summary:        Movie player for GNOME 2
25Summary(ja):    GNOME2 用動画プレイヤー
26Name:           totem
27Version:        2.30.2
28Release:        1%{?_dist_release}
29License:        GPL
30Group:          Applications/Multimedia
31URL:            http://www.gnome.org/projects/totem/
32Source0:        http://ftp.gnome.org/pub/GNOME/sources/totem/2.30/totem-%{version}.tar.bz2
33
34BuildRoot:      %{_tmppath}/%{name}-%{version}-root
35Vendor:         Project Vine
36Distribution:   Vine Linux
37
38BuildRequires:  gtk2-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
39BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
40BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
41BuildRequires:  dbus-devel >= %{_dbus_ver}
42BuildRequires:  nautilus-devel >= %{_nautilus_ver}
43BuildRequires:  gettext, scrollkeeper
44BuildRequires:  perl-XML-Parser
45BuildRequires:  iso-codes
46BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
47BuildRequires:  bluez-libs-devel >= 4.15
48BuildRequires:  lirc
49BuildRequires:  unique-devel >= %{_unique_ver}
50BuildRequires:  vala-devel >= %{_vala_ver}
51BuildRequires:  python-devel
52BuildRequires:  pygtk2-devel
53BuildRequires:  libgdata-devel >= %{_libgdata_ver}
54
55BuildRequires:  gstreamer-devel >= %{_gst_ver}
56BuildRequires:  gstreamer-plugins-base-devel >= %{_gstpb_ver}
57BuildRequires:  gstreamer-plugins-good >= %{_gstpg_ver}
58
59%if %{build_plugin}
60BuildRequires:  xulrunner-devel >= %{_xulrunner_ver}
61BuildRequires:  nautilus-devel >= %{_nautilus_ver}
62BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
63%endif
64
65Requires:       gstreamer >= %{_gst_ver}
66Requires:       gstreamer-plugins-base >= %{_gstpb_ver}
67Requires:       gstreamer-plugins-good >= %{_gstpg_ver}
68Requires:       iso-codes
69# for opensubtitles plugin
70Requires:       pyxdg
71# for python plugins
72Requires:       pygtk2
73# for coherence plugins
74Requires:       python-Coherence >= 0.6.6.2
75
76Obsoletes:      nautilus-media
77Obsoletes:      %{name}-gstreamer < 2.30.1-2
78Obsoletes:      %{name}-xine < 2.30.1-2
79Obsoletes:      %{name}-common < 2.30.1-3
80
81Provides:       nautilus-media
82Provides:       %{name}-common = %{version}-%{release}
83
84Requires(post):     ldconfig, scrollkeeper, desktop-file-utils, GConf2
85Requires(postun):   ldconfig, scrollkeeper, desktop-file-utils
86Requires(preun):    GConf2
87
88%description
89Totem is simple movie player for the Gnome desktop. It features a
90simple playlist, a full-screen mode, seek and volume controls, as well as
91a pretty complete keyboard navigation.
92
93%if %{build_plugin}
94%package mozilla
95Summary:        Totem movie plugin for Mozilla
96Summary(ja):    Mozilla 用 Totem 動画プラグイン
97Group:          Applications/Internet
98Requires:       %{name} = %{version}-%{release}
99Obsoletes:      %{name}-mozilla-common
100Obsoletes:      %{name}-mozilla-gstreamer
101Obsoletes:      %{name}-mozilla-xine
102
103%description mozilla
104Totem is simple movie player for the Gnome desktop. It features a
105simple playlist, a full-screen mode, seek and volume controls, as well as
106a pretty complete keyboard navigation.
107
108This package contains a Totem video plugin for Mozilla. It allows Totem
109movie player to be embedded into a web browser.
110
111%endif
112
113%prep
114%setup -q
115
116%build
117DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-0.10 --print-all > /dev/null
118export MOZILLA_PLUGINDIR=%{mozplug_dir}
119%configure \
120        --disable-schemas-install \
121        --disable-scrollkeeper \
122        --enable-python \
123        --enable-nautilus \
124        --enable-gmp-plugin \
125        --enable-narrowspace-plugin \
126        --enable-mully-plugin \
127%if %{build_plugin}
128        --enable-browser-plugins
129%else
130        --disable-browser-plugins
131%endif
132
133make %{?_smp_mflags}
134
135%install
136rm -rf $RPM_BUILD_ROOT
137export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
138
139make install DESTDIR=$RPM_BUILD_ROOT
140
141# remove unneeded files
142%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
143%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
144%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
145%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
146%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
147%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
148 
149%find_lang %{name} --with-gnome
150
151# save space by linking identical images in translated docs
152helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
153for f in $helpdir/C/figures/*.png; do
154  b="$(basename $f)"
155  for d in $helpdir/*; do
156    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
157      g="$d/figures/$b"
158      if [ -f "$g" ]; then
159        if cmp -s $f $g; then
160          rm "$g"; ln -s "../../C/figures/$b" "$g"
161        fi
162      fi
163    fi
164  done
165done
166
167
168%clean
169%__rm -rf %{buildroot}
170
171%post
172%{_bindir}/scrollkeeper-update -q
173%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
174export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
175gconftool-2 --makefile-install-rule \
176        %{_sysconfdir}/gconf/schemas/totem.schemas \
177        %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
178        %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
179    >& /dev/null || :
180touch %{_datadir}/icons/hicolor
181if [ -x /usr/bin/gtk-update-icon-cache ]; then
182  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
183fi
184
185%pre
186if [ "$1" -gt 1 ]; then
187    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
188    gconftool-2 --makefile-uninstall-rule \
189        %{_sysconfdir}/gconf/schemas/totem.schemas \
190        %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
191        %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
192        >& /dev/null || :
193fi
194
195%preun
196if [ "$1" -eq 0 ]; then
197    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
198    gconftool-2 --makefile-uninstall-rule \
199        %{_sysconfdir}/gconf/schemas/totem.schemas \
200        %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
201        %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
202 >& /dev/null || :
203fi
204
205%postun
206%{_bindir}/scrollkeeper-update -q
207%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
208touch %{_datadir}/icons/hicolor
209if [ -x /usr/bin/gtk-update-icon-cache ]; then
210  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
211fi
212
213%files -f %{name}.lang
214%defattr(-,root,root,-)
215%doc AUTHORS COPYING ChangeLog NEWS README TODO
216%config %{_sysconfdir}/gconf/schemas/*.schemas
217%{_bindir}/totem
218%{_bindir}/totem-audio-preview
219%{_bindir}/totem-video-indexer
220%{_bindir}/totem-video-thumbnailer
221%{_datadir}/applications/%{name}.desktop
222%{_datadir}/icons/*/*/apps/*
223%{_datadir}/icons/*/*/devices/*
224%{_datadir}/%{name}
225%{_datadir}/gtk-doc/html/totem
226%dir %{_libdir}/totem
227%dir %{_libdir}/totem/plugins
228%{_libdir}/totem/plugins/brasero-disc-recorder
229%{_libdir}/totem/plugins/coherence_upnp
230%{_libdir}/totem/plugins/dbus
231%{_libdir}/totem/plugins/gromit
232%{_libdir}/totem/plugins/iplayer
233%{_libdir}/totem/plugins/jamendo
234%{_libdir}/totem/plugins/lirc
235%{_libdir}/totem/plugins/media-player-keys
236%{_libdir}/totem/plugins/ontop
237%{_libdir}/totem/plugins/opensubtitles
238%{_libdir}/totem/plugins/properties
239%{_libdir}/totem/plugins/pythonconsole
240%{_libdir}/totem/plugins/sample-vala
241%{_libdir}/totem/plugins/screensaver
242%{_libdir}/totem/plugins/screenshot
243%{_libdir}/totem/plugins/skipto
244%{_libdir}/totem/plugins/thumbnail
245%{_libdir}/totem/plugins/youtube
246%{_libdir}/totem/plugins/totem
247%if %{build_plugin}
248%{_libdir}/nautilus/extensions-2.0/*.so*
249%endif
250%{_libexecdir}/%{name}/totem-bugreport.py
251%{_mandir}/man1/*
252
253%if %{build_plugin}
254%files mozilla
255%defattr(-,root,root,-)
256%{mozplug_dir}/*
257%{_libexecdir}/totem-plugin-viewer
258%endif
259
260%changelog
261* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
262- new upstream release
263
264* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
265- clean up spec file
266- remove totem-common and merged to totem main package.
267  - add Obsoletes: totem-common
268- remove unneeded BR: and R:
269  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
270  - libmusicbrainz, alternatives
271- remove explicit dependency
272  - gtk2, glib2, dbus
273- add R: pygtk2, pyxdg, python-Coherence for python plugins
274- add R: gstreamer-plugins-good
275
276* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
277- rebuild with libgdata (add youtube plugin)
278- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
279- add Obsolete: totem-gstreamer, totem-xine)
280
281* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
282- new upstream release
283- chagnge _gst_ver from 0.10.19 to 0.10.29
284
285* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
286- new upstream release
287- drop totem-tracker package
288- add BuildRequires: unique-devel
289- remove BuildRequires: hal-devel
290- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
291
292* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
293- remove unneeded autoreconf
294- add BR: lirc
295
296* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
297- new upstream release
298
299* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
300- remove bemused plugin
301
302* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
303- new upstream release
304
305* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
306- added tracker video search sub-package
307
308* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
309- new upstream release
310
311* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
312- new upstream release
313
314* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
315- remove libxine dependency from totem-common
316- build xine backend with minimum dependency
317
318* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
319- add BR: bluez-libs-devel >= 4.15
320- fix typo in %%postun xine
321
322* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
323- rebuild with bluez-libs-devel-4.15
324
325* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
326- new upstream release
327
328* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
329- new upstream release
330
331* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
332- new upstream release
333- add patch1 to build with xulrunner-1.9
334
335* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
336- new upstream release
337
338* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
339- new upstream release
340- disabled devel package (replaced by totem-pl-parser-devel)
341
342* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
343- new upstream release
344- update version macros
345- enable browser plugins on x86_64
346
347* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
348- new upstream release
349
350* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
351- upstream release
352- drop obsolete ja.po.patch (patch0)
353- revert change of 1.4.4-0vl2
354
355* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
356- upstream release
357- enable browser plugins (exclude x86_64 arch)
358
359* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
360- upstream release
361
362* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
363- update configure options
364- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
365
366* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
367- fix mistranslation (patch0)
368- add icon symlink
369- add BuildRequires: gstreamer-plugins-good
370
371* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
372- upstream release
373- update %%_glib_ver, %%_xine_ver
374- add BuildRequires: hal
375- update %%configure options
376- update %%files
377
378* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
379- upstream release
380
381* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
382- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
383
384* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
385- upstream release
386- drop obsolete patch0
387
388* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
389- upstream release
390- add patch0 to build with intltool-0.35
391
392* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
393- upstream release
394
395* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
396- upstream release
397- update alternatives entry
398
399* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
400- upstream release
401- drop fix-sort-function.patch (was merged to upstream, #331426)
402
403* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
404- rebuild with gnome-2.14rc
405
406* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
407- upstream release
408- add macros
409  - _gtk_ver, _glib_ver
410  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
411  - _dbus_ver
412  - _gst_ver, gstpb_ver, _xine_ver
413- add fix-sort-function.patch to build with glib < 2.9.1
414
415* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
416- upstream release
417- add BuildRequires:
418  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
419  - gnome-vfs2-devel >= 2.9.92
420  - dbus-devel >= 0.35
421- use gstreamer-0.10 as backend for totem-gstreamer
422
423* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
424- use gstreamer08 instead of gstreamer
425
426* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
427- upstream release
428
429* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
430- fix missing links
431  - update file list
432  - update update-alternatives scripts
433- fix totem-gstreamer's %%postun script
434
435* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
436- upstream release
437- add BuildRequires: iso-codes, libmusicbrainz-devel
438- add Requires: iso-codes, libmusicbrains to -common package
439- remove BuildRequires: nautilus-cd-burner
440- remove Requires: nautilus-cd-burner from -common package
441
442* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
443- totem-gstreamer obsoletes nautilus-media
444
445* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
446- upstream release
447- add Requires(post,postun): alternatives for gstreamer,xine
448- add Requires(postun,triggers): alternatives for common
449
450* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
451- upstream release
452
453* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
454- build xine backend
455  - move common files to common package
456  - move GStreamer related files to gstreamer package
457  - install xine related files to xine package
458- fix scripts
459
460* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
461- upstream release
462- update URL
463- move *.{a,la} to devel package
464
465* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
466- fix %%{post,preun} script (video-thumbnail.schemas)
467- sync with Fedora Core's 1.0.1-1
468
469  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
470  - Update to upstream version 1.0.1
471  - Break out devel package
472
473* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
474- add %%{post,pre}un script
475
476* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
477- initial build for Vine Linux
478
479* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
480- fix %%post
481
482* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
483- Obsolete nautilus-media
484- Install property page and thumbnailer
485
486* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
487- Update to 0.101
488 
489* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
490- Grab patch totem-0.100-desktopfile.patch from CVS to fix
491  missing menu entry (144088)
492- Remove workaround for desktop file being misinstalled, fixed
493  by above patch
494
495* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
496- New upstream version 0.100
497
498* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
499- update to 0.99.22
500
501* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
502- Add patch to remove removed items from package from help
503
504* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
505- New upstream 0.99.19
506  - Fixes crasher with CD playback (see NEWS)
507
508* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
509- Call update-desktop-database in post
510
511* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
512- update to 0.99.18
513
514* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
515- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
516
Note: See TracBrowser for help on using the repository browser.