source: projects/specs/trunk/t/totem/totem-vl.spec @ 12005

Revision 12005, 19.2 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1# define versions
2%define _glib_ver               2.48.0
3%define _gtk_ver                3.20.0
4%define _gnomeicon_ver          3.12.0
5%define _gnome_doc_utils_ver    0.20.0
6%define _dbus_ver               1.6.0
7%define _gst_ver                1.2.0
8%define _gstpb_ver              1.2.0
9%define _gstpg_ver              1.2.0
10%define _gstpbad_ver            1.2.0
11%define _xulrunner_ver          1.9
12%define _nautilus_ver           3.20.0
13%define _shared_mime_info_ver   0.17
14%define _unique_ver             1.0
15%define _totem_pl_parser_ver    3.4.4
16
17%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
18%define _unpackaged_files_terminate_build 1
19
20
21Summary:        Movie player for GNOME 3
22Summary(ja):    GNOME3 用動画プレイヤー
23Name:           totem
24Version:        3.30.0
25Release:        1%{?_dist_release}
26License:        GPL
27Group:          Applications/Multimedia
28URL:            http://www.gnome.org/projects/totem/
29Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.20/%{name}-%{version}.tar.xz
30
31# from upstream
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34
35Vendor:         Project Vine
36Distribution:   Vine Linux
37
38BuildRequires:  meson
39BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
40BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
41BuildRequires:  dbus-devel >= %{_dbus_ver}
42BuildRequires:  nautilus-devel >= %{_nautilus_ver}
43BuildRequires:  gnome-desktop3-devel
44BuildRequires:  gettext
45BuildRequires:  perl-XML-Parser
46BuildRequires:  iso-codes
47BuildRequires:  yelp-tools
48BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
49BuildRequires:  grilo-devel
50BuildRequires:  bluez-libs-devel >= 4.15
51BuildRequires:  lirc-devel
52BuildRequires:  unique-devel >= %{_unique_ver}
53BuildRequires:  python3-devel
54BuildRequires:  pylint
55BuildRequires:  python3-pygobject
56BuildRequires:  pygobject3-devel
57BuildRequires:  libpeas-devel
58BuildRequires:  libXtst-devel
59BuildRequires:  gsettings-desktop-schemas-devel
60BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
61BuildRequires:  vala
62BuildRequires:  libappstream-glib-devel
63
64BuildRequires:  gstreamer1-devel >= %{_gst_ver}
65BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
66BuildRequires:  gstreamer1-plugins-good >= %{_gstpg_ver}
67
68BuildRequires:  clutter-gtk-devel
69BuildRequires:  clutter-gst3-devel
70
71BuildRequires:  nautilus-devel >= %{_nautilus_ver}
72BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
73
74
75Requires:       gstreamer1 >= %{_gst_ver}
76Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
77Requires:       gstreamer1-plugins-good >= %{_gstpg_ver}
78Requires:       iso-codes
79Requires:       grilo-plugins
80
81Obsoletes:      nautilus-media
82Obsoletes:      %{name}-gstreamer < 2.30.1-2
83Obsoletes:      %{name}-xine < 2.30.1-2
84Obsoletes:      %{name}-common < 2.30.1-3
85Obsoletes:      %{name}-mozilla < 3.14.0
86
87Provides:       nautilus-media
88Provides:       %{name}-common = %{version}-%{release}
89
90Requires(post):     ldconfig, desktop-file-utils
91Requires(postun):   ldconfig, desktop-file-utils
92
93%description
94Totem is simple movie player for the Gnome desktop. It features a
95simple playlist, a full-screen mode, seek and volume controls, as well as
96a pretty complete keyboard navigation.
97
98%package devel
99Summary:        Plugin writer's documentation for totem
100Group:          Development/Libraries
101Requires:       %{name} = %{version}-%{release}
102
103%description devel
104The %{name}-devel package contains API documentation for
105developing developing plugins for %{name}.
106
107%prep
108%setup -q
109
110%build
111export LANG=ja_JP.UTF-8
112
113%meson \
114  -Denable-python=yes \
115  -Denable-vala=yes \
116  -Denable-nautilus=yes \
117  -Denable-introspection=yes \
118  -Dwith-plugins=auto
119
120%meson_build
121
122%install
123rm -rf $RPM_BUILD_ROOT
124export LANG=ja_JP.UTF-8
125
126%meson_install
127
128# remove unneeded files
129%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
130%__rm -f %{buildroot}%{_libdir}/*.{a,la}
131%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
132%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
133%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
134%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
135%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
136
137# remove unused file
138%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
139%__rm -f %{buildroot}%{_libexecdir}/%{name}/totem-bugreport.py
140 
141%find_lang %{name} --with-gnome
142
143# save space by linking identical images in translated docs
144helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
145for f in $helpdir/C/figures/*.png; do
146  b="$(basename $f)"
147  for d in $helpdir/*; do
148    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
149      g="$d/figures/$b"
150      if [ -f "$g" ]; then
151        if cmp -s $f $g; then
152          rm "$g"; ln -s "../../C/figures/$b" "$g"
153        fi
154      fi
155    fi
156  done
157done
158
159
160%clean
161%__rm -rf %{buildroot}
162
163%post
164%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
165touch %{_datadir}/icons/hicolor
166if [ -x /usr/bin/gtk-update-icon-cache ]; then
167  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
168fi
169
170%postun
171%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
172touch %{_datadir}/icons/hicolor
173if [ -x /usr/bin/gtk-update-icon-cache ]; then
174  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
175fi
176glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
177
178%posttrans
179glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
180
181%files -f %{name}.lang
182%defattr(-,root,root,-)
183%license COPYING
184%doc AUTHORS NEWS README TODO
185%{_bindir}/totem
186%{_bindir}/totem-video-thumbnailer
187%{_datadir}/GConf/gsettings/opensubtitles.convert
188#%{_datadir}/GConf/gsettings/pythonconsole.convert
189%{_datadir}/GConf/gsettings/totem.convert
190%{_datadir}/metainfo/org.gnome.Totem.appdata.xml
191%{_datadir}/applications/org.gnome.Totem.desktop
192%{_datadir}/dbus-1/services/org.gnome.Totem.service
193%{_datadir}/glib-2.0/schemas/*.xml
194%{_datadir}/icons/*/*/*/*
195%{_datadir}/thumbnailers/totem.thumbnailer
196%{_datadir}/%{name}
197#%{_datadir}/gtk-doc/html/totem
198%{_libdir}/libtotem.so.*
199%{_libdir}/girepository-1.0/*.typelib
200%dir %{_libdir}/totem
201%dir %{_libdir}/totem/plugins
202%{_libdir}/totem/plugins/apple-trailers/
203%{_libdir}/totem/plugins/autoload-subtitles
204%{_libdir}/totem/plugins/brasero-disc-recorder
205%{_libdir}/totem/plugins/dbus
206%{_libdir}/totem/plugins/gromit
207%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
208%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
209#%{_libdir}/totem/plugins/lirc
210%{_libdir}/totem/plugins/media-player-keys
211%{_libdir}/totem/plugins/ontop
212%{_libdir}/totem/plugins/opensubtitles
213%{_libdir}/totem/plugins/properties
214%{_libdir}/totem/plugins/pythonconsole
215%{_libdir}/totem/plugins/recent
216%{_libdir}/totem/plugins/rotation
217%{_libdir}/totem/plugins/screensaver
218%{_libdir}/totem/plugins/screenshot
219%{_libdir}/totem/plugins/skipto
220%{_libdir}/totem/plugins/save-file/libsave-file.so
221%{_libdir}/totem/plugins/save-file/save-file.plugin
222%{_libdir}/totem/plugins/variable-rate
223%{_libdir}/totem/plugins/vimeo
224%{_libdir}/nautilus/extensions-3.0/*.so*
225%{_libexecdir}/totem-gallery-thumbnailer
226%{_mandir}/man1/*
227
228%files devel
229%defattr(-, root, root,-)
230%{_includedir}/totem
231%{_libdir}/libtotem.so
232%{_libdir}/pkgconfig/totem.pc
233%{_datadir}/gir-1.0/Totem-1.0.gir
234#%{_datadir}/gtk-doc/html/totem
235
236
237%changelog
238* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.0-1
239- new upstream release.
240- dropped Patch0: fixed in upstream.
241- drop lirc plugin: meson cannot detect lirc.
242
243* Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.1-1
244- new upstream release
245- add BuildRequires: lirc-devel
246- add Patch0 (totem-3.20.1-gint64-format.patch)
247
248* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
249- new upstream release
250
251* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
252- new upstream release
253
254* Wed Jul 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
255- add Requires: grilo-plugins
256
257* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
258- remove BuildRequires: gstreamer1-plugins-bad-free-devel
259
260* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
261- new upstream release
262
263* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
264- new upstream release
265
266* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
267- new upstream release
268- change BuildRequires: clutter-gst3-devel instead of clutter-gst-devel
269
270* Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
271- new upstream release
272
273* Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
274- new upstream release
275
276* Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
277- new upstream release
278- add BuildRequires: gnome-desktop3-devel
279- remove BuildRequires: xulrunner-devel
280- remove %%{name}-mozilla subpackage
281
282* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
283- new upstream release
284
285* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
286- new upstream release
287
288* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
289- new upstream release
290
291* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
292- rebuild with VineSeed environment
293
294* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
295- new upstream release
296
297* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
298- new upstream release
299
300* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
301- new upstream release
302- add BuildRequires: yelp-tools, vala
303- change configure option (--enable-vala)
304
305* Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
306- new upstream release
307
308* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
309- new upstream release
310- change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
311
312* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
313- new upstream release
314- add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
315
316* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
317- new upstream release
318
319* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
320- add configure option (--disable-vegas-plugin)
321
322* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
323- new upstream release
324
325* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
326- new upstream release
327- add BuildRequires: pylint
328- remove BuildRequires: libgdata-devel
329
330* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
331- new upstream release
332
333* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
334- new upstream release
335
336* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
337- new upstream release
338- change BuildRequires: pygobject3-devel instead of pygobject-devel
339
340* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
341- new upstream release
342- change BuildRequires: gtk3-devel instead of gtk2-devel
343- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
344                     clutter-gst-devel, libmx-devel
345- change configure option (--disable-vala)
346
347* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
348- new upstream release
349- fix %files
350
351* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
352- new upstream release
353
354* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
355- clean up spec file
356- remove totem-common and merged to totem main package.
357  - add Obsoletes: totem-common
358- remove unneeded BR: and R:
359  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
360  - libmusicbrainz, alternatives
361- remove explicit dependency
362  - gtk2, glib2, dbus
363- add R: pygtk2, pyxdg, python-Coherence for python plugins
364- add R: gstreamer-plugins-good
365
366* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
367- rebuild with libgdata (add youtube plugin)
368- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
369- add Obsolete: totem-gstreamer, totem-xine)
370
371* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
372- new upstream release
373- chagnge _gst_ver from 0.10.19 to 0.10.29
374
375* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
376- new upstream release
377- drop totem-tracker package
378- add BuildRequires: unique-devel
379- remove BuildRequires: hal-devel
380- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
381
382* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
383- remove unneeded autoreconf
384- add BR: lirc
385
386* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
387- new upstream release
388
389* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
390- remove bemused plugin
391
392* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
393- new upstream release
394
395* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
396- added tracker video search sub-package
397
398* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
399- new upstream release
400
401* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
402- new upstream release
403
404* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
405- remove libxine dependency from totem-common
406- build xine backend with minimum dependency
407
408* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
409- add BR: bluez-libs-devel >= 4.15
410- fix typo in %%postun xine
411
412* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
413- rebuild with bluez-libs-devel-4.15
414
415* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
416- new upstream release
417
418* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
419- new upstream release
420
421* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
422- new upstream release
423- add patch1 to build with xulrunner-1.9
424
425* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
426- new upstream release
427
428* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
429- new upstream release
430- disabled devel package (replaced by totem-pl-parser-devel)
431
432* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
433- new upstream release
434- update version macros
435- enable browser plugins on x86_64
436
437* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
438- new upstream release
439
440* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
441- upstream release
442- drop obsolete ja.po.patch (patch0)
443- revert change of 1.4.4-0vl2
444
445* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
446- upstream release
447- enable browser plugins (exclude x86_64 arch)
448
449* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
450- upstream release
451
452* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
453- update configure options
454- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
455
456* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
457- fix mistranslation (patch0)
458- add icon symlink
459- add BuildRequires: gstreamer-plugins-good
460
461* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
462- upstream release
463- update %%_glib_ver, %%_xine_ver
464- add BuildRequires: hal
465- update %%configure options
466- update %%files
467
468* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
469- upstream release
470
471* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
472- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
473
474* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
475- upstream release
476- drop obsolete patch0
477
478* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
479- upstream release
480- add patch0 to build with intltool-0.35
481
482* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
483- upstream release
484
485* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
486- upstream release
487- update alternatives entry
488
489* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
490- upstream release
491- drop fix-sort-function.patch (was merged to upstream, #331426)
492
493* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
494- rebuild with gnome-2.14rc
495
496* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
497- upstream release
498- add macros
499  - _gtk_ver, _glib_ver
500  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
501  - _dbus_ver
502  - _gst_ver, gstpb_ver, _xine_ver
503- add fix-sort-function.patch to build with glib < 2.9.1
504
505* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
506- upstream release
507- add BuildRequires:
508  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
509  - gnome-vfs2-devel >= 2.9.92
510  - dbus-devel >= 0.35
511- use gstreamer-0.10 as backend for totem-gstreamer
512
513* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
514- use gstreamer08 instead of gstreamer
515
516* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
517- upstream release
518
519* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
520- fix missing links
521  - update file list
522  - update update-alternatives scripts
523- fix totem-gstreamer's %%postun script
524
525* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
526- upstream release
527- add BuildRequires: iso-codes, libmusicbrainz-devel
528- add Requires: iso-codes, libmusicbrains to -common package
529- remove BuildRequires: nautilus-cd-burner
530- remove Requires: nautilus-cd-burner from -common package
531
532* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
533- totem-gstreamer obsoletes nautilus-media
534
535* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
536- upstream release
537- add Requires(post,postun): alternatives for gstreamer,xine
538- add Requires(postun,triggers): alternatives for common
539
540* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
541- upstream release
542
543* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
544- build xine backend
545  - move common files to common package
546  - move GStreamer related files to gstreamer package
547  - install xine related files to xine package
548- fix scripts
549
550* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
551- upstream release
552- update URL
553- move *.{a,la} to devel package
554
555* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
556- fix %%{post,preun} script (video-thumbnail.schemas)
557- sync with Fedora Core's 1.0.1-1
558
559  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
560  - Update to upstream version 1.0.1
561  - Break out devel package
562
563* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
564- add %%{post,pre}un script
565
566* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
567- initial build for Vine Linux
568
569* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
570- fix %%post
571
572* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
573- Obsolete nautilus-media
574- Install property page and thumbnailer
575
576* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
577- Update to 0.101
578 
579* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
580- Grab patch totem-0.100-desktopfile.patch from CVS to fix
581  missing menu entry (144088)
582- Remove workaround for desktop file being misinstalled, fixed
583  by above patch
584
585* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
586- New upstream version 0.100
587
588* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
589- update to 0.99.22
590
591* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
592- Add patch to remove removed items from package from help
593
594* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
595- New upstream 0.99.19
596  - Fixes crasher with CD playback (see NEWS)
597
598* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
599- Call update-desktop-database in post
600
601* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
602- update to 0.99.18
603
604* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
605- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
606
Note: See TracBrowser for help on using the repository browser.