source: projects/specs/trunk/t/totem/totem-vl.spec @ 9791

Revision 9791, 18.7 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1# define versions
2%define _glib_ver               2.46.0
3%define _gtk_ver                3.18.0
4%define _gnomeicon_ver          3.12.0
5%define _gnome_doc_utils_ver    0.20.0
6%define _dbus_ver               1.6.0
7%define _gst_ver                1.2.0
8%define _gstpb_ver              1.2.0
9%define _gstpg_ver              1.2.0
10%define _gstpbad_ver            1.2.0
11%define _xulrunner_ver          1.9
12%define _nautilus_ver           3.18.0
13%define _shared_mime_info_ver   0.17
14%define _unique_ver             1.0
15%define _totem_pl_parser_ver    3.4.4
16
17%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
18
19Summary:        Movie player for GNOME 3
20Summary(ja):    GNOME3 用動画プレイヤー
21Name:           totem
22Version:        3.18.1
23Release:        1%{?_dist_release}
24License:        GPL
25Group:          Applications/Multimedia
26URL:            http://www.gnome.org/projects/totem/
27Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.18/%{name}-%{version}.tar.xz
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33Packager:       Takemikaduchi
34
35BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
36BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
37BuildRequires:  dbus-devel >= %{_dbus_ver}
38BuildRequires:  nautilus-devel >= %{_nautilus_ver}
39BuildRequires:  gnome-desktop3-devel
40BuildRequires:  gettext
41BuildRequires:  perl-XML-Parser
42BuildRequires:  iso-codes
43BuildRequires:  yelp-tools
44BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
45BuildRequires:  grilo-devel
46BuildRequires:  bluez-libs-devel >= 4.15
47BuildRequires:  lirc
48BuildRequires:  unique-devel >= %{_unique_ver}
49BuildRequires:  python-devel
50BuildRequires:  pylint
51BuildRequires:  pygobject3-devel
52BuildRequires:  libpeas-devel
53BuildRequires:  libXtst-devel
54BuildRequires:  gsettings-desktop-schemas-devel
55BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
56BuildRequires:  vala
57
58BuildRequires:  gstreamer1-devel >= %{_gst_ver}
59BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
60BuildRequires:  gstreamer1-plugins-good >= %{_gstpg_ver}
61
62BuildRequires:  clutter-gtk-devel
63BuildRequires:  clutter-gst3-devel
64
65BuildRequires:  nautilus-devel >= %{_nautilus_ver}
66BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
67
68
69Requires:       gstreamer1 >= %{_gst_ver}
70Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
71Requires:       gstreamer1-plugins-good >= %{_gstpg_ver}
72Requires:       iso-codes
73Requires:       grilo-plugins
74
75Obsoletes:      nautilus-media
76Obsoletes:      %{name}-gstreamer < 2.30.1-2
77Obsoletes:      %{name}-xine < 2.30.1-2
78Obsoletes:      %{name}-common < 2.30.1-3
79Obsoletes:      %{name}-mozilla < 3.14.0
80
81Provides:       nautilus-media
82Provides:       %{name}-common = %{version}-%{release}
83
84Requires(post):     ldconfig, desktop-file-utils
85Requires(postun):   ldconfig, desktop-file-utils
86
87%description
88Totem is simple movie player for the Gnome desktop. It features a
89simple playlist, a full-screen mode, seek and volume controls, as well as
90a pretty complete keyboard navigation.
91
92%package devel
93Summary:        Plugin writer's documentation for totem
94Group:          Development/Libraries
95Requires:       %{name} = %{version}-%{release}
96
97%description devel
98The %{name}-devel package contains API documentation for
99developing developing plugins for %{name}.
100
101%prep
102%setup -q
103
104%build
105#DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
106#export MOZILLA_PLUGINDIR=%{mozplug_dir}
107%configure \
108        --enable-python \
109        --enable-vala \
110        --enable-nautilus
111
112make %{?_smp_mflags}
113
114%install
115rm -rf $RPM_BUILD_ROOT
116
117make install DESTDIR=$RPM_BUILD_ROOT
118
119# remove unneeded files
120%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
121%__rm -f %{buildroot}%{_libdir}/*.{a,la}
122%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
123%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
124%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
125%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
126%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
127
128# remove unused file
129%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
130%__rm -f %{buildroot}%{_libexecdir}/%{name}/totem-bugreport.py
131 
132%find_lang %{name} --with-gnome
133
134# save space by linking identical images in translated docs
135helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
136for f in $helpdir/C/figures/*.png; do
137  b="$(basename $f)"
138  for d in $helpdir/*; do
139    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
140      g="$d/figures/$b"
141      if [ -f "$g" ]; then
142        if cmp -s $f $g; then
143          rm "$g"; ln -s "../../C/figures/$b" "$g"
144        fi
145      fi
146    fi
147  done
148done
149
150
151%clean
152%__rm -rf %{buildroot}
153
154%post
155%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
156touch %{_datadir}/icons/hicolor
157if [ -x /usr/bin/gtk-update-icon-cache ]; then
158  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
159fi
160
161%postun
162%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
163touch %{_datadir}/icons/hicolor
164if [ -x /usr/bin/gtk-update-icon-cache ]; then
165  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
166fi
167glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
168
169%posttrans
170glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
171
172%files -f %{name}.lang
173%defattr(-,root,root,-)
174%doc AUTHORS COPYING ChangeLog NEWS README TODO
175%{_bindir}/totem
176%{_bindir}/totem-audio-preview
177%{_bindir}/totem-video-thumbnailer
178%{_datadir}/GConf/gsettings/opensubtitles.convert
179#%{_datadir}/GConf/gsettings/pythonconsole.convert
180%{_datadir}/GConf/gsettings/totem.convert
181%{_datadir}/appdata/org.gnome.Totem.appdata.xml
182%{_datadir}/applications/org.gnome.Totem.desktop
183%{_datadir}/dbus-1/services/org.gnome.Totem.service
184%{_datadir}/glib-2.0/schemas/*.xml
185%{_datadir}/icons/*/*/*/*
186%{_datadir}/thumbnailers/totem.thumbnailer
187%{_datadir}/%{name}
188%{_datadir}/gtk-doc/html/totem
189%{_libdir}/libtotem.so.*
190%{_libdir}/girepository-1.0/*.typelib
191%dir %{_libdir}/totem
192%dir %{_libdir}/totem/plugins
193%{_libdir}/totem/plugins/apple-trailers/
194%{_libdir}/totem/plugins/autoload-subtitles
195%{_libdir}/totem/plugins/brasero-disc-recorder
196%{_libdir}/totem/plugins/dbus
197%{_libdir}/totem/plugins/gromit
198%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
199%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
200%{_libdir}/totem/plugins/lirc
201%{_libdir}/totem/plugins/media-player-keys
202%{_libdir}/totem/plugins/ontop
203%{_libdir}/totem/plugins/opensubtitles
204%{_libdir}/totem/plugins/properties
205%{_libdir}/totem/plugins/pythonconsole
206%{_libdir}/totem/plugins/recent
207%{_libdir}/totem/plugins/rotation
208%{_libdir}/totem/plugins/screensaver
209%{_libdir}/totem/plugins/screenshot
210%{_libdir}/totem/plugins/skipto
211%{_libdir}/totem/plugins/save-file/libsave-file.so
212%{_libdir}/totem/plugins/save-file/save-file.plugin
213%{_libdir}/totem/plugins/vimeo
214%{_libdir}/nautilus/extensions-3.0/*.so*
215%{_mandir}/man1/*
216
217%files devel
218%defattr(-, root, root,-)
219%{_includedir}/totem
220%{_libdir}/libtotem.so
221%{_libdir}/pkgconfig/totem.pc
222%{_datadir}/gir-1.0/Totem-1.0.gir
223%{_datadir}/gtk-doc/html/totem
224
225
226%changelog
227* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
228- new upstream release
229
230* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
231- new upstream release
232
233* Wed Jul 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
234- add Requires: grilo-plugins
235
236* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
237- remove BuildRequires: gstreamer1-plugins-bad-free-devel
238
239* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
240- new upstream release
241
242* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
243- new upstream release
244
245* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
246- new upstream release
247- change BuildRequires: clutter-gst3-devel instead of clutter-gst-devel
248
249* Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
250- new upstream release
251
252* Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
253- new upstream release
254
255* Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
256- new upstream release
257- add BuildRequires: gnome-desktop3-devel
258- remove BuildRequires: xulrunner-devel
259- remove %%{name}-mozilla subpackage
260
261* Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
262- new upstream release
263
264* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
265- new upstream release
266
267* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
268- new upstream release
269
270* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
271- rebuild with VineSeed environment
272
273* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
274- new upstream release
275
276* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
277- new upstream release
278
279* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
280- new upstream release
281- add BuildRequires: yelp-tools, vala
282- change configure option (--enable-vala)
283
284* Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
285- new upstream release
286
287* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
288- new upstream release
289- change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
290
291* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
292- new upstream release
293- add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
294
295* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
296- new upstream release
297
298* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
299- add configure option (--disable-vegas-plugin)
300
301* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
302- new upstream release
303
304* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
305- new upstream release
306- add BuildRequires: pylint
307- remove BuildRequires: libgdata-devel
308
309* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
310- new upstream release
311
312* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
313- new upstream release
314
315* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
316- new upstream release
317- change BuildRequires: pygobject3-devel instead of pygobject-devel
318
319* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
320- new upstream release
321- change BuildRequires: gtk3-devel instead of gtk2-devel
322- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
323                     clutter-gst-devel, libmx-devel
324- change configure option (--disable-vala)
325
326* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
327- new upstream release
328- fix %files
329
330* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
331- new upstream release
332
333* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
334- clean up spec file
335- remove totem-common and merged to totem main package.
336  - add Obsoletes: totem-common
337- remove unneeded BR: and R:
338  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
339  - libmusicbrainz, alternatives
340- remove explicit dependency
341  - gtk2, glib2, dbus
342- add R: pygtk2, pyxdg, python-Coherence for python plugins
343- add R: gstreamer-plugins-good
344
345* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
346- rebuild with libgdata (add youtube plugin)
347- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
348- add Obsolete: totem-gstreamer, totem-xine)
349
350* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
351- new upstream release
352- chagnge _gst_ver from 0.10.19 to 0.10.29
353
354* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
355- new upstream release
356- drop totem-tracker package
357- add BuildRequires: unique-devel
358- remove BuildRequires: hal-devel
359- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
360
361* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
362- remove unneeded autoreconf
363- add BR: lirc
364
365* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
366- new upstream release
367
368* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
369- remove bemused plugin
370
371* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
372- new upstream release
373
374* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
375- added tracker video search sub-package
376
377* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
378- new upstream release
379
380* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
381- new upstream release
382
383* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
384- remove libxine dependency from totem-common
385- build xine backend with minimum dependency
386
387* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
388- add BR: bluez-libs-devel >= 4.15
389- fix typo in %%postun xine
390
391* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
392- rebuild with bluez-libs-devel-4.15
393
394* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
395- new upstream release
396
397* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
398- new upstream release
399
400* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
401- new upstream release
402- add patch1 to build with xulrunner-1.9
403
404* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
405- new upstream release
406
407* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
408- new upstream release
409- disabled devel package (replaced by totem-pl-parser-devel)
410
411* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
412- new upstream release
413- update version macros
414- enable browser plugins on x86_64
415
416* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
417- new upstream release
418
419* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
420- upstream release
421- drop obsolete ja.po.patch (patch0)
422- revert change of 1.4.4-0vl2
423
424* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
425- upstream release
426- enable browser plugins (exclude x86_64 arch)
427
428* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
429- upstream release
430
431* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
432- update configure options
433- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
434
435* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
436- fix mistranslation (patch0)
437- add icon symlink
438- add BuildRequires: gstreamer-plugins-good
439
440* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
441- upstream release
442- update %%_glib_ver, %%_xine_ver
443- add BuildRequires: hal
444- update %%configure options
445- update %%files
446
447* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
448- upstream release
449
450* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
451- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
452
453* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
454- upstream release
455- drop obsolete patch0
456
457* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
458- upstream release
459- add patch0 to build with intltool-0.35
460
461* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
462- upstream release
463
464* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
465- upstream release
466- update alternatives entry
467
468* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
469- upstream release
470- drop fix-sort-function.patch (was merged to upstream, #331426)
471
472* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
473- rebuild with gnome-2.14rc
474
475* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
476- upstream release
477- add macros
478  - _gtk_ver, _glib_ver
479  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
480  - _dbus_ver
481  - _gst_ver, gstpb_ver, _xine_ver
482- add fix-sort-function.patch to build with glib < 2.9.1
483
484* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
485- upstream release
486- add BuildRequires:
487  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
488  - gnome-vfs2-devel >= 2.9.92
489  - dbus-devel >= 0.35
490- use gstreamer-0.10 as backend for totem-gstreamer
491
492* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
493- use gstreamer08 instead of gstreamer
494
495* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
496- upstream release
497
498* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
499- fix missing links
500  - update file list
501  - update update-alternatives scripts
502- fix totem-gstreamer's %%postun script
503
504* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
505- upstream release
506- add BuildRequires: iso-codes, libmusicbrainz-devel
507- add Requires: iso-codes, libmusicbrains to -common package
508- remove BuildRequires: nautilus-cd-burner
509- remove Requires: nautilus-cd-burner from -common package
510
511* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
512- totem-gstreamer obsoletes nautilus-media
513
514* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
515- upstream release
516- add Requires(post,postun): alternatives for gstreamer,xine
517- add Requires(postun,triggers): alternatives for common
518
519* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
520- upstream release
521
522* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
523- build xine backend
524  - move common files to common package
525  - move GStreamer related files to gstreamer package
526  - install xine related files to xine package
527- fix scripts
528
529* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
530- upstream release
531- update URL
532- move *.{a,la} to devel package
533
534* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
535- fix %%{post,preun} script (video-thumbnail.schemas)
536- sync with Fedora Core's 1.0.1-1
537
538  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
539  - Update to upstream version 1.0.1
540  - Break out devel package
541
542* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
543- add %%{post,pre}un script
544
545* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
546- initial build for Vine Linux
547
548* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
549- fix %%post
550
551* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
552- Obsolete nautilus-media
553- Install property page and thumbnailer
554
555* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
556- Update to 0.101
557 
558* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
559- Grab patch totem-0.100-desktopfile.patch from CVS to fix
560  missing menu entry (144088)
561- Remove workaround for desktop file being misinstalled, fixed
562  by above patch
563
564* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
565- New upstream version 0.100
566
567* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
568- update to 0.99.22
569
570* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
571- Add patch to remove removed items from package from help
572
573* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
574- New upstream 0.99.19
575  - Fixes crasher with CD playback (see NEWS)
576
577* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
578- Call update-desktop-database in post
579
580* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
581- update to 0.99.18
582
583* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
584- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
585
Note: See TracBrowser for help on using the repository browser.