source: projects/specs/trunk/t/totem/totem-vl.spec @ 805

Revision 805, 20.9 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file of gnome-2.30

Line 
1# select backend (GStreamer, xine)
2#define build_gst       1
3%define build_xine      1
4
5# build browser plugins
6%define build_plugin    %{!?_without_mozilla:1}%{?_without_mozilla:0}
7
8# define versions
9%define _glib_ver               2.24.0
10%define _gtk_ver                2.20.0
11%define _gnomevfs_ver           2.24.0
12%define _gnomeui_ver            2.24.3
13%define _gnomeicon_ver          2.30.0
14%define _gnome_desktop_ver      2.30.0
15%define _libgnome_ver           2.30.0
16%define _gnome_doc_utils_ver    0.20.0
17%define _dbus_ver               1.2.24
18%define _gst_ver                0.10.19
19%define _gstpb_ver              0.10.7
20%define _xine_ver               1.1.11.1
21%define _xulrunner_ver          1.9
22%define _nautilus_ver           2.26.0
23%define _shared_mime_info_ver   0.17
24%define _unique_ver             1.0
25%define _vala_ver               0.7.5
26%define _totem_pl_parser_ver    2.30.0
27
28%define nautilus_extdir %{_libdir}/nautilus/extensions-2.0
29%define mozplug_dir %{_libdir}/mozilla/plugins
30
31Summary:        Movie player for GNOME 2
32Summary(ja):    GNOME2 用動画プレイヤー
33Name:           totem
34Version:        2.30.0
35Release:        1%{?_dist_release}
36License:        GPL
37Group:          Applications/Multimedia
38URL:            http://www.gnome.org/projects/totem/
39Source0:        http://ftp.gnome.org/pub/GNOME/sources/totem/2.30/totem-%{version}.tar.bz2
40
41BuildRoot:      %{_tmppath}/%{name}-%{version}-root
42Vendor:         Project Vine
43Distribution:   Vine Linux
44
45BuildRequires:  gtk2-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
46BuildRequires:  gnome-desktop-devel >= %{_gnome_desktop_ver}
47BuildRequires:  gnome-vfs2-devel >= %{_gnomevfs_ver}
48BuildRequires:  libgnomeui-devel >= %{_gnomeui_ver}
49BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
50BuildRequires:  libgnome-devel >= %{_libgnome_ver}
51BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
52BuildRequires:  dbus-devel >= %{_dbus_ver}
53BuildRequires:  libmusicbrainz-devel
54BuildRequires:  nautilus-devel >= %{_nautilus_ver}
55BuildRequires:  gettext, scrollkeeper
56BuildRequires:  perl-XML-Parser
57BuildRequires:  iso-codes
58BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
59BuildRequires:  bluez-libs-devel >= 4.15
60BuildRequires:  lirc
61BuildRequires:  unique-devel >= %{_unique_ver}
62BuildRequires:  vala-devel >= %{_vala_ver}
63
64Requires: %{name}-common = %{version}-%{release}
65Requires: %{name}-gstreamer = %{version}-%{release}
66
67%if %{build_plugin}
68BuildRequires:  xulrunner-devel >= %{_xulrunner_ver}
69BuildRequires:  nautilus-devel >= %{_nautilus_ver}
70BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
71%endif
72
73%description
74Totem is simple movie player for the Gnome desktop. It features a
75simple playlist, a full-screen mode, seek and volume controls, as well as
76a pretty complete keyboard navigation.
77This is virtual package to install totem common package and totem backend
78package.
79
80%package gstreamer
81Summary:        GStramer backend for Totem
82Summary(ja):    Totem 用 GStreamer バックエンド
83Group:          Applications/Multimedia
84Requires:       %{name}-common = %{version}-%{release}
85Requires:       gstreamer >= %{_gst_ver}
86Requires:       gstreamer-plugins-base >= %{_gstpb_ver}
87BuildRequires:  gstreamer-devel >= %{_gst_ver}
88BuildRequires:  gstreamer-plugins-base-devel >= %{_gstpb_ver}
89BuildRequires:  gstreamer-plugins-good
90Obsoletes:      %{name} < 1.0.2-0vl2, nautilus-media
91Provides:       %{name} = %{version}-%{release}
92
93Requires(post):   alternatives
94Requires(postun): alternatives
95
96%description gstreamer
97Totem is simple movie player for the Gnome desktop. It features a
98simple playlist, a full-screen mode, seek and volume controls, as well as
99a pretty complete keyboard navigation.
100
101%if %{build_xine}
102%package xine
103Summary:        Xine backend for Totem
104Summary(ja):    Totem 用 Xine バックエンド
105Group:          Applications/Multimedia
106Requires:       %{name}-common = %{version}-%{release}
107Requires:       xine-lib >= %{_xine_ver}
108BuildRequires:  xine-lib-devel >= %{_xine_ver}
109Obsoletes:      %{name} < 1.0.2-0vl2
110Provides:       %{name} = %{version}-%{release}
111
112Requires(post):   alternatives
113Requires(postun): alternatives
114
115%description xine
116Totem is simple movie player for the Gnome desktop. It features a
117simple playlist, a full-screen mode, seek and volume controls, as well as
118a pretty complete keyboard navigation.
119%endif
120
121%package common
122Summary:        common files for Totem
123Summary(ja):    Totem の共通ファイル
124Group:          Applications/Multimedia
125Requires:       gtk2 >= %{_gtk_ver}, glib2 >= %{_glib_ver}
126Requires:       gnome-desktop-libs >= %{_gnome_desktop_ver}
127Requires:       gnome-vfs2 >= %{_gnomevfs_ver}
128Requires:       libgnomeui >= %{_gnomeui_ver}
129Requires:       libgnome >= %{_libgnome_ver}
130Requires:       dbus >= %{_dbus_ver}
131Requires:       iso-codes, libmusicbrainz
132Conflicts:      %{name} < 1.0.2-0vl2
133
134Requires(post):     ldconfig, scrollkeeper, desktop-file-utils, GConf2
135Requires(postun):   ldconfig, scrollkeeper, desktop-file-utils, alternatives
136Requires(preun):    GConf2
137Requires(triggers): alternatives
138
139%description common
140Totem is simple movie player for the Gnome desktop. It features a
141simple playlist, a full-screen mode, seek and volume controls, as well as
142a pretty complete keyboard navigation.
143
144This package contains common files for Totem (GStreamer/xine backend).
145
146%if %{build_plugin}
147%package mozilla
148Summary:        Totem movie plugin for Mozilla
149Summary(ja):    Mozilla 用 Totem 動画プラグイン
150Group:          Applications/Internet
151Requires:       %{name}-common = %{version}-%{release}
152Obsoletes:      %{name}-mozilla-common
153Obsoletes:      %{name}-mozilla-gstreamer
154Obsoletes:      %{name}-mozilla-xine
155
156Requires(post):   alternatives
157Requires(postun): alternatives
158
159%description mozilla
160Totem is simple movie player for the Gnome desktop. It features a
161simple playlist, a full-screen mode, seek and volume controls, as well as
162a pretty complete keyboard navigation.
163
164This package contains a Totem video plugin for Mozilla. It allows Totem
165movie player to be embedded into a web browser.
166
167## %package tracker
168## Summary:     Tracker-based video search plugin for Totem
169## Summary(ja): Tracker を使った Totem 用動画検索プラグイン
170## Group:               Applications/Multimedia
171## Requires:    %{name}-common = %{version}-%{release}
172## BuildRequires:       tracker-devel
173
174## %description tracker
175## A plugin to allow searching local videos, based on their tags, metadata,
176## or filenames, as indexing by the Tracker indexer.
177%endif
178
179%prep
180%setup -q -c
181# Whatever needs to be changed in both copies do here
182## remember to update me when changing %doc
183for i in AUTHORS COPYING ChangeLog NEWS README TODO;do
184  cp totem-%{version}/$i .
185done
186
187# duplicate sources
188cp -a totem-%{version} xine
189mv totem-%{version} gstreamer
190
191%build
192
193# build Totem (GStreamer backend)
194pushd gstreamer
195DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-0.10 --print-all > /dev/null
196export MOZILLA_PLUGINDIR=%{mozplug_dir}
197%configure \
198        --disable-schemas-install \
199        --disable-scrollkeeper \
200%if %{build_plugin}
201        --enable-browser-plugins \
202        --enable-nautilus \
203        --enable-gmp-plugin \
204        --enable-narrowspace-plugin \
205        --enable-mully-plugin
206%else
207        --disable-browser-plugins
208%endif
209make %{?_smp_mflags}
210popd
211
212# build Totem (xine backend)
213%if %{build_xine}
214pushd xine
215export MOZILLA_PLUGINDIR=%{mozplug_dir}
216%configure \
217        --disable-schemas-install \
218        --disable-scrollkeeper \
219        --disable-nautilus \
220        --disable-browser-plugins
221cd src/backend/
222make %{?_smp_mflags}
223popd
224%endif
225
226%install
227rm -rf $RPM_BUILD_ROOT
228export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
229
230# install Totem (GStreamer backend)
231pushd gstreamer/
232make install DESTDIR=$RPM_BUILD_ROOT
233## mv $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget.so.0.0.0 \
234##    $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0
235# language hack
236%find_lang %{name} --with-gnome
237mv %{name}.lang ../
238popd
239
240# install Totem (xine backend)
241%if %{build_xine}
242pushd xine/src/backend/
243make install DESTDIR=$RPM_BUILD_ROOT
244## mv $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget.so.0.0.0 \
245##    $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget-xine.so.0.0.0
246popd
247%endif
248
249# remove unneeded files
250%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
251%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
252%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
253%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
254## %__rm -f %{buildroot}%{_libdir}/libbaconvideowidget*.{a,la}
255## %__rm -f %{buildroot}%{_libdir}/libbaconvideowidget.so
256%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
257%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
258 
259%find_lang %{name} --with-gnome
260
261%clean
262%__rm -rf %{buildroot}
263
264%post gstreamer
265## %{_syssbindir}/update-alternatives --install \
266##      %{_libdir}/libbaconvideowidget.so.0.0.0 totem \
267##         %{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0 10
268/sbin/ldconfig
269
270%postun gstreamer
271## [ "$1" = "1" ] && exit
272## %{_syssbindir}/update-alternatives --remove \
273##         totem %{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0
274## [ -f "%{_libdir}/libbaconvideowidget.so.0.0.0" ] || %{_syssbindir}/update-alternatives --auto totem
275/sbin/ldconfig
276
277%if %{build_xine}
278%post xine
279## %{_syssbindir}/update-alternatives --install \
280##      %{_libdir}/libbaconvideowidget.so.0.0.0 totem \
281##         %{_libdir}/libbaconvideowidget-xine.so.0.0.0 15
282/sbin/ldconfig
283
284%postun xine
285## [ "$1" = "1" ] && exit
286## %{_syssbindir}/update-alternatives --remove \
287##         totem %{_libdir}/libbaconvideowidget-xine.so.0.0.0
288## [ -f "%{_libdir}/libbaconvideowidget.so.0.0.0" ] || %{_syssbindir}/update-alternatives --auto totem
289/sbin/ldconfig
290%endif
291
292%post common
293%{_bindir}/scrollkeeper-update -q
294%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
295export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
296gconftool-2 --makefile-install-rule \
297        %{_sysconfdir}/gconf/schemas/totem.schemas \
298        %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
299        %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
300    >& /dev/null || :
301touch %{_datadir}/icons/hicolor
302if [ -x /usr/bin/gtk-update-icon-cache ]; then
303  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
304fi
305
306%pre common
307if [ "$1" -gt 1 ]; then
308    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
309    gconftool-2 --makefile-uninstall-rule \
310        %{_sysconfdir}/gconf/schemas/totem.schemas \
311        %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
312        %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
313        >& /dev/null || :
314fi
315
316%preun common
317if [ "$1" -eq 0 ]; then
318    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
319    gconftool-2 --makefile-uninstall-rule \
320        %{_sysconfdir}/gconf/schemas/totem.schemas \
321        %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
322        %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
323 >& /dev/null || :
324fi
325
326%postun common
327%{_bindir}/scrollkeeper-update -q
328%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
329touch %{_datadir}/icons/hicolor
330if [ -x /usr/bin/gtk-update-icon-cache ]; then
331  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
332fi
333[ -f "%{_bindir}/totem" ] || %{_syssbindir}/update-alternatives --auto totem
334
335%triggerpostun common -- %{name} < 1.0.2-0vl2
336export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
337for schema in totem totem-video-thumbnail totem-handlers ; do
338        %{_bindir}/gconftool-2 --makefile-install-rule \
339                %{_sysconfdir}/gconf/schemas/${schema}.schemas > /dev/null ||:
340done
341[ -f "%{_bindir}/totem" ] || %{_syssbindir}/update-alternatives --auto totem
342
343
344%files
345
346%files gstreamer
347%defattr(-,root,root,-)
348## %{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0
349
350%if %{build_xine}
351%files xine
352%defattr(-,root,root,-)
353## %{_libdir}/libbaconvideowidget-xine.so.0.0.0
354%endif
355
356%files common -f %{name}.lang
357%defattr(-,root,root,-)
358%doc AUTHORS COPYING ChangeLog NEWS README TODO
359%config %{_sysconfdir}/gconf/schemas/*.schemas
360%{_bindir}/totem
361%{_bindir}/totem-audio-preview
362%{_bindir}/totem-video-indexer
363%{_bindir}/totem-video-thumbnailer
364%{_datadir}/applications/%{name}.desktop
365%{_datadir}/icons/*/*/apps/*
366%{_datadir}/icons/*/*/devices/*
367%{_datadir}/%{name}
368%{_datadir}/gtk-doc/html/totem
369%dir %{_libdir}/totem
370%dir %{_libdir}/totem/plugins
371%{_libdir}/totem/plugins/brasero-disc-recorder
372%{_libdir}/totem/plugins/coherence_upnp
373%{_libdir}/totem/plugins/gromit
374%{_libdir}/totem/plugins/jamendo
375%{_libdir}/totem/plugins/lirc
376%{_libdir}/totem/plugins/media-player-keys
377%{_libdir}/totem/plugins/ontop
378%{_libdir}/totem/plugins/opensubtitles
379%{_libdir}/totem/plugins/properties
380%{_libdir}/totem/plugins/pythonconsole
381%{_libdir}/totem/plugins/screensaver
382%{_libdir}/totem/plugins/screenshot
383%{_libdir}/totem/plugins/skipto
384%{_libdir}/totem/plugins/thumbnail
385## %{_libdir}/totem/plugins/youtube
386## %{_libdir}/totem/plugins/totem
387## %{_libdir}/totem/plugins/tracker
388%{_libdir}/totem/plugins/brasero-disc-recorder
389%{_libdir}/totem/plugins/dbus
390%{_libdir}/totem/plugins/gromit
391%{_libdir}/totem/plugins/iplayer
392%{_libdir}/totem/plugins/jamendo
393%{_libdir}/totem/plugins/lirc
394%{_libdir}/totem/plugins/media-player-keys
395%{_libdir}/totem/plugins/ontop
396%{_libdir}/totem/plugins/opensubtitles
397%{_libdir}/totem/plugins/properties
398%{_libdir}/totem/plugins/pythonconsole
399%{_libdir}/totem/plugins/sample-vala
400%{_libdir}/totem/plugins/screensaver
401%{_libdir}/totem/plugins/screenshot
402%{_libdir}/totem/plugins/skipto
403%{_libdir}/totem/plugins/thumbnail
404%if %{build_plugin}
405%{_libdir}/nautilus/extensions-2.0/*.so*
406%endif
407## %{_libdir}/libbaconvideowidget.so*
408%{_libexecdir}/%{name}/totem-bugreport.py
409%{_mandir}/man1/*
410
411%if %{build_plugin}
412%files mozilla
413%defattr(-,root,root,-)
414%{mozplug_dir}/*
415%{_libexecdir}/totem-plugin-viewer
416
417## %files tracker
418## %defattr(-, root, root)
419## %{_libdir}/totem/plugins/tracker
420%endif
421
422%changelog
423* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
424- new upstream release
425- drop totem-tracker package
426- add BuildRequires: unique-devel
427- remove BuildRequires: hal-devel
428- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
429
430* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
431- remove unneeded autoreconf
432- add BR: lirc
433
434* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
435- new upstream release
436
437* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
438- remove bemused plugin
439
440* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
441- new upstream release
442
443* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
444- added tracker video search sub-package
445
446* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
447- new upstream release
448
449* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
450- new upstream release
451
452* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
453- remove libxine dependency from totem-common
454- build xine backend with minimum dependency
455
456* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
457- add BR: bluez-libs-devel >= 4.15
458- fix typo in %%postun xine
459
460* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
461- rebuild with bluez-libs-devel-4.15
462
463* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
464- new upstream release
465
466* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
467- new upstream release
468
469* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
470- new upstream release
471- add patch1 to build with xulrunner-1.9
472
473* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
474- new upstream release
475
476* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
477- new upstream release
478- disabled devel package (replaced by totem-pl-parser-devel)
479
480* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
481- new upstream release
482- update version macros
483- enable browser plugins on x86_64
484
485* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
486- new upstream release
487
488* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
489- upstream release
490- drop obsolete ja.po.patch (patch0)
491- revert change of 1.4.4-0vl2
492
493* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
494- upstream release
495- enable browser plugins (exclude x86_64 arch)
496
497* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
498- upstream release
499
500* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
501- update configure options
502- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
503
504* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
505- fix mistranslation (patch0)
506- add icon symlink
507- add BuildRequires: gstreamer-plugins-good
508
509* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
510- upstream release
511- update %%_glib_ver, %%_xine_ver
512- add BuildRequires: hal
513- update %%configure options
514- update %%files
515
516* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
517- upstream release
518
519* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
520- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
521
522* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
523- upstream release
524- drop obsolete patch0
525
526* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
527- upstream release
528- add patch0 to build with intltool-0.35
529
530* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
531- upstream release
532
533* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
534- upstream release
535- update alternatives entry
536
537* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
538- upstream release
539- drop fix-sort-function.patch (was merged to upstream, #331426)
540
541* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
542- rebuild with gnome-2.14rc
543
544* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
545- upstream release
546- add macros
547  - _gtk_ver, _glib_ver
548  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
549  - _dbus_ver
550  - _gst_ver, gstpb_ver, _xine_ver
551- add fix-sort-function.patch to build with glib < 2.9.1
552
553* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
554- upstream release
555- add BuildRequires:
556  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
557  - gnome-vfs2-devel >= 2.9.92
558  - dbus-devel >= 0.35
559- use gstreamer-0.10 as backend for totem-gstreamer
560
561* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
562- use gstreamer08 instead of gstreamer
563
564* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
565- upstream release
566
567* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
568- fix missing links
569  - update file list
570  - update update-alternatives scripts
571- fix totem-gstreamer's %%postun script
572
573* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
574- upstream release
575- add BuildRequires: iso-codes, libmusicbrainz-devel
576- add Requires: iso-codes, libmusicbrains to -common package
577- remove BuildRequires: nautilus-cd-burner
578- remove Requires: nautilus-cd-burner from -common package
579
580* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
581- totem-gstreamer obsoletes nautilus-media
582
583* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
584- upstream release
585- add Requires(post,postun): alternatives for gstreamer,xine
586- add Requires(postun,triggers): alternatives for common
587
588* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
589- upstream release
590
591* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
592- build xine backend
593  - move common files to common package
594  - move GStreamer related files to gstreamer package
595  - install xine related files to xine package
596- fix scripts
597
598* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
599- upstream release
600- update URL
601- move *.{a,la} to devel package
602
603* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
604- fix %%{post,preun} script (video-thumbnail.schemas)
605- sync with Fedora Core's 1.0.1-1
606
607  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
608  - Update to upstream version 1.0.1
609  - Break out devel package
610
611* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
612- add %%{post,pre}un script
613
614* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
615- initial build for Vine Linux
616
617* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
618- fix %%post
619
620* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
621- Obsolete nautilus-media
622- Install property page and thumbnailer
623
624* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
625- Update to 0.101
626 
627* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
628- Grab patch totem-0.100-desktopfile.patch from CVS to fix
629  missing menu entry (144088)
630- Remove workaround for desktop file being misinstalled, fixed
631  by above patch
632
633* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
634- New upstream version 0.100
635
636* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
637- update to 0.99.22
638
639* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
640- Add patch to remove removed items from package from help
641
642* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
643- New upstream 0.99.19
644  - Fixes crasher with CD playback (see NEWS)
645
646* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
647- Call update-desktop-database in post
648
649* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
650- update to 0.99.18
651
652* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
653- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
654
Note: See TracBrowser for help on using the repository browser.