source: projects/specs/trunk/t/totem/totem-vl.spec @ 7938

Revision 7938, 18.4 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

RevLine 
[521]1# build browser plugins
2%define build_plugin    %{!?_without_mozilla:1}%{?_without_mozilla:0}
3
4# define versions
[7938]5%define _glib_ver               2.38.0
6%define _gtk_ver                3.10.0
7%define _gnomeicon_ver          3.10.0
[805]8%define _gnome_doc_utils_ver    0.20.0
[7938]9%define _dbus_ver               1.6.0
10%define _gst_ver                1.2.0
11%define _gstpb_ver              1.2.0
12%define _gstpg_ver              1.2.0
13%define _gstpbad_ver            1.2.0
[805]14%define _xulrunner_ver          1.9
[7938]15%define _nautilus_ver           3.10.0
[521]16%define _shared_mime_info_ver   0.17
[805]17%define _unique_ver             1.0
[7633]18%define _totem_pl_parser_ver    3.4.4
[521]19
[4616]20%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
[521]21%define mozplug_dir %{_libdir}/mozilla/plugins
22
[5038]23Summary:        Movie player for GNOME 3
24Summary(ja):    GNOME3 用動画プレイヤー
[521]25Name:           totem
[7938]26Version:        3.10.1
[6537]27Release:        1%{?_dist_release}
[521]28License:        GPL
29Group:          Applications/Multimedia
30URL:            http://www.gnome.org/projects/totem/
[7938]31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.10/%{name}-%{version}.tar.xz
[521]32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
[4616]34
[521]35Vendor:         Project Vine
36Distribution:   Vine Linux
[6890]37Packager:       Takemikaduchi
[521]38
[4616]39BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
[521]40BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
41BuildRequires:  dbus-devel >= %{_dbus_ver}
[805]42BuildRequires:  nautilus-devel >= %{_nautilus_ver}
[7681]43BuildRequires:  gettext
[521]44BuildRequires:  perl-XML-Parser
45BuildRequires:  iso-codes
[7633]46BuildRequires:  yelp-tools
[805]47BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
[6890]48BuildRequires:  grilo-devel
[521]49BuildRequires:  bluez-libs-devel >= 4.15
50BuildRequires:  lirc
[805]51BuildRequires:  unique-devel >= %{_unique_ver}
[975]52BuildRequires:  python-devel
[6011]53BuildRequires:  pylint
[4812]54BuildRequires:  pygobject3-devel
[4616]55BuildRequires:  libpeas-devel
56BuildRequires:  libXtst-devel
[6890]57BuildRequires:  gsettings-desktop-schemas-devel
58BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
[7633]59BuildRequires:  vala
[521]60
[6890]61BuildRequires:  gstreamer1-devel >= %{_gst_ver}
62BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
63BuildRequires:  gstreamer1-plugins-good >= %{_gstpg_ver}
[7018]64BuildRequires:  gstreamer1-plugins-bad-free-devel >= %{_gstpbad_ver}
[521]65
[4616]66BuildRequires:  clutter-gtk-devel
67BuildRequires:  clutter-gst-devel
68BuildRequires:  libmx-devel
69
[7633]70
[521]71%if %{build_plugin}
[805]72BuildRequires:  xulrunner-devel >= %{_xulrunner_ver}
[521]73BuildRequires:  nautilus-devel >= %{_nautilus_ver}
74BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
75%endif
76
[6890]77Requires:       gstreamer1 >= %{_gst_ver}
78Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
79Requires:       gstreamer1-plugins-good >= %{_gstpg_ver}
[7018]80Requires:       gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
[981]81Requires:       iso-codes
[975]82
83Obsoletes:      nautilus-media
84Obsoletes:      %{name}-gstreamer < 2.30.1-2
85Obsoletes:      %{name}-xine < 2.30.1-2
[981]86Obsoletes:      %{name}-common < 2.30.1-3
[975]87
88Provides:       nautilus-media
[981]89Provides:       %{name}-common = %{version}-%{release}
[975]90
[7938]91Requires(post):     ldconfig, desktop-file-utils
[7681]92Requires(postun):   ldconfig, desktop-file-utils
[521]93
[981]94%description
[521]95Totem is simple movie player for the Gnome desktop. It features a
96simple playlist, a full-screen mode, seek and volume controls, as well as
97a pretty complete keyboard navigation.
98
99%if %{build_plugin}
100%package mozilla
101Summary:        Totem movie plugin for Mozilla
102Summary(ja):    Mozilla 用 Totem 動画プラグイン
103Group:          Applications/Internet
[981]104Requires:       %{name} = %{version}-%{release}
[521]105Obsoletes:      %{name}-mozilla-common
106Obsoletes:      %{name}-mozilla-gstreamer
107Obsoletes:      %{name}-mozilla-xine
108
109%description mozilla
110Totem is simple movie player for the Gnome desktop. It features a
111simple playlist, a full-screen mode, seek and volume controls, as well as
112a pretty complete keyboard navigation.
113
114This package contains a Totem video plugin for Mozilla. It allows Totem
115movie player to be embedded into a web browser.
116
117%endif
118
[4616]119%package devel
120Summary:        Plugin writer's documentation for totem
121Group:          Development/Libraries
122Requires:       %{name} = %{version}-%{release}
123
124%description devel
125The %{name}-devel package contains API documentation for
126developing developing plugins for %{name}.
127
[521]128%prep
[975]129%setup -q
[521]130
131%build
[6890]132DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
[521]133export MOZILLA_PLUGINDIR=%{mozplug_dir}
[4616]134
[521]135%configure \
[981]136        --enable-python \
[7633]137        --enable-vala \
[521]138        --enable-nautilus \
139        --enable-gmp-plugin \
140        --enable-narrowspace-plugin \
[981]141        --enable-mully-plugin \
[6256]142        --disable-vegas-plugin \
[981]143%if %{build_plugin}
144        --enable-browser-plugins
[521]145%else
[981]146        --disable-browser-plugins
[521]147%endif
[981]148
[521]149make %{?_smp_mflags}
150
151%install
152rm -rf $RPM_BUILD_ROOT
153
154make install DESTDIR=$RPM_BUILD_ROOT
155
156# remove unneeded files
157%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
[4616]158%__rm -f %{buildroot}%{_libdir}/*.{a,la}
[521]159%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
160%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
161%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
162%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
163%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
[4616]164
165# remove unused file
166%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
[521]167 
168%find_lang %{name} --with-gnome
169
[975]170# save space by linking identical images in translated docs
171helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
172for f in $helpdir/C/figures/*.png; do
173  b="$(basename $f)"
174  for d in $helpdir/*; do
175    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
176      g="$d/figures/$b"
177      if [ -f "$g" ]; then
178        if cmp -s $f $g; then
179          rm "$g"; ln -s "../../C/figures/$b" "$g"
180        fi
181      fi
182    fi
183  done
184done
185
186
[521]187%clean
188%__rm -rf %{buildroot}
189
[981]190%post
[521]191%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
192touch %{_datadir}/icons/hicolor
193if [ -x /usr/bin/gtk-update-icon-cache ]; then
194  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
195fi
196
[981]197%postun
[521]198%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
199touch %{_datadir}/icons/hicolor
200if [ -x /usr/bin/gtk-update-icon-cache ]; then
201  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
202fi
[4616]203glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]204
[4616]205%posttrans
206glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
207
[981]208%files -f %{name}.lang
[521]209%defattr(-,root,root,-)
210%doc AUTHORS COPYING ChangeLog NEWS README TODO
211%{_bindir}/totem
212%{_bindir}/totem-audio-preview
213%{_bindir}/totem-video-thumbnailer
[4616]214%{_datadir}/GConf/gsettings/opensubtitles.convert
215#%{_datadir}/GConf/gsettings/pythonconsole.convert
216%{_datadir}/GConf/gsettings/totem.convert
[521]217%{_datadir}/applications/%{name}.desktop
[4616]218%{_datadir}/glib-2.0/schemas/*.xml
219%{_datadir}/icons/*/*/*/*
220%{_datadir}/thumbnailers/totem.thumbnailer
[521]221%{_datadir}/%{name}
222%{_datadir}/gtk-doc/html/totem
[4616]223%{_libdir}/libtotem.so.*
224%{_libdir}/girepository-1.0/*.typelib
[521]225%dir %{_libdir}/totem
226%dir %{_libdir}/totem/plugins
[6890]227%{_libdir}/totem/plugins/apple-trailers/
228%{_libdir}/totem/plugins/autoload-subtitles
[521]229%{_libdir}/totem/plugins/brasero-disc-recorder
[2041]230%{_libdir}/totem/plugins/chapters
[805]231%{_libdir}/totem/plugins/dbus
[6890]232%{_libdir}/totem/plugins/grilo
[805]233%{_libdir}/totem/plugins/gromit
[7633]234%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
235%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
[805]236%{_libdir}/totem/plugins/lirc
237%{_libdir}/totem/plugins/media-player-keys
238%{_libdir}/totem/plugins/ontop
239%{_libdir}/totem/plugins/opensubtitles
240%{_libdir}/totem/plugins/properties
241%{_libdir}/totem/plugins/pythonconsole
[6890]242%{_libdir}/totem/plugins/recent
[7633]243%{_libdir}/totem/plugins/rotation
[805]244%{_libdir}/totem/plugins/screensaver
245%{_libdir}/totem/plugins/screenshot
246%{_libdir}/totem/plugins/skipto
[4616]247%{_libdir}/totem/plugins/save-file/libsave-file.so
248%{_libdir}/totem/plugins/save-file/save-file.plugin
[7938]249%{_libdir}/totem/plugins/vimeo
[521]250%if %{build_plugin}
[4616]251%{_libdir}/nautilus/extensions-3.0/*.so*
[521]252%endif
253%{_libexecdir}/%{name}/totem-bugreport.py
254%{_mandir}/man1/*
255
256%if %{build_plugin}
257%files mozilla
258%defattr(-,root,root,-)
259%{mozplug_dir}/*
260%{_libexecdir}/totem-plugin-viewer
261%endif
262
[4616]263%files devel
264%defattr(-, root, root,-)
265%{_includedir}/totem
266%{_libdir}/libtotem.so
267%{_libdir}/pkgconfig/totem.pc
268%{_datadir}/gir-1.0/Totem-1.0.gir
269%{_datadir}/gtk-doc/html/totem
270
271
[521]272%changelog
[7938]273* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
274- new upstream release
275
[7681]276* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
277- new upstream release
278
[7633]279* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
280- new upstream release
281- add BuildRequires: yelp-tools, vala
282- change configure option (--enable-vala)
283
[7088]284* Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
285- new upstream release
286
[7018]287* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
288- new upstream release
289- change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
290
[6890]291* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
292- new upstream release
293- add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
294
[6256]295* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
[6537]296- new upstream release
297
298* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
[6256]299- add configure option (--disable-vegas-plugin)
300
[6201]301* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
302- new upstream release
303
[6078]304* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
[6011]305- new upstream release
306- add BuildRequires: pylint
307- remove BuildRequires: libgdata-devel
308
[5038]309* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
310- new upstream release
311
[4850]312* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
313- new upstream release
314
[4812]315* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
316- new upstream release
317- change BuildRequires: pygobject3-devel instead of pygobject-devel
318
[4616]319* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
320- new upstream release
321- change BuildRequires: gtk3-devel instead of gtk2-devel
322- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
323                     clutter-gst-devel, libmx-devel
324- change configure option (--disable-vala)
325
[2041]326* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
327- new upstream release
328- fix %files
329
[1260]330* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
331- new upstream release
332
[981]333* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
334- clean up spec file
335- remove totem-common and merged to totem main package.
336  - add Obsoletes: totem-common
337- remove unneeded BR: and R:
338  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
339  - libmusicbrainz, alternatives
340- remove explicit dependency
341  - gtk2, glib2, dbus
342- add R: pygtk2, pyxdg, python-Coherence for python plugins
343- add R: gstreamer-plugins-good
344
[975]345* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
346- rebuild with libgdata (add youtube plugin)
347- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
348- add Obsolete: totem-gstreamer, totem-xine)
349
[926]350* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
351- new upstream release
352- chagnge _gst_ver from 0.10.19 to 0.10.29
353
[805]354* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
355- new upstream release
356- drop totem-tracker package
357- add BuildRequires: unique-devel
358- remove BuildRequires: hal-devel
359- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
360
[521]361* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
362- remove unneeded autoreconf
363- add BR: lirc
364
365* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
366- new upstream release
367
368* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
369- remove bemused plugin
370
371* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
372- new upstream release
373
374* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
375- added tracker video search sub-package
376
377* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
378- new upstream release
379
380* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
381- new upstream release
382
383* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
384- remove libxine dependency from totem-common
385- build xine backend with minimum dependency
386
387* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
388- add BR: bluez-libs-devel >= 4.15
389- fix typo in %%postun xine
390
391* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
392- rebuild with bluez-libs-devel-4.15
393
394* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
395- new upstream release
396
397* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
398- new upstream release
399
400* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
401- new upstream release
402- add patch1 to build with xulrunner-1.9
403
404* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
405- new upstream release
406
407* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
408- new upstream release
409- disabled devel package (replaced by totem-pl-parser-devel)
410
411* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
412- new upstream release
413- update version macros
414- enable browser plugins on x86_64
415
416* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
417- new upstream release
418
419* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
420- upstream release
421- drop obsolete ja.po.patch (patch0)
422- revert change of 1.4.4-0vl2
423
424* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
425- upstream release
426- enable browser plugins (exclude x86_64 arch)
427
428* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
429- upstream release
430
431* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
432- update configure options
433- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
434
435* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
436- fix mistranslation (patch0)
437- add icon symlink
438- add BuildRequires: gstreamer-plugins-good
439
440* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
441- upstream release
442- update %%_glib_ver, %%_xine_ver
443- add BuildRequires: hal
444- update %%configure options
445- update %%files
446
447* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
448- upstream release
449
450* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
451- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
452
453* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
454- upstream release
455- drop obsolete patch0
456
457* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
458- upstream release
459- add patch0 to build with intltool-0.35
460
461* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
462- upstream release
463
464* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
465- upstream release
466- update alternatives entry
467
468* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
469- upstream release
470- drop fix-sort-function.patch (was merged to upstream, #331426)
471
472* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
473- rebuild with gnome-2.14rc
474
475* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
476- upstream release
477- add macros
478  - _gtk_ver, _glib_ver
479  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
480  - _dbus_ver
481  - _gst_ver, gstpb_ver, _xine_ver
482- add fix-sort-function.patch to build with glib < 2.9.1
483
484* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
485- upstream release
486- add BuildRequires:
487  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
488  - gnome-vfs2-devel >= 2.9.92
489  - dbus-devel >= 0.35
490- use gstreamer-0.10 as backend for totem-gstreamer
491
492* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
493- use gstreamer08 instead of gstreamer
494
495* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
496- upstream release
497
498* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
499- fix missing links
500  - update file list
501  - update update-alternatives scripts
502- fix totem-gstreamer's %%postun script
503
504* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
505- upstream release
506- add BuildRequires: iso-codes, libmusicbrainz-devel
507- add Requires: iso-codes, libmusicbrains to -common package
508- remove BuildRequires: nautilus-cd-burner
509- remove Requires: nautilus-cd-burner from -common package
510
511* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
512- totem-gstreamer obsoletes nautilus-media
513
514* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
515- upstream release
516- add Requires(post,postun): alternatives for gstreamer,xine
517- add Requires(postun,triggers): alternatives for common
518
519* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
520- upstream release
521
522* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
523- build xine backend
524  - move common files to common package
525  - move GStreamer related files to gstreamer package
526  - install xine related files to xine package
527- fix scripts
528
529* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
530- upstream release
531- update URL
532- move *.{a,la} to devel package
533
534* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
535- fix %%{post,preun} script (video-thumbnail.schemas)
536- sync with Fedora Core's 1.0.1-1
537
538  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
539  - Update to upstream version 1.0.1
540  - Break out devel package
541
542* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
543- add %%{post,pre}un script
544
545* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
546- initial build for Vine Linux
547
548* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
549- fix %%post
550
551* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
552- Obsolete nautilus-media
553- Install property page and thumbnailer
554
555* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
556- Update to 0.101
557 
558* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
559- Grab patch totem-0.100-desktopfile.patch from CVS to fix
560  missing menu entry (144088)
561- Remove workaround for desktop file being misinstalled, fixed
562  by above patch
563
564* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
565- New upstream version 0.100
566
567* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
568- update to 0.99.22
569
570* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
571- Add patch to remove removed items from package from help
572
573* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
574- New upstream 0.99.19
575  - Fixes crasher with CD playback (see NEWS)
576
577* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
578- Call update-desktop-database in post
579
580* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
581- update to 0.99.18
582
583* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
584- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
585
Note: See TracBrowser for help on using the repository browser.