source: projects/specs/trunk/t/totem/totem-vl.spec @ 7681

Revision 7681, 18.3 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME 3.8.2

RevLine 
[521]1# build browser plugins
2%define build_plugin    %{!?_without_mozilla:1}%{?_without_mozilla:0}
3
4# define versions
[7633]5%define _glib_ver               2.36.0
6%define _gtk_ver                3.8.0
7%define _gnomeicon_ver          3.8.0
[805]8%define _gnome_doc_utils_ver    0.20.0
[2041]9%define _dbus_ver               1.4.0
[6890]10%define _gst_ver                0.11.93
11%define _gstpb_ver              0.11.93
12%define _gstpg_ver              0.11.93
13%define _gstpbad_ver            0.11.93
[805]14%define _xulrunner_ver          1.9
[7633]15%define _nautilus_ver           3.8.0
[521]16%define _shared_mime_info_ver   0.17
[805]17%define _unique_ver             1.0
[7633]18%define _totem_pl_parser_ver    3.4.4
[521]19
[4616]20%define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
[521]21%define mozplug_dir %{_libdir}/mozilla/plugins
22
[5038]23Summary:        Movie player for GNOME 3
24Summary(ja):    GNOME3 用動画プレイヤー
[521]25Name:           totem
[7681]26Version:        3.8.2
[6537]27Release:        1%{?_dist_release}
[521]28License:        GPL
29Group:          Applications/Multimedia
30URL:            http://www.gnome.org/projects/totem/
[7633]31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.8/%{name}-%{version}.tar.xz
[521]32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
[4616]34
[521]35Vendor:         Project Vine
36Distribution:   Vine Linux
[6890]37Packager:       Takemikaduchi
[521]38
[4616]39BuildRequires:  gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
[521]40BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
41BuildRequires:  dbus-devel >= %{_dbus_ver}
[805]42BuildRequires:  nautilus-devel >= %{_nautilus_ver}
[7681]43BuildRequires:  gettext
[521]44BuildRequires:  perl-XML-Parser
45BuildRequires:  iso-codes
[7633]46BuildRequires:  yelp-tools
[805]47BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
[6890]48BuildRequires:  grilo-devel
[521]49BuildRequires:  bluez-libs-devel >= 4.15
50BuildRequires:  lirc
[805]51BuildRequires:  unique-devel >= %{_unique_ver}
[975]52BuildRequires:  python-devel
[6011]53BuildRequires:  pylint
[4812]54BuildRequires:  pygobject3-devel
[4616]55BuildRequires:  libpeas-devel
56BuildRequires:  libXtst-devel
[6890]57BuildRequires:  gsettings-desktop-schemas-devel
58BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
[7633]59BuildRequires:  vala
[521]60
[6890]61BuildRequires:  gstreamer1-devel >= %{_gst_ver}
62BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
63BuildRequires:  gstreamer1-plugins-good >= %{_gstpg_ver}
[7018]64BuildRequires:  gstreamer1-plugins-bad-free-devel >= %{_gstpbad_ver}
[521]65
[4616]66BuildRequires:  clutter-gtk-devel
67BuildRequires:  clutter-gst-devel
68BuildRequires:  libmx-devel
69
[7633]70
[521]71%if %{build_plugin}
[805]72BuildRequires:  xulrunner-devel >= %{_xulrunner_ver}
[521]73BuildRequires:  nautilus-devel >= %{_nautilus_ver}
74BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
75%endif
76
[6890]77Requires:       gstreamer1 >= %{_gst_ver}
78Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
79Requires:       gstreamer1-plugins-good >= %{_gstpg_ver}
[7018]80Requires:       gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
[981]81Requires:       iso-codes
[975]82
83Obsoletes:      nautilus-media
84Obsoletes:      %{name}-gstreamer < 2.30.1-2
85Obsoletes:      %{name}-xine < 2.30.1-2
[981]86Obsoletes:      %{name}-common < 2.30.1-3
[975]87
88Provides:       nautilus-media
[981]89Provides:       %{name}-common = %{version}-%{release}
[975]90
[7681]91Requires(post):     ldconfig, desktop-file-utils, GConf2
92Requires(postun):   ldconfig, desktop-file-utils
[521]93Requires(preun):    GConf2
94
[981]95%description
[521]96Totem is simple movie player for the Gnome desktop. It features a
97simple playlist, a full-screen mode, seek and volume controls, as well as
98a pretty complete keyboard navigation.
99
100%if %{build_plugin}
101%package mozilla
102Summary:        Totem movie plugin for Mozilla
103Summary(ja):    Mozilla 用 Totem 動画プラグイン
104Group:          Applications/Internet
[981]105Requires:       %{name} = %{version}-%{release}
[521]106Obsoletes:      %{name}-mozilla-common
107Obsoletes:      %{name}-mozilla-gstreamer
108Obsoletes:      %{name}-mozilla-xine
109
110%description mozilla
111Totem is simple movie player for the Gnome desktop. It features a
112simple playlist, a full-screen mode, seek and volume controls, as well as
113a pretty complete keyboard navigation.
114
115This package contains a Totem video plugin for Mozilla. It allows Totem
116movie player to be embedded into a web browser.
117
118%endif
119
[4616]120%package devel
121Summary:        Plugin writer's documentation for totem
122Group:          Development/Libraries
123Requires:       %{name} = %{version}-%{release}
124
125%description devel
126The %{name}-devel package contains API documentation for
127developing developing plugins for %{name}.
128
[521]129%prep
[975]130%setup -q
[521]131
132%build
[6890]133DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
[521]134export MOZILLA_PLUGINDIR=%{mozplug_dir}
[4616]135
[521]136%configure \
[981]137        --enable-python \
[7633]138        --enable-vala \
[521]139        --enable-nautilus \
140        --enable-gmp-plugin \
141        --enable-narrowspace-plugin \
[981]142        --enable-mully-plugin \
[6256]143        --disable-vegas-plugin \
[981]144%if %{build_plugin}
145        --enable-browser-plugins
[521]146%else
[981]147        --disable-browser-plugins
[521]148%endif
[981]149
[521]150make %{?_smp_mflags}
151
152%install
153rm -rf $RPM_BUILD_ROOT
154export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
155
156make install DESTDIR=$RPM_BUILD_ROOT
157
158# remove unneeded files
159%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
[4616]160%__rm -f %{buildroot}%{_libdir}/*.{a,la}
[521]161%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
162%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
163%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
164%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
165%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
[4616]166
167# remove unused file
168%__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
[521]169 
170%find_lang %{name} --with-gnome
171
[975]172# save space by linking identical images in translated docs
173helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
174for f in $helpdir/C/figures/*.png; do
175  b="$(basename $f)"
176  for d in $helpdir/*; do
177    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
178      g="$d/figures/$b"
179      if [ -f "$g" ]; then
180        if cmp -s $f $g; then
181          rm "$g"; ln -s "../../C/figures/$b" "$g"
182        fi
183      fi
184    fi
185  done
186done
187
188
[521]189%clean
190%__rm -rf %{buildroot}
191
[981]192%post
[521]193%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
194touch %{_datadir}/icons/hicolor
195if [ -x /usr/bin/gtk-update-icon-cache ]; then
196  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
197fi
198
[981]199%postun
[521]200%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
201touch %{_datadir}/icons/hicolor
202if [ -x /usr/bin/gtk-update-icon-cache ]; then
203  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
204fi
[4616]205glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]206
[4616]207%posttrans
208glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
209
[981]210%files -f %{name}.lang
[521]211%defattr(-,root,root,-)
212%doc AUTHORS COPYING ChangeLog NEWS README TODO
213%{_bindir}/totem
214%{_bindir}/totem-audio-preview
215%{_bindir}/totem-video-thumbnailer
[4616]216%{_datadir}/GConf/gsettings/opensubtitles.convert
217#%{_datadir}/GConf/gsettings/pythonconsole.convert
218%{_datadir}/GConf/gsettings/totem.convert
[521]219%{_datadir}/applications/%{name}.desktop
[4616]220%{_datadir}/glib-2.0/schemas/*.xml
221%{_datadir}/icons/*/*/*/*
222%{_datadir}/thumbnailers/totem.thumbnailer
[521]223%{_datadir}/%{name}
224%{_datadir}/gtk-doc/html/totem
[4616]225%{_libdir}/libtotem.so.*
226%{_libdir}/girepository-1.0/*.typelib
[521]227%dir %{_libdir}/totem
228%dir %{_libdir}/totem/plugins
[6890]229%{_libdir}/totem/plugins/apple-trailers/
230%{_libdir}/totem/plugins/autoload-subtitles
[521]231%{_libdir}/totem/plugins/brasero-disc-recorder
[2041]232%{_libdir}/totem/plugins/chapters
[805]233%{_libdir}/totem/plugins/dbus
[6890]234%{_libdir}/totem/plugins/grilo
[805]235%{_libdir}/totem/plugins/gromit
[7633]236%{_libdir}/totem/plugins/im-status/libtotem-im-status.so
237%{_libdir}/totem/plugins/im-status/totem-im-status.plugin
[805]238%{_libdir}/totem/plugins/lirc
239%{_libdir}/totem/plugins/media-player-keys
240%{_libdir}/totem/plugins/ontop
241%{_libdir}/totem/plugins/opensubtitles
242%{_libdir}/totem/plugins/properties
243%{_libdir}/totem/plugins/pythonconsole
[6890]244%{_libdir}/totem/plugins/recent
[7633]245%{_libdir}/totem/plugins/rotation
[805]246%{_libdir}/totem/plugins/screensaver
247%{_libdir}/totem/plugins/screenshot
248%{_libdir}/totem/plugins/skipto
[4616]249%{_libdir}/totem/plugins/save-file/libsave-file.so
250%{_libdir}/totem/plugins/save-file/save-file.plugin
[521]251%if %{build_plugin}
[4616]252%{_libdir}/nautilus/extensions-3.0/*.so*
[521]253%endif
254%{_libexecdir}/%{name}/totem-bugreport.py
255%{_mandir}/man1/*
256
257%if %{build_plugin}
258%files mozilla
259%defattr(-,root,root,-)
260%{mozplug_dir}/*
261%{_libexecdir}/totem-plugin-viewer
262%endif
263
[4616]264%files devel
265%defattr(-, root, root,-)
266%{_includedir}/totem
267%{_libdir}/libtotem.so
268%{_libdir}/pkgconfig/totem.pc
269%{_datadir}/gir-1.0/Totem-1.0.gir
270%{_datadir}/gtk-doc/html/totem
271
272
[521]273%changelog
[7681]274* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
275- new upstream release
276
[7633]277* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
278- new upstream release
279- add BuildRequires: yelp-tools, vala
280- change configure option (--enable-vala)
281
[7088]282* Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
283- new upstream release
284
[7018]285* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
286- new upstream release
287- change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
288
[6890]289* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
290- new upstream release
291- add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
292
[6256]293* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
[6537]294- new upstream release
295
296* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
[6256]297- add configure option (--disable-vegas-plugin)
298
[6201]299* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
300- new upstream release
301
[6078]302* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
[6011]303- new upstream release
304- add BuildRequires: pylint
305- remove BuildRequires: libgdata-devel
306
[5038]307* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
308- new upstream release
309
[4850]310* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
311- new upstream release
312
[4812]313* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
314- new upstream release
315- change BuildRequires: pygobject3-devel instead of pygobject-devel
316
[4616]317* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
318- new upstream release
319- change BuildRequires: gtk3-devel instead of gtk2-devel
320- add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
321                     clutter-gst-devel, libmx-devel
322- change configure option (--disable-vala)
323
[2041]324* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
325- new upstream release
326- fix %files
327
[1260]328* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
329- new upstream release
330
[981]331* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
332- clean up spec file
333- remove totem-common and merged to totem main package.
334  - add Obsoletes: totem-common
335- remove unneeded BR: and R:
336  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
337  - libmusicbrainz, alternatives
338- remove explicit dependency
339  - gtk2, glib2, dbus
340- add R: pygtk2, pyxdg, python-Coherence for python plugins
341- add R: gstreamer-plugins-good
342
[975]343* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
344- rebuild with libgdata (add youtube plugin)
345- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
346- add Obsolete: totem-gstreamer, totem-xine)
347
[926]348* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
349- new upstream release
350- chagnge _gst_ver from 0.10.19 to 0.10.29
351
[805]352* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
353- new upstream release
354- drop totem-tracker package
355- add BuildRequires: unique-devel
356- remove BuildRequires: hal-devel
357- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
358
[521]359* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
360- remove unneeded autoreconf
361- add BR: lirc
362
363* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
364- new upstream release
365
366* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
367- remove bemused plugin
368
369* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
370- new upstream release
371
372* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
373- added tracker video search sub-package
374
375* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
376- new upstream release
377
378* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
379- new upstream release
380
381* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
382- remove libxine dependency from totem-common
383- build xine backend with minimum dependency
384
385* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
386- add BR: bluez-libs-devel >= 4.15
387- fix typo in %%postun xine
388
389* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
390- rebuild with bluez-libs-devel-4.15
391
392* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
393- new upstream release
394
395* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
396- new upstream release
397
398* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
399- new upstream release
400- add patch1 to build with xulrunner-1.9
401
402* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
403- new upstream release
404
405* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
406- new upstream release
407- disabled devel package (replaced by totem-pl-parser-devel)
408
409* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
410- new upstream release
411- update version macros
412- enable browser plugins on x86_64
413
414* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
415- new upstream release
416
417* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
418- upstream release
419- drop obsolete ja.po.patch (patch0)
420- revert change of 1.4.4-0vl2
421
422* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
423- upstream release
424- enable browser plugins (exclude x86_64 arch)
425
426* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
427- upstream release
428
429* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
430- update configure options
431- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
432
433* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
434- fix mistranslation (patch0)
435- add icon symlink
436- add BuildRequires: gstreamer-plugins-good
437
438* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
439- upstream release
440- update %%_glib_ver, %%_xine_ver
441- add BuildRequires: hal
442- update %%configure options
443- update %%files
444
445* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
446- upstream release
447
448* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
449- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
450
451* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
452- upstream release
453- drop obsolete patch0
454
455* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
456- upstream release
457- add patch0 to build with intltool-0.35
458
459* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
460- upstream release
461
462* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
463- upstream release
464- update alternatives entry
465
466* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
467- upstream release
468- drop fix-sort-function.patch (was merged to upstream, #331426)
469
470* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
471- rebuild with gnome-2.14rc
472
473* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
474- upstream release
475- add macros
476  - _gtk_ver, _glib_ver
477  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
478  - _dbus_ver
479  - _gst_ver, gstpb_ver, _xine_ver
480- add fix-sort-function.patch to build with glib < 2.9.1
481
482* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
483- upstream release
484- add BuildRequires:
485  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
486  - gnome-vfs2-devel >= 2.9.92
487  - dbus-devel >= 0.35
488- use gstreamer-0.10 as backend for totem-gstreamer
489
490* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
491- use gstreamer08 instead of gstreamer
492
493* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
494- upstream release
495
496* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
497- fix missing links
498  - update file list
499  - update update-alternatives scripts
500- fix totem-gstreamer's %%postun script
501
502* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
503- upstream release
504- add BuildRequires: iso-codes, libmusicbrainz-devel
505- add Requires: iso-codes, libmusicbrains to -common package
506- remove BuildRequires: nautilus-cd-burner
507- remove Requires: nautilus-cd-burner from -common package
508
509* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
510- totem-gstreamer obsoletes nautilus-media
511
512* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
513- upstream release
514- add Requires(post,postun): alternatives for gstreamer,xine
515- add Requires(postun,triggers): alternatives for common
516
517* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
518- upstream release
519
520* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
521- build xine backend
522  - move common files to common package
523  - move GStreamer related files to gstreamer package
524  - install xine related files to xine package
525- fix scripts
526
527* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
528- upstream release
529- update URL
530- move *.{a,la} to devel package
531
532* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
533- fix %%{post,preun} script (video-thumbnail.schemas)
534- sync with Fedora Core's 1.0.1-1
535
536  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
537  - Update to upstream version 1.0.1
538  - Break out devel package
539
540* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
541- add %%{post,pre}un script
542
543* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
544- initial build for Vine Linux
545
546* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
547- fix %%post
548
549* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
550- Obsolete nautilus-media
551- Install property page and thumbnailer
552
553* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
554- Update to 0.101
555 
556* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
557- Grab patch totem-0.100-desktopfile.patch from CVS to fix
558  missing menu entry (144088)
559- Remove workaround for desktop file being misinstalled, fixed
560  by above patch
561
562* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
563- New upstream version 0.100
564
565* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
566- update to 0.99.22
567
568* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
569- Add patch to remove removed items from package from help
570
571* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
572- New upstream 0.99.19
573  - Fixes crasher with CD playback (see NEWS)
574
575* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
576- Call update-desktop-database in post
577
578* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
579- update to 0.99.18
580
581* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
582- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
583
Note: See TracBrowser for help on using the repository browser.