source: projects/specs/trunk/t/tomoe/tomoe-vl.spec @ 9077

Revision 9077, 7.4 KB checked in by inagaki, 9 years ago (diff)

2014-11-11 Ryoichi INAGAKI <ryo1@…>

  • tomoe: updated
  • zinnia: rebuilt


Line 
1# to activate, add --with [python|ruby] to rpmbuild
2%bcond_with python
3%bcond_with ruby
4
5Summary:        Japanese handwritten input system
6Summary(ja):    日本語手書き文字認識エンジン
7Name:           tomoe
8Version:        0.6.0
9Release:        3%{?_dist_release}
10Group:          System Environment/Libraries
11License:        LGPLv2
12URL:            http://tomoe.sourceforge.jp/
13
14Source0:        tomoe-%{version}.tar.gz
15Patch0:         tomoe-0.6.0-multiarch-conflict.patch
16Patch1:         tomoe-0.6.0-bz502662.patch
17Patch2:         tomoe-0.6.0-fixes-glib-includes.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20BuildRequires:  gettext
21BuildRequires:  glib2-devel >= 2.4.0
22BuildRequires:  gtk-doc >= 1.4
23BuildRequires:  intltool
24BuildRequires:  libtool
25BuildRequires:  perl(XML::Parser)
26BuildRequires:  python
27%if %{with python}
28BuildRequires:  pygobject-devel
29BuildRequires:  pygtk2-devel
30BuildRequires:  python-devel
31%endif
32%if %{with ruby}
33BuildRequires:  ruby-gnome2-devel
34%endif
35## for extra dictionary backends
36#BuildRequires:  mysql-devel, subversion-devel, hyperestraier-devel
37
38%if %{with python}
39Requires: python
40Provides: python-tomoe = %{version}-%{release}
41%endif
42
43%description
44A program which does Japanese handwriting recognition.
45
46%description -l ja
47日本語の手書き文字を認識するエンジンです。
48
49%package devel
50Summary:        Header files for developing tomoe applications
51Summary(ja):    tomoe アプリケーション開発用ヘッダファイル
52Group:          Development/Libraries
53Requires:       %{name} = %{version}-%{release}
54Requires:       pkgconfig
55%if %{with python}
56Requires:       pygobject-devel
57Provides:       python-tomoe-devel = %{version}-%{release}
58%endif
59
60%description devel
61The tomoe-devel package includes the header files for the tomoe package.
62Install this package if you want to develop programs which use tomoe.
63
64%description -l ja devel
65tomoe-devel パッケージには、tomoe を使うアプリケーションを開発するための
66ヘッダファイルが含まれています。
67
68%if %{with ruby}
69%package -n ruby-tomoe
70Summary:        Tomoe library for Ruby
71Summary(ja):    Ruby から巴を使うためのライブラリ
72Group:          System Environment/Libraries
73Requires:       %{name} = %{version}-%{release}
74Requires:       ruby
75
76%description -n ruby-tomoe
77Ruby extension library to use Tomoe
78
79%description -l ja -n ruby-tomoe
80Ruby から巴を使うための拡張ライブラリです。
81
82%package -n ruby-tomoe-devel
83Summary:        Header files for developing ruby-tomoe applications
84Summary(ja):    ruby-tomoe アプリケーション開発用ヘッダファイル
85Group:          Development/Libraries
86Requires:       ruby-tomoe = %{version}-%{release}
87Requires:       %{name}-devel = %{version}-%{release}
88
89%description -n ruby-tomoe-devel
90The ruby-tomoe-devel package includes the header files for the ruby-tomoe
91package.
92Install this package if you want to develop programs which use ruby-tomoe.
93
94%description -l ja -n ruby-tomoe-devel
95ruby-tomoe-devel パッケージには、ruby-tomoe を使うアプリケーションを開発
96するためのヘッダファイルが含まれています。
97%endif
98
99%prep
100%setup -q
101%patch0 -p0 -b .multiarch-conflict
102%patch1 -p0 -b .bz502662
103%patch2 -p1 -b .glib
104
105%build
106autoreconf -vif
107%configure \
108        --disable-static \
109        --enable-silent-rules \
110%if %{without python}
111        --without-python \
112%endif
113%if %{with ruby}
114        --with-ruby-extdir=%{rarchdir} \
115        --with-ruby-libdir=%{rlibdir} \
116%else
117        --without-ruby \
118%endif
119        --enable-gtk-doc
120
121make %{?_smp_mflags}
122
123%install
124rm -rf $RPM_BUILD_ROOT
125make DESTDIR=$RPM_BUILD_ROOT install
126
127%if %{with ruby}
128#rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/tomoe.rb $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*-linux/*
129chmod 755 $RPM_BUILD_ROOT%{_datadir}/%{name}/xml2est.rb
130%endif
131
132# remove unneeded files
133rm -f $RPM_BUILD_ROOT%{_libdir}/tomoe/module/dict/libmysql.*
134rm -f $RPM_BUILD_ROOT%{_libdir}/tomoe/module/dict/libsvn.*
135find $RPM_BUILD_ROOT -name '*.la' | xargs rm
136
137#%if !%{with ruby}
138#rm -rf %{buildroot}%{rarchdir}
139#rm -rf %{buildroot}%{rlibdir}
140#endif
141
142%find_lang %{name}
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%post -p /sbin/ldconfig
148
149%postun -p /sbin/ldconfig
150
151
152%files -f %{name}.lang
153%defattr(-,root,root,-)
154%doc AUTHORS COPYING ChangeLog NEWS README TODO
155%dir %{_sysconfdir}/tomoe
156%config(noreplace) %{_sysconfdir}/tomoe/config
157%{_libdir}/*.so.*
158%if %{with python}
159%{_libdir}/python?.?/site-packages/tomoe.so
160%endif
161%dir %{_libdir}/tomoe
162%dir %{_libdir}/tomoe/module
163%dir %{_libdir}/tomoe/module/dict
164%{_libdir}/tomoe/module/dict/*.so
165%dir %{_libdir}/tomoe/module/recognizer
166%{_libdir}/tomoe/module/recognizer/*.so
167%{_datadir}/tomoe
168
169%files devel
170%defattr(-,root,root,-)
171%{_includedir}/tomoe
172%{_libdir}/pkgconfig/*.pc
173%{_libdir}/*.so
174%{_datadir}/gtk-doc/html/tomoe
175
176%if %{with ruby}
177%files -n ruby-tomoe
178%defattr(-,root,root,-)
179%{rarchdir}/*.so.*
180%{rlibdir}/tomoe.rb
181
182%files -n ruby-tomoe-devel
183%defattr(-,root,root,-)
184%{rarchdir}/*.h
185%{rarchdir}/*.so
186%endif
187
188%changelog
189* Mon Nov 10 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.6.0-3
190- rebuilt on current VineSeed
191- added Patch1 and 2 from Fedora
192  * Tue Jul 24 2012  Peng Wu <pwu@redhat.com> - 0.6.0-22
193  - Fixes glib includes
194  * Tue Jun  2 2009 Ding-Yi Chen <dchen at redhat.com> - 0.6.0-14
195  - [Bug 502662] SCIM-tomoe doesn't load - no error msgs
196
197* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.0-2
198- rebuilt with rpm-4.8.1 for pkg-config
199
200* Sun May 31 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.6.0-1
201- new upstream release
202- added --disable-static in %%configure
203- applied tomoe-0.6.0-multiarch-conflict.patch
204
205* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.5.1-1vl5
206- applied new versioning policy, spec in utf-8
207- remove *.la
208
209* Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.1-0vl1
210- new upstream release
211
212* Sun Jan 07 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl3
213- disable ruby extension by default
214
215* Fri Jan 05 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl2
216- move from tomoe-devel to tomoe
217  - %%{_libdir}/tomoe/module/dict/*.so
218  - %%{_libdir}/tomoe/module/recognizer/*.so
219
220* Sat Dec 31 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl1
221- new upstream release
222- add BuildRequires: unzip
223- update %%files section
224
225* Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.4.0-0vl1
226- new upstream release
227- update dependencies
228  - drop BuildRequires: libxml2-devel, libxslt-devel, doxygen
229  - add BuildRequires:
230    - gtk-doc, libxslt, glib2-devel
231    - ruby-devel, ruby-gnome2-devel
232  - drop Requires: libxml2, libxslt
233  - add Requires: glib2
234- add new sub-package: ruby-tomoe
235
236* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.3.0-0vl2
237- oops, add Requires: libxml2, libxslt instead of *-devel
238
239* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.3.0-0vl1
240- new upstream release
241- add BuildRequires: libxml2-devel, libxslt-devel, doxygen
242- add Requires: pkgconfig to -devel package
243- update %%files
244
245* Mon Nov 07 2005 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.2.1-3vl1
246- initial release for Vine Linux
247- disable %%__libtoolize
248- add Japanase summary and description
249
250* Sat Sep 3 2005 Warren Togami <wtogami@redhat.com> - 0.2.1-3
251- some spec cleanup
252
253* Sat Sep 2 2005 Ryo Dairiki <ryo-dairiki@mbm.nifty.com> - 0.2.1-2
254- Sync with Jens's spec file
255
256* Wed Aug 31 2005 Ryo Dairiki <ryo-dairiki@mbm.nifty.com> - 0.2.1-1
257- Initial packaging for Extras
258
259* Fri Jul  1 2005 Ichiro Nakai <ichiro@n.email.ne.jp>
260- (0.2.0-1m)
261- version 0.2.0
262- add a package tomoe-devel
263- add %%post and %%postun sections
264
265* Wed Mar  2 2005 Ichiro Nakai <ichiro@n.email.ne.jp>
266- (0.1.1-1m)
267- initial package for Momonga Linux
268- import %%description from cooker
Note: See TracBrowser for help on using the repository browser.