source: projects/specs/trunk/t/tomoe-gtk/tomoe-gtk-vl.spec @ 521

Revision 521, 3.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define with_python     0
2
3%define _tomoe_ver      0.6.0
4
5Summary:        A class library for tomoe's GUI parts
6Summary(ja):    tomoe の GUI パーツのクラスライブラリ
7Name:           tomoe-gtk
8Version:        0.6.0
9Release:        1%{?_dist_release}
10Group:          System Environment/Libraries
11License:        LGPL
12URL:            http://tomoe.sourceforge.jp/
13Source0:        tomoe-gtk-%{version}.tar.gz
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  tomoe-devel >= %{_tomoe_ver}
16BuildRequires:  gtk2-devel >= 2.4.0, gtk-doc >= 1.4
17# does not currently build with gucharmap-2
18#BuildRequires:  gucharmap-devel
19Requires:       tomoe >= %{_tomoe_ver}
20Requires:       gtk2 >= 2.4.0
21Requires(post):         ldconfig
22Obsoletes:      libtomoe-gtk < 0.6.0
23
24%description
25The tomoe-gtk is a class library for tomoe's GUI parts.
26
27%description -l ja
28tomoe-gtk は tomoe の GUI パーツのクラスライブラリです。
29
30%package devel
31Summary:        Header files for developing tomoe-gtk applications
32Summary(ja):    tomoe-gtk アプリケーション開発用ヘッダファイル
33Group:          Development/Libraries
34Requires:       %{name} = %{version}-%{release}
35Requires:       tomoe-devel >= %{_tomoe_ver}
36Requires:       gucharmap-devel >= 1.4.0
37Requires:       pkgconfig
38Obsoletes:      libtomoe-gtk-devel < 0.6.0
39
40%description devel
41The tomoe-gtk-devel package includes the header files for the tomoe-gtk
42package.
43Install this package if you want to develop programs which use tomoe-gtk.
44
45%description -l ja devel
46tomoe-gtk-devel パッケージには、tomoe-gtk を使うアプリケーションを開発
47するためのヘッダファイルが含まれています。
48
49%if %{with_python}
50%package -n python-tomoe-gtk
51Summary:        tomoe-gtk library for Python binding
52Summary(ja):    Python から tomoe-gtk を使うためのライブラリ
53Group:          System Environment/Libraries
54Requires:       %{name} = %{version}-%{release}
55Requires:       python
56BuildRequires:  python-devel
57
58%description -n python-tomoe
59Python extension library to use tomoe-gtk
60
61%description -l ja -n python-tomoe
62Python から tomoe-gtk を使うための拡張ライブラリです。
63%endif
64
65
66%prep
67%setup -q
68
69%build
70%configure \
71    --disable-static \
72    --without-gucharmap
73
74%__make %{?_smp_mflags}
75
76%install
77%__rm -rf $RPM_BUILD_ROOT
78
79%makeinstall
80
81## remove unuse files
82find ${RPM_BUILD_ROOT} -name '*.la' | xargs rm
83
84%if !%{with_python}
85%__rm -f %{buildroot}%{_libdir}/python?.?/site-packages/gtk-?.?/tomoegtk.so
86%endif
87
88%find_lang %{name}
89
90%clean
91%__rm -rf %{buildroot}
92
93%post
94%{_syssbindir}/ldconfig
95
96%postun
97%{_syssbindir}/ldconfig
98
99
100%files -f %{name}.lang
101%defattr(-,root,root,-)
102%doc AUTHORS COPYING ChangeLog INSTALL
103%{_libdir}/*.so.*
104%{_datadir}/tomoe-gtk
105
106%files devel
107%defattr(-,root,root,-)
108%{_includedir}/tomoe/gtk/*.h
109%{_libdir}/pkgconfig/*.pc
110%{_libdir}/*.so
111%{_datadir}/gtk-doc/html/libtomoe-gtk
112
113
114%changelog
115* Sun May 31 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.6.0-1
116- new upstream release
117- added %%configure:
118  - --disable-static
119  - --without-gucharmap
120
121* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 0.5.1-1vl5
122- applied new versioning policy, spec in utf-8
123- removed *.la
124
125* Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.1-0vl1
126- new upstream release
127- drop obsolete test-fix.patch (patch0)
128
129* Mon Jan 08 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl2
130- add Requires: gucharmap-devel to -devel package
131
132* Mon Dec 31 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl1
133- new upstream release
134- update required version of tomoe
135- add test-fix.patch (patch0)
136- add Requires: tomoe-devel to -devel package
137- add BuildRequires: gtk-doc >= 1.4, gucharmap-devel >= 1.4.0
138
139* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.3.0-0vl1
140- new upstream release
141- update required-version of tomoe
142- add Requires: pkgconfig to -devel package
143- update %%files
144
145* Mon Nov 07 2005 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.1.0-0vl1
146- initial release for Vine Linux
Note: See TracBrowser for help on using the repository browser.