source: projects/specs/trunk/t/tmux/tmux-vl.spec @ 12131

Revision 12131, 4.8 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define ver 2.9a
2%define rel 1
3
4Name:           tmux
5Version:        %{ver}
6Release:        %{rel}%{?_dist_release}
7Summary:        A terminal multiplexer
8
9Group:          Applications/System
10# Most of the source is ISC licensed; some of the files in compat/ are 2 and
11# 3 clause BSD licensed.
12License:        ISC and BSD
13URL:            https://github.com/tmux/tmux
14Source0:        https://github.com/tmux/tmux/releases/download/%{version}/tmux-%{version}.tar.gz
15
16BuildRequires:  ncurses-devel
17BuildRequires:  libevent-devel
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23tmux is a "terminal multiplexer."  It enables a number of terminals (or
24windows) to be accessed and controlled from a single terminal.  tmux is
25intended to be a simple, modern, BSD-licensed alternative to programs such
26as GNU Screen.
27
28%prep
29%setup -q
30
31%build
32%configure
33make %{?_smp_mflags} LDFLAGS="%{optflags}"
34
35%install
36rm -rf %{buildroot}
37make install DESTDIR=%{buildroot} INSTALLBIN="install -p -m 755" INSTALLMAN="install -p -m 644"
38
39%post
40if [ ! -f %{_sysconfdir}/shells ] ; then
41    echo "%{_bindir}/tmux" > %{_sysconfdir}/shells
42else
43    grep -q "^%{_bindir}/tmux$" %{_sysconfdir}/shells || echo "%{_bindir}/tmux" >> %{_sysconfdir}/shells
44fi
45
46%files
47%defattr(-,root,root,-)
48%license COPYING
49%doc CHANGES FAQ TODO examples/
50%{_bindir}/tmux
51%{_mandir}/man1/tmux.1.*
52
53%changelog
54* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.9a-1
55- new upstream release.
56
57* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8-1
58- new upstream release.
59- built with libevent-2.1.8.
60
61* Thu Mar 31 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1-1
62- new upstream release
63- fixed %%doc in %%files
64
65* Fri Oct  4 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8-1
66- update to 1.8
67
68* Fri Jan 18 2013 IWAI, Masaharu <iwai@alib.jp> 1.7-1
69- initial build for Vine Linux
70
71* Sat Oct 13 2012 Sven Lankes <sven@lank.es> 1.7-1
72- New upstream release
73
74* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6-2
75- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
76
77* Tue Jan 31 2012 Sven Lankes <sven@lank.es> 1.6-1
78- New upstream release
79
80* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-2
81- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
82
83* Tue Nov 01 2011 Sven Lankes <sven@lank.es> 1.5-1
84- New upstream release
85- Do the right thing (tm) and revert to $upstream-behaviour:
86   No longer install tmux setgid and no longer use /var/run/tmux
87   for sockets. Use "tmux -S /var/run/tmux/tmux-`id -u`/default attach"
88   if you need to access an "old" tmux session
89- tmux can be used as a login shell so add it to /etc/shells
90
91* Sat Apr 16 2011 Sven Lankes <sven@lank.es> 1.4-4
92- Add /var/run/tmp to tmpdir.d - fixes rhbz 656704 and 697134
93
94* Sun Apr 10 2011 Sven Lankes <sven@lank.es> 1.4-3
95- Fix CVE-2011-1496
96- Fixes rhbz #693824
97
98* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-2
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
100
101* Tue Dec 28 2010 Filipe Rosset <rosset.filipe@gmail.com> 1.4-1
102- New upstream release
103
104* Fri Aug 06 2010 Filipe Rosset <filiperosset@fedoraproject.org> 1.3-2
105- Rebuild for F-13
106
107* Mon Jul 19 2010 Sven Lankes <sven@lank.es> 1.3-1
108- New upstream release
109
110* Sun Mar 28 2010 Sven Lankes <sven@lank.es> 1.2-1
111- New upstream release
112- rediff writehard patch
113
114* Mon Nov 09 2009 Sven Lankes <sven@lank.es> 1.1-1
115- New upstream release
116
117* Sun Nov 01 2009 Sven Lankes <sven@lank.es> 1.0-2
118- Add debian patches
119- Add tmux group for improved socket handling
120
121* Sat Oct 24 2009 Sven Lankes <sven@lank.es> 1.0-1
122- New upstream release
123
124* Mon Jul 13 2009 Chess Griffin <chess@chessgriffin.com> 0.9-1
125- Update to version 0.9.
126- Remove sed invocation as this was adopted upstream.
127- Remove optflags patch since upstream source now uses ./configure and
128  detects the flags when passed to make.
129
130* Tue Jun 23 2009 Chess Griffin <chess@chessgriffin.com> 0.8-5
131- Note that souce is mostly ISC licensed with some 2 and 3 clause BSD in
132  compat/.
133- Remove fixiquote.patch and instead use a sed invocation in setup.
134
135* Mon Jun 22 2009 Chess Griffin <chess@chessgriffin.com> 0.8-4
136- Add optimization flags by patching GNUmakefile and passing LDFLAGS
137  to make command.
138- Use consistent macro format.
139- Change examples/* to examples/ and add TODO to docs.
140
141* Sun Jun 21 2009 Chess Griffin <chess@chessgriffin.com> 0.8-3
142- Remove fixperms.patch and instead pass them at make install stage.
143
144* Sat Jun 20 2009 Chess Griffin <chess@chessgriffin.com> 0.8-2
145- Fix Source0 URL to point to correct upstream source.
146- Modify fixperms.patch to set 644 permissions on the tmux.1.gz man page.
147- Remove wildcards from 'files' section and replace with specific paths and
148  filenames.
149
150* Mon Jun 15 2009 Chess Griffin <chess@chessgriffin.com> 0.8-1
151- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.