source: projects/specs/trunk/t/tmux/tmux-vl.spec @ 11864

Revision 11864, 4.7 KB checked in by tomop, 6 years ago (diff)

tmux-2.8-1

Line 
1%define ver 2.8
2%define rel 1
3
4Name:           tmux
5Version:        %{ver}
6Release:        %{rel}%{?_dist_release}
7Summary:        A terminal multiplexer
8
9Group:          Applications/System
10# Most of the source is ISC licensed; some of the files in compat/ are 2 and
11# 3 clause BSD licensed.
12License:        ISC and BSD
13URL:            http://sourceforge.net/projects/tmux
14Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
15
16BuildRequires:  ncurses-devel
17BuildRequires:  libevent-devel
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23tmux is a "terminal multiplexer."  It enables a number of terminals (or
24windows) to be accessed and controlled from a single terminal.  tmux is
25intended to be a simple, modern, BSD-licensed alternative to programs such
26as GNU Screen.
27
28%prep
29%setup -q
30
31%build
32%configure
33make %{?_smp_mflags} LDFLAGS="%{optflags}"
34
35%install
36rm -rf %{buildroot}
37make install DESTDIR=%{buildroot} INSTALLBIN="install -p -m 755" INSTALLMAN="install -p -m 644"
38
39%post
40if [ ! -f %{_sysconfdir}/shells ] ; then
41    echo "%{_bindir}/tmux" > %{_sysconfdir}/shells
42else
43    grep -q "^%{_bindir}/tmux$" %{_sysconfdir}/shells || echo "%{_bindir}/tmux" >> %{_sysconfdir}/shells
44fi
45
46%files
47%defattr(-,root,root,-)
48%doc CHANGES COPYING FAQ TODO examples/
49%{_bindir}/tmux
50%{_mandir}/man1/tmux.1.*
51
52%changelog
53* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8-1
54- new upstream release.
55- built with libevent-2.1.8.
56
57* Thu Mar 31 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1-1
58- new upstream release
59- fixed %%doc in %%files
60
61* Fri Oct  4 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8-1
62- update to 1.8
63
64* Fri Jan 18 2013 IWAI, Masaharu <iwai@alib.jp> 1.7-1
65- initial build for Vine Linux
66
67* Sat Oct 13 2012 Sven Lankes <sven@lank.es> 1.7-1
68- New upstream release
69
70* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6-2
71- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
72
73* Tue Jan 31 2012 Sven Lankes <sven@lank.es> 1.6-1
74- New upstream release
75
76* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-2
77- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
78
79* Tue Nov 01 2011 Sven Lankes <sven@lank.es> 1.5-1
80- New upstream release
81- Do the right thing (tm) and revert to $upstream-behaviour:
82   No longer install tmux setgid and no longer use /var/run/tmux
83   for sockets. Use "tmux -S /var/run/tmux/tmux-`id -u`/default attach"
84   if you need to access an "old" tmux session
85- tmux can be used as a login shell so add it to /etc/shells
86
87* Sat Apr 16 2011 Sven Lankes <sven@lank.es> 1.4-4
88- Add /var/run/tmp to tmpdir.d - fixes rhbz 656704 and 697134
89
90* Sun Apr 10 2011 Sven Lankes <sven@lank.es> 1.4-3
91- Fix CVE-2011-1496
92- Fixes rhbz #693824
93
94* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-2
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
96
97* Tue Dec 28 2010 Filipe Rosset <rosset.filipe@gmail.com> 1.4-1
98- New upstream release
99
100* Fri Aug 06 2010 Filipe Rosset <filiperosset@fedoraproject.org> 1.3-2
101- Rebuild for F-13
102
103* Mon Jul 19 2010 Sven Lankes <sven@lank.es> 1.3-1
104- New upstream release
105
106* Sun Mar 28 2010 Sven Lankes <sven@lank.es> 1.2-1
107- New upstream release
108- rediff writehard patch
109
110* Mon Nov 09 2009 Sven Lankes <sven@lank.es> 1.1-1
111- New upstream release
112
113* Sun Nov 01 2009 Sven Lankes <sven@lank.es> 1.0-2
114- Add debian patches
115- Add tmux group for improved socket handling
116
117* Sat Oct 24 2009 Sven Lankes <sven@lank.es> 1.0-1
118- New upstream release
119
120* Mon Jul 13 2009 Chess Griffin <chess@chessgriffin.com> 0.9-1
121- Update to version 0.9.
122- Remove sed invocation as this was adopted upstream.
123- Remove optflags patch since upstream source now uses ./configure and
124  detects the flags when passed to make.
125
126* Tue Jun 23 2009 Chess Griffin <chess@chessgriffin.com> 0.8-5
127- Note that souce is mostly ISC licensed with some 2 and 3 clause BSD in
128  compat/.
129- Remove fixiquote.patch and instead use a sed invocation in setup.
130
131* Mon Jun 22 2009 Chess Griffin <chess@chessgriffin.com> 0.8-4
132- Add optimization flags by patching GNUmakefile and passing LDFLAGS
133  to make command.
134- Use consistent macro format.
135- Change examples/* to examples/ and add TODO to docs.
136
137* Sun Jun 21 2009 Chess Griffin <chess@chessgriffin.com> 0.8-3
138- Remove fixperms.patch and instead pass them at make install stage.
139
140* Sat Jun 20 2009 Chess Griffin <chess@chessgriffin.com> 0.8-2
141- Fix Source0 URL to point to correct upstream source.
142- Modify fixperms.patch to set 644 permissions on the tmux.1.gz man page.
143- Remove wildcards from 'files' section and replace with specific paths and
144  filenames.
145
146* Mon Jun 15 2009 Chess Griffin <chess@chessgriffin.com> 0.8-1
147- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.