source: projects/specs/trunk/t/tmux/tmux-vl.spec @ 10108

Revision 10108, 4.6 KB checked in by kudoh, 8 years ago (diff)

new upstream release

Line 
1%define ver 2.1
2%define rel 1
3
4Name:           tmux
5Version:        %{ver}
6Release:        %{rel}%{?_dist_release}
7Summary:        A terminal multiplexer
8
9Group:          Applications/System
10# Most of the source is ISC licensed; some of the files in compat/ are 2 and
11# 3 clause BSD licensed.
12License:        ISC and BSD
13URL:            http://sourceforge.net/projects/tmux
14Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
15
16BuildRequires:  ncurses-devel
17BuildRequires:  libevent-devel
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23tmux is a "terminal multiplexer."  It enables a number of terminals (or
24windows) to be accessed and controlled from a single terminal.  tmux is
25intended to be a simple, modern, BSD-licensed alternative to programs such
26as GNU Screen.
27
28%prep
29%setup -q
30
31%build
32%configure
33make %{?_smp_mflags} LDFLAGS="%{optflags}"
34
35%install
36rm -rf %{buildroot}
37make install DESTDIR=%{buildroot} INSTALLBIN="install -p -m 755" INSTALLMAN="install -p -m 644"
38
39%post
40if [ ! -f %{_sysconfdir}/shells ] ; then
41    echo "%{_bindir}/tmux" > %{_sysconfdir}/shells
42else
43    grep -q "^%{_bindir}/tmux$" %{_sysconfdir}/shells || echo "%{_bindir}/tmux" >> %{_sysconfdir}/shells
44fi
45
46%files
47%defattr(-,root,root,-)
48%doc CHANGES COPYING FAQ TODO examples/
49%{_bindir}/tmux
50%{_mandir}/man1/tmux.1.*
51
52%changelog
53* Thu Mar 31 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1-1
54- new upstream release
55- fixed %%doc in %%files
56
57* Fri Oct  4 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8-1
58- update to 1.8
59
60* Fri Jan 18 2013 IWAI, Masaharu <iwai@alib.jp> 1.7-1
61- initial build for Vine Linux
62
63* Sat Oct 13 2012 Sven Lankes <sven@lank.es> 1.7-1
64- New upstream release
65
66* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6-2
67- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
68
69* Tue Jan 31 2012 Sven Lankes <sven@lank.es> 1.6-1
70- New upstream release
71
72* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-2
73- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
74
75* Tue Nov 01 2011 Sven Lankes <sven@lank.es> 1.5-1
76- New upstream release
77- Do the right thing (tm) and revert to $upstream-behaviour:
78   No longer install tmux setgid and no longer use /var/run/tmux
79   for sockets. Use "tmux -S /var/run/tmux/tmux-`id -u`/default attach"
80   if you need to access an "old" tmux session
81- tmux can be used as a login shell so add it to /etc/shells
82
83* Sat Apr 16 2011 Sven Lankes <sven@lank.es> 1.4-4
84- Add /var/run/tmp to tmpdir.d - fixes rhbz 656704 and 697134
85
86* Sun Apr 10 2011 Sven Lankes <sven@lank.es> 1.4-3
87- Fix CVE-2011-1496
88- Fixes rhbz #693824
89
90* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-2
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
92
93* Tue Dec 28 2010 Filipe Rosset <rosset.filipe@gmail.com> 1.4-1
94- New upstream release
95
96* Fri Aug 06 2010 Filipe Rosset <filiperosset@fedoraproject.org> 1.3-2
97- Rebuild for F-13
98
99* Mon Jul 19 2010 Sven Lankes <sven@lank.es> 1.3-1
100- New upstream release
101
102* Sun Mar 28 2010 Sven Lankes <sven@lank.es> 1.2-1
103- New upstream release
104- rediff writehard patch
105
106* Mon Nov 09 2009 Sven Lankes <sven@lank.es> 1.1-1
107- New upstream release
108
109* Sun Nov 01 2009 Sven Lankes <sven@lank.es> 1.0-2
110- Add debian patches
111- Add tmux group for improved socket handling
112
113* Sat Oct 24 2009 Sven Lankes <sven@lank.es> 1.0-1
114- New upstream release
115
116* Mon Jul 13 2009 Chess Griffin <chess@chessgriffin.com> 0.9-1
117- Update to version 0.9.
118- Remove sed invocation as this was adopted upstream.
119- Remove optflags patch since upstream source now uses ./configure and
120  detects the flags when passed to make.
121
122* Tue Jun 23 2009 Chess Griffin <chess@chessgriffin.com> 0.8-5
123- Note that souce is mostly ISC licensed with some 2 and 3 clause BSD in
124  compat/.
125- Remove fixiquote.patch and instead use a sed invocation in setup.
126
127* Mon Jun 22 2009 Chess Griffin <chess@chessgriffin.com> 0.8-4
128- Add optimization flags by patching GNUmakefile and passing LDFLAGS
129  to make command.
130- Use consistent macro format.
131- Change examples/* to examples/ and add TODO to docs.
132
133* Sun Jun 21 2009 Chess Griffin <chess@chessgriffin.com> 0.8-3
134- Remove fixperms.patch and instead pass them at make install stage.
135
136* Sat Jun 20 2009 Chess Griffin <chess@chessgriffin.com> 0.8-2
137- Fix Source0 URL to point to correct upstream source.
138- Modify fixperms.patch to set 644 permissions on the tmux.1.gz man page.
139- Remove wildcards from 'files' section and replace with specific paths and
140  filenames.
141
142* Mon Jun 15 2009 Chess Griffin <chess@chessgriffin.com> 0.8-1
143- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.