source: projects/specs/trunk/t/tla/tla-vl.spec @ 521

Revision 521, 4.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        A version control system
2Summary(ja):    GNU Arch バージョンコントロールシステム
3Name:           tla
4Version:        1.3.5
5Release:        1%{?_dist_release}
6License:        GPLv2+
7Group:          Development/Tools
8URL:            http://www.gnu.org/software/gnu-arch/
9Source0:        ftp://ftp.gnu.org/gnu/gnu-arch/%{name}-%{version}.tar.gz
10Source1:        %{name}-generate-manpage.pl
11Source2:        %{name}-gpg-check.1
12
13Patch0:         %{name}-%{version}-alignment-hppa-sparc.patch
14Patch1:         %{name}-%{version}-neon.patch
15Patch2:         %{name}-%{version}-neon-327111.patch
16Patch3:         %{name}-%{version}-posix.patch
17Patch4:         %{name}-%{version}-remove-invariant.patch
18Patch5:         %{name}-%{version}-segfault-ia64.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22Requires:       diffutils
23Requires:       patch
24Requires:       tar
25
26BuildRequires:  check-devel
27BuildRequires:  neon-devel
28
29%description
30GNU Arch 1 (also known as tla) is a revision control system, similar in
31purpose to tools such as CVS, SCCS, and Subversion. It is used to keep track
32of the changes made to a source tree and to help programmers combine and
33otherwise manipulate changes made by multiple people or at different times.
34
35TLA is a punning acronym that stands for either "true love, always" and "three
36letter acronym".
37
38%prep
39%setup -q
40%patch0 -p1
41%patch1 -p1
42%patch2 -p1
43%patch3 -p1
44%patch4 -p1
45%patch5 -p1
46
47# Build against neon-devel.
48rm -rf ./src/libneon
49
50# Suppress rpmlint error.
51iconv --from-code ISO8859-1 --to-code UTF-8 ./src/tla/AUTHORS \
52  --output AUTHORS.utf-8 && mv AUTHORS.utf-8 ./src/tla/AUTHORS
53iconv --from-code ISO8859-1 --to-code UTF-8 ./src/tla/README \
54  --output README.utf-8 && mv README.utf-8 ./src/tla/README
55
56%build
57# configure script and Makefiles are not generated by Autoconf/Automake.
58mkdir -p ./build
59pushd ./build
60  ../src/configure \
61  --prefix=%{_prefix} --with-install-link-tools=yes --with-cc=%{__cc}
62  # Parallel make does not work.
63  make CFLAGS="$RPM_OPT_FLAGS $(neon-config --cflags)"
64
65  # Use only HTML and CSS files for documentation.
66  # To be later listed against %doc.
67  mkdir -p ./docs-tla
68  pushd ./docs-tla
69  find ../../src/docs-tla -name "*.css" -o -name "*.html" \
70  | xargs tar --atime-preserve -cf- \
71  | tar --atime-preserve -xf-
72  popd
73popd
74
75# man page
76mkdir -p ./debian/tmp
77PATH="`pwd`/build/tla/tla:$PATH" perl %{SOURCE1} tla.1
78
79%check
80pushd ./build
81  make test CFLAGS="$RPM_OPT_FLAGS $(neon-config --cflags)"
82popd
83
84%install
85rm -rf $RPM_BUILD_ROOT
86mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
87
88pushd ./build
89  # Makefiles use destdir instead of DESTDIR.
90  make install CFLAGS="$RPM_OPT_FLAGS $(neon-config --cflags)" \
91  destdir=$RPM_BUILD_ROOT
92popd
93
94# man page
95install -p -m644 ./debian/tmp/%{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
96install -p -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man1
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%files
102%defattr(-,root,root,-)
103%doc build/docs-tla/src/docs-tla
104%doc src/tla/AUTHORS
105%doc src/tla/README
106%{_bindir}/make-links
107%{_bindir}/%{name}
108%{_bindir}/remove-links
109%{_mandir}/man1/%{name}.1.gz
110%{_mandir}/man1/%{name}-gpg-check.1.gz
111
112%changelog
113* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.3.5-1
114- initial build for Vine Linux
115
116* Sat Feb 09 2008 Debarshi Ray <rishi@fedoraproject.org> - 1.3.5-5
117- Added 'BuildRequires: check-devel' for check stanza.
118
119* Wed Dec 12 2007 Debarshi Ray <rishi@fedoraproject.org> - 1.3.5-4
120- Added online manual page, and patches to fix alignment errors on HP-PA and
121  SPARC and segmentation fault on IA-64 from Debian.
122- Fixed sources to work with neon >= 0.27.2 for all distributions, except
123  Fedora 7. Closes Red Hat Bugzilla bug #327111.
124
125* Sun Nov 18 2007 Debarshi Ray <rishi@fedoraproject.org> - 1.3.5-3
126- Resolved CVS merge conflicts for Fedora 7.
127
128* Fri Nov 16 2007 Debarshi Ray <rishi@fedoraproject.org> - 1.3.5-2
129- Changed value of License to GPLv2+.
130
131* Sat Nov 10 2007 Debarshi Ray <rishi@fedoraproject.org> - 1.3.5-1
132- Initial build. Imported SPEC from Rawhide.
133- Added online manual page generator and patch to build against neon-devel
134  from Debian.
135- Added patch to test-dir-regexps.sh from SuSE.
136- Removed call to invariant to prevent failure on ppc. Closes Red Hat Bugzilla
137  bug #182742.
138- Disabled parallel make to prevent failure.
Note: See TracBrowser for help on using the repository browser.