source: projects/specs/trunk/t/tkscanfax/tkscanfax-vl.spec @ 521

Revision 521, 7.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1name: tkscanfax
2version: 1.01
3release: 1%{?_dist_release}
4summary: Tk/Tcl based GUI fax and scanner program
5summary(ja): GUIのFAXとScannerのプログラム
6License: GPL
7url: http://shino.pos.to/linux/tkscanfax.html
8group: Applications/Communications
9
10packager: Masaki SHINOMIYA <shino@pos.to>
11Vendor: Project Vine
12Distribution: Vine Linux
13source: http://shino.pos.to/linux/%{name}-%{version}.tar.gz
14
15prefix: %_prefix
16Buildarch: noarch
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18Requires: tk, tcl, ImageMagick, ghostscript, file
19Requires: netpbm-progs
20#^  most of distributions including Vine-2.5
21#Requires: libgr-progs    # for Vine-2.0/2.1.x
22#Requires: a2ps, psutils  # or,  mpage
23#Requires: efax >= 0.9a001114a6   # or, mgetty+sendfax
24#Requires: tetex, tetex-latex, tetex-ptex, tetex-dvips, tetex-fonts  # optional
25#Requires: pLaTeX2e, pTeX, dvipsk # optional for Vine-2.0/2.1.x
26#Requires: sane-backends          # optional
27
28%description
29TkFax, a Tk/Tcl based frontend of mgetty+sendfax or efax,
30combinated with TkScan, a frontend of scanner hanndling.
31It helps making the cover page, converting text files, postscript files and
32image files into fax file and sending. TkFax works with and without scanner.
33The efax program supports Class-1 faxmodems.
34%description -l ja
35Tcl/Tkで動くGUIのFAXプログラムTkFaxとスキャナプログラムTkScanです。
36 カバーページの作成やテキスト、ポストスクリプト、画像ファイルから
37 FAXページを作成、送信できます。またSANEなどと組合せスキャナも使えます。
38スキャナが無くてもFAXプログラムは動作します。
39 FAXプログラムにはefaxかmgetty+sendfaxが使えます。efaxを使えば
40 CLASS1コマンドのモデムもサポートできます。もちろん日本語も使えます。
41
42%prep
43%setup -q -n %{name}
44
45%build
46for i in tkscan tkfax; do
47sed "s,/usr/local,%{prefix}," $i > $i.tmp && ( mv $i.tmp $i; chmod +x $i )
48done
49
50mv doc/images/* images
51rmdir doc/images
52mv doc/* ./
53
54%install
55rm -rf $RPM_BUILD_ROOT
56mkdir -p $RPM_BUILD_ROOT%{prefix}/lib/%{name}
57cp -pR *.tcl  tkfax tkscan scan-drivers tex $RPM_BUILD_ROOT%{prefix}/lib/%{name}
58mkdir -p $RPM_BUILD_ROOT%{prefix}/lib/%{name}/images
59cp -R images/*.gif $RPM_BUILD_ROOT%{prefix}/lib/%{name}/images
60mkdir -p $RPM_BUILD_ROOT%{prefix}/bin
61for i in tkscan tkfax; do
62ln -sf %{prefix}/lib/%{name}/$i $RPM_BUILD_ROOT%{prefix}/bin/$i
63done
64
65
66# prepare applnk
67%define applnkdir /etc/X11/applnk/Applications
68%define icondir %{prefix}/share/pixmaps
69
70mkdir -p $RPM_BUILD_ROOT%{icondir}
71cp -p images/tkfax-s.xpm  $RPM_BUILD_ROOT%{icondir}
72
73mkdir -p $RPM_BUILD_ROOT/%{applnkdir}
74cat > $RPM_BUILD_ROOT/%{applnkdir}/%{name}.desktop <<EOF
75[Desktop Entry]
76Name=TkFax
77Comment=Sending and recieiving Fax
78Name[ja_JP.eucJP]=TkFax
79Comment[ja_JP.eucJP]=FAX送受信(TkFax)
80Exec=tkfax
81Icon=%{icondir}/tkfax-s.xpm
82Terminal=false
83MultipleArgs=false
84Type=Application
85EOF
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89#rm -rf $RPM_BUILD_DIR/%{name}
90
91%files
92%defattr(-, root, root)
93%{prefix}/bin/*
94%{prefix}/lib/%{name}/*-[^c]*.tcl
95#%{prefix}/lib/%{name}/fax-conf-win.tcl
96%{prefix}/lib/%{name}/msg*.tcl
97%config(noreplace) %{prefix}/lib/%{name}/tk*
98%config %{prefix}/lib/%{name}/*-conf.tcl
99#%config %{prefix}/lib/%{name}/*-conf_ja.tcl
100%config %{prefix}/lib/%{name}/tex/*
101%dir %{prefix}/lib/%{name}/tex
102%config %{prefix}/lib/%{name}/scan-drivers/*
103%dir %{prefix}/lib/%{name}/scan-drivers
104%{prefix}/lib/%{name}/images
105%dir %{prefix}/lib/%{name}
106%config(noreplace, missingok) %{icondir}/*
107%config(noreplace, missingok) %{applnkdir}/*.desktop
108%doc README* INSTALL* TRANSLATION  *.html images  *.sample* fax *.sh
109
110%changelog
111* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.01-1vl5
112- applied new versioning policy, spec in utf-8
113- s/Copyright/License/
114
115* Mon Apr 1 2002 Masaki Shinomiya <shino@pos.to>
116- 1.01-0vl1 for Vine-2.0/2.1.x, 1.01-0vl2 for Vine-2.5
117* Sun Mar 24 2002 Masaki Shinomiya <shino@pos.to>
118- version 1.01-1(/usr/doc) , -2(/usr/share/doc)
119- bugfix in making faxes using scanners
120
121* Sat Feb 2 2002 Masaki Shinomiya <shino@pos.to>
122- version 1.0-1(/usr/doc) , -2(/usr/share/doc), -0vl1 for Vine-2.x
123- log browser, bugfixes, requires
124
125* Sun Jan 20 2002 Masaki Shinomiya <shino@pos.to>
126- version 0.99final-1(/usr/doc) , -2(/usr/share/doc)
127- log browser
128
129* Mon Jan 14 2002 Masaki Shinomiya <shino@pos.to>
130- version 0.99f-1
131-  Keep fax pages of previous session.  Special charactors escaped. TkScan bugfix
132
133* Sun Dec 16 2001 Masaki Shinomiya <shino@pos.to>
134- version 0.99e-1
135- TkScan bugfix, fax spooling bugfix, fax spooling with LPRng
136- include fax script in doc
137
138* Sun Oct 21 2001 Masaki Shinomiya <shino@pos.to>
139- version 0.99d-1
140- fax spooling bugfix, english typo
141
142* Sun Oct 7 2001 Masaki Shinomiya <shino@pos.to>
143- version 0.99c-1
144- Support 'Fax Outgoing' box with efax spooling function.
145- Windows expandable
146- 'From', 'To' order in the cover page
147- error traps in fax^pbook.tcl
148- eliminate tex/cover-??.tex
149- include html documents on efax settings
150
151* Sat Sep 8 2001 Masaki Shinomiya <shino@pos.to>
152  - version 0.99b-1
153  - fixed  some system does not work properly  when calling dvips
154  - Japanese input method in Tk-8.3
155  - try to keep proper size in image conversion
156  - allow to run without LaTeX
157  - support 'a2ps' in place of 'mpage'
158  - automatic configuration in selecting some commands for the system
159  - configuration parameters
160  - improved error trap
161
162* Sat Aug 25 2001 Masaki Shinomiya <shino@pos.to>
163  - version 0.99a-1
164  - looking up env(LANG)
165  - fax-received box, fax print, fax view, english typo
166  - images in documents
167
168* Sun Jul 29 2001 Masaki Shinomiya <shino@pos.to>
169  - version 0.99-1, 1ja
170  - add english documents
171
172* Fri Jul 20 2001 Masaki Shinomiya <shino@pos.to>
173  - version 0.91j1-0.5
174  - Link with LyX in face cover page making, by Ryoji Kawagishi
175
176* Wed Jul 4 2001 Masaki Shinomiya <shino@pos.to>
177  - version 0.91j-0.5
178  - GUI for face cover page making, by Ryoji Kawagishi
179
180* Fri Jun 15 2001 Masaki Shinomiya <shino@pos.to>
181  - version 0.91-0.96e
182  - launch fax-received window after receive completed
183  - fixed misleading message after deleting fax page
184
185* Thu Jun 14 2001 Masaki Shinomiya <shino@pos.to>
186  - version 0.91-0.95e
187  - supports manual dialing
188  - new scanner driver for SHARP JX-250
189
190* Sun Jun 10 2001 Masaki Shinomiya <shino@pos.to>
191  - version 0.91-0.94e
192  - fixed the problem in launching tkscan alone
193
194* Sat Jun 9 2001 Masaki Shinomiya <shino@pos.to>
195  - version 0.91-0.93e
196  - halftoning in scanner drivers, misc bugs fix
197  - error logs to be colected in /var/log/fax
198  - build architechture is now noarch
199
200* Mon Jun 4 2001 Masaki Shinomiya <shino@pos.to>
201  - version 0.91-0.92e
202  - Fixed image conversion
203
204* Thu May 31 2001 Masaki Shinomiya <shino@pos.to>
205  - version 0.91-0.91e
206  - Fixed printing nomal-mode fax
207
208* Wed May 30 2001 Masaki Shinomiya <shino@pos.to>
209  - version 0.91-0.90e
210  - Fixed printing, phone book, scroll mouse support
211
212* Tue May 29 2001 Masaki Shinomiya <shino@pos.to>
213  - version 0.91-0.8efax2
214  - Fixed scanning, printing, pbm to tiffg3
215
216* Mon May 28 2001 Masaki Shinomiya <shino@pos.to>
217  - version 0.91-0.8efax1
218  - Japanese TeX tenplate by Ryoji Kawagishi <kawagisi@yk.rim.or.jp>
219  - bugfix in attaching text files
220
221* Tue May 23 2001 Masaki Shinomiya <shino@pos.to>
222  - version 0.91-0.8efax
223  - Implemented internationalization.
224  - Primitive epson-scanimage driver
Note: See TracBrowser for help on using the repository browser.