source: projects/specs/trunk/t/tk/tk-vl.spec @ 521

Revision 521, 8.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define majorver        8.4
2%define minorver        19
3Summary: A Tcl/Tk development environment: tk
4Summary(ja): Tcl/Tk 開発環境: tk
5Name: tk
6Version: %{majorver}.%{minorver}
7Release: 1%{?_dist_release}
8Group: Development/Languages
9License: BSD
10URL: http://tcl.sourceforge.net/
11Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
12Patch2: tk-8.4.12-lib-perm.patch
13Patch3: tk-8.4-lastevent.patch
14Patch4: tk-8.4.18-tkBind.patch 
15
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: tcl = %{version}, autoconf
18BuildRequires: libX11-devel
19Requires: tcl >= %{majorver}
20Provides: libtk%{majorver}.so
21
22%description
23Tk is a X Windows widget set designed to work closely with the tcl
24scripting language. It allows you to write simple programs with full
25featured GUI's in only a little more time then it takes to write a
26text based interface. Tcl/Tk applications can also be run on Windows
27and Macintosh platforms.
28
29%description -l ja
30Tk は tcl スクリプト言語と密接に動作するようにデザインされた X Window
31System のウィジェットセットです。 テキストベースのインターフェースを
32採用してるので、あらゆる特徴をもった GUI を少ない時間で、簡単なプログラ
33ムで書くことができます。Tcl/Tk アプリケーションは Windows や Macintosh
34のプラットフォームで実行することもできます。
35
36
37%prep
38%setup -n %{name}%{version} -q
39%patch2 -p1 -b .rolib
40%patch3 -p0 -b .lastevent
41%patch4 -p1 -b .tkbind
42cd unix
43autoconf
44
45
46%build
47cd unix
48%configure \
49        --with-tcl=%{_libdir} --enable-shared \
50        --enable-threads --enable-64bit --with-x
51
52make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/tk%{majorver}
53
54%install
55rm -rf $RPM_BUILD_ROOT
56make install -C unix INSTALL_ROOT=%{buildroot} TK_LIBRARY=%{_datadir}/tk%{majorver}
57ln -s wish%{majorver} %{buildroot}%{_bindir}/wish
58
59# for linking with -ltk
60ln -s libtk%{majorver}.so %{buildroot}%{_libdir}/libtk.so
61
62mkdirhier %buildroot/%{_includedir}/tk-private/{generic,unix}
63cp -p generic/{default,tkInt,tkIntDecls,tkPort}.h %buildroot/%{_includedir}/tk-private/generic
64cp -p unix/tkUnix{Default,Port}.h %buildroot/%{_includedir}/tk-private/unix
65
66# Fix up the include files.
67cp generic/*.h $RPM_BUILD_ROOT%{_includedir}/tk-private/generic
68cp unix/*.h $RPM_BUILD_ROOT%{_includedir}/tk-private/unix
69
70# remove buildroot traces
71perl -pi -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/tk-private|" %buildroot/%{_libdir}/tkConfig.sh
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post
77/sbin/ldconfig
78
79%postun
80/sbin/ldconfig
81
82%files
83%defattr(-,root,root,-)
84%doc
85%{_bindir}/wish*
86%{_datadir}/tk%{majorver}
87%{_libdir}/libtk%{majorver}.so
88%{_libdir}/tk%{majorver}
89%{_libdir}/tkConfig.sh
90%{_mandir}/man1/*
91%{_includedir}/*
92%{_libdir}/libtk.so
93%{_libdir}/libtkstub%{majorver}.a
94%{_mandir}/man3/*
95%{_mandir}/mann/*
96
97%changelog
98* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
99- new upstream release
100- add Patch3,4 to fix bug (broken if built with xproto-7.x)
101
102* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-2
103- spec in utf-8
104
105* Mon May 12 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
106- rebuild with xorg-x11-7.3
107  - remove Requires: XFree86-libs
108  - add BuildRequires: libX11-devel
109- use autoconf instead of autoconf217
110
111* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
112- updated tk to 8.4.18
113- included CVE-2008-0553
114
115* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
116- updated tk to 8.4.16
117
118* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
119- updated tk to 8.4.15
120- rebuilt with new toolchain
121
122* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
123- updated tk to 8.4.13
124
125* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
126- updated tk to 8.4.12
127- updated tk-%%{version}-lib-perm.patch
128
129* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.11-0vl1
130- dropped tk-8.3.5-tclm4-soname.patch (fixed tcl.m4)
131- replaced tk-8.4.4-lib-perm.patch with tk-8.4.11-lib-perm.patch
132- dropped tk-8.4.5-no_rpath.patch (fixed tcl.m4)
133- dropped tk-8.4.6-tkUnixWm.patch (fixed invalid 118n title)
134
135* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl2
136- added tk-8.4.6-tkUnixWm.patch
137
138* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
139- updated tk to 8.4.6
140
141* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
142- syncd with fedora
143  * Fri Dec 12 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-3
144  - add private header files needed to build tix in /usr/include/tk-private
145
146  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-2
147  - removed rpath (patch 3)
148
149  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
150  - new package split out from tcltk
151  - update to tk 8.4.5 (#88429)
152  - filtered changelog for tk
153  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
154  - remove build remnants from tkConfig.sh
155
156* Tue Apr 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl2
157- fix buildrequires and requires section
158
159* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
160- update based on BitWalk's tcltk-8.4.2-83bw
161
162* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
163- splite source package
164- add include files
165
166* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
167- expand some macros.. (FIXME)
168
169* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
170- use %configure macros
171- add Patch 47,50
172
173* Thu May 31 2001 <sagami@vinelinux.org>
174- 8.0.5_jp-10
175- unexpand old %%{configure}, new one causes build failure
176- fixed missing libtkx.so libtclx.so symlink in /usr/lib
177- install manpages into %%{_mandir} and mode 644
178
179* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
180- 8.0.5_jp-9
181- modified %install section to handle compressed man pages
182- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
183
184* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
185- changed default fonts
186
187* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
188- added defattr
189
190* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
191- added some symlinks, such as libtcl8.0.so.
192- obsoletes version number using _jp, now 8.0.5-31vl1
193
194* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
195- Apply Tcl/Tk 8.0 Japanese Patch 1.7
196
197* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
198- fix tclX symlinks.
199- compile on systems where SIGPWR == SIGLOST.
200
201* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
202- update tcl/tk to 8.0.5.
203- avoid "containing" in Tix (#2332).
204
205* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
206- use /usr/bin/write in kibitz (#1320).
207- use cirrus.sprl.umich.edu in weather (#1926).
208
209* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
210- auto rebuild in the new build environment (release 28)
211
212* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
213- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
214
215* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
216- expect does unaligned access on alpha (#989)
217- upgrade tcl/tk/tclX to 8.0.4
218- upgrade expect to 5.28.
219- add itcl 3.0.1
220
221* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
222- call libtoolize to allow building on the arm
223- build for glibc 2.1
224- strip binaries
225
226* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
227- update tcl/tk/tclX to 8.0.3, expect is updated also.
228
229* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
230- expect: mkpasswd needs delay before sending password (problem #576)
231
232* Thu May 07 1998 Prospector System <bugs@redhat.com>
233- translations modified for de, fr, tr
234
235* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
236- fixed expect binaries exec permissions
237
238* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
239- updated to Tix 4.1.0.006
240- updated version numbers of tcl/tk to relflect includsion of p2
241
242* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
243- updated tcl/tk to patch level 2
244- updated tclX to 8.0.2
245
246* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
247- fixed filelist for tix... replacing path to the expect binary in scripts
248  was leaving junk files around.
249
250* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
251- added patch to remove libieee test in configure.in for tcl and tk.
252  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
253  solution for all systems
254- fixed src urls
255
256* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
257- removed version numbers from descriptions
258
259* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
260- updated to tcl/tk 8.0 and related versions of packages
261
262* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
263- built against glibc
264- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.