source: projects/specs/trunk/t/tk/tk-vl.spec @ 12236

Revision 12236, 10.6 KB checked in by tomop, 5 years ago (diff)

updated 8 packages

expect-5.45.4-1

postgresql-12.0-1

python-2.7.16-4

python3-3.5.7-3

rp-pppoe-3.13-3

tcl-8.6.9-1

tix-8.4.3-4

tk-8.6.9-1

Line 
1%define majorver        8.6
2%define minorver        9
3Summary: A Tcl/Tk development environment: tk
4Summary(ja): Tcl/Tk 開発環境: tk
5Name: tk
6Version: %{majorver}.%{minorver}
7Release: 1%{?_dist_release}
8Group: Development/Languages
9License: TCL
10URL: https://tcl.sourceforge.net/
11Source0: https://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
12
13Buildroot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: autoconf
15BuildRequires: libX11-devel
16BuildRequires: libXft-devel
17BuildRequires: tcl-devel = %{version}
18Requires: tcl >= %{majorver}
19Provides: libtk%{majorver}.so
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24
25%description
26Tk is a X Windows widget set designed to work closely with the tcl
27scripting language. It allows you to write simple programs with full
28featured GUI's in only a little more time then it takes to write a
29text based interface. Tcl/Tk applications can also be run on Windows
30and Macintosh platforms.
31
32%description -l ja
33Tk は tcl スクリプト言語と密接に動作するようにデザインされた X Window
34System のウィジェットセットです。 テキストベースのインターフェースを
35採用してるので、あらゆる特徴をもった GUI を少ない時間で、簡単なプログラ
36ムで書くことができます。Tcl/Tk アプリケーションは Windows や Macintosh
37のプラットフォームで実行することもできます。
38
39%package devel
40Summary: Tk graphical toolkit development files
41Summary(ja): Tk ツールキットの開発環境
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44Requires: tcl-devel = %{version}
45Requires: libX11-devel
46Requires: libXft-devel
47
48%description devel
49Tk is a X Windows widget set designed to work closely with the tcl
50scripting language. It allows you to write simple programs with full
51featured GUI's in only a little more time then it takes to write a
52text based interface. Tcl/Tk applications can also be run on Windows
53and Macintosh platforms.
54
55The package contains the development files and man pages for tk.
56
57
58%prep
59%setup -n %{name}%{version} -q
60
61sed -i -e 's/555/755/g' unix/Makefile.in
62sed -i -e 's/@SHLIB_LD@/@SHLIB_LD@ -fPIC -Wl,-soname,libtk%{majorver}.so/' unix/Makefile.in
63
64%build
65cd unix
66autoconf
67
68export CFLAGS="%{optflags} -fPIC"
69%configure \
70--disable-rpath
71
72make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/%{name}%{majorver}
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TK_LIBRARY=%{_datadir}/%{name}%{majorver}
78
79ln -s wish%{majorver} $RPM_BUILD_ROOT%{_bindir}/wish
80
81# for linking with -l%{name}
82ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
83
84mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic/ttk,unix}
85find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
86( cd $RPM_BUILD_ROOT/%{_includedir}
87  for i in *.h ; do
88    [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
89  done
90)
91
92# remove buildroot traces
93sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
94rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tkAppInit.c
95rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/prolog.ps
96
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post -p /sbin/ldconfig
102
103%postun -p /sbin/ldconfig
104
105%files
106%defattr(-,root,root,-)
107%license license.terms
108%doc README changes
109%{_bindir}/wish*
110%{_datadir}/tk%{majorver}
111%{_libdir}/libtk%{majorver}.so
112%{_libdir}/tk%{majorver}
113%{_libdir}/tkConfig.sh
114%{_mandir}/man1/*
115%{_mandir}/mann/*
116
117%files devel
118%defattr(-,root,root)
119%{_includedir}/*
120%{_libdir}/libtk.so
121%{_libdir}/libtkstub%{majorver}.a
122%{_libdir}/tkConfig.sh
123%{_libdir}/pkgconfig/tk.pc
124%{_mandir}/man3/*
125
126%changelog
127* Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.9-1
128- new upstream release.
129- dropped Patch102: get same effects by sed and configure options.
130- dropped Patch101: get same effects by sed.
131- dropped Patch103: fixed in upstream.
132- dropped Patch105: fixed in upstream.
133
134* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.5.15-2
135- split development files into devel subpackage
136- added BR: libXft-devel
137
138* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-1
139- new upstream release
140- drop obsolete patche (Patch104)
141
142* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
143- update to 5.8.7: sync Red Hat Enterprise Linux 6 tk-8.4.19-4vl6
144- update License: TCL
145- drop obsolete patches
146 - lib-perm patch (Patch2)
147 - lastevent patch (Patch3)
148 - tkBind patch (Patch4)
149- add some patches from RHEL tk-8.5.7-6.el6
150 - make patch (Patch101)
151 - conf patch (Patch102)
152 - seg_input patch (Patch103)
153 - color patch (Patch104)
154 - nofont sigsegv patch (Patch105)
155- add some documents
156- update build and install section: sync RHEL tk-8.5.7-6.el6
157
158* Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
159- added "BuildRequires: imake".
160
161* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
162- rebuilt with rpm-4.8.1-3
163
164* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
165- rebuilt with tcl-8.4.19-2
166- dropt Patch4: tk-8.4.18-tkBind.patch
167
168* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
169- new upstream release
170- add Patch3,4 to fix bug (broken if built with xproto-7.x)
171
172* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-2
173- spec in utf-8
174
175* Mon May 12 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
176- rebuild with xorg-x11-7.3
177  - remove Requires: XFree86-libs
178  - add BuildRequires: libX11-devel
179- use autoconf instead of autoconf217
180
181* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
182- updated tk to 8.4.18
183- included CVE-2008-0553
184
185* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
186- updated tk to 8.4.16
187
188* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
189- updated tk to 8.4.15
190- rebuilt with new toolchain
191
192* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
193- updated tk to 8.4.13
194
195* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
196- updated tk to 8.4.12
197- updated tk-%%{version}-lib-perm.patch
198
199* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.11-0vl1
200- dropped tk-8.3.5-tclm4-soname.patch (fixed tcl.m4)
201- replaced tk-8.4.4-lib-perm.patch with tk-8.4.11-lib-perm.patch
202- dropped tk-8.4.5-no_rpath.patch (fixed tcl.m4)
203- dropped tk-8.4.6-tkUnixWm.patch (fixed invalid 118n title)
204
205* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl2
206- added tk-8.4.6-tkUnixWm.patch
207
208* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
209- updated tk to 8.4.6
210
211* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
212- syncd with fedora
213  * Fri Dec 12 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-3
214  - add private header files needed to build tix in /usr/include/tk-private
215
216  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-2
217  - removed rpath (patch 3)
218
219  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
220  - new package split out from tcltk
221  - update to tk 8.4.5 (#88429)
222  - filtered changelog for tk
223  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
224  - remove build remnants from tkConfig.sh
225
226* Tue Apr 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl2
227- fix buildrequires and requires section
228
229* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
230- update based on BitWalk's tcltk-8.4.2-83bw
231
232* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
233- splite source package
234- add include files
235
236* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
237- expand some macros.. (FIXME)
238
239* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
240- use %configure macros
241- add Patch 47,50
242
243* Thu May 31 2001 <sagami@vinelinux.org>
244- 8.0.5_jp-10
245- unexpand old %%{configure}, new one causes build failure
246- fixed missing libtkx.so libtclx.so symlink in /usr/lib
247- install manpages into %%{_mandir} and mode 644
248
249* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
250- 8.0.5_jp-9
251- modified %install section to handle compressed man pages
252- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
253
254* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
255- changed default fonts
256
257* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
258- added defattr
259
260* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
261- added some symlinks, such as libtcl8.0.so.
262- obsoletes version number using _jp, now 8.0.5-31vl1
263
264* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
265- Apply Tcl/Tk 8.0 Japanese Patch 1.7
266
267* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
268- fix tclX symlinks.
269- compile on systems where SIGPWR == SIGLOST.
270
271* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
272- update tcl/tk to 8.0.5.
273- avoid "containing" in Tix (#2332).
274
275* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
276- use /usr/bin/write in kibitz (#1320).
277- use cirrus.sprl.umich.edu in weather (#1926).
278
279* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
280- auto rebuild in the new build environment (release 28)
281
282* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
283- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
284
285* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
286- expect does unaligned access on alpha (#989)
287- upgrade tcl/tk/tclX to 8.0.4
288- upgrade expect to 5.28.
289- add itcl 3.0.1
290
291* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
292- call libtoolize to allow building on the arm
293- build for glibc 2.1
294- strip binaries
295
296* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
297- update tcl/tk/tclX to 8.0.3, expect is updated also.
298
299* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
300- expect: mkpasswd needs delay before sending password (problem #576)
301
302* Thu May 07 1998 Prospector System <bugs@redhat.com>
303- translations modified for de, fr, tr
304
305* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
306- fixed expect binaries exec permissions
307
308* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
309- updated to Tix 4.1.0.006
310- updated version numbers of tcl/tk to relflect includsion of p2
311
312* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
313- updated tcl/tk to patch level 2
314- updated tclX to 8.0.2
315
316* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
317- fixed filelist for tix... replacing path to the expect binary in scripts
318  was leaving junk files around.
319
320* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
321- added patch to remove libieee test in configure.in for tcl and tk.
322  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
323  solution for all systems
324- fixed src urls
325
326* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
327- removed version numbers from descriptions
328
329* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
330- updated to tcl/tk 8.0 and related versions of packages
331
332* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
333- built against glibc
334- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.