source: projects/specs/trunk/t/tk/tk-vl.spec @ 9294

Revision 9294, 10.5 KB checked in by inagaki, 9 years ago (diff)

2015-01-26 Ryoichi INAGAKI <ryo1@…>

  • hdf: updated
  • tcl, tk: split development files into devel subpackage


Line 
1%define majorver        8.5
2%define minorver        15
3Summary: A Tcl/Tk development environment: tk
4Summary(ja): Tcl/Tk 開発環境: tk
5Name: tk
6Version: %{majorver}.%{minorver}
7Release: 2%{?_dist_release}
8Group: Development/Languages
9License: TCL
10URL: http://tcl.sourceforge.net/
11Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
12# patches from Red Hat Enterprise Linux tk-8.5.7-6.el6
13Patch101: tk8.5-make.patch
14Patch102: tk8.5-conf.patch
15# this patch isn't needed since tk8.6b1
16Patch103: tk-seg_input.patch
17# fixes sigsegv if there is no font seen by fontconfig (#606671)
18Patch105: tk-8.5.7-nofont-sigsegv.patch
19
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: autoconf
22BuildRequires: libX11-devel
23BuildRequires: libXft-devel
24BuildRequires: tcl-devel = %{version}
25Requires: tcl >= %{majorver}
26Provides: libtk%{majorver}.so
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31
32%description
33Tk is a X Windows widget set designed to work closely with the tcl
34scripting language. It allows you to write simple programs with full
35featured GUI's in only a little more time then it takes to write a
36text based interface. Tcl/Tk applications can also be run on Windows
37and Macintosh platforms.
38
39%description -l ja
40Tk は tcl スクリプト言語と密接に動作するようにデザインされた X Window
41System のウィジェットセットです。 テキストベースのインターフェースを
42採用してるので、あらゆる特徴をもった GUI を少ない時間で、簡単なプログラ
43ムで書くことができます。Tcl/Tk アプリケーションは Windows や Macintosh
44のプラットフォームで実行することもできます。
45
46%package devel
47Summary: Tk graphical toolkit development files
48Summary(ja): Tk ツールキットの開発環境
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51Requires: tcl-devel = %{version}
52Requires: libX11-devel
53Requires: libXft-devel
54
55%description devel
56Tk is a X Windows widget set designed to work closely with the tcl
57scripting language. It allows you to write simple programs with full
58featured GUI's in only a little more time then it takes to write a
59text based interface. Tcl/Tk applications can also be run on Windows
60and Macintosh platforms.
61
62The package contains the development files and man pages for tk.
63
64
65%prep
66%setup -n %{name}%{version} -q
67
68%patch101 -p1 -b .make
69%patch102 -p1 -b .conf
70%patch103 -p1 -b .seg
71%patch105 -p1 -b .nofont-sigsegv
72
73%build
74cd unix
75autoconf
76%configure
77make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/%{name}%{majorver}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TK_LIBRARY=%{_datadir}/%{name}%{majorver}
83
84ln -s wish%{majorver} $RPM_BUILD_ROOT%{_bindir}/wish
85
86# for linking with -l%{name}
87ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
88
89mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic/ttk,unix}
90find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
91( cd $RPM_BUILD_ROOT/%{_includedir}
92  for i in *.h ; do
93    [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
94  done
95)
96
97# remove buildroot traces
98sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
99rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tkAppInit.c
100rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/prolog.ps
101
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -p /sbin/ldconfig
107
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(-,root,root,-)
112%doc README changes license.terms
113%{_bindir}/wish*
114%{_datadir}/tk%{majorver}
115%{_libdir}/libtk%{majorver}.so
116%{_libdir}/tk%{majorver}
117%{_libdir}/tkConfig.sh
118%{_mandir}/man1/*
119%{_mandir}/mann/*
120
121%files devel
122%defattr(-,root,root)
123%{_includedir}/*
124%{_libdir}/libtk.so
125%{_libdir}/libtkstub%{majorver}.a
126%{_libdir}/tkConfig.sh
127%{_mandir}/man3/*
128
129%changelog
130* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.5.15-2
131- split development files into devel subpackage
132- added BR: libXft-devel
133
134* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-1
135- new upstream release
136- drop obsolete patche (Patch104)
137
138* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
139- update to 5.8.7: sync Red Hat Enterprise Linux 6 tk-8.4.19-4vl6
140- update License: TCL
141- drop obsolete patches
142 - lib-perm patch (Patch2)
143 - lastevent patch (Patch3)
144 - tkBind patch (Patch4)
145- add some patches from RHEL tk-8.5.7-6.el6
146 - make patch (Patch101)
147 - conf patch (Patch102)
148 - seg_input patch (Patch103)
149 - color patch (Patch104)
150 - nofont sigsegv patch (Patch105)
151- add some documents
152- update build and install section: sync RHEL tk-8.5.7-6.el6
153
154* Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
155- added "BuildRequires: imake".
156
157* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
158- rebuilt with rpm-4.8.1-3
159
160* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
161- rebuilt with tcl-8.4.19-2
162- dropt Patch4: tk-8.4.18-tkBind.patch
163
164* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
165- new upstream release
166- add Patch3,4 to fix bug (broken if built with xproto-7.x)
167
168* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-2
169- spec in utf-8
170
171* Mon May 12 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
172- rebuild with xorg-x11-7.3
173  - remove Requires: XFree86-libs
174  - add BuildRequires: libX11-devel
175- use autoconf instead of autoconf217
176
177* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
178- updated tk to 8.4.18
179- included CVE-2008-0553
180
181* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
182- updated tk to 8.4.16
183
184* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
185- updated tk to 8.4.15
186- rebuilt with new toolchain
187
188* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
189- updated tk to 8.4.13
190
191* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
192- updated tk to 8.4.12
193- updated tk-%%{version}-lib-perm.patch
194
195* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.11-0vl1
196- dropped tk-8.3.5-tclm4-soname.patch (fixed tcl.m4)
197- replaced tk-8.4.4-lib-perm.patch with tk-8.4.11-lib-perm.patch
198- dropped tk-8.4.5-no_rpath.patch (fixed tcl.m4)
199- dropped tk-8.4.6-tkUnixWm.patch (fixed invalid 118n title)
200
201* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl2
202- added tk-8.4.6-tkUnixWm.patch
203
204* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
205- updated tk to 8.4.6
206
207* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
208- syncd with fedora
209  * Fri Dec 12 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-3
210  - add private header files needed to build tix in /usr/include/tk-private
211
212  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-2
213  - removed rpath (patch 3)
214
215  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
216  - new package split out from tcltk
217  - update to tk 8.4.5 (#88429)
218  - filtered changelog for tk
219  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
220  - remove build remnants from tkConfig.sh
221
222* Tue Apr 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl2
223- fix buildrequires and requires section
224
225* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
226- update based on BitWalk's tcltk-8.4.2-83bw
227
228* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
229- splite source package
230- add include files
231
232* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
233- expand some macros.. (FIXME)
234
235* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
236- use %configure macros
237- add Patch 47,50
238
239* Thu May 31 2001 <sagami@vinelinux.org>
240- 8.0.5_jp-10
241- unexpand old %%{configure}, new one causes build failure
242- fixed missing libtkx.so libtclx.so symlink in /usr/lib
243- install manpages into %%{_mandir} and mode 644
244
245* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
246- 8.0.5_jp-9
247- modified %install section to handle compressed man pages
248- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
249
250* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
251- changed default fonts
252
253* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
254- added defattr
255
256* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
257- added some symlinks, such as libtcl8.0.so.
258- obsoletes version number using _jp, now 8.0.5-31vl1
259
260* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
261- Apply Tcl/Tk 8.0 Japanese Patch 1.7
262
263* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
264- fix tclX symlinks.
265- compile on systems where SIGPWR == SIGLOST.
266
267* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
268- update tcl/tk to 8.0.5.
269- avoid "containing" in Tix (#2332).
270
271* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
272- use /usr/bin/write in kibitz (#1320).
273- use cirrus.sprl.umich.edu in weather (#1926).
274
275* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
276- auto rebuild in the new build environment (release 28)
277
278* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
279- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
280
281* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
282- expect does unaligned access on alpha (#989)
283- upgrade tcl/tk/tclX to 8.0.4
284- upgrade expect to 5.28.
285- add itcl 3.0.1
286
287* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
288- call libtoolize to allow building on the arm
289- build for glibc 2.1
290- strip binaries
291
292* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
293- update tcl/tk/tclX to 8.0.3, expect is updated also.
294
295* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
296- expect: mkpasswd needs delay before sending password (problem #576)
297
298* Thu May 07 1998 Prospector System <bugs@redhat.com>
299- translations modified for de, fr, tr
300
301* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
302- fixed expect binaries exec permissions
303
304* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
305- updated to Tix 4.1.0.006
306- updated version numbers of tcl/tk to relflect includsion of p2
307
308* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
309- updated tcl/tk to patch level 2
310- updated tclX to 8.0.2
311
312* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
313- fixed filelist for tix... replacing path to the expect binary in scripts
314  was leaving junk files around.
315
316* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
317- added patch to remove libieee test in configure.in for tcl and tk.
318  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
319  solution for all systems
320- fixed src urls
321
322* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
323- removed version numbers from descriptions
324
325* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
326- updated to tcl/tk 8.0 and related versions of packages
327
328* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
329- built against glibc
330- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.