source: projects/specs/trunk/t/tix/tix-vl.spec @ 521

Revision 521, 9.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define tcl_major       8.4
2%define tk_major        8.4
3%define thread_major    2.6
4%define tix_major       8.4
5%define tixversion      %{tix_major}.2
6Summary: A Tcl/Tk development environment: tix
7Summary(ja): Tcl/Tk 開発環境: tix
8Name: tix
9Version: %{tixversion}
10Release: 1%{?_dist_release}
11Group: Development/Languages
12License: BSD
13URL: http://tix.sourceforge.net/
14Source0: Tix%{tixversion}-src.tar.gz
15Patch20: tix-8.1.4-perf.patch
16Patch22: tix-8.2.0b1-dirtree.patch
17BuildRequires: tcl >= %{tcl_major}
18BuildRequires: tk >= %{tk_major}
19BuildRequires: thread >= %{thread_major}
20Requires: tcl >= %{tcl_major}
21Requires: tk >= %{tk_major}
22Requires: thread >= %{thread_major}
23Buildroot: %{_tmppath}/%{name}-%{version}-root
24
25%description -n tix
26Tix (Tk Interface Extension), an add-on for the Tk widget set, is an
27extensive set of over 40 widgets.  In general, Tix widgets are more
28complex and more capable than the widgets provided in Tk.  Tix widgets
29include a ComboBox, a Motif-style FileSelectBox, an MS Windows-style
30FileSelectBox, a PanedWindow, a NoteBook, a hierarchical list, a
31directory tree and a file manager.
32
33Install the tix package if you want to try out more complicated widgets
34for Tk.  You'll also need to have the tcl and tk packages installed.
35
36%description -n tix -l ja
37Tk ウィジェットセットのためのアドオンである、Tix (Tk Interface Extension)
38は 40 ウィジェットを超える拡張セットです。Tix ウィジェットの多くが、
39Tk から供給されるウィジェットよりも高機能です。Tix ウィジェットは
40コンボボックス、Motif スタイルのファイルボックス、MS Windows スタイルの
41ファイルボックス、パネルウィンドウ、ノートブック、階層リスト、
42ディレクトリツリー、ファイルマネージャを含んでいます。
43
44Tk で、より複雑ななウィジェットを試したい時には、tix パッケージをインストール
45してください。tcl と tk のパッケージもインストールする必要があります。
46
47
48%prep
49%setup -q -n Tix%{tixversion}
50%patch20 -p1 -b .perf
51%patch22 -p1 -b .dirtree
52
53%build
54# make the libraries reentrant
55RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
56%configure \
57        --with-tcl=%{_libdir} \
58        --with-tk=%{_libdir} \
59        --enable-shared \
60        --enable-threads \
61
62make %{?_smp_mflags} all
63
64%install
65rm -rf ${RPM_BUILD_ROOT}
66%makeinstall
67
68SOFILE=libTix%{version}.so
69mv $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE $RPM_BUILD_ROOT%{_libdir}
70ln -sf ../$SOFILE $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE
71ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix.so
72ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix%{tix_major}.so
73ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix.so
74ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
75
76install -d $RPM_BUILD_ROOT%{_mandir}/man1
77install -d $RPM_BUILD_ROOT%{_mandir}/mann
78install -m 644 man/tixwish.1 $RPM_BUILD_ROOT%{_mandir}/man1
79install -m 644 man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
80
81install -d $RPM_BUILD_ROOT%{_includedir}
82install -m 0644 generic/tix.h $RPM_BUILD_ROOT%{_includedir}/tix.h
83
84## others
85SHAREDDIR=$RPM_BUILD_ROOT%{_datadir}/tix-%{version}
86install -d $SHAREDDIR/demos/bitmaps
87install -d $SHAREDDIR/demos/samples
88install -m 755 demos/widget $SHAREDDIR/demos
89install -m 644 demos/{*.tcl,tclIndex}  $SHAREDDIR/demos
90install -m 644 demos/bitmaps/* $SHAREDDIR/demos/bitmaps
91install -m 644 demos/samples/* $SHAREDDIR/demos/samples
92cp -a tests $SHAREDDIR
93
94## * old scripts *
95## find . -type d -name CVS | xargs -r rm -frv
96## echo "%%defattr(-,root,root)" > tix.files
97## (find ${RPM_BUILD_ROOT}%{_bindir} \
98##         ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
99##  find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
100##         | sort | uniq -u >> tix.files
101##
102## set +x +H
103## for n in `cat tix.files`; do
104##         test -f $n || continue
105##         head -1 $n | grep -q ^#! || continue
106##         chmod u+w $n
107##         perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
108## done
109## set -x -H
110##
111## #==========================================
112## # post process the *.files list, removing build sys references and mark
113## # which are directories
114## set +x
115## for n in *.files; do
116##         mv $n $n.in
117##         sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
118##             if [ -d ${RPM_BUILD_ROOT}/$file ]; then
119##                 echo -n '%dir '
120##             fi
121##             echo $file
122##         done > $n
123##         rm -f $n.in
124## done
125## set -x
126##
127## # Man pages can be compressed
128## perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
129
130
131%post -p /sbin/ldconfig -n tix
132
133%postun -p /sbin/ldconfig -n tix
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%files -n tix
139%defattr(-,root,root,-)
140%doc ChangeLog README.txt man/html man/index.html
141%{_libdir}/lib*.so
142%{_libdir}/Tix%{version}
143%{_datadir}/tix-8.4.2
144%{_mandir}/man1/tixwish.1.gz
145%{_mandir}/mann/*.n.gz
146%{_includedir}/*.h
147
148
149%changelog
150* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
151- applied new versioning policy
152
153* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
154- rebuild with tcl/tk-8.4.18
155
156* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
157- rebuild with tcl/tk-8.4.16
158
159* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl1
160- updated tix to 8.4.2
161- rebuilt with new toolchain
162
163* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl5
164- rebuild for tcl/tk-8.4.12, and x86_64 architecture support
165
166* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl4
167- changed url to http://tix.sourceforge.net/download.shtml
168- rebuild for tcl/tk-8.4.11
169
170* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl3
171- rebuild for tcl/tk-8.4.6
172
173* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl2
174- rebuild for tcl/tk-8.4.5
175
176* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl1
177- update based on BitWalk's tcltk-8.4.2-83bw
178
179* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
180- splite source package
181
182* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
183- expand some macros.. (FIXME)
184
185* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
186- use %configure macros
187- add Patch 47,50
188
189* Thu May 31 2001 <sagami@vinelinux.org>
190- 8.0.5_jp-10
191- unexpand old %%{configure}, new one causes build failure
192- fixed missing libtkx.so libtclx.so symlink in /usr/lib
193- install manpages into %%{_mandir} and mode 644
194
195* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
196- 8.0.5_jp-9
197- modified %install section to handle compressed man pages
198- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
199
200* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
201- changed default fonts
202
203* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
204- added defattr
205
206* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
207- added some symlinks, such as libtcl8.0.so.
208- obsoletes version number using _jp, now 8.0.5-31vl1
209
210* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
211- Apply Tcl/Tk 8.0 Japanese Patch 1.7
212
213* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
214- fix tclX symlinks.
215- compile on systems where SIGPWR == SIGLOST.
216
217* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
218- update tcl/tk to 8.0.5.
219- avoid "containing" in Tix (#2332).
220
221* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
222- use /usr/bin/write in kibitz (#1320).
223- use cirrus.sprl.umich.edu in weather (#1926).
224
225* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
226- auto rebuild in the new build environment (release 28)
227
228* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
229- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
230
231* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
232- expect does unaligned access on alpha (#989)
233- upgrade tcl/tk/tclX to 8.0.4
234- upgrade expect to 5.28.
235- add itcl 3.0.1
236
237* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
238- call libtoolize to allow building on the arm
239- build for glibc 2.1
240- strip binaries
241
242* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
243- update tcl/tk/tclX to 8.0.3, expect is updated also.
244
245* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
246- expect: mkpasswd needs delay before sending password (problem #576)
247
248* Thu May 07 1998 Prospector System <bugs@redhat.com>
249- translations modified for de, fr, tr
250
251* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
252- fixed expect binaries exec permissions
253
254* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
255- updated to Tix 4.1.0.006
256- updated version numbers of tcl/tk to relflect includsion of p2
257
258* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
259- updated tcl/tk to patch level 2
260- updated tclX to 8.0.2
261
262* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
263- fixed filelist for tix... replacing path to the expect binary in scripts
264  was leaving junk files around.
265
266* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
267- added patch to remove libieee test in configure.in for tcl and tk.
268  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
269  solution for all systems
270- fixed src urls
271
272* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
273- removed version numbers from descriptions
274
275* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
276- updated to tcl/tk 8.0 and related versions of packages
277
278* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
279- built against glibc
280- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.