source: projects/specs/trunk/t/tix/tix-vl.spec @ 2747

Revision 2747, 9.5 KB checked in by owa, 13 years ago (diff)

tix-8.4.3-1

Line 
1%define tcl_major       8.4
2%define tk_major        8.4
3%define thread_major    2.6
4%define tix_major       8.4
5%define tixversion      %{tix_major}.3
6## can't find all provides
7#define _use_internal_dependency_generator 0
8
9Summary: A Tcl/Tk development environment: tix
10Summary(ja): Tcl/Tk 開発環境: tix
11Name: tix
12Version: %{tixversion}
13Release: 1%{?_dist_release}
14Group: Development/Languages
15License: BSD
16URL: http://tix.sourceforge.net/
17Source0: Tix%{tixversion}-src.tar.gz
18Patch20: tix-8.1.4-perf.patch
19Patch22: tix-8.2.0b1-dirtree.patch
20BuildRequires: tcl >= %{tcl_major}
21BuildRequires: tk >= %{tk_major}
22BuildRequires: thread >= %{thread_major}
23Requires: tcl >= %{tcl_major}
24Requires: tk >= %{tk_major}
25Requires: thread >= %{thread_major}
26Buildroot: %{_tmppath}/%{name}-%{version}-root
27
28%description
29Tix (Tk Interface Extension), an add-on for the Tk widget set, is an
30extensive set of over 40 widgets.  In general, Tix widgets are more
31complex and more capable than the widgets provided in Tk.  Tix widgets
32include a ComboBox, a Motif-style FileSelectBox, an MS Windows-style
33FileSelectBox, a PanedWindow, a NoteBook, a hierarchical list, a
34directory tree and a file manager.
35
36Install the tix package if you want to try out more complicated widgets
37for Tk.  You'll also need to have the tcl and tk packages installed.
38
39%description -l ja
40Tk ウィジェットセットのためのアドオンである、Tix (Tk Interface Extension)
41は 40 ウィジェットを超える拡張セットです。Tix ウィジェットの多くが、
42Tk から供給されるウィジェットよりも高機能です。Tix ウィジェットは
43コンボボックス、Motif スタイルのファイルボックス、MS Windows スタイルの
44ファイルボックス、パネルウィンドウ、ノートブック、階層リスト、
45ディレクトリツリー、ファイルマネージャを含んでいます。
46
47Tk で、より複雑ななウィジェットを試したい時には、tix パッケージをインストール
48してください。tcl と tk のパッケージもインストールする必要があります。
49
50
51%prep
52%setup -q -n Tix%{tixversion}
53#patch20 -p1 -b .perf
54#patch22 -p1 -b .dirtree
55
56%build
57# make the libraries reentrant
58RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
59%configure \
60        --with-tcl=%{_libdir} \
61        --with-tk=%{_libdir} \
62        --enable-shared \
63        --disable-threads \
64        ;
65
66make %{?_smp_mflags} all
67
68%install
69rm -rf ${RPM_BUILD_ROOT}
70%makeinstall
71
72SOFILE=libTix%{version}.so
73mv $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE $RPM_BUILD_ROOT%{_libdir}
74ln -sf ../$SOFILE $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE
75ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix.so
76ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix%{tix_major}.so
77ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix.so
78## internal_dependency_generator can't find provides
79#ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
80cp -p ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
81
82install -d $RPM_BUILD_ROOT%{_mandir}/man1
83install -d $RPM_BUILD_ROOT%{_mandir}/mann
84install -m 644 man/tixwish.1 $RPM_BUILD_ROOT%{_mandir}/man1
85install -m 644 man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
86
87install -d $RPM_BUILD_ROOT%{_includedir}
88install -m 0644 generic/tix.h $RPM_BUILD_ROOT%{_includedir}/tix.h
89
90## others
91SHAREDDIR=$RPM_BUILD_ROOT%{_datadir}/tix-%{version}
92install -d $SHAREDDIR/demos/bitmaps
93install -d $SHAREDDIR/demos/samples
94install -m 755 demos/widget $SHAREDDIR/demos
95install -m 644 demos/{*.tcl,tclIndex}  $SHAREDDIR/demos
96install -m 644 demos/bitmaps/* $SHAREDDIR/demos/bitmaps
97install -m 644 demos/samples/* $SHAREDDIR/demos/samples
98cp -a tests $SHAREDDIR
99
100## * old scripts *
101## find . -type d -name CVS | xargs -r rm -frv
102## echo "%%defattr(-,root,root)" > tix.files
103## (find ${RPM_BUILD_ROOT}%{_bindir} \
104##         ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
105##  find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
106##         | sort | uniq -u >> tix.files
107##
108## set +x +H
109## for n in `cat tix.files`; do
110##         test -f $n || continue
111##         head -1 $n | grep -q ^#! || continue
112##         chmod u+w $n
113##         perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
114## done
115## set -x -H
116##
117## #==========================================
118## # post process the *.files list, removing build sys references and mark
119## # which are directories
120## set +x
121## for n in *.files; do
122##         mv $n $n.in
123##         sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
124##             if [ -d ${RPM_BUILD_ROOT}/$file ]; then
125##                 echo -n '%dir '
126##             fi
127##             echo $file
128##         done > $n
129##         rm -f $n.in
130## done
131## set -x
132##
133## # Man pages can be compressed
134## perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
135
136
137%post -p /sbin/ldconfig
138%postun -p /sbin/ldconfig
139%clean
140rm -rf $RPM_BUILD_ROOT
141
142%files
143%defattr(-,root,root,-)
144%{_libdir}/libTix*.so
145%{_libdir}/libtix*.so
146%{_libdir}/Tix%{version}
147%{_datadir}/tix-%{tixversion}
148%{_mandir}/man1/tixwish.1.gz
149%{_mandir}/mann/*.n.gz
150%{_includedir}/*.h
151%doc ChangeLog README.txt man/html man/index.html
152
153
154%changelog
155* Tue Feb 22 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
156- updated tix to 8.4.3
157- dropt tix-8.1.4-perf.patch
158- dropt tix-8.2.0b1-dirtree.patch
159- added "cp -p libTix8.4.3.so libtix8.4.so"
160- rebuilt with file-5.05-2
161
162* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
163- rebuilt with tcl/tk-8.4.19-2
164
165* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
166- applied new versioning policy
167
168* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
169- rebuild with tcl/tk-8.4.18
170
171* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
172- rebuild with tcl/tk-8.4.16
173
174* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl1
175- updated tix to 8.4.2
176- rebuilt with new toolchain
177
178* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl5
179- rebuild for tcl/tk-8.4.12, and x86_64 architecture support
180
181* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl4
182- changed url to http://tix.sourceforge.net/download.shtml
183- rebuild for tcl/tk-8.4.11
184
185* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl3
186- rebuild for tcl/tk-8.4.6
187
188* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl2
189- rebuild for tcl/tk-8.4.5
190
191* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl1
192- update based on BitWalk's tcltk-8.4.2-83bw
193
194* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
195- splite source package
196
197* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
198- expand some macros.. (FIXME)
199
200* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
201- use %configure macros
202- add Patch 47,50
203
204* Thu May 31 2001 <sagami@vinelinux.org>
205- 8.0.5_jp-10
206- unexpand old %%{configure}, new one causes build failure
207- fixed missing libtkx.so libtclx.so symlink in /usr/lib
208- install manpages into %%{_mandir} and mode 644
209
210* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
211- 8.0.5_jp-9
212- modified %install section to handle compressed man pages
213- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
214
215* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
216- changed default fonts
217
218* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
219- added defattr
220
221* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
222- added some symlinks, such as libtcl8.0.so.
223- obsoletes version number using _jp, now 8.0.5-31vl1
224
225* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
226- Apply Tcl/Tk 8.0 Japanese Patch 1.7
227
228* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
229- fix tclX symlinks.
230- compile on systems where SIGPWR == SIGLOST.
231
232* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
233- update tcl/tk to 8.0.5.
234- avoid "containing" in Tix (#2332).
235
236* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
237- use /usr/bin/write in kibitz (#1320).
238- use cirrus.sprl.umich.edu in weather (#1926).
239
240* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
241- auto rebuild in the new build environment (release 28)
242
243* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
244- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
245
246* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
247- expect does unaligned access on alpha (#989)
248- upgrade tcl/tk/tclX to 8.0.4
249- upgrade expect to 5.28.
250- add itcl 3.0.1
251
252* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
253- call libtoolize to allow building on the arm
254- build for glibc 2.1
255- strip binaries
256
257* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
258- update tcl/tk/tclX to 8.0.3, expect is updated also.
259
260* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
261- expect: mkpasswd needs delay before sending password (problem #576)
262
263* Thu May 07 1998 Prospector System <bugs@redhat.com>
264- translations modified for de, fr, tr
265
266* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
267- fixed expect binaries exec permissions
268
269* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
270- updated to Tix 4.1.0.006
271- updated version numbers of tcl/tk to relflect includsion of p2
272
273* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
274- updated tcl/tk to patch level 2
275- updated tclX to 8.0.2
276
277* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
278- fixed filelist for tix... replacing path to the expect binary in scripts
279  was leaving junk files around.
280
281* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
282- added patch to remove libieee test in configure.in for tcl and tk.
283  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
284  solution for all systems
285- fixed src urls
286
287* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
288- removed version numbers from descriptions
289
290* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
291- updated to tcl/tk 8.0 and related versions of packages
292
293* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
294- built against glibc
295- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.