source: projects/specs/trunk/t/tix/tix-vl.spec @ 12277

Revision 12277, 9.5 KB checked in by tomop, 5 years ago (diff)

updated 22 packages

Cython-0.29.13-1

alsa-lib-1.1.9-1

alsa-plugins-1.1.9-1

alsa-tools-1.1.7-1

alsa-utils-1.1.9-1

cairo-1.16.0-1

evince-3.30.3-1

expat-2.2.9-1

file-roller-3.30.1-1

gtk-doc-1.32-2

libplist-2.0.0-1

libsndfile-1.0.28-1

ncurses-6.1-2

openssh-8.1p1-1

python-2.7.16-5

python3-3.5.7-4

rsync-3.1.3-1

samba-4.10.9-1

sudo-1.8.28-1

sysstat-12.1.7-1

tix-8.4.3-5

zabbix-4.0.13-1

Line 
1%{!?tcl_version: %global tcl_version %(echo 'puts $tcl_version' | tclsh)}
2%{!?tcl_sitearch: %global tcl_sitearch %{_libdir}/tcl%{tcl_version}}
3%{!?tcl_sitelib: %global tcl_sitelib %{_datadir}/tcl%{tcl_version}}
4
5%define tcl_major       8.6
6%define tk_major        8.6
7%define thread_major    2.8
8%define tix_major       8.4
9%define tixversion      %{tix_major}.3
10## can't find all provides
11#define _use_internal_dependency_generator 0
12
13Summary: A Tcl/Tk development environment: tix
14Summary(ja): Tcl/Tk 開発環境: tix
15Name: tix
16Version: %{tixversion}
17Release: 5%{?_dist_release}
18Group: Development/Languages
19License: BSD
20Vendor: Project Vine
21Distribution: Vine Linux
22
23URL: http://tix.sourceforge.net/
24Source0: Tix%{tixversion}-src.tar.gz
25#  0: Fixes BZ#81297 (soname of libraries)
26Patch0: tix-8.4.2-link.patch
27Patch1: tix-8.4.3-tcl86.patch
28Patch2: tix-8.4.3-covscan-fixes.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: tcl-devel >= %{tcl_major}
32BuildRequires: tk-devel >= %{tk_major}
33BuildRequires: tcl-thread
34BuildRequires: libX11-devel
35Requires: tcl >= %{tcl_major}
36Requires: tk >= %{tk_major}
37Requires: tcl-thread
38
39%description
40Tix (Tk Interface Extension), an add-on for the Tk widget set, is an
41extensive set of over 40 widgets.  In general, Tix widgets are more
42complex and more capable than the widgets provided in Tk.  Tix widgets
43include a ComboBox, a Motif-style FileSelectBox, an MS Windows-style
44FileSelectBox, a PanedWindow, a NoteBook, a hierarchical list, a
45directory tree and a file manager.
46
47Install the tix package if you want to try out more complicated widgets
48for Tk.  You'll also need to have the tcl and tk packages installed.
49
50%description -l ja
51Tk ウィジェットセットのためのアドオンである、Tix (Tk Interface Extension)
52は 40 ウィジェットを超える拡張セットです。Tix ウィジェットの多くが、
53Tk から供給されるウィジェットよりも高機能です。Tix ウィジェットは
54コンボボックス、Motif スタイルのファイルボックス、MS Windows スタイルの
55ファイルボックス、パネルウィンドウ、ノートブック、階層リスト、
56ディレクトリツリー、ファイルマネージャを含んでいます。
57
58Tk で、より複雑ななウィジェットを試したい時には、tix パッケージをインストール
59してください。tcl と tk のパッケージもインストールする必要があります。
60
61
62%prep
63%setup -q -n Tix%{tixversion}
64%patch0 -p1 -b .link
65%patch1 -p1 -b .tcl86
66%patch2 -p1 -b .covscan-fixes
67
68# Remove executable permission of images in html documentation
69chmod ugo-x docs/html/gif/tix/*.png docs/html/gif/tix/*.gif \
70  docs/html/gif/tix/*/*.gif
71
72# Fix end-of-line encoding
73sed -i 's/\r//' docs/Release-8.4.0.txt
74
75%build
76# make the libraries reentrant
77RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
78%configure \
79        --libdir=%{tcl_sitearch} \
80        --with-tcl=%{_libdir} \
81        --with-tk=%{_libdir} \
82        --enable-shared \
83        --disable-threads \
84        ;
85
86make %{?_smp_mflags} all PKG_LIB_FILE=libTix.so
87
88%install
89rm -rf ${RPM_BUILD_ROOT}
90make install DESTDIR=$RPM_BUILD_ROOT PKG_LIB_FILE=libTix.so
91
92# move shared lib to tcl sitearch
93mv $RPM_BUILD_ROOT%{tcl_sitearch}/Tix%{version}/libTix.so \
94        $RPM_BUILD_ROOT%{tcl_sitearch}/
95
96# make links
97ln -sf ../libTix.so \
98        $RPM_BUILD_ROOT%{tcl_sitearch}/Tix%{version}/libTix.so
99ln -sf tcl%{tcl_version}/Tix%{version}/libTix.so $RPM_BUILD_ROOT%{_libdir}/libTix.so
100ln -sf tcl%{tcl_version}/Tix%{version}/libTix.so $RPM_BUILD_ROOT%{_libdir}/libtix.so
101
102install -d $RPM_BUILD_ROOT%{_mandir}/man1
103install -d $RPM_BUILD_ROOT%{_mandir}/mann
104install -m 644 man/tixwish.1 $RPM_BUILD_ROOT%{_mandir}/man1
105install -m 644 man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
106
107install -d $RPM_BUILD_ROOT%{_includedir}
108install -m 0644 generic/tix.h $RPM_BUILD_ROOT%{_includedir}/tix.h
109
110## others
111SHAREDDIR=$RPM_BUILD_ROOT%{_datadir}/tix-%{version}
112install -d $SHAREDDIR/demos/bitmaps
113install -d $SHAREDDIR/demos/samples
114install -m 755 demos/widget $SHAREDDIR/demos
115install -m 644 demos/{*.tcl,tclIndex}  $SHAREDDIR/demos
116install -m 644 demos/bitmaps/* $SHAREDDIR/demos/bitmaps
117install -m 644 demos/samples/* $SHAREDDIR/demos/samples
118cp -a tests $SHAREDDIR
119
120
121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%files
127%defattr(-,root,root,-)
128%{tcl_sitearch}/libTix.so
129%{tcl_sitearch}/Tix%{version}
130%{_datadir}/tix-%{tixversion}
131%{_mandir}/man1/tixwish.1.gz
132%{_libdir}/libtix.so
133%{_libdir}/libTix.so
134%{_includedir}/*.h
135%{_mandir}/mann/*.n.gz
136%doc ChangeLog README.txt man/html man/index.html
137
138
139%changelog
140* Tue Oct 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.3-5
141- moved .so to fix warnings of ldconfig.
142
143* Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.3-4
144- rebuilt with tcl/tk-8.6.9.
145- dropped all patches.
146- imported Patch0-2 from rawhide.
147
148* Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.4.3-3
149- rebuilt with tcl/tk 8.5.15 and thread 2.7.1
150
151* Thu Feb 24 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-2
152- added BR: libX11-devel
153
154* Tue Feb 22 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
155- updated tix to 8.4.3
156- dropt tix-8.1.4-perf.patch
157- dropt tix-8.2.0b1-dirtree.patch
158- added "cp -p libTix8.4.3.so libtix8.4.so"
159- rebuilt with file-5.05-2
160
161* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
162- rebuilt with tcl/tk-8.4.19-2
163
164* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
165- applied new versioning policy
166
167* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
168- rebuild with tcl/tk-8.4.18
169
170* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
171- rebuild with tcl/tk-8.4.16
172
173* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl1
174- updated tix to 8.4.2
175- rebuilt with new toolchain
176
177* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl5
178- rebuild for tcl/tk-8.4.12, and x86_64 architecture support
179
180* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl4
181- changed url to http://tix.sourceforge.net/download.shtml
182- rebuild for tcl/tk-8.4.11
183
184* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl3
185- rebuild for tcl/tk-8.4.6
186
187* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl2
188- rebuild for tcl/tk-8.4.5
189
190* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl1
191- update based on BitWalk's tcltk-8.4.2-83bw
192
193* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
194- splite source package
195
196* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
197- expand some macros.. (FIXME)
198
199* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
200- use %configure macros
201- add Patch 47,50
202
203* Thu May 31 2001 <sagami@vinelinux.org>
204- 8.0.5_jp-10
205- unexpand old %%{configure}, new one causes build failure
206- fixed missing libtkx.so libtclx.so symlink in /usr/lib
207- install manpages into %%{_mandir} and mode 644
208
209* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
210- 8.0.5_jp-9
211- modified %install section to handle compressed man pages
212- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
213
214* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
215- changed default fonts
216
217* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
218- added defattr
219
220* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
221- added some symlinks, such as libtcl8.0.so.
222- obsoletes version number using _jp, now 8.0.5-31vl1
223
224* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
225- Apply Tcl/Tk 8.0 Japanese Patch 1.7
226
227* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
228- fix tclX symlinks.
229- compile on systems where SIGPWR == SIGLOST.
230
231* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
232- update tcl/tk to 8.0.5.
233- avoid "containing" in Tix (#2332).
234
235* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
236- use /usr/bin/write in kibitz (#1320).
237- use cirrus.sprl.umich.edu in weather (#1926).
238
239* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
240- auto rebuild in the new build environment (release 28)
241
242* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
243- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
244
245* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
246- expect does unaligned access on alpha (#989)
247- upgrade tcl/tk/tclX to 8.0.4
248- upgrade expect to 5.28.
249- add itcl 3.0.1
250
251* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
252- call libtoolize to allow building on the arm
253- build for glibc 2.1
254- strip binaries
255
256* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
257- update tcl/tk/tclX to 8.0.3, expect is updated also.
258
259* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
260- expect: mkpasswd needs delay before sending password (problem #576)
261
262* Thu May 07 1998 Prospector System <bugs@redhat.com>
263- translations modified for de, fr, tr
264
265* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
266- fixed expect binaries exec permissions
267
268* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
269- updated to Tix 4.1.0.006
270- updated version numbers of tcl/tk to relflect includsion of p2
271
272* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
273- updated tcl/tk to patch level 2
274- updated tclX to 8.0.2
275
276* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
277- fixed filelist for tix... replacing path to the expect binary in scripts
278  was leaving junk files around.
279
280* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
281- added patch to remove libieee test in configure.in for tcl and tk.
282  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
283  solution for all systems
284- fixed src urls
285
286* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
287- removed version numbers from descriptions
288
289* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
290- updated to tcl/tk 8.0 and related versions of packages
291
292* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
293- built against glibc
294- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.