source: projects/specs/trunk/t/tinyxml/tinyxml-vl.spec @ 647

Revision 647, 3.1 KB checked in by kudoh, 14 years ago (diff)
Line 
1%define underscore_version 2_6_1
2
3Name:           tinyxml
4Version:        2.6.1
5Release:        1%{?_dist_release}
6Summary:        A simple, small, C++ XML parser
7Summary(ja):    シンプルで小さな C++ XML パーサー
8Group:          System Environment/Libraries
9License:        zlib
10URL:            http://www.grinninglizard.com/tinyxml/
11Source0:        http://downloads.sourceforge.net/%{name}/%{name}_%{underscore_version}.tar.gz
12Patch0:         tinyxml-2.5.3-stl.patch
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15%description
16TinyXML is a simple, small, C++ XML parser that can be easily integrating
17into other programs. Have you ever found yourself writing a text file parser
18every time you needed to save human readable data or serialize objects?
19TinyXML solves the text I/O file once and for all.
20(Or, as a friend said, ends the Just Another Text File Parser problem.)
21
22
23%package        devel
24Summary:        Development files for %{name}
25Summary(ja):    %{name} の開発ファイル
26Group:          Development/Libraries
27Requires:       %{name} = %{version}-%{release}
28
29%description    devel
30The %{name}-devel package contains libraries and header files for
31developing applications that use %{name}.
32
33
34%prep
35%setup -q -n %{name}
36%patch0 -p1 -b .stl
37touch -r tinyxml.h.stl tinyxml.h
38
39
40%build
41# Not really designed to be build as lib, DYI
42for i in tinyxml.cpp tinystr.cpp tinyxmlerror.cpp tinyxmlparser.cpp; do
43  g++ $RPM_OPT_FLAGS -fPIC -o $i.o -c $i
44done
45g++ $RPM_OPT_FLAGS -shared -o lib%{name}.so.0.%{version} \
46   -Wl,-soname,lib%{name}.so.0 *.cpp.o
47
48
49%install
50rm -rf $RPM_BUILD_ROOT
51# Not really designed to be build as lib, DYI
52mkdir -p $RPM_BUILD_ROOT%{_libdir}
53mkdir -p $RPM_BUILD_ROOT%{_includedir}
54install -m 755 lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}
55ln -s lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.0
56ln -s lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
57install -p -m 644 %{name}.h $RPM_BUILD_ROOT%{_includedir}
58
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63
64%post -p /sbin/ldconfig
65
66%postun -p /sbin/ldconfig
67
68
69%files
70%defattr(-,root,root,-)
71%doc changes.txt readme.txt
72%{_libdir}/*.so.*
73
74%files devel
75%defattr(-,root,root,-)
76%doc docs/*
77%{_includedir}/*
78%{_libdir}/*.so
79
80
81%changelog
82* Tue Mar 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.6.1-1
83- new upstream release
84
85* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.6.0-1
86- new upstream release
87- applied new naming policy to spec
88- added summary(ja)
89
90* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.3-3
91- rebuilt with new toolchain
92
93* Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.5.3-2vl5
94- fixed %BuildRoot
95- spec in UTF-8
96
97* Wed Jan 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.5.3-1vl5
98- initial build for VineSeed
99- import Fedora's 2.5.3-3
100
101* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.5.3-3
102- Autorebuild for GCC 4.3
103
104* Fri Dec 14 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.5.3-2
105- Various improvements from review (bz 407571)
106
107* Fri Nov 30 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.5.3-1
108- Initial Fedora Package
Note: See TracBrowser for help on using the repository browser.