source: projects/specs/trunk/t/tinyxml/tinyxml-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define underscore_version 2_5_3
2
3Name:           tinyxml
4Version:        2.5.3
5Release:        3%{?_dist_release}
6Summary:        A simple, small, C++ XML parser
7Group:          System Environment/Libraries
8License:        zlib
9URL:            http://www.grinninglizard.com/tinyxml/
10Source0:        http://downloads.sourceforge.net/%{name}/%{name}_%{underscore_version}.tar.gz
11Patch0:         tinyxml-2.5.3-stl.patch
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14%description
15TinyXML is a simple, small, C++ XML parser that can be easily integrating
16into other programs. Have you ever found yourself writing a text file parser
17every time you needed to save human readable data or serialize objects?
18TinyXML solves the text I/O file once and for all.
19(Or, as a friend said, ends the Just Another Text File Parser problem.)
20
21
22%package        devel
23Summary:        Development files for %{name}
24Group:          Development/Libraries
25Requires:       %{name} = %{version}-%{release}
26
27%description    devel
28The %{name}-devel package contains libraries and header files for
29developing applications that use %{name}.
30
31
32%prep
33%setup -q -n %{name}
34%patch0 -p1 -b .stl
35touch -r tinyxml.h.stl tinyxml.h
36
37
38%build
39# Not really designed to be build as lib, DYI
40for i in tinyxml.cpp tinystr.cpp tinyxmlerror.cpp tinyxmlparser.cpp; do
41  g++ $RPM_OPT_FLAGS -fPIC -o $i.o -c $i
42done
43g++ $RPM_OPT_FLAGS -shared -o lib%{name}.so.0.%{version} \
44   -Wl,-soname,lib%{name}.so.0 *.cpp.o
45
46
47%install
48rm -rf $RPM_BUILD_ROOT
49# Not really designed to be build as lib, DYI
50mkdir -p $RPM_BUILD_ROOT%{_libdir}
51mkdir -p $RPM_BUILD_ROOT%{_includedir}
52install -m 755 lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}
53ln -s lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.0
54ln -s lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
55install -p -m 644 %{name}.h $RPM_BUILD_ROOT%{_includedir}
56
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61
62%post -p /sbin/ldconfig
63
64%postun -p /sbin/ldconfig
65
66
67%files
68%defattr(-,root,root,-)
69%doc changes.txt readme.txt
70%{_libdir}/*.so.*
71
72%files devel
73%defattr(-,root,root,-)
74%doc docs/*
75%{_includedir}/*
76%{_libdir}/*.so
77
78
79%changelog
80* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.3-3
81- rebuilt with new toolchain
82
83* Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.5.3-2vl5
84- fixed %BuildRoot
85- spec in UTF-8
86
87* Wed Jan 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.5.3-1vl5
88- initial build for VineSeed
89- import Fedora's 2.5.3-3
90
91* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.5.3-3
92- Autorebuild for GCC 4.3
93
94* Fri Dec 14 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.5.3-2
95- Various improvements from review (bz 407571)
96
97* Fri Nov 30 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.5.3-1
98- Initial Fedora Package
Note: See TracBrowser for help on using the repository browser.