source: projects/specs/trunk/t/tinycdb/tinycdb-vl.spec @ 10143

Revision 10143, 2.7 KB checked in by ara_t, 8 years ago (diff)

initial release

Line 
1%define pkg_name    tinycdb
2%define pkg_version 0.78
3%define pkg_release 2%{?_dist_release}
4
5Summary: A package for maintenance of constant databases
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: Public Domain
11Group:   Applications/System
12URL:     http://www.corpit.ru/mjt/tinycdb.html
13
14Source:  http://www.corpit.ru/mjt/tinycdb/%{name}-%{version}.tar.gz
15BuildRoot: %{_tmppath}/%{name}-root
16BuildRequires: build-essential
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: ara_t
21
22
23%description
24tinycdb is a small, fast and reliable utility set and subroutine
25library for creating and reading constant databases. The database
26structure is tuned for fast reading:
27+ Successful lookups take normally just two disk accesses.
28+ Unsuccessful lookups take only one disk access.
29+ Small disk space and memory size requirements; a database
30  uses 2048 bytes for the header and 24 bytes plus size of
31  (key,value) per record.
32+ Maximum database size is 4GB; individual record size is not
33  otherwise limited.
34+ Portable file format.
35+ Fast creation of new databases.
36+ No locking, updates are atomical.
37
38This package contains both the utility and the development
39files, together with nss_cdb module.
40
41
42%package devel
43Summary: Development files for the tinycdb library.
44Group:   Development/Libraries
45Requires: %{name} = %{version}-%{release}
46
47%description devel
48tinycdb is a small, fast and reliable utility set and subroutine
49library for creating and reading constant databases.
50
51This package contains tinycdb development libraries and header files.
52
53
54%package devel-static
55Summary: Development files for the tinycdb static library.
56Group:   Development/Libraries
57Requires: %{name}-devel = %{version}-%{release}
58
59%description devel-static
60Static library for tinycdb
61
62
63%prep
64%setup -q
65
66%build
67%{__make} CFLAGS="$RPM_OPT_FLAGS" \
68          staticlib sharedlib cdb-shared nss \
69          sysconfdir=/etc
70
71%install
72%{__rm} -rf ${RPM_BUILD_ROOT}
73%{__mkdir} -p ${RPM_BUILD_ROOT}
74%{make_install} \
75 libdir=%{_libdir} bindir=%{_bindir} mandir=%{_mandir} \
76 syslibdir=%{_libdir} sysconfdir=/etc \
77 includedir=%{_includedir} \
78 install-all install-nss install-piclib install-sharedlib
79
80%clean
81%{__rm} -rf ${RPM_BUILD_ROOT}
82
83%post -p %{_syssbindir}/ldconfig
84%postun -p %{_syssbindir}/ldconfig
85
86
87%files
88%defattr(-,root,root)
89%{_bindir}/*
90%{_mandir}/man1/*
91%{_mandir}/man3/*
92%{_mandir}/man5/*
93%{_libdir}/libcdb.so*
94%{_libdir}/libnss_cdb*
95/etc/cdb-Makefile
96%doc ChangeLog NEWS debian/changelog
97
98%files devel
99%defattr(-,root,root)
100%{_includedir}/*
101
102%files devel-static
103%defattr(-,root,root)
104%{_libdir}/libcdb.a
105%{_libdir}/libcdb_pic.a
106
107
108%changelog
109* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 0.78-2
110- correct SPEC file
111
112* Mon Jul 13 2015 Toshiaki Ara <ara_t@384.jp> 0.78-1
113- Initial release
Note: See TracBrowser for help on using the repository browser.