source: projects/specs/trunk/t/timeconfig/timeconfig-vl.spec @ 521

Revision 521, 5.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Text mode tools for setting system time parameters.
2Summary(ja): システムの時間のパラメータを設定するテキストモードのツール
3Name: timeconfig
4Version: 3.0.3
5Release: 4%{?_dist_release}
6License: GPL
7Group: Applications/System
8Source: timeconfig-%{version}.tar.gz
9Source1: timeconfig.ja.po
10Source2: setclock.8
11Source3: timeconfig.8
12Patch0: timeconfig.vine.patch
13Patch1: timeconfig-3.0.3-mandir.patch
14Patch2: timeconfig-3.0.3-checkbox.patch
15Requires: initscripts >= 2.81, glibc >= 2.0.5-5
16Requires(post): coreutils, gawk
17BuildRequires: newt-devel
18Buildroot: %{_tmppath}/%{name}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24The timeconfig package contains two utilities:  timeconfig and setclock.
25Timeconfig provides a simple text mode tool for configuring the time
26parameters in /etc/sysconfig/clock and /etc/localtime. The setclock tool
27sets the hardware clock on the system to the current time stored in the
28system clock.
29
30%description -l ja
31timeconfig パッケージは二つのユーティリティを含んでいます: timeconfig と
32setclock です。timeconfig /etc/sysconfig/clock と /etc/localtime の
33時間のパラメータを設定するシンプルなテキストモードのツールを供給します。
34setclock ツールはシステムクロックに入っている現在の時間をシステムの
35ハードウェアクロックにセットします。
36
37%prep
38%setup -q
39%patch0 -p1
40%patch1 -p1
41%patch2 -p1
42
43#copy ja.po
44cp %{SOURCE1} po/ja.po
45
46%build
47make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
48
49%install
50rm -rf $RPM_BUILD_ROOT
51make PREFIX=$RPM_BUILD_ROOT MANDIR=%{_mandir} install
52rm -f %{_libdir}/zoneinfo
53
54mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8/
55install -m 644 %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/ja/man8/
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%post
61if [ -L /etc/localtime ]; then
62    _FNAME=`ls -ld /etc/localtime | awk '{ print $11}' | sed 's/lib/share/'`
63    rm /etc/localtime
64    cp -f $_FNAME /etc/localtime
65    if ! grep -q "^ZONE=" /etc/sysconfig/clock ; then
66      echo "ZONE=\"$_FNAME"\" | sed -e "s|[^\"]*/usr/share/zoneinfo/||" >> /etc/sysconfig/clock
67    fi
68fi
69
70%files
71%defattr(-,root,root)
72%{_sbindir}/timeconfig
73%{_sbindir}/setclock
74%{_localedir}/*/LC_MESSAGES/timeconfig.mo
75%{_mandir}/man8/*
76%{_mandir}/ja/man8/timeconfig.8*
77%{_mandir}/ja/man8/setclock.8*
78
79%changelog
80* Thu Aug 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.3-4vl5
81- rebuild with newt-0.52
82
83* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.3-3vl5
84- applied new versioning policy, spec in utf-8
85
86* Sat Oct 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.3-2vl6
87- add BuildRequires: newt-devel
88
89* Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.3-2vl5
90- rebuild to add gpg sign
91- use License:
92
93* Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
94- 3.0.3-2vl4
95- change checkbox color
96- use better macros
97
98* Sat Jun 09 2001 <sagami@vinelinux.org>
99- 3.0.3-2vl3: install manpage into _mandir and mode 644
100- fixed typo in ja.po
101
102* Thu Jul 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
103- 3.0.3-2vl2
104- modified %files section to handle compressed man pages
105
106* Thu Jun  1 2000 Jun Nishii <jun@vinelinux.org>
107- 3.0.3-2vl1
108
109* Sat Sep 9 1999 Norihito Ohmori <ohmori@flatout.org>
110- added Japanese descrition and summary
111- change default timezone to Japan
112- add Japanese Message Catalog
113- add Japanese Man Page
114
115* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
116- rebuilt against newt 0.50
117
118* Thu Jul 29 1999 Bill Nottingham <notting@redhat.com>
119- fix %post
120
121* Thu Jul  8 1999 Bill Nottingham <notting@redhat.com>
122- fix %post
123
124* Mon Jun 21 1999 Bill Nottingham <notting@redhat.com>
125- fix link in %post, too...
126
127* Wed Jun 16 1999 Bill Nottingham <notting@redhat.com>
128- copy file to /etc/localtime, don't link it
129- add a field to /etc/sysconfig/clock to point to the actual file
130
131* Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
132- release for Red Hat Linux 6.0
133
134* Tue Mar  9 1999 Jeff Johnson <jbj@redhat.com>
135- add in_ID.po
136
137* Sun Jan 10 1999 Matt Wilson <msw@redhat.com>
138- rebuilt against newt 0.40
139
140* Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
141- add ru.po.
142
143* Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
144- built for Raw Hide (slang-1.2.2)
145
146* Thu Oct 08 1998 Cristian Gafton <gafton@redhat.com>
147- updated czech translation (and use cs instead of cz)
148
149* Fri Sep 25 1998 Arnaldo Carvalho de Melo <acme@conectiva.com.br>
150- added pt_BR translations
151- pt_BR man translations
152- man tree, with Makefile
153- top level Makefile calls make -C po clean & make -C man install
154
155* Fri Sep 25 1998 Jeff Johnson <jbj@redhat.com>
156- add sr.po.
157
158* Sun Aug 02 1998 Erik Troan <ewt@redhat.com>
159- added NEWT_FLAG_SCROLL to listbox creation for newt 0.30
160- added --test
161
162* Fri Jun 05 1998 Erik Troan <ewt@redhat.com>
163- return 0 on success
164
165* Thu May 07 1998 Erik Troan <ewt@redhat.com>
166- many more translations
167
168* Mon Apr 20 1998 Erik Troan <ewt@redhat.com>
169- uses a build root
170- added de and en_RN translations
171
172* Mon Mar 23 1998 Erik Troan <ewt@redhat.com>
173- shortended window a bit -- white (rather, blue) space is a good thing
174
175* Sun Mar 22 1998 Erik Troan <ewt@redhat.com>
176- added --back option
177
178* Sat Oct 11 1997 Erik Troan <ewt@redhat.com>
179- use proper flags for hwclock
180
181* Tue Sep 16 1997 Erik Troan <ewt@redhat.com>
182- instead of creating /usr/lib/zoneinfo, just update /etc/localtime
183
184* Wed Sep 10 1997 Erik Troan <ewt@redhat.com>
185- look for zoneinfo in /usr/share instead of /usr/lib
186- provide /usr/lib/zoneinfo symlink
Note: See TracBrowser for help on using the repository browser.