source: projects/specs/trunk/t/tigervnc/tigervnc-vl.spec @ 9453

Revision 9453, 25.7 KB checked in by munepi, 9 years ago (diff)

new file: t/tigervnc/tigervnc-vl.spec

Line 
1Name:           tigervnc
2Version:        1.4.3
3Release:        1%{?_dist_release}
4Summary:        A TigerVNC remote display system
5Group:          User Interface/Desktops
6License:        GPLv2+
7URL:            http://www.tigervnc.com
8
9Source0:        %{name}-%{version}.tar.gz
10Source1:        vncserver.service
11Source2:        vncserver.sysconfig
12Source3:        10-libvnc.conf
13Source6:        vncviewer.desktop
14
15#[ad-hoc] xorg-x11-server-source: has no hw/xfree86/Xorg.sh.in
16Source1000:     Xorg.sh.in
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19
20Provides:       vnc = 4.1.3, vnc-libs = 4.1.3, vnc-server = 4.1.3
21Obsoletes:      vnc < 4.1.3, vnc-libs < 4.1.3, vnc-server < 4.1.3
22
23BuildRequires:  automake, autoconf, libtool, gettext
24BuildRequires:  libX11-devel
25BuildRequires:  libXext-devel, xorg-x11-server-source, libXi-devel
26BuildRequires:  xorg-x11-xtrans-devel, xorg-x11-util-macros, libXtst-devel
27BuildRequires:  libdrm-devel, libXt-devel, pixman-devel libXfont-devel
28BuildRequires:  libxkbfile-devel, openssl-devel, libpciaccess-devel
29BuildRequires:  mesa-libGL-devel, libXinerama-devel, ImageMagick
30BuildRequires:  freetype2-devel, libXdmcp-devel
31BuildRequires:  desktop-file-utils, java-devel, jpackage-utils
32BuildRequires:  libjpeg-turbo-devel, gnutls-devel, pam-devel
33BuildRequires:  cmake, fltk-devel
34
35Requires(post): coreutils
36Requires(postun):coreutils
37
38Requires:       hicolor-icon-theme
39
40Patch1:         tigervnc-cookie.patch
41Patch2:         tigervnc11-ldnow.patch
42Patch3:         tigervnc-libvnc-os.patch
43Patch4:         tigervnc11-rh692048.patch
44Patch5:         tigervnc-inetd-nowait.patch
45Patch7:         tigervnc-manpages.patch
46Patch8:         tigervnc-getmaster.patch
47Patch9:         tigervnc-shebang.patch
48Patch11:        tigervnc-format-security.patch
49Patch14:        tigervnc-xstartup.patch
50Patch15:        tigervnc-xserver117.patch
51
52# This is tigervnc-%{version}/unix/xserver116.patch rebased on the latest xorg
53Patch100:       tigervnc-xserver116-rebased.patch
54
55%description
56Virtual Network Computing (VNC) is a remote display system which
57allows you to view a computing 'desktop' environment not only on the
58machine where it is running, but from anywhere on the Internet and
59from a wide variety of machine architectures.
60This package contains a client which will allow you to connect to
61other desktops running a VNC server.
62
63%package server
64Summary:        A TigerVNC server
65Group:          User Interface/X
66Provides:       vnc = 4.1.3, vnc-libs = 4.1.3, vnc-server = 4.1.3
67Obsoletes:      vnc < 4.1.3, vnc-libs < 4.1.3, vnc-server < 4.1.3
68Requires:       perl
69Requires:       xorg-x11-xauth, xorg-x11-xinit, xorg-x11-server-Xorg
70Requires:       mesa-dri-drivers, xkeyboard-config, xorg-x11-xkb-utils
71Requires(post): chkconfig
72Requires(preun):chkconfig
73Requires(preun):initscripts
74Requires(postun):initscripts
75
76%description server
77The VNC system allows you to access the same desktop from a wide
78variety of platforms. 
79This package includes the following
80 - TigerVNC server: It allows others to access the desktop on your machine
81 - set of utilities: It makes usage of TigerVNC server more user friendly
82 - x0vncserver program: It can export your active X session
83
84%package server-applet
85Summary:        Java TigerVNC viewer applet for TigerVNC server
86Group:          User Interface/X
87Requires:       tigervnc-server, java, jpackage-utils
88BuildArch:      noarch
89
90%description server-applet
91The Java TigerVNC viewer applet for web browsers.
92Install this package to allow clients to use web browser when connect
93to the TigerVNC server.
94
95
96%prep
97%setup -q
98
99%patch1 -p1 -b .cookie
100%patch2 -p1 -b .ldnow
101%patch3 -p1 -b .libvnc-os
102%patch4 -p1 -b .rh692048
103
104cp -r /usr/share/xorg-x11-server-source/* unix/xserver || exit 1
105cp -a %{SOURCE1000} unix/xserver/hw/xfree86/ || exit 1
106pushd unix/xserver
107for all in `find . -type f -perm -001`; do
108        chmod -x "$all"
109done
110%patch100 -p1 -b .xserver116-rebased
111popd
112
113# Applied Debian patch to fix busy loop when run from inetd in nowait
114# mode (bug #920373).
115%patch5 -p1 -b .inetd-nowait
116
117# Synchronise manpages and --help output (bug #980870).
118%patch7 -p1 -b .manpages
119
120# libvnc.so: don't use unexported GetMaster function (bug #744881 again).
121%patch8 -p1 -b .getmaster
122
123# Don't use shebang in vncserver script.
124%patch9 -p1 -b .shebang
125
126# Fixed build failure with -Werror=format-security (bug #1037358).
127%patch11 -p1 -b .format-security
128
129# Clearer xstartup file (bug #923655).
130%patch14 -p1 -b .xstartup
131
132# Allow build against xorg-x11-server-1.17.
133%patch15 -p1 -b .xserver117
134
135%build
136#export CFLAGS="$RPM_OPT_FLAGS -fpic"
137#export CXXFLAGS="$CFLAGS"
138
139%{cmake} .
140make %{?_smp_mflags}
141
142pushd unix/xserver
143autoreconf -fiv
144%configure \
145        --disable-xorg --disable-xnest --disable-xvfb --disable-dmx \
146        --disable-xwin --disable-xephyr --disable-kdrive --disable-xwayland \
147        --with-pic --disable-static \
148        --with-default-font-path="catalogue:%{_sysconfdir}/X11/fontpath.d,built-ins" \
149        --with-fontdir=%{_datadir}/X11/fonts \
150        --with-xkb-output=%{_localstatedir}/lib/xkb \
151        --enable-install-libxf86config \
152        --enable-glx --disable-dri --enable-dri2 --enable-dri3 \
153        --disable-unit-tests \
154        --disable-config-hal \
155        --disable-config-udev \
156        --with-dri-driver-path=%{_libdir}/dri \
157        --without-dtrace \
158        --disable-devel-docs \
159        --disable-selective-werror \
160        ;
161
162make %{?_smp_mflags}
163popd
164
165# Build icons
166pushd media
167make
168popd
169
170# Build Java applet
171pushd java
172%{cmake} .
173make
174popd
175
176%install
177rm -rf $RPM_BUILD_ROOT
178make install DESTDIR=$RPM_BUILD_ROOT
179rm -f $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{README.txt,LICENCE.TXT}
180
181pushd unix/xserver/hw/vnc
182make install DESTDIR=$RPM_BUILD_ROOT
183popd
184
185# Install init stuff
186mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
187mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
188install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/init.d/vncserver
189install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/vncservers
190
191# Install desktop stuff
192mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/{16x16,24x24,48x48}/apps
193
194pushd media/icons
195for s in 16 24 48; do
196install -m644 tigervnc_$s.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${s}x$s/apps/tigervnc.png
197done
198popd
199
200mkdir $RPM_BUILD_ROOT%{_datadir}/applications
201desktop-file-install \
202        --dir $RPM_BUILD_ROOT%{_datadir}/applications \
203        %{SOURCE6}
204
205# Install Java applet
206pushd java
207mkdir -p $RPM_BUILD_ROOT%{_datadir}/vnc/classes
208install -m755 VncViewer.jar $RPM_BUILD_ROOT%{_datadir}/vnc/classes
209install -m644 com/tigervnc/vncviewer/index.vnc $RPM_BUILD_ROOT%{_datadir}/vnc/classes
210popd
211
212%find_lang %{name} %{name}.lang
213
214# remove unwanted files
215rm -f  $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions/libvnc.la
216
217mkdir -p %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
218install -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/10-libvnc.conf
219
220%clean
221rm -rf $RPM_BUILD_ROOT
222
223%post
224touch -c %{_datadir}/icons/hicolor
225if [ -x %{_bindir}/gtk-update-icon-cache ]; then
226        %{_bindir}/gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
227fi
228
229%postun
230touch -c %{_datadir}/icons/hicolor
231if [ -x %{_bindir}/gtk-update-icon-cache ]; then
232        %{_bindir}/gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
233fi
234
235%post server
236/sbin/chkconfig --add vncserver
237
238%triggerun -- vnc-server < 4.1.3
239/sbin/service vncserver stop &>/dev/null || :
240/sbin/chkconfig --del vncserver >/dev/null 2>&1 || :
241
242%files -f %{name}.lang
243%defattr(-,root,root,-)
244%doc README.txt LICENCE.TXT
245%{_bindir}/vncviewer
246%{_datadir}/applications/*
247%{_mandir}/man1/vncviewer.1*
248%{_datadir}/icons/hicolor/*/apps/*
249
250%files server
251%defattr(-,root,root,-)
252%config(noreplace) %{_sysconfdir}/sysconfig/vncservers
253%config(noreplace) %{_sysconfdir}/init.d/vncserver
254%{_bindir}/x0vncserver
255%{_bindir}/vncserver
256%{_bindir}/vncconfig
257%{_bindir}/vncpasswd
258%{_bindir}/Xvnc
259%{_mandir}/man1/vncserver.1*
260%{_mandir}/man1/x0vncserver.1*
261%{_mandir}/man1/Xvnc.1*
262%{_mandir}/man1/vncpasswd.1*
263%{_mandir}/man1/vncconfig.1*
264%{_libdir}/xorg/modules/extensions/libvnc.so
265%config %{_sysconfdir}/X11/xorg.conf.d/10-libvnc.conf
266
267%files server-applet
268%defattr(-,root,root,-)
269%doc java/com/tigervnc/vncviewer/README
270%{_datadir}/vnc/classes/*
271
272%changelog
273* Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.3-1
274- new upstream release
275
276* Wed Mar  4 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.1-2
277- rebuilt
278
279* Sun Jan  4 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.1-1
280- initial build based on Fedora rawhide
281
282* Tue Sep  9 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-11
283- Added missing part of xserver114.patch (bug #1137023).
284
285* Wed Sep  3 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-10
286- Fix build against xorg-x11-server-1.16.0 (bug #1136532).
287
288* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-9
289- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
290
291* Tue Jul 15 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-8
292- Input reset fixes from upstream (bug #1116956).
293- No longer need ppc64le patch as it's now in xorg-x11-server.
294- Rebased xserver114.patch again.
295
296* Fri Jun 20 2014 Hans de Goede <hdegoede@redhat.com> - 1.3.1-7
297- xserver 1.15.99.903 ABI rebuild
298
299* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-6
300- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
301
302* Thu May 22 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-5
303- Keep pointer in sync when using module (upstream bug #152).
304
305* Mon Apr 28 2014 Adam Jackson <ajax@redhat.com> 1.3.1-4
306- Add version interlocks for -server-module
307
308* Mon Apr 28 2014 Hans de Goede <hdegoede@redhat.com> - 1.3.1-3
309- xserver 1.15.99-20140428 git snapshot ABI rebuild
310
311* Mon Apr  7 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-2
312- Allow build with dri3 and present extensions (bug #1063392).
313
314* Thu Mar 27 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-1
315- 1.3.1 (bug #1078806).
316- Add ppc64le support (bug #1078495).
317
318* Wed Mar 19 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-15
319- Disable dri3 to enable building (bug #1063392).
320- Fixed heap-based buffer overflow (CVE-2014-0011, bug #1050928).
321
322* Fri Feb 21 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-14
323- Enabled hardened build (bug #955206).
324
325* Mon Feb 10 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-13
326- Clearer xstartup file (bug #923655).
327
328* Tue Jan 14 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-12
329- Fixed instructions in systemd unit file.
330
331* Fri Jan 10 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-11
332- Fixed viewer crash when cursor has not been set (bug #1038701).
333
334* Thu Dec 12 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-10
335- Avoid invalid read when ZRLE connection closed (upstream bug #133).
336
337* Tue Dec  3 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-9
338- Fixed build failure with -Werror=format-security (bug #1037358).
339
340* Thu Nov 07 2013 Adam Jackson <ajax@redhat.com> 1.3.0-8
341- Rebuild against xserver 1.15RC1
342
343* Tue Sep 24 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-7
344- Removed incorrect patch (for unexpected key_is_down). Fixes stuck
345  keys bug (bug #989502).
346
347* Thu Sep 19 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-6
348- Fixed typo in 10-libvnc.conf (bug #1009111).
349
350* Wed Sep 18 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-5
351- Better fix for PIDFile problem (bug #983232).
352
353* Mon Aug  5 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-4
354- Fixed doc-related build failure (bug #992790).
355
356* Wed Jul 24 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-3
357- Avoid PIDFile problems in systemd unit file (bug #983232).
358- libvnc.so: don't use unexported key_is_down function.
359- Don't use shebang in vncserver script.
360
361* Fri Jul 12 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-2
362- Renumbered patches.
363- libvnc.so: don't use unexported GetMaster function (bug #744881 again).
364
365* Mon Jul  8 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-1
366- 1.3.0.
367
368* Wed Jul  3 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.18.20130314svn5065
369- Removed systemd_requires macro in order to fix the build.
370
371* Wed Jul  3 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.17.20130314svn5065
372- Synchronise manpages and --help output (bug #980870).
373
374* Mon Jun 17 2013 Adam Jackson <ajax@redhat.com> 1.2.80-0.16.20130314svn5065
375- tigervnc-setcursor-crash.patch: Attempt to paper over a crash in Xvnc when
376  setting the cursor.
377
378* Sat Jun 08 2013 Dennis Gilmore <dennis@ausil.us> 1.2.80-0.15.20130314svn5065
379- bump to rebuild and pick up bugfix causing X to crash on ppc and arm
380
381* Thu May 23 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.14.20130314svn5065
382- Use systemd rpm macros (bug #850340).  Moved systemd requirements
383  from main package to server sub-package.
384- Applied Debian patch to fix busy loop when run from inetd in nowait
385  mode (bug #920373).
386- Added dependency on xorg-x11-xinit to server sub-package so that
387  default window manager can be found (bug #896284, bug #923655).
388- Fixed bogus changelog date.
389
390* Thu Mar 14 2013 Adam Jackson <ajax@redhat.com> 1.2.80-0.13.20130314svn5065
391- Less RHEL customization
392
393* Thu Mar 14 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.12.20130314svn5065
394- include /etc/X11/xorg.conf.d/10-libvnc.conf sample configuration (#712482)
395- vncserver now honors specified -geometry parameter (#755947)
396
397* Tue Mar 12 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.11.20130307svn5060
398- update to r5060
399- split icons to separate package to avoid multilib issues
400
401* Tue Feb 19 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.10.20130219svn5047
402- update to r5047 (X.Org 1.14 support)
403
404* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.80-0.9.20121126svn5015
405- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
406
407* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.8.20121126svn5015
408- rebuild due to "jpeg8-ABI" feature drop
409
410* Wed Jan 16 2013 Adam Tkac <atkac redhat com> 1.2.80-0.7.20121126svn5015
411- rebuild
412
413* Tue Dec 04 2012 Adam Tkac <atkac redhat com> 1.2.80-0.6.20121126svn5015
414- rebuild against new fltk
415
416* Mon Nov 26 2012 Adam Tkac <atkac redhat com> 1.2.80-0.5.20121126svn5015
417- update to r5015
418- build with -fpic instead of -fPIC on all archs except s390/sparc
419
420* Wed Nov  7 2012 Peter Robinson <pbrobinson@fedoraproject.org> 1.2.80-0.4.20120905svn4996
421- Build with -fPIC to fix FTBFS on ARM
422
423* Wed Oct 31 2012 Adam Jackson <ajax@redhat.com> 1.2.80-0.3.20120905svn4996
424- tigervnc12-xorg113-glx.patch: Fix to only init glx on the first server
425  generation
426
427* Fri Sep 28 2012 Adam Jackson <ajax@redhat.com> 1.2.80-0.2.20120905svn4996
428- tigervnc12-xorg113-glx.patch: Re-enable GLX against xserver 1.13
429
430* Fri Aug 17 2012 Adam Tkac <atkac redhat com> 1.2.80-0.1.20120905svn4996
431- update to 1.2.80
432- remove deprecated patches
433  - tigervnc-102434.patch
434  - tigervnc-viewer-reparent.patch
435  - tigervnc11-java7.patch
436- patches merged
437  - tigervnc11-xorg111.patch
438  - tigervnc11-xorg112.patch
439
440* Fri Aug 10 2012 Dave Airlie <airlied@redhat.com> 1.1.0-10
441- fix build against newer X server
442
443* Mon Jul 23 2012 Adam Jackson <ajax@redhat.com> 1.1.0-9
444- Build with the Composite extension for feature parity with other X servers
445
446* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-8
447- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
448
449* Thu Jul 19 2012 Dave Airlie <airlied@redhat.com> 1.1.0-7
450- fix building against X.org 1.13
451
452* Wed Apr 04 2012 Adam Jackson <ajax@redhat.com> 1.1.0-6
453- RHEL exclusion for -server-module on ppc* too
454
455* Mon Mar 26 2012 Adam Tkac <atkac redhat com> - 1.1.0-5
456- clean Xvnc's /tmp environment in service file before startup
457- fix building against the latest JAVA 7 and X.Org 1.12
458
459* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-4
460- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
461
462* Tue Nov 22 2011 Adam Tkac <atkac redhat com> - 1.1.0-3
463- don't build X.Org devel docs (#755782)
464- applet: BR generic java-devel instead of java-gcj-devel (#755783)
465- use runuser to start Xvnc in systemd service file (#754259)
466- don't attepmt to restart Xvnc session during update/erase (#753216)
467
468* Fri Nov 11 2011 Adam Tkac <atkac redhat com> - 1.1.0-2
469- libvnc.so: don't use unexported GetMaster function (#744881)
470- remove nasm buildreq
471
472* Mon Sep 12 2011 Adam Tkac <atkac redhat com> - 1.1.0-1
473- update to 1.1.0
474- update the xorg11 patch
475- patches merged
476  - tigervnc11-glx.patch
477  - tigervnc11-CVE-2011-1775.patch
478  - 0001-Use-memmove-instead-of-memcpy-in-fbblt.c-when-memory.patch
479
480* Thu Jul 28 2011 Adam Tkac <atkac redhat com> - 1.0.90-6
481- add systemd service file and remove legacy SysV initscript (#717227)
482
483* Thu May 12 2011 Adam Tkac <atkac redhat com> - 1.0.90-5
484- make Xvnc buildable against X.Org 1.11
485
486* Tue May 10 2011 Adam Tkac <atkac redhat com> - 1.0.90-4
487- viewer can send password without proper validation of X.509 certs
488  (CVE-2011-1775)
489
490* Wed Apr 13 2011 Adam Tkac <atkac redhat com> - 1.0.90-3
491- fix wrong usage of memcpy which caused screen artifacts (#652590)
492- don't point to inaccessible link in sysconfig/vncservers (#644975)
493
494* Fri Apr 08 2011 Adam Tkac <atkac redhat com> - 1.0.90-2
495- improve compatibility with vinagre client (#692048)
496
497* Tue Mar 22 2011 Adam Tkac <atkac redhat com> - 1.0.90-1
498- update to 1.0.90
499
500* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.90-0.32.20110117svn4237
501- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
502
503* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.31.20110117svn4237
504- fix libvnc.so module loading
505
506* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.30.20110117svn4237
507- update to r4237
508- patches merged
509  - tigervnc11-optionsdialog.patch
510  - tigervnc11-rh607866.patch
511
512* Fri Jan 14 2011 Adam Tkac <atkac redhat com> 1.0.90-0.29.20101208svn4225
513- improve patch for keyboard issues
514
515* Fri Jan 14 2011 Adam Tkac <atkac redhat com> 1.0.90-0.28.20101208svn4225
516- attempt to fix various keyboard-related issues (key repeating etc)
517
518* Fri Jan 07 2011 Adam Tkac <atkac redhat com> 1.0.90-0.27.20101208svn4225
519- render "Ok" and "Cancel" buttons in the options dialog correctly
520
521* Wed Dec 15 2010 Jan Görig <jgorig redhat com> 1.0.90-0.26.20101208svn4225
522- added vncserver lock file (#662784)
523
524* Fri Dec 10 2010 Adam Tkac <atkac redhat com> 1.0.90-0.25.20101208svn4225
525- update to r4225
526- patches merged
527  - tigervnc11-rh611677.patch
528  - tigervnc11-rh633931.patch
529  - tigervnc11-xorg1.10.patch
530- enable VeNCrypt and PAM support
531
532* Mon Dec 06 2010 Adam Tkac <atkac redhat com> 1.0.90-0.24.20100813svn4123
533- rebuild against xserver 1.10.X
534- 0001-Return-Success-from-generate_modkeymap-when-max_keys.patch merged
535
536* Wed Sep 29 2010 jkeating - 1.0.90-0.23.20100813svn4123
537- Rebuilt for gcc bug 634757
538
539* Tue Sep 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.22.20100420svn4030
540- drop xorg-x11-fonts-misc dependency (#636170)
541
542* Tue Sep 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.21.20100420svn4030
543- improve patch for #633645 (fix tcsh incompatibilities)
544
545* Thu Sep 16 2010 Adam Tkac <atkac redhat com> 1.0.90-0.20.20100813svn4123
546- press fake modifiers correctly (#633931)
547- supress unneeded debug information emitted from initscript (#633645)
548
549* Wed Aug 25 2010 Adam Tkac <atkac redhat com> 1.0.90-0.19.20100813svn4123
550- separate Xvnc, vncpasswd and vncconfig to -server-minimal subpkg (#626946)
551- move license to separate subpkg and Requires it from main subpkgs
552- Xvnc: handle situations when no modifiers exist well (#611677)
553
554* Fri Aug 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.18.20100813svn4123
555- update to r4123 (#617973)
556- add perl requires to -server subpkg (#619791)
557
558* Thu Jul 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.17.20100721svn4113
559- update to r4113
560- patches merged
561  - tigervnc11-rh586406.patch
562  - tigervnc11-libvnc.patch
563  - tigervnc11-rh597172.patch
564  - tigervnc11-rh600070.patch
565  - tigervnc11-options.patch
566- don't own %%{_datadir}/icons directory (#614301)
567- minor improvements in the .desktop file (#616340)
568- bundled libjpeg configure requires nasm; is executed even if system-wide
569  libjpeg is used
570
571* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.90-0.16.20100420svn4030
572- build against system-wide libjpeg-turbo (#494458)
573- build no longer requires nasm
574
575* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 1.0.90-0.15.20100420svn4030
576- vncserver: accept <+optname> option when specified as the first one
577
578* Thu Jun 24 2010 Adam Tkac <atkac redhat com> 1.0.90-0.14.20100420svn4030
579- fix memory leak in Xvnc input code (#597172)
580- don't crash when receive negative encoding (#600070)
581- explicitly disable udev configuration support
582- add gettext-autopoint to BR
583
584* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 1.0.90-0.13.20100420svn4030
585- update URL about SSH tunneling in the sysconfig file (#601996)
586
587* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 1.0.90-0.12.20100420svn4030
588- use newer gettext
589- autopoint now uses git instead of cvs, adjust BuildRequires appropriately
590
591* Thu May 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.11.20100420svn4030
592- link libvnc.so "now" to catch "undefined symbol" errors during Xorg startup
593- use always XkbConvertCase instead of XConvertCase (#580159, #586406)
594- don't link libvnc.so against libXi.la, libdix.la and libxkb.la; use symbols
595  from Xorg instead
596
597* Thu May 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.10.20100420svn4030
598- update to r4030 snapshot
599- patches merged to upstream
600  - tigervnc11-rh522369.patch
601  - tigervnc11-rh551262.patch
602  - tigervnc11-r4002.patch
603  - tigervnc11-r4014.patch
604
605* Thu Apr 08 2010 Adam Tkac <atkac redhat com> 1.0.90-0.9.20100219svn3993
606- add server-applet subpackage which contains Java vncviewer applet
607- fix Java applet; it didn't work when run from web browser
608- add xorg-x11-xkb-utils to server Requires
609
610* Fri Mar 12 2010 Adam Tkac <atkac redhat com> 1.0.90-0.8.20100219svn3993
611- add French translation to vncviewer.desktop (thanks to Alain Portal)
612
613* Thu Mar 04 2010 Adam Tkac <atkac redhat com> 1.0.90-0.7.20100219svn3993
614- don't crash during pixel format change (#522369, #551262)
615
616* Mon Mar 01 2010 Adam Tkac <atkac redhat com> 1.0.90-0.6.20100219svn3993
617- add mesa-dri-drivers and xkeyboard-config to -server Requires
618- update to r3993 1.0.90 snapshot
619  - tigervnc11-noexecstack.patch merged
620  - tigervnc11-xorg18.patch merged
621  - xserver18.patch is no longer needed
622
623* Wed Jan 27 2010 Jan Gorig <jgorig redhat com> 1.0.90-0.5.20091221svn3929
624- initscript LSB compliance fixes (#523974)
625
626* Fri Jan 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.4.20091221svn3929
627- mark stack as non-executable in jpeg ASM code
628- add xorg-x11-xauth to Requires
629- add support for X.Org 1.8
630- drop shave sources, they are no longer needed
631
632* Thu Jan 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.3.20091221svn3929
633- drop tigervnc-xorg25909.patch, it has been merged to X.Org upstream
634
635* Thu Jan 07 2010 Adam Tkac <atkac redhat com> 1.0.90-0.2.20091221svn3929
636- add patch for upstream X.Org issue #25909
637- add libXdmcp-devel to build requires to build Xvnc with XDMCP support (#552322)
638
639* Mon Dec 21 2009 Adam Tkac <atkac redhat com> 1.0.90-0.1.20091221svn3929
640- update to 1.0.90 snapshot
641- patches merged
642  - tigervnc10-compat.patch
643  - tigervnc10-rh510185.patch
644  - tigervnc10-rh524340.patch
645  - tigervnc10-rh516274.patch
646
647* Mon Oct 26 2009 Adam Tkac <atkac redhat com> 1.0.0-3
648- create Xvnc keyboard mapping before first keypress (#516274)
649
650* Thu Oct 08 2009 Adam Tkac <atkac redhat com> 1.0.0-2
651- update underlying X source to 1.6.4-0.3.fc11
652- remove bogus '-nohttpd' parameter from /etc/sysconfig/vncservers (#525629)
653- initscript LSB compliance fixes (#523974)
654- improve -LowColorSwitch documentation and handling (#510185)
655- honor dotWhenNoCursor option (and it's changes) every time (#524340)
656
657* Fri Aug 28 2009 Adam Tkac <atkac redhat com> 1.0.0-1
658- update to 1.0.0
659- tigervnc10-rh495457.patch merged to upstream
660
661* Mon Aug 24 2009 Karsten Hopp <karsten@redhat.com> 0.0.91-0.17
662- fix ifnarch s390x for server-module
663
664* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.0.91-0.16
665- rebuilt with new openssl
666
667* Tue Aug 04 2009 Adam Tkac <atkac redhat com> 0.0.91-0.15
668- make Xvnc compilable
669
670* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.91-0.14.1
671- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
672
673* Mon Jul 13 2009 Adam Tkac <atkac redhat com> 0.0.91-0.13.1
674- don't write warning when initscript is called with condrestart param (#508367)
675
676* Tue Jun 23 2009 Adam Tkac <atkac redhat com> 0.0.91-0.13
677- temporary use F11 Xserver base to make Xvnc compilable
678- BuildRequires: libXi-devel
679- don't ship tigervnc-server-module on s390/s390x
680
681* Mon Jun 22 2009 Adam Tkac <atkac redhat com> 0.0.91-0.12
682- fix local rendering of cursor (#495457)
683
684* Thu Jun 18 2009 Adam Tkac <atkac redhat com> 0.0.91-0.11
685- update to 0.0.91 (1.0.0 RC1)
686- patches merged
687  - tigervnc10-rh499401.patch
688  - tigervnc10-rh497592.patch
689  - tigervnc10-rh501832.patch
690- after discusion in upstream drop tigervnc-bounds.patch
691- configure flags cleanup
692
693* Thu May 21 2009 Adam Tkac <atkac redhat com> 0.0.90-0.10
694- rebuild against 1.6.1.901 X server (#497835)
695- disable i18n, vncviewer is not UTF-8 compatible (#501832)
696
697* Mon May 18 2009 Adam Tkac <atkac redhat com> 0.0.90-0.9
698- fix vncpasswd crash on long passwords (#499401)
699- start session dbus daemon correctly (#497592)
700
701* Mon May 11 2009 Adam Tkac <atkac redhat com> 0.0.90-0.8.1
702- remove merged tigervnc-manminor.patch
703
704* Tue May 05 2009 Adam Tkac <atkac redhat com> 0.0.90-0.8
705- update to 0.0.90
706
707* Thu Apr 30 2009 Adam Tkac <atkac redhat com> 0.0.90-0.7.20090427svn3789
708- server package now requires xorg-x11-fonts-misc (#498184)
709
710* Mon Apr 27 2009 Adam Tkac <atkac redhat com> 0.0.90-0.6.20090427svn3789
711- update to r3789
712  - tigervnc-rh494801.patch merged
713- tigervnc-newfbsize.patch is no longer needed
714- fix problems when vncviewer and Xvnc run on different endianess (#496653)
715- UltraVNC and TightVNC clients work fine again (#496786)
716
717* Wed Apr 08 2009 Adam Tkac <atkac redhat com> 0.0.90-0.5.20090403svn3751
718- workaround broken fontpath handling in vncserver script (#494801)
719
720* Fri Apr 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.4.20090403svn3751
721- update to r3751
722- patches merged
723  - tigervnc-xclients.patch
724  - tigervnc-clipboard.patch
725  - tigervnc-rh212985.patch
726- basic RandR support in Xvnc (resize of the desktop)
727- use built-in libjpeg (SSE2/MMX accelerated encoding on x86 platform)
728- use Tight encoding by default
729- use TigerVNC icons
730
731* Tue Mar 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.3.20090303svn3631
732- update to r3631
733
734* Tue Mar 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.2.20090302svn3621
735- package review related fixes
736
737* Mon Mar 02 2009 Adam Tkac <atkac redhat com> 0.0.90-0.1.20090302svn3621
738- initial package, r3621
Note: See TracBrowser for help on using the repository browser.