source: projects/specs/trunk/t/tigervnc/tigervnc-vl.spec @ 12487

Revision 12487, 26.7 KB checked in by tomop, 4 years ago (diff)

updated 11 packages

chrony-3.5.1-2

dnsmasq-2.82-1

epiphany-3.36.4-2

filezilla-3.50.0-1

gnutls-3.6.15-1

libfilezilla-0.24.1-1

nettle-3.6-1

rdesktop-1.9.0-2

tigervnc-1.10.1-2

webkitgtk4-2.28.4-1

wxGTK3-3.0.5-1

Line 
1%bcond_with systemd
2
3Name:           tigervnc
4Version:        1.10.1
5Release:        2%{?_dist_release}%{?with_systemd:.systemd}
6Summary:        A TigerVNC remote display system
7Group:          network
8Vendor:         Project Vine
9Distribution:   Vine Linux
10
11License:        GPLv2+
12URL:            http://www.tigervnc.com
13Source0:        https://github.com/TigerVNC/tigervnc/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
14Source1:        vncserver.service.upstart
15Source2:        vncserver.sysconfig.upstart
16Source3:        10-libvnc.conf
17Source6:        vncviewer.desktop
18Source11:       xvnc.service
19Source12:       xvnc.socket
20
21#[ad-hoc] xorg-x11-server-source: has no hw/xfree86/Xorg.sh.in
22Source1000:     Xorg.sh.in
23
24Patch1:         tigervnc-manpages.patch
25Patch2:         tigervnc-getmaster.patch
26Patch3:         tigervnc-shebang.patch
27Patch4:         tigervnc-xstartup.patch
28Patch5:         tigervnc-utilize-system-crypto-policies.patch
29Patch7:         tigervnc-passwd-crash-with-malloc-checks.patch
30
31Patch1000:      xorg-server-1.20.7-ddxInputThreadInit.patch
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
34
35BuildRequires:  libX11-devel, automake, autoconf, libtool, gettext
36BuildRequires:  libXext-devel, xorg-x11-server-source, libXi-devel
37BuildRequires:  xorg-x11-xtrans-devel, xorg-x11-util-macros, libXtst-devel
38BuildRequires:  libdrm-devel, libXt-devel, pixman-devel libXfont2-devel
39BuildRequires:  libxkbfile-devel, openssl-devel, libpciaccess-devel
40BuildRequires:  mesa-libGL-devel, mesa-libEGL-devel
41BuildRequires:  libXinerama-devel, ImageMagick
42BuildRequires:  freetype2-devel, libXdmcp-devel, libxshmfence-devel
43BuildRequires:  desktop-file-utils
44BuildRequires:  libjpeg-turbo-devel, gnutls-devel, pam-devel
45BuildRequires:  cmake
46# TigerVNC 1.4.x requires fltk 1.3.3 for keyboard handling support
47# See https://github.com/TigerVNC/tigervnc/issues/8, also bug #1208814
48BuildRequires:  fltk-devel >= 1.3.3
49
50Requires(post): coreutils
51Requires(postun):coreutils
52%if %{with systemd}
53%{?systemd_requires}
54%else
55Requires(post): chkconfig, /sbin/service
56Requires(preun): chkconfig, /sbin/service
57Requires(postun): /sbin/service
58%endif
59
60Requires:       hicolor-icon-theme
61Provides:       vnc = 4.1.3, vnc-libs = 4.1.3, vnc-server = 4.1.3
62Obsoletes:      vnc < 4.1.3, vnc-libs < 4.1.3, vnc-server < 4.1.3
63
64%description
65Virtual Network Computing (VNC) is a remote display system which
66allows you to view a computing 'desktop' environment not only on the
67machine where it is running, but from anywhere on the Internet and
68from a wide variety of machine architectures.
69This package contains a client which will allow you to connect to
70other desktops running a VNC server.
71
72
73%package server
74Summary:        A TigerVNC server
75Group:          servers
76Provides:       vnc = 4.1.3, vnc-libs = 4.1.3, vnc-server = 4.1.3
77Obsoletes:      vnc < 4.1.3, vnc-libs < 4.1.3, vnc-server < 4.1.3
78Requires:       perl
79Requires:       xorg-x11-xauth, xorg-x11-xinit, xorg-x11-server-Xorg
80Requires:       mesa-dri-drivers, xkeyboard-config, xorg-x11-xkb-utils
81Requires(post): chkconfig
82Requires(preun):chkconfig
83Requires(preun):initscripts
84Requires(postun):initscripts
85
86%description server
87The VNC system allows you to access the same desktop from a wide
88variety of platforms. 
89This package includes the following components:
90 - TigerVNC server: It allows others to access the desktop on your machine
91 - set of utilities: It makes usage of TigerVNC server more user friendly
92 - x0vncserver program: It can export your active X session
93
94
95%debug_package
96
97
98%prep
99%setup -q
100
101cp -r /usr/share/xorg-x11-server-source/* unix/xserver || exit 1
102cp -a %{SOURCE1000} unix/xserver/hw/xfree86/ || exit 1
103pushd unix/xserver
104for all in `find . -type f -perm -001`; do
105        chmod -x "$all"
106done
107patch -p1 < ../xserver120.patch
108popd
109
110# Synchronise manpages and --help output (bug #980870).
111%patch1 -p1 -b .manpages
112
113# libvnc.so: don't use unexported GetMaster function (bug #744881 again).
114%patch2 -p1 -b .getmaster
115
116# Don't use shebang in vncserver script.
117%patch3 -p1 -b .shebang
118
119# Clearer xstartup file (bug #923655).
120%patch4 -p1 -b .xstartup
121
122# Utilize system-wide crypto policies
123#patch5 -p1 -b .utilize-system-crypto-policies
124
125%patch7 -p1 -b .tigervnc-passwd-crash-with-malloc-checks
126
127%patch1000 -p1
128
129
130%build
131#export CFLAGS="$RPM_OPT_FLAGS -fpic"
132export CFLAGS="$RPM_OPT_FLAGS -fpic -I%{_includedir}/libdrm"
133
134#export CXXFLAGS="$CFLAGS"
135export CXXFLAGS="$CFLAGS -std=c++11"
136
137%{cmake} .
138make %{?_smp_mflags}
139
140pushd unix/xserver
141autoreconf -fiv
142%configure \
143        --disable-xorg --disable-xnest --disable-xvfb --disable-dmx \
144        --disable-xwin --disable-xephyr --disable-kdrive --disable-xwayland \
145        --with-pic --disable-static \
146        --with-default-font-path="catalogue:%{_sysconfdir}/X11/fontpath.d,built-ins" \
147        --with-fontdir=%{_datadir}/X11/fonts \
148        --with-xkb-output=%{_localstatedir}/lib/xkb \
149        --enable-install-libxf86config \
150        --enable-glx --disable-dri --enable-dri2 --enable-dri3 \
151        --disable-unit-tests \
152        --disable-config-hal \
153        --disable-config-udev \
154        --with-dri-driver-path=%{_libdir}/dri \
155        --without-dtrace \
156        --disable-devel-docs \
157        --disable-selective-werror \
158        ;
159
160make %{?_smp_mflags}
161popd
162
163# Build icons
164pushd media
165make
166popd
167
168%install
169rm -rf $RPM_BUILD_ROOT
170make install DESTDIR=$RPM_BUILD_ROOT
171rm -f $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{README.txt,LICENCE.TXT}
172
173pushd unix/xserver/hw/vnc
174make install DESTDIR=$RPM_BUILD_ROOT
175popd
176
177mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
178install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/vncservers
179
180
181%if %{with systemd}
182mkdir -p %{buildroot}%{_unitdir}
183#make -C unix/vncserver install DESTDIR=%{buildroot}
184# Install systemd unit file
185install -m644 %{SOURCE11} %{buildroot}%{_unitdir}/xvnc@.service
186install -m644 %{SOURCE12} %{buildroot}%{_unitdir}/xvnc.socket
187%else
188# Install init stuff
189mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
190install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/init.d/vncserver
191%endif
192
193# Install desktop stuff
194mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/{16x16,24x24,48x48}/apps
195
196pushd media/icons
197for s in 16 24 48; do
198install -m644 tigervnc_$s.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${s}x$s/apps/tigervnc.png
199done
200popd
201
202mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
203desktop-file-install \
204        --dir $RPM_BUILD_ROOT%{_datadir}/applications \
205        %{SOURCE6}
206
207%find_lang %{name} %{name}.lang
208
209# remove unwanted files
210rm -f  $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions/libvnc.la
211
212mkdir -p %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
213install -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/10-libvnc.conf
214
215
216%clean
217rm -rf $RPM_BUILD_ROOT
218
219
220%post
221touch -c %{_datadir}/icons/hicolor
222if [ -x %{_bindir}/gtk-update-icon-cache ]; then
223        %{_bindir}/gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
224fi
225
226%postun
227touch -c %{_datadir}/icons/hicolor
228if [ -x %{_bindir}/gtk-update-icon-cache ]; then
229        %{_bindir}/gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
230fi
231
232%post server
233%if %{with systemd}
234%systemd_post xvnc.service
235%systemd_post xvnc.socket
236%else
237/sbin/chkconfig --add vncserver
238%endif
239
240%preun server
241%if %{with systemd}
242%systemd_preun xvnc.service
243%systemd_preun xvnc.socket
244%else
245if [ "$1" = 0 -o -x /bin/systemctl ]; then
246  /sbin/service vncserver stop 2>&1 ||:
247  /sbin/chkconfig --del vncserver 2>&1 ||:
248fi
249%endif
250
251%postun server
252%if %{with systemd}
253%systemd_postun xvnc.service
254%systemd_postun xvnc.socket
255%else
256  /sbin/service vncserver condrestart 2>&1 ||:
257%endif
258
259%triggerun -- vnc-server < 4.1.3
260/sbin/service vncserver stop &>/dev/null || :
261/sbin/chkconfig --del vncserver >/dev/null 2>&1 || :
262
263
264%files -f %{name}.lang
265%defattr(-,root,root,-)
266%license LICENCE.TXT
267%doc README.txt
268%{_bindir}/vncviewer
269%{_datadir}/applications/*
270%{_mandir}/man1/vncviewer.1*
271%{_datadir}/icons/hicolor/*/apps/*
272
273%files server
274%defattr(-,root,root,-)
275%config(noreplace) %{_sysconfdir}/sysconfig/vncservers
276%{_bindir}/x0vncserver
277%{_bindir}/vncserver
278%{_bindir}/vncconfig
279%{_bindir}/vncpasswd
280%{_bindir}/Xvnc
281%{_mandir}/man1/vncserver.1*
282%{_mandir}/man1/x0vncserver.1*
283%{_mandir}/man1/Xvnc.1*
284%{_mandir}/man1/vncpasswd.1*
285%{_mandir}/man1/vncconfig.1*
286%{_libdir}/xorg/modules/extensions/libvnc.so
287%config %{_sysconfdir}/X11/xorg.conf.d/10-libvnc.conf
288%if %{with systemd}
289#%{_unitdir}/vncserver@.service
290%{_unitdir}/xvnc@.service
291%{_unitdir}/xvnc.socket
292%else
293%config(noreplace) %{_sysconfdir}/init.d/vncserver
294%endif
295
296%changelog
297* Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-2
298- rebuilt with nettle-3.6.
299- added systemd support (disabled as default).
300
301* Mon Mar 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
302- new upstream release.
303- replaced all patches.
304- dropped java stuff.
305
306* Wed Apr  5 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.7.1-1
307- new upstream release
308- added BR: libxshmfence-devel
309
310* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.0-1
311- new upstream release
312
313* Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.3-1
314- new upstream release
315
316* Wed Mar  4 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.1-2
317- rebuilt
318
319* Sun Jan  4 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.1-1
320- initial build based on Fedora rawhide
321
322* Tue Sep  9 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-11
323- Added missing part of xserver114.patch (bug #1137023).
324
325* Wed Sep  3 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-10
326- Fix build against xorg-x11-server-1.16.0 (bug #1136532).
327
328* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-9
329- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
330
331* Tue Jul 15 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-8
332- Input reset fixes from upstream (bug #1116956).
333- No longer need ppc64le patch as it's now in xorg-x11-server.
334- Rebased xserver114.patch again.
335
336* Fri Jun 20 2014 Hans de Goede <hdegoede@redhat.com> - 1.3.1-7
337- xserver 1.15.99.903 ABI rebuild
338
339* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-6
340- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
341
342* Thu May 22 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-5
343- Keep pointer in sync when using module (upstream bug #152).
344
345* Mon Apr 28 2014 Adam Jackson <ajax@redhat.com> 1.3.1-4
346- Add version interlocks for -server-module
347
348* Mon Apr 28 2014 Hans de Goede <hdegoede@redhat.com> - 1.3.1-3
349- xserver 1.15.99-20140428 git snapshot ABI rebuild
350
351* Mon Apr  7 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-2
352- Allow build with dri3 and present extensions (bug #1063392).
353
354* Thu Mar 27 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-1
355- 1.3.1 (bug #1078806).
356- Add ppc64le support (bug #1078495).
357
358* Wed Mar 19 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-15
359- Disable dri3 to enable building (bug #1063392).
360- Fixed heap-based buffer overflow (CVE-2014-0011, bug #1050928).
361
362* Fri Feb 21 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-14
363- Enabled hardened build (bug #955206).
364
365* Mon Feb 10 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-13
366- Clearer xstartup file (bug #923655).
367
368* Tue Jan 14 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-12
369- Fixed instructions in systemd unit file.
370
371* Fri Jan 10 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-11
372- Fixed viewer crash when cursor has not been set (bug #1038701).
373
374* Thu Dec 12 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-10
375- Avoid invalid read when ZRLE connection closed (upstream bug #133).
376
377* Tue Dec  3 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-9
378- Fixed build failure with -Werror=format-security (bug #1037358).
379
380* Thu Nov 07 2013 Adam Jackson <ajax@redhat.com> 1.3.0-8
381- Rebuild against xserver 1.15RC1
382
383* Tue Sep 24 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-7
384- Removed incorrect patch (for unexpected key_is_down). Fixes stuck
385  keys bug (bug #989502).
386
387* Thu Sep 19 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-6
388- Fixed typo in 10-libvnc.conf (bug #1009111).
389
390* Wed Sep 18 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-5
391- Better fix for PIDFile problem (bug #983232).
392
393* Mon Aug  5 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-4
394- Fixed doc-related build failure (bug #992790).
395
396* Wed Jul 24 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-3
397- Avoid PIDFile problems in systemd unit file (bug #983232).
398- libvnc.so: don't use unexported key_is_down function.
399- Don't use shebang in vncserver script.
400
401* Fri Jul 12 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-2
402- Renumbered patches.
403- libvnc.so: don't use unexported GetMaster function (bug #744881 again).
404
405* Mon Jul  8 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-1
406- 1.3.0.
407
408* Wed Jul  3 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.18.20130314svn5065
409- Removed systemd_requires macro in order to fix the build.
410
411* Wed Jul  3 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.17.20130314svn5065
412- Synchronise manpages and --help output (bug #980870).
413
414* Mon Jun 17 2013 Adam Jackson <ajax@redhat.com> 1.2.80-0.16.20130314svn5065
415- tigervnc-setcursor-crash.patch: Attempt to paper over a crash in Xvnc when
416  setting the cursor.
417
418* Sat Jun 08 2013 Dennis Gilmore <dennis@ausil.us> 1.2.80-0.15.20130314svn5065
419- bump to rebuild and pick up bugfix causing X to crash on ppc and arm
420
421* Thu May 23 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.14.20130314svn5065
422- Use systemd rpm macros (bug #850340).  Moved systemd requirements
423  from main package to server sub-package.
424- Applied Debian patch to fix busy loop when run from inetd in nowait
425  mode (bug #920373).
426- Added dependency on xorg-x11-xinit to server sub-package so that
427  default window manager can be found (bug #896284, bug #923655).
428- Fixed bogus changelog date.
429
430* Thu Mar 14 2013 Adam Jackson <ajax@redhat.com> 1.2.80-0.13.20130314svn5065
431- Less RHEL customization
432
433* Thu Mar 14 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.12.20130314svn5065
434- include /etc/X11/xorg.conf.d/10-libvnc.conf sample configuration (#712482)
435- vncserver now honors specified -geometry parameter (#755947)
436
437* Tue Mar 12 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.11.20130307svn5060
438- update to r5060
439- split icons to separate package to avoid multilib issues
440
441* Tue Feb 19 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.10.20130219svn5047
442- update to r5047 (X.Org 1.14 support)
443
444* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.80-0.9.20121126svn5015
445- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
446
447* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.8.20121126svn5015
448- rebuild due to "jpeg8-ABI" feature drop
449
450* Wed Jan 16 2013 Adam Tkac <atkac redhat com> 1.2.80-0.7.20121126svn5015
451- rebuild
452
453* Tue Dec 04 2012 Adam Tkac <atkac redhat com> 1.2.80-0.6.20121126svn5015
454- rebuild against new fltk
455
456* Mon Nov 26 2012 Adam Tkac <atkac redhat com> 1.2.80-0.5.20121126svn5015
457- update to r5015
458- build with -fpic instead of -fPIC on all archs except s390/sparc
459
460* Wed Nov  7 2012 Peter Robinson <pbrobinson@fedoraproject.org> 1.2.80-0.4.20120905svn4996
461- Build with -fPIC to fix FTBFS on ARM
462
463* Wed Oct 31 2012 Adam Jackson <ajax@redhat.com> 1.2.80-0.3.20120905svn4996
464- tigervnc12-xorg113-glx.patch: Fix to only init glx on the first server
465  generation
466
467* Fri Sep 28 2012 Adam Jackson <ajax@redhat.com> 1.2.80-0.2.20120905svn4996
468- tigervnc12-xorg113-glx.patch: Re-enable GLX against xserver 1.13
469
470* Fri Aug 17 2012 Adam Tkac <atkac redhat com> 1.2.80-0.1.20120905svn4996
471- update to 1.2.80
472- remove deprecated patches
473  - tigervnc-102434.patch
474  - tigervnc-viewer-reparent.patch
475  - tigervnc11-java7.patch
476- patches merged
477  - tigervnc11-xorg111.patch
478  - tigervnc11-xorg112.patch
479
480* Fri Aug 10 2012 Dave Airlie <airlied@redhat.com> 1.1.0-10
481- fix build against newer X server
482
483* Mon Jul 23 2012 Adam Jackson <ajax@redhat.com> 1.1.0-9
484- Build with the Composite extension for feature parity with other X servers
485
486* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-8
487- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
488
489* Thu Jul 19 2012 Dave Airlie <airlied@redhat.com> 1.1.0-7
490- fix building against X.org 1.13
491
492* Wed Apr 04 2012 Adam Jackson <ajax@redhat.com> 1.1.0-6
493- RHEL exclusion for -server-module on ppc* too
494
495* Mon Mar 26 2012 Adam Tkac <atkac redhat com> - 1.1.0-5
496- clean Xvnc's /tmp environment in service file before startup
497- fix building against the latest JAVA 7 and X.Org 1.12
498
499* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-4
500- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
501
502* Tue Nov 22 2011 Adam Tkac <atkac redhat com> - 1.1.0-3
503- don't build X.Org devel docs (#755782)
504- applet: BR generic java-devel instead of java-gcj-devel (#755783)
505- use runuser to start Xvnc in systemd service file (#754259)
506- don't attepmt to restart Xvnc session during update/erase (#753216)
507
508* Fri Nov 11 2011 Adam Tkac <atkac redhat com> - 1.1.0-2
509- libvnc.so: don't use unexported GetMaster function (#744881)
510- remove nasm buildreq
511
512* Mon Sep 12 2011 Adam Tkac <atkac redhat com> - 1.1.0-1
513- update to 1.1.0
514- update the xorg11 patch
515- patches merged
516  - tigervnc11-glx.patch
517  - tigervnc11-CVE-2011-1775.patch
518  - 0001-Use-memmove-instead-of-memcpy-in-fbblt.c-when-memory.patch
519
520* Thu Jul 28 2011 Adam Tkac <atkac redhat com> - 1.0.90-6
521- add systemd service file and remove legacy SysV initscript (#717227)
522
523* Thu May 12 2011 Adam Tkac <atkac redhat com> - 1.0.90-5
524- make Xvnc buildable against X.Org 1.11
525
526* Tue May 10 2011 Adam Tkac <atkac redhat com> - 1.0.90-4
527- viewer can send password without proper validation of X.509 certs
528  (CVE-2011-1775)
529
530* Wed Apr 13 2011 Adam Tkac <atkac redhat com> - 1.0.90-3
531- fix wrong usage of memcpy which caused screen artifacts (#652590)
532- don't point to inaccessible link in sysconfig/vncservers (#644975)
533
534* Fri Apr 08 2011 Adam Tkac <atkac redhat com> - 1.0.90-2
535- improve compatibility with vinagre client (#692048)
536
537* Tue Mar 22 2011 Adam Tkac <atkac redhat com> - 1.0.90-1
538- update to 1.0.90
539
540* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.90-0.32.20110117svn4237
541- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
542
543* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.31.20110117svn4237
544- fix libvnc.so module loading
545
546* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.30.20110117svn4237
547- update to r4237
548- patches merged
549  - tigervnc11-optionsdialog.patch
550  - tigervnc11-rh607866.patch
551
552* Fri Jan 14 2011 Adam Tkac <atkac redhat com> 1.0.90-0.29.20101208svn4225
553- improve patch for keyboard issues
554
555* Fri Jan 14 2011 Adam Tkac <atkac redhat com> 1.0.90-0.28.20101208svn4225
556- attempt to fix various keyboard-related issues (key repeating etc)
557
558* Fri Jan 07 2011 Adam Tkac <atkac redhat com> 1.0.90-0.27.20101208svn4225
559- render "Ok" and "Cancel" buttons in the options dialog correctly
560
561* Wed Dec 15 2010 Jan Görig <jgorig redhat com> 1.0.90-0.26.20101208svn4225
562- added vncserver lock file (#662784)
563
564* Fri Dec 10 2010 Adam Tkac <atkac redhat com> 1.0.90-0.25.20101208svn4225
565- update to r4225
566- patches merged
567  - tigervnc11-rh611677.patch
568  - tigervnc11-rh633931.patch
569  - tigervnc11-xorg1.10.patch
570- enable VeNCrypt and PAM support
571
572* Mon Dec 06 2010 Adam Tkac <atkac redhat com> 1.0.90-0.24.20100813svn4123
573- rebuild against xserver 1.10.X
574- 0001-Return-Success-from-generate_modkeymap-when-max_keys.patch merged
575
576* Wed Sep 29 2010 jkeating - 1.0.90-0.23.20100813svn4123
577- Rebuilt for gcc bug 634757
578
579* Tue Sep 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.22.20100420svn4030
580- drop xorg-x11-fonts-misc dependency (#636170)
581
582* Tue Sep 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.21.20100420svn4030
583- improve patch for #633645 (fix tcsh incompatibilities)
584
585* Thu Sep 16 2010 Adam Tkac <atkac redhat com> 1.0.90-0.20.20100813svn4123
586- press fake modifiers correctly (#633931)
587- supress unneeded debug information emitted from initscript (#633645)
588
589* Wed Aug 25 2010 Adam Tkac <atkac redhat com> 1.0.90-0.19.20100813svn4123
590- separate Xvnc, vncpasswd and vncconfig to -server-minimal subpkg (#626946)
591- move license to separate subpkg and Requires it from main subpkgs
592- Xvnc: handle situations when no modifiers exist well (#611677)
593
594* Fri Aug 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.18.20100813svn4123
595- update to r4123 (#617973)
596- add perl requires to -server subpkg (#619791)
597
598* Thu Jul 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.17.20100721svn4113
599- update to r4113
600- patches merged
601  - tigervnc11-rh586406.patch
602  - tigervnc11-libvnc.patch
603  - tigervnc11-rh597172.patch
604  - tigervnc11-rh600070.patch
605  - tigervnc11-options.patch
606- don't own %%{_datadir}/icons directory (#614301)
607- minor improvements in the .desktop file (#616340)
608- bundled libjpeg configure requires nasm; is executed even if system-wide
609  libjpeg is used
610
611* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.90-0.16.20100420svn4030
612- build against system-wide libjpeg-turbo (#494458)
613- build no longer requires nasm
614
615* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 1.0.90-0.15.20100420svn4030
616- vncserver: accept <+optname> option when specified as the first one
617
618* Thu Jun 24 2010 Adam Tkac <atkac redhat com> 1.0.90-0.14.20100420svn4030
619- fix memory leak in Xvnc input code (#597172)
620- don't crash when receive negative encoding (#600070)
621- explicitly disable udev configuration support
622- add gettext-autopoint to BR
623
624* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 1.0.90-0.13.20100420svn4030
625- update URL about SSH tunneling in the sysconfig file (#601996)
626
627* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 1.0.90-0.12.20100420svn4030
628- use newer gettext
629- autopoint now uses git instead of cvs, adjust BuildRequires appropriately
630
631* Thu May 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.11.20100420svn4030
632- link libvnc.so "now" to catch "undefined symbol" errors during Xorg startup
633- use always XkbConvertCase instead of XConvertCase (#580159, #586406)
634- don't link libvnc.so against libXi.la, libdix.la and libxkb.la; use symbols
635  from Xorg instead
636
637* Thu May 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.10.20100420svn4030
638- update to r4030 snapshot
639- patches merged to upstream
640  - tigervnc11-rh522369.patch
641  - tigervnc11-rh551262.patch
642  - tigervnc11-r4002.patch
643  - tigervnc11-r4014.patch
644
645* Thu Apr 08 2010 Adam Tkac <atkac redhat com> 1.0.90-0.9.20100219svn3993
646- add server-applet subpackage which contains Java vncviewer applet
647- fix Java applet; it didn't work when run from web browser
648- add xorg-x11-xkb-utils to server Requires
649
650* Fri Mar 12 2010 Adam Tkac <atkac redhat com> 1.0.90-0.8.20100219svn3993
651- add French translation to vncviewer.desktop (thanks to Alain Portal)
652
653* Thu Mar 04 2010 Adam Tkac <atkac redhat com> 1.0.90-0.7.20100219svn3993
654- don't crash during pixel format change (#522369, #551262)
655
656* Mon Mar 01 2010 Adam Tkac <atkac redhat com> 1.0.90-0.6.20100219svn3993
657- add mesa-dri-drivers and xkeyboard-config to -server Requires
658- update to r3993 1.0.90 snapshot
659  - tigervnc11-noexecstack.patch merged
660  - tigervnc11-xorg18.patch merged
661  - xserver18.patch is no longer needed
662
663* Wed Jan 27 2010 Jan Gorig <jgorig redhat com> 1.0.90-0.5.20091221svn3929
664- initscript LSB compliance fixes (#523974)
665
666* Fri Jan 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.4.20091221svn3929
667- mark stack as non-executable in jpeg ASM code
668- add xorg-x11-xauth to Requires
669- add support for X.Org 1.8
670- drop shave sources, they are no longer needed
671
672* Thu Jan 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.3.20091221svn3929
673- drop tigervnc-xorg25909.patch, it has been merged to X.Org upstream
674
675* Thu Jan 07 2010 Adam Tkac <atkac redhat com> 1.0.90-0.2.20091221svn3929
676- add patch for upstream X.Org issue #25909
677- add libXdmcp-devel to build requires to build Xvnc with XDMCP support (#552322)
678
679* Mon Dec 21 2009 Adam Tkac <atkac redhat com> 1.0.90-0.1.20091221svn3929
680- update to 1.0.90 snapshot
681- patches merged
682  - tigervnc10-compat.patch
683  - tigervnc10-rh510185.patch
684  - tigervnc10-rh524340.patch
685  - tigervnc10-rh516274.patch
686
687* Mon Oct 26 2009 Adam Tkac <atkac redhat com> 1.0.0-3
688- create Xvnc keyboard mapping before first keypress (#516274)
689
690* Thu Oct 08 2009 Adam Tkac <atkac redhat com> 1.0.0-2
691- update underlying X source to 1.6.4-0.3.fc11
692- remove bogus '-nohttpd' parameter from /etc/sysconfig/vncservers (#525629)
693- initscript LSB compliance fixes (#523974)
694- improve -LowColorSwitch documentation and handling (#510185)
695- honor dotWhenNoCursor option (and it's changes) every time (#524340)
696
697* Fri Aug 28 2009 Adam Tkac <atkac redhat com> 1.0.0-1
698- update to 1.0.0
699- tigervnc10-rh495457.patch merged to upstream
700
701* Mon Aug 24 2009 Karsten Hopp <karsten@redhat.com> 0.0.91-0.17
702- fix ifnarch s390x for server-module
703
704* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.0.91-0.16
705- rebuilt with new openssl
706
707* Tue Aug 04 2009 Adam Tkac <atkac redhat com> 0.0.91-0.15
708- make Xvnc compilable
709
710* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.91-0.14.1
711- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
712
713* Mon Jul 13 2009 Adam Tkac <atkac redhat com> 0.0.91-0.13.1
714- don't write warning when initscript is called with condrestart param (#508367)
715
716* Tue Jun 23 2009 Adam Tkac <atkac redhat com> 0.0.91-0.13
717- temporary use F11 Xserver base to make Xvnc compilable
718- BuildRequires: libXi-devel
719- don't ship tigervnc-server-module on s390/s390x
720
721* Mon Jun 22 2009 Adam Tkac <atkac redhat com> 0.0.91-0.12
722- fix local rendering of cursor (#495457)
723
724* Thu Jun 18 2009 Adam Tkac <atkac redhat com> 0.0.91-0.11
725- update to 0.0.91 (1.0.0 RC1)
726- patches merged
727  - tigervnc10-rh499401.patch
728  - tigervnc10-rh497592.patch
729  - tigervnc10-rh501832.patch
730- after discusion in upstream drop tigervnc-bounds.patch
731- configure flags cleanup
732
733* Thu May 21 2009 Adam Tkac <atkac redhat com> 0.0.90-0.10
734- rebuild against 1.6.1.901 X server (#497835)
735- disable i18n, vncviewer is not UTF-8 compatible (#501832)
736
737* Mon May 18 2009 Adam Tkac <atkac redhat com> 0.0.90-0.9
738- fix vncpasswd crash on long passwords (#499401)
739- start session dbus daemon correctly (#497592)
740
741* Mon May 11 2009 Adam Tkac <atkac redhat com> 0.0.90-0.8.1
742- remove merged tigervnc-manminor.patch
743
744* Tue May 05 2009 Adam Tkac <atkac redhat com> 0.0.90-0.8
745- update to 0.0.90
746
747* Thu Apr 30 2009 Adam Tkac <atkac redhat com> 0.0.90-0.7.20090427svn3789
748- server package now requires xorg-x11-fonts-misc (#498184)
749
750* Mon Apr 27 2009 Adam Tkac <atkac redhat com> 0.0.90-0.6.20090427svn3789
751- update to r3789
752  - tigervnc-rh494801.patch merged
753- tigervnc-newfbsize.patch is no longer needed
754- fix problems when vncviewer and Xvnc run on different endianess (#496653)
755- UltraVNC and TightVNC clients work fine again (#496786)
756
757* Wed Apr 08 2009 Adam Tkac <atkac redhat com> 0.0.90-0.5.20090403svn3751
758- workaround broken fontpath handling in vncserver script (#494801)
759
760* Fri Apr 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.4.20090403svn3751
761- update to r3751
762- patches merged
763  - tigervnc-xclients.patch
764  - tigervnc-clipboard.patch
765  - tigervnc-rh212985.patch
766- basic RandR support in Xvnc (resize of the desktop)
767- use built-in libjpeg (SSE2/MMX accelerated encoding on x86 platform)
768- use Tight encoding by default
769- use TigerVNC icons
770
771* Tue Mar 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.3.20090303svn3631
772- update to r3631
773
774* Tue Mar 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.2.20090302svn3621
775- package review related fixes
776
777* Mon Mar 02 2009 Adam Tkac <atkac redhat com> 0.0.90-0.1.20090302svn3621
778- initial package, r3621
Note: See TracBrowser for help on using the repository browser.